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1 ORGANIZATION 

OVERVIEW 

In this module we will discuss the organization model in Microsoft Dynamics AX 2012 is 
used to create the hierarchical structures that can be used for the performance 
improvements cycle. 

An organization is a group of people who are working together to perform a business 
process or achieve a goal. Organizational hierarchies represent the relationships 
between the organizations that make up your business. 

The conceptual model for Retail Organizations is as shown in the Architecture – Retail 
Conceptual Model. 

 

 

Figure 1 – Architecture – Retail Conceptual Model 
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International corporations can grow from inside or through mergers and acquisitions. 
They can also grow by targeting new markets, or they can establish new subsidiaries or 
obtain new legal entities in their own country or other countries. Additionally, 
International corporations can grow by targeting new consumer market segments or 
vertical industry segments. The new markets they serve might require new products and 
services. Effectively measuring the performance of such a growing business can become 
a challenge. 

Typically, these corporations measure performance that is based on the dimensions of 
the business, such as business units, business divisions, lines of business, or product 
lines. Corporations can also be organized based on these dimensions, or on functions 
such as sales, marketing, product development, production, human resources, and 
accounting. In a mixed organization, services such as human resources and accounting 
are shared across business units. 

Corporations might need both internal and external reporting structures. Generally, a 
legal or statutory structure is used for legal, regulatory, or external reporting 
requirements of federal, state, or local government entities. An operating or managerial 
structure is used for internal profit and loss reporting and for measuring the 
performance of the organization. Nonprofit, public sector, and governmental 
organizations can require an operating structure to create a statement of financial 
position. 

Most corporations use an iterative operating cycle of Monitor > Measure > Analyze > 
Improve. The Analyze phase results in new business rules and policies, and new 
strategic and operational initiatives that are used to improve performance. This cycle of 
performance improvement also occurs at lower levels of the organization, such as 
business units, divisions, departments, and cost centers. 

 INTERNAL ORGANIZATION 

There are two types of internal organizations—legal entities and operating units.  

To create both types of organizations go to Organization administration > Setup > 
Organizations and then select Legal entities or Operating unit. 
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Figure 2 – Microsoft Dynamics AX 2012 – Retail – Organization Administration Area 
Page 

 ORGANIZATION HIERARCHY 

Set up organizational hierarchies to view and report on your business from different 
perspectives. For example, you can set up a hierarchy of legal entities for tax, legal, or 
statutory reporting. Set up a hierarchy that is based on operating units to report 
financial information that is not legally required, and is still used for internal reporting. 
For example, you can create a purchasing hierarchy to control purchasing policies, rules, 
and business processes.  

Organizations in a hierarchy can share parameters, policies, and transactions. 

Important 

An organization can inherit or override the parameters of its parent organization. 
However, shared master data, such as products and address books, applies to the 
whole organization and cannot be overridden for individual organizations.  
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The following topics describe some suggestions and guidance about how to model 
organization hierarchies. However, business requirements should be the primary factor 
that determines your approach. The size and complexity of the business are important 
considerations in creating the hierarchy. 

1.2.1 ORGANIZATION MODELING FOR A SMALL ORGANIZATION 

Typically, small organizations have just one or a few legal entities. Frequently, the legal 
structure is also used as the operating structure, because the business includes a limited 
number of product lines or groups. A small organization can use the legal structure to 
measure performance and control operations for product lines.  

An organizational hierarchy is not required for a small organization, if the business does 
not require complex internal control policies and data security access that are based on 
hierarchies. Simple policies and data security can be based on a list of legal entities that 
is not organized in a hierarchy. However, we recommend that you always create a single 
mixed hierarchy to support the organization as it grows. If more complex scenarios for 
internal control, such as audit control and invoice control become necessary, a small 
organization must define additional hierarchies that consist of legal entities only.  

A typical retail organization has a single mixed hierarchy that has a legal entity at the top 
with department and cost centers rolling up to the top. 

 

Figure 3: Typical Retail Organization with a single mixed hierarchy 
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1.2.2 ORGANIZATION MODELING FOR A MIDSIZED ORGANIZATION 

Midsized organizations might require complex internal control policies and therefore 
might require separate hierarchies for legal entities and operating units.  

The structure of the legal entities might be based on industries, consumers or product 
lines. In the following illustration, the legal entity structure is based on geographic 
regions. 

 

Figure 4: Typical Midsized Organization – Based on Geographical Regions 

The hierarchy of operating units might have a legal entity at the top and business units 
under the legal entity. Each business unit might contain departments and each 
department might consist of cost centers. Departments that are inside a single legal 
entity in the legal entity hierarchy can roll up to different business units in the operating 
hierarchy, as is shown in the following illustration. 
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Figure 5: Typical Midsized Organization – Based on Operating Hierarchy 

1.2.3 ORGANIZATION MODELING FOR A LARGE ORGANIZATION 

Large organizations grow through mergers and acquisitions. Typically, leaders of these 
organizations want to analyze the business based on operating structures such as 
industries, consumers, or product lines. Additionally, leaders restructure their 
businesses to meet the requirements of the marketplace in an agile manner. A large 
organization requires an organizational structure that supports internal controls, 
effective performance measurement, and efficient delivery of goods and services. Large 
organizations must model multiple hierarchies to measure the effectiveness of 
restructuring, and to compare old and new organizational structures.  

Larger organizations might require some hierarchies that are based on business units 
and other hierarchies that are based on shared services, such as human resources and 
IT. However, when you design hierarchies, make sure that cost centers are created in 
shared service departments, and that the cost centers are positioned inside the business 
units so that the costs of shared services are appropriately allocated. 

1.2.4 CREATE OR MODIFY AN ORGANIZATION HIERARCHY 

You can use organizational hierarchies to view and report on your business from several 
perspectives. For example, you can set up one hierarchy for tax, legal, or statutory 
reporting. You can then set up another hierarchy to report financial information that is 
not legally required, and can still be used for internal reporting.  

This topic describes how to create and modify an organizational hierarchy. 
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Before you create an organizational hierarchy, you must create organizations. For more 
information, see Create or modify a legal entity or Create or modify an operating unit. 

To create a hierarchy and assign a purpose to the hierarchy, use the following steps.  

1.2.4.1 CREATE A HIERARCHY 

1. Click Organization administration > Setup > Organization > Organization 
hierarchies.  

2. Click New.  

3. Enter a name for the organizational hierarchy.  Notice that the Name field is a 
mandatory field when you create a new hierarchy. 

4. Press CTRL+S to save the new hierarchy.  

5. Click the Close button to close the form. Refer to the next topic to assign a 

purpose to the newly created hierarchy. 

 

Figure 6: Organization Hierarchy – Store by Type 

 

Buttons 

The buttons that are used to create an organizational hierarchy are described in the 
following table. 
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Button  Description 

New  Click New to create a new organization hierarchy. 

Delete 

Click Delete to remove an organization hierarchy.  

Caution 

Make sure to review the impact on the associated legal entities and operating 
units before you delete an organization hierarchy. 

View 
Click View to view the organization hierarchy structure that links with other 
legal entities and operating units. 

 

 

 

Figure 7: Organization Hierarchy – Store by Type – Hierarchy Detail View  

  

Store Types 

 Outlet Stores 

 Super Stores 

 Mall Stores 
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1.2.4.2 ASSIGN A ORGANIZATION PURPOSE TO THE HIERARCHY 

Before you add organizations to a hierarchy, you must select a purpose for the 
hierarchy. The purpose that you select determines the types of organizations that can 
be included in the hierarchy. The types of organizations that can be used for each 
default hierarchy purpose are described in the following table. 

Hierarchy 

purpose 

Description  Organization 

types allowed 

Procurement 

internal control  

Used to define policies that control the purchasing process.  All 

Expenditure 

internal control  

Used to define policies for expense reports.  All 

Organization 

chart  

Used in Human resources to define reporting relationships.  All 

Signature 

authority 

internal control  

Used to define policies for signing limits. These policies 

control the spending and approval limits that are assigned 

to employees.  

All 

Vendor 

payment 

internal control  

Used to define policies for the payment of vendor invoices.  Legal entities 

Audit internal 

control  

Used to define policies for identifying documents for audit.  Legal entities 

Centralized 

payments  

Used to make payments by one legal entity on behalf of 

other legal entities.  

Legal entities 

Security  Used to define the organization's security access to data.  All 
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Hierarchy 

purpose 

Description  Organization 

types allowed 

Retail 

assortment 

Used to define the organization’s assortment model for 

store models. 

All 

Retail 

replenishment 

Used to define the organization’s replenishment model for 

store fulfillment. 

All 

Retail reporting Used to define the organization’s reporting model for retail 

channels. 

All 

Benefit 

Eligibility 

Control 

Use to define the benefits eligibility for the legal entities. Legal Entity 

Budget 

Planning 

Use to define the organization’s planning for the budget. All 

Retail POS 

Posting 

Use to define the organization’s posting of retail Point of 

Sale (POS). 

All 

Project 

Management 

Use to define the model of project management for 

business units and legal entities. 

Business Unit 

Legal Entity 

 

Note 

Organization hierarchy purposes are predefined in Microsoft Dynamics AX and they 
cannot be modified. 

The retail types on the organization hierarchy purposes are: 

 Retail assortment 

 Retail replenishment 

 Retail reporting 
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 Retail POS posting 

To select the purpose and organization hierarchy, follow these steps. 

 
1. Click Organization administration > Setup > Organization > Organization 

hierarchy purposes.  

 
 
Figure 8: Organization Hierarchy Purpose – Retail Assortment  

Note 

You can use the Allowed organization types with a list of organization types that you 
can associate to the purpose. 

 

2. Select a purpose from the left hand list, and then click Add. The 
Organizations form is displayed. 
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3. Select the organizational hierarchy that you want to assign the purpose to 
and then click OK.   Select View hierarchy to add organizations to the 
selected organization or alternatively use the Organization hierarchies form 
to perform a similar operation. 
 

4. Click Close to close the form. 

 

Buttons 

The buttons that are used to select, add and delete purposes and hierarchies are 
described in the following table. 

Button  Description 

Add  Click Add to add an organization hierarchy to the purpose that is selected 
from the left hand list. 

Remove 

Click Remove to remove the selected organization hierarchy from the purpose. 

Caution 

Make sure to review the impact on the draft assortments and replenishments 
that are associated with the organization hierarchy before you remove them 
from a purpose. 
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Button  Description 

Set as default 
Click set as default to set the selected organization hierarchy as the default for 
the purpose. 

View 
Click View to view the organization hierarchy structure. The form that is 
shown in the Organization Hierarchy Purpose – Retail Assortment – Hierarchy 
Purpose View figure opens. 

 

 

Figure 9: Organization Hierarchy Purpose – Retail Assortment – Hierarchy Purpose View 

1.2.4.3 ADD ORGANIZATIONS TO THE HIERARCHY 

You can add organizations to the hierarchy to represent the structure of the 
organization’s business requirements. 

Based on the organization hierarchy purpose, both legal entities and the operating unit 
can be added to the organization hierarchy. 

Note 

An operating unit or legal entity cannot be added two times in the same organization 
hierarchy. 

To add organizations to an organization hierarchy, follow these steps. 

Retail Assortments – 
By Store Region 

 East Region 

 West Region 

 Central Region 
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1. Click Organization administration > Setup > Organization > Organization 
hierarchies. Select a hierarchy, and then click View.  

2. Click Edit to add or modify organization types to the organization hierarchy. 

 

3. Click Insert, and then select an organization type. In the form that is displayed, 
select an organization type, and then click OK.  (Legal Entity, Department, Cost 
Center, Value Stream, Business Unit or Retail Channel) 

 

Figure 10: Edit an Organization Hierarchy – View Insert Org Type Selection 

      Example: If you select the legal entity as the organization type to insert, the following 
screen is displayed.  
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To add levels underneath an organization, select the organization type that you 
want to add to the levels, then select the value from the FactBox and then click 
Insert.  

4. When you finish making changes, save the hierarchy.  

 

Figure 11: Save an Organization Hierarchy 
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5. To save a draft, click Save as draft. Your changes are saved. However, the hierarchy 
does not become active.  

6. If you finish making changes to the hierarchy, click Publish and close. When you 
publish a hierarchy, you must specify an effective date. The effective date indicates 
when the hierarchy becomes active.  

 

Figure 12: Publish an Organization Hierarchy –- Enter Effective Date for Publish 

 

Note 

If you close the Hierarchy designer form without saving the changes, a FactBox appears, 
with options to save the hierarchy as a draft or to discard your changes. If you close the 
FactBox without making a selection, your changes will be discarded. 

 

Buttons 

The buttons that are used to change an organizational hierarchy are described in the 
following table.  
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Button  Description 

Save as draft  Click Save as draft to save the changes to the organization hierarchy as a 
draft. 

Publish and 
close 

Click Publish and close to commit the changes to the organization hierarchy 
and to publish the changes. 

Insert Click Insert to insert an organization type to the organization hierarchy. 

Remove Click Remove to remove an organization type from the organization hierarchy. 

Cut Click Cut to cut an organization type from the organization hierarchy. 

Paste Click Paste to paste an organization type to the organization hierarchy. 

Undo Click Undo to cancel the recent change to the organization hierarchy. 

Hierarchy 
details 

Click Hierarchy details to view the hierarchy details form for the selected 
organization type. 

Organization 
details 

Click Organization details for the details to view the organization hierarchy 
form. 

Purposes 
Click Purposes to view the organization hierarchy purpose form that is 
associated with the organization hierarchy. 

Hide or show 
preview pane 

Click Hide or show preview pane to view or hide details that are related to 
the selected organization type. 

 

1.2.4.4 MODIFY A HIERARCHY 

If a reorganization, merger, or acquisition occurs, you must modify existing 
organizational hierarchies.  

You can view or change a hierarchy as of any future date or as of an effective date is 
published. However, you cannot publish updates to the hierarchy between existing 
effective dates. Changes must take effect after the last effective date that is published 
for the hierarchy. 
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Note 

To view or modify a draft hierarchy, you must view the published hierarchy that the 
draft is based on, and then click Edit. Draft hierarchies cannot be accessed directly. 

1. Click Organization administration > Setup > Organization > Organization 
hierarchies. Select a hierarchy, and then click View.  

2. Future Date Changes: If you must make a correction, you can delete the last future 
published version of a hierarchy. In the Future changes FactBox, click More to open 
the Future change dates form.  

 

3. Click Delete latest date. 

 

4. Click Edit.  

If a draft already exists for the hierarchy, a message appears when you click Edit. 
You can either continue to work on the draft, or delete the draft and start a new 
draft. You can save a draft for each effective date that is published.  

5. Add or remove organizations, or change the position of organizations in the 
hierarchy.  
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6. When you finish making changes, save the hierarchy.  

To save a draft, click Save as draft. Your changes are saved. However, the modified 
hierarchy does not become active. If you finish making changes to the hierarchy, 
click Publish and close. When you publish a hierarchy, you must specify an effective 
date. If versions of the hierarchy already exist that have future effective dates, your 
changes must take effect after the last effective date that is published for the 
hierarchy. 

Note 

If you close the Hierarchy designer form without saving the changes, a FactBox appears, 
with options to save the hierarchy as a draft or to discard your changes. If you close the 
FactBox without making a selection, your changes will be discarded. 

 LEGAL ENTITIES 

A legal entity is an organization, and or a company that has a registered or legislated 
legal structure. Legal entities can enter into legal contracts and legal entities are 
required to prepare statements that report on their performance.  

In Microsoft Dynamics AX, companies are the only legal entities that can be created with 
a company ID.  

1.3.1 CREATE OR MODIFY A LEGAL ENTITY 

To create or modify a legal entity, follow these steps. 

1. Click Organization administration > Setup > Organization > Legal entities.  

2. To create a new legal entity, click New. The New legal entity form is displayed. Here, 

you can enter the required information for a legal entity record. Enter information in 

the Name, Company, Country/region fields and then click OK.  
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To modify an existing legal entity, select the legal entity in the list. To modify the 

name of an existing legal entity, click Change name. You cannot change the 

company ID that is associated with an existing legal entity. 

 

The History button on the Change name form displays the previous changes that are 

made to the legal entity. 

Note: 

A company ID is a unique identifier for the data that is associated with the legal entity. A 
company can be associated with only one legal entity, and a legal entity can be 
associated with only one company. 

3. On the General FastTab, provide the following general information about the legal 
entity: 
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 Enter the Memo information for the legal entity. 

 Enter a search name, if a search name is required. A search name is an alternate 
name that can be used to search for this legal entity by using Enterprise Search.  

 In hierarchy – The check box indicates if the legal entity is part of any 
organization hierarchy. 

 Use for financial consolidation process - Select the check box if the legal entity is 
used as a consolidation company.  

In a consolidation, you gather transactions from several company accounts and 
combine these transactions into a single company. You can print reports, such as 
financial statements, from the consolidated company. However, you cannot use 
the company for daily transactions.  

 Use for financial elimination process - Select the check box if the legal entity is 
used as an elimination company.  

When a parent company does business with one or more subsidiary companies 
and the parent company uses consolidated financial reporting, any transactions 
between the companies must be removed, or eliminated, from the financial 
reports. These transactions are called elimination transactions. The destination 
company for eliminations is called the elimination company.  

 Select the default Language that is used for the legal entity. 

 Select the time zone in which the legal entity will operate. 

4. On the Addresses FastTab, enter address information, such as the street name and 
number, postal code, and city.  

Click Add to enter a new address record, or click Edit to modify an existing address 
record. For more information about the address fields, press F1 in the forms that 
open when you click Add or Edit. 

Click the Add button on the grid. The new address form opens. 
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 Enter the Name or the description of the address. Notice that the Name field 
is a mandatory field for addresses.  

 Select the Purpose of the address from the drop-down list box. This includes 
the business, delivery, invoice or payment, and so on. (The list is a pre-
defined list of purposes.) 

 Under the Address FastTab select the County/region. Enter the postal code 
and street name. Select city, state and county information. If you want to set 
the address as the primary address for the legal entity, select the Primary 
check box. 

 Underneath the Contact Information FastTab, click the Add button on the 
grid to add new contacts. Enter the name or description for the contact. 
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Select the Type of contact. The options available for contact types include 
the following: 

o Phone 
o Email address 
o URL 
o Telex 
o Fax 

Enter the contact information or the address that is appropriate for the 
selected contact type. 

 Underneath the General FastTab, select the Default Sales tax that applies to 
the address or location of the legal entity. Select the time zone in which the 
address or the location will operate. Select an effective date, if this is 
necessary, to indicate the date that the address will be active. Select an 
expiration date if the address is no longer active. 

 Select the Time zone from the drop-down list box that applies to the legal 
entity. 

Note: 

The country/region that you select for the primary address of the legal entity controls 
the country/region-specific features that are available for the legal entity. 

 

5. On the Contact information FastTab, enter information about the methods of 
communication, such as email addresses, URLs, and telephone numbers. To enter a 
new communication record, click Add. To modify an existing communication record, 
click More options > Advanced. For more information about the communication 
fields, press F1 in the forms that open when you click New or Advanced. 
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Click the Primary check box for the selected contact information to be set as the 
primary contact. 

 
6. On the Tax registration FastTab, enter the registration number that is required by 

the country for tax reporting purposes. 
 

 
 

7. On the Tax 1099 FastTab, enter the tax 1099 information for the legal entity. 
 

 

Note: 

Applicable to USA only: The fields on this tab are available only to legal entities whose 
primary address is in the United States. 
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8. On the Statutory reporting FastTab, enter the registration numbers that are used for 
statutory reporting. Countries have different registration numbers and the 
registration numbers are based on the localization that is applied. 
 

 
 

9. On the Bank account information FastTab, enter bank accounts and routing 
numbers for the legal entity. 
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10. On the Foreign trade and logistics FastTab, enter shipping information for the legal 
entity. This shipping information includes Intrastat information. 

 

11. On the Number sequences FastTab, you can view the number sequences that are 
associated with the legal entity. To change this information, use the Number 
sequences form. (Click Organization administration > Common > Number 
sequences > Number sequences.) 
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12. To view or change the logo that is associated with the legal entity, click Company 
logo. 

 
 

13. To view the legal entity in the organizational hierarchy, click View in hierarchy. 

Note: 

Refer to the Financials I training manual for more information on legal entity set up. 

 OPERATING UNITS 

An operating unit is an organization type that is used to divide the control of economic 
resources and operational processes in a business. Typically, people in an operating unit 
try to maximize the use of scarce resources, improve processes, and account for their 
performance.  

In Microsoft Dynamics AX, the types of operating units include cost centers, business 
units, value streams, and departments. More information about each type of operating 
unit is described in the following table.  

Operating 

unit type 

Description Purpose 

Cost center  An operating unit in which 

managers are accountable for 

budgeted and actual expenditures.  

Used for the management and 

operational control of business 

processes that span legal entities.  

Business unit  A semi-autonomous operating unit 

that is created to meet strategic 

business objectives.  

Used for financial reporting that is 

based on industries or product lines 

that the organization serves 

independently of legal entities.  

Value stream  An operating unit that controls one 

or more production flows.  

Commonly used in lean 

manufacturing to control the 

activities and the flows required to 

supply a product or service to 
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Operating 

unit type 

Description Purpose 

consumers.  

Department  An operating unit that represents a 

category or a functional part of an 

organization that performs a 

specific task, such as sales or 

accounting.  

Used to report on functional areas. 

A department might have profit 

and loss responsibility, and might 

consist of a group of cost centers.  

Retail 

Channel 

An operating unit that represents a 

retail store that is used to configure 

and manage stores. 

Used to create and configure retail 

stores. Set the default company, 

warehouse, sales taxes and 

customer. 

Note: 

The retail category on the operating unit is the Retail channel where users can create 
and configure retail stores. The retail stores can be assigned to the organization 
hierarchy for assortment and replenishment purposes. 

 

1.4.1 CREATE OR MODIFY AN OPERATING UNIT 

The following information is a guide to create a new operating unit or modify an existing 
operating unit.  

Note: 

The operating unit types are predefined in Microsoft Dynamics AX.  
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1.4.1.1 CREATE A BUSINESS UNIT 

To create a new operating unit or modify an existing operating unit, follow these steps. 

1. Click Organization administration > Setup > Organization > Operating units.  
2. Click New. Select Business Unit as the operating unit type. Click OK. 

 

3. Enter the Name of the business unit and the Business Unit number. The Name 
field and the Business unit number field are mandatory.  

 
4. Enter the Search name for the business unit. 

 

5. Under the General FastTab, enter the Memo information if it is required.  
 

6. In hierarchy – The check box is selected if the business unit is part of any 
organization hierarchy.  
 

7. Enter the DUNS number for the business unit. 
 

8. Assign the default Manager for the business unit. 
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9. Underneath the Addresses FastTab, click the Add button on the grid to add 
address information for the business unit. To edit an existing address, select the 
address line and click Edit. 

 
 

10. Underneath the Contact information FastTab, click Add to add new contact 
information. To edit existing contact information, click More options -> 
Advanced.  

 

 

1.4.1.2 CREATE A RETAIL CHANNEL 

To create a retail channel, follow these steps. 

1. Click Organization administration > Setup > Organization > Operating units, and 
then click New. 
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2. Select Retail Channel as the operating unit type, and then click OK. 

 

3. Enter the Name of the retail channel. 

 

4. Enter the Retail channel number. The retail channel number is the store 
number. This number is a unique number that you allocate to the store. 
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5. Enter the Search name for the retail channel. A search name is an alternate 
name that can be used to search for this operating unit by using Enterprise 
Search. 

6. Select the Retail channel type. Options that are available include the following: 

 

Name Description 

Retail Store Select this for a brick and mortal store. 

Obsolete online 

store 

Select this when the online store is deprecated. 

Online Marketplace Select Online marketplace for commerce services such as e-bay. 

Online Store Select Online store when this is accessed from the Microsoft 

SharePoint site. 

 

7. Select the Company from the drop-down list box. This specifies the legal entity 
that the retail channel will be associated with.  The company will default to the 
current company the user is working with.  

8. Select the default Warehouse for the retail channel. 

9. Select the default Sales tax group for the retail channel. The sales tax is 
important because it defines how the taxes are calculated at the stores. 

10. Select the Default customer for the retail channel.  

Note: 

The Name field, Retail channel number field, Warehouse field, Sales tax group field 
and the Default customer field are mandatory to create retail channels. 

11. On the General FastTab, provide general information about the operating unit, 
such as an identification number, DUNS number, and manager. 
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12. On the Addresses FastTab, click Add to enter address information, such as the 
street name and number, postal code, and city. Click Add to enter a new address 
record, or click Edit to modify an existing address record.  

13. On the Contact information FastTab, enter information about the methods of 
communication, such as email addresses, URLs, and telephone numbers. To 
enter a new communication record, click Add. To modify an existing 
communication record, click More options > Advanced. For more information 
about the communication fields, press F1 in the forms that open when you click 
Add or Advanced. 

14. To view the operating unit in the organizational hierarchy, click View in 
hierarchy. 

The organization hierarchy for a retail company usually consists of the business unit 
and the stores that are associated to the business unit as is shown in the following 
illustration. 

 

 Note: 

In a Specific Retail Hierarchy, the retail channel can only be added one time. 
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15. Click Retail channel details to view the Store details form. 

 

 

 MASTER DATA AND PARAMETERS 

Retail entity Visibility 

Retail parameters Legal entity and enterprise 

Store Enterprise 

Terminal (incl. configuration) Enterprise 

Assortment Enterprise 
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Retail entity Visibility 

Staff Enterprise 

Tender types Enterprise 

Scheduler Enterprise 

Discounts offers Legal entity 

Reason codes Legal entity 

Functionality profile Legal entity 

Retail product categories Legal entity 

Customer Legal entity 

Loyalty Legal entity 

 

 BEST PRACTICES FOR MODELING ORGANIZATION AND 
HIERARCHIES 

Consider the following best practices when you implement an organization hierarchy:  

 Create a department to model the intersection between a legal entity and a 
business unit. You can then roll up data from a department to a legal entity for 
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statutory reporting, and from a department to a business unit for internal 
reporting.  

Departments can serve as profit centers. If you use departments, you do not have 
to use both legal entities and business units as dimensions in the account 
structure. You can just use departments as a dimension. However, you must use 
both cost centers and departments as dimensions in the account structure if cost 
centers are used only as cost accumulators, and departments are used for revenue 
recognition.  

 Allocate the costs of shared service departments, such as Human Resources and 
Information Technology, so that the costs are accounted for in the profit and loss 
statements of profit centers, such as departments and business units.  

 Model multiple hierarchies for operating units if you have complex requirements 
for reporting profit and loss.  

 Do not model multiple hierarchies for one hierarchy purpose.  

 Do not create a hierarchy for every purpose. Usually, you can use one hierarchy 
for multiple purposes. For example, one hierarchy of operating units can be 
assigned to all policy-related purposes.  

 Create balanced hierarchies. In a hierarchy, all nodes that are the same distance 
from the root node are defined as a level. In a balanced hierarchy, only one type 
of operating unit can occur at each level, and the distance from the root node to 
each level is consistent. If there are intermediate levels between a department 
and a legal entity or a business unit, placeholder organizations might be required 
to create a balanced hierarchy.  

 Do not model a separate hierarchy of operating units if the structure for legal 
entities is also your operating structure. A mixed hierarchy of legal entities and 
operating units might serve both purposes.  

 Before you model major restructuring scenarios, use the hierarchy's effective 
dates to perform an impact analysis and a validation test.  

 Use draft mode to change a hierarchy before you publish a new version in a 
production environment.  

 Limit the number of people who have permissions to add or remove organizations 
from a hierarchy in a production environment. A smaller number reduces the 
chance that costly mistakes can occur and corrections must be made. 
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2 STORE LOCATOR 

OVERVIEW  

In this module we will discuss how to set up store locator groups, to create groups of 
stores based on location or other criteria. You can use the locator groups to direct 
customers to locations where products are available, based on the retail store or the 
online store where a product inquiry is made. You can set up store locator groups so 
that, when a customer or a cashier searches for a store where a product is available, 
only a subset of stores is displayed. For example, the customer is located in the 
northeast United States, so only stores in that region are displayed.  

When you set up a store locator group, you can add one or more stores to the group. 
You can then assign one or more store locator groups to a store.  

Important  

The store locator feature uses the address for the default warehouse that is assigned to 
the customer, product, or store to determine the shipping information to use when 
product orders are shipped. If no address is defined for the default warehouse, an error 
can occur.  

1. To set up a store locator group for a retail store or an online store, following 
these steps.  

o For a retail store: Click Retail > Common > Retail channels > Retail 
stores. In the Retail stores list, double-click a store. In the Stores form, 
on the Action Pane, click the Set up tab. Then, in the Set up group, click 
Store locator group assignment.  

 

o For an online store: Click Retail > Common > Retail channels > Online 
stores. In the Online stores list, double-click a store. In the Online store 
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form, on the Action Pane, click the Set up tab. Then, in the Setup group, 
click Store locator group assignment.  

 

 

2.1.1 SETUP STORE LOCATOR GROUP 

Use this form to define store locator groups. Add retail stores and online stores to store 
locator groups, and use the groups to direct customers to locations where products are 
available, based on the retail store or the online store where a product inquiry is made.  

For example, a customer purchases a product at an online store and wants to pick up 
the product locally instead of paying for shipping. You can set up store locator groups to 
display product availability for retail stores only, and only in a specified geographical 
area. 

To setup a store locator group, follow these steps:  

1. Click Retail > Setup > Store locator groups.  

OR 

Click Retail > Common > Retail channels > Retail stores. In the Retail stores list, 
double-click a store. In the Stores form, on the Action Pane, click the Set up tab. 
Then, in the Set up group, click Store locator group assignment. In the Store 
locator group assignment form, click Store locator groups.  

 OR 

Click Retail > Common > Retail channels > Online stores. In the Online stores 
list, double-click a store. In the Online store form, on the Action Pane, click the 
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Set up tab. Then, in the Setup group, click Store locator group assignment. In 
the Store locator group assignment form, click Store locator groups.  

2. In the Store locator groups form, click New, and then enter a name and 
description for the store locator group.  

 

3. On the Setup FastTab, click Add, and then, in the Store field, select a store to 
add to the new store locator group. Add a new line for each store that you want 
to add to the group.  

4. Close the form.  

2.1.2 SETUP STORE LOCATOR GROUP ASSIGNMENT 

Use this form to assign retail stores or online stores to a store locator group. When you 
assign stores to store locator groups, customers are directed to locations where 
products are available, based on the retail store or online store where a product inquiry 
is made. 

To setup a store locator group assignment, follow these steps. 

1. Click Retail > Common > Retail channels > Retail stores. In the Retail stores list, 
double-click a store. In the Stores form, on the Action Pane, on the Set up tab, in 
the Set up group, click Store locator group assignment.  

OR 
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Click Retail > Common > Retail channels > Online stores. In the Online stores 
list, double-click a store. In the Online store form, on the Action Pane, on the Set 
up tab, in the Setup group, click Store locator group assignment.  
 

2. In the Store locator group assignment form, in the Locator group field, select 
the store locator group to assign a store to.  
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3 RETAIL WORKFLOW 

OVERVIEW 

In this module we will discuss how to set up an approval process, you can create a 
workflow. A workflow represents a business process. It defines how a document flows 
through the system and indicates who must complete a task or approve a document. 
There are several benefits to using the workflow system in your organization. These 
benefits include the following:  

 Consistent processes — The Approval Process can be defined by users for specific 
documents, such as purchase requisitions and expense reports. Using the 
workflow system helps to make sure that documents are processed and 
approved in a consistent and efficient manner.  

 Process visibility — Users can track the status, history, and performance metrics 
of a specific workflow instance. This helps determine whether changes should be 
made to the workflow to improve efficiency.  

 Centralized work list — Users can view a centralized work list to view the 
workflow tasks and approvals that are assigned to them. This work list is 
available from the Role Center pages in the Microsoft Dynamics AX client and the 
Enterprise Portal.  

3.1.1 CONFIGURE THE WORKFLOW SYSTEM 

In Microsoft Dynamics AX, to use the workflow functionality, Microsoft Dynamics AX 
administrators must complete the following procedures.   

3.1.1.1 Specify the workflow execution account 

Complete the following procedure to select a domain account to serve as the workflow 
execution account. The workflow execution account runs business logic for the 
application and accesses Microsoft Dynamics AX data.  

The domain account that you select to serve as the workflow execution account must 
have the following characteristics:  

 Dedicated account—used only for a specific purpose 
 Password that does not expire 
 Minimal access to network resources 

1. Click System administration > Setup > System > System service accounts.  
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2. Go to the Workflow execution account area of the form.  
3. Specify a domain account to serve as the workflow execution account. You can 

specify the domain account in one of two ways:  
o Enter the domain and user name, or alias, of the account.  
o Select a Microsoft Dynamics AX user.  

The account that you specify is assigned to the Microsoft Dynamics AX system 
administrator role.  

4. If you use Microsoft Dynamics AX 2012 R2, repeat steps 1 through 3 for each 
partition in your Microsoft Dynamics AX installation.  

3.1.1.2 Select number sequences for the workflow system 

An identification number is automatically assigned to every workflow that is created and 
every instance of a workflow that is generated. The identification numbers are based on 
number sequences. This topic provides information that will help you create number 
sequences. It also describes how to specify the number sequence that is used to 
generate IDs for workflows, and the number sequence that is used to generate IDs for 
workflow instances. 

To specify which number sequences are used to generate workflow IDs and workflow 
instance IDs, follow these steps.  
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1. Click System administration > Setup > System parameters.  
2. Click Number sequences.  

 

3. On the Workflow ID row, in the Number sequence code field, select the number 
sequence to use to generate workflow IDs.  

4. On the Instance ID row, in the Number sequence code field, select the number 
sequence to use to generate workflow instance IDs.  

3.1.1.3 Configure the workflow batch jobs 

The workflow system uses batch jobs to process messages, determine due dates for 
work items, and process notifications for line items. 

1. Click System administration > Setup > Batch group.  
2. Click New to create a new batch group.  
3. In the Group field, enter a unique name for the batch group. For example, enter 

Workflow.  
4. In the Description field, enter a description to help you identify the batch group.  
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5. Click the Batch servers Tab.  

The Selected servers list displays the AOS instances that the batch group runs on. 
The Remaining servers list displays the remaining AOS instances that are 
available as batch servers.  

6. Use the arrow buttons to add servers to the Selected servers list or to remove 
servers from the Selected servers list.  

3.1.1.3.1 Run the Workflow infrastructure configuration wizard 

Run the Workflow infrastructure configuration wizard to specify how often workflow 
batch jobs should run.  

1. Click System administration > Setup > Workflow > Workflow infrastructure 
configuration.  

2. On the Welcome to the Workflow infrastructure configuration wizard page, 
click Next.  

3. On the Configure the workflow message processing batch job page, select a 
batch group, and then click Next.  

4. On the Configure the workflow due date processing batch job page, specify how 
often workflow due dates should be calculated by doing the following:  

o Select a batch group.  
o Enter a number of hours to indicate how often the batch job should run.  
o Click Next.  

5. On the Configure the line-item workflow notifications batch job page, specify 
how often line-item notifications should be processed by doing the following:  

o Select a batch group.  
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o Enter a number of minutes to indicate how often the batch job should 
run.  

o Click Next.  
6. On the Completing the workflow infrastructure configuration wizard page, click 

Finish to close the wizard.  

3.1.1.4 Set up users for the workflow system 

To make sure that Microsoft Dynamics AX users can participate in workflow processes, 
you must complete the following steps:  

 Assign users to roles – Assign users to roles in Microsoft Dynamics AX.  

1. Click System administration > Setup > Security > Assign users to roles.  

 

2. Select a role. The users who are currently assigned to the role are displayed.  
3. In the Rules for dynamically assigning users to role pane, click Add rule to 

open a list of queries that can be used for automatic role assignment. 
Queries in the list use the UserInfo table as the primary data source, and the 
User field is included in the list of fields.  

Important  

By default, the Security administrator role has access to only a subset of 
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tables and fields in Microsoft Dynamics AX. If the Security administrator role 
is required to use other tables in a query, the permissions for the role must 
be modified to grant access to those tables.  

4. Select a query in the list.  
a. To modify a query, select it, and then click Edit query. In the Inquiry 

form, use the Range FastTab to add or remove fields. Click OK to save 
the query. When you save a query, it runs immediately.  

5. The rule is assigned a default name. If necessary, you can modify the name or 
add a description by typing in the list.  

 

 Assign users to employee IDs – Assign each user to an employee ID by specifying 
user relations.  

1. Click System administration > Common > Users > User relations.  

 

2. Click New.  
3. In the Person list, select the person, and then click OK.  

a. If the person's name is not in this list, then the person has not 
completed the customer/partner on-boarding processes and he or 
she does not exist in the global address book.  

4. In the User ID list, select the Microsoft Dynamics AX user ID for this relation. 
If the user ID that you want to assign is not in this list, then make sure that 
the ID is added to the list of Microsoft Dynamics AX users.  

5. If the user is external to your business or organization, such as a customer or 
partner, click the Add button under External relations.  
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a. In the Relationship list, select the type of external relation for this 
user.  

b. In the Party list, select the user's business or organization.  
6. Click Close to save your changes.  

3.1.1.5 Configure workflow notifications 

You can configure the workflow system so that users receive email notifications when 
workflow-related events occur. For example, notifications can be sent to users who have 
documents to approve. 

To use an email template for alerts, broadcasts, or other functions in Microsoft 
Dynamics AX, you must create an email ID and then specify this email ID for the 
function.  

1. Click Organization administration > Setup > E-mail templates.  
2. Press CTRL+N to create a new email ID.  

 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

48 

 

3. Enter the following information for the email ID:  
o In the E-mail ID field, create an ID that corresponds to the function that 

the ID will be used for.  
o In the E-mail description field, create an optional description of the email 

ID.  
o In the Default language code field, select the language code. The 

language code determines the template to use when a user has set a 
language that is different from any available templates.  

o In the Sender name field, enter the sender name. This is the name that is 
visible in the recipient’s inbox when he or she receives an email message.  

o In the Sender e-mail field, enter the email address.  
o In the Priority field on the General tab, enter a priority. This determines 

whether the email message appears with priority in the recipient’s inbox.  
o In the Batch group field on the General FastTab, enter a batch group. 

This determines the batch that will process the email construction.  
4. In the lower pane, press CTRL+N to create a template. You can create a template 

for each language. For each template, enter the following information:  
o The email ID is automatically entered in the E-mail ID field, based on the 

ID that you created.  
o In the Language field, select the language code.  
o In the Layout field, select either XSLT or HTML. Depending on your 

selection in the Layout field, the message is displayed in either XSLT or 
HTML.  

5. Click E-mail message to open a form where you can type the contents of your 
message. Depending on your selection in the Layout field, the XSLT editor form 
or the E-mail editor form is opened.  

Tip  

A set of merge-data elements can be added to the email template. You can insert the 
merge-data elements into the body text and the subject line of the email template. For 
example, if you add the %subject% merge-data element, the actual value of %subject% 
is inserted into the email message when it is sent. 

3.1.1.6 Configure work item queues 

A manual task can be assigned to a work item queue. A work item queue is a collection 
of documents that must be processed. Every work item queue must have users assigned 
to it who are responsible for monitoring the queue and processing the documents that 
are in it. The following topics explain how to create and use work item queues. 

When you create a queue, you are automatically assigned as the administrator of the 
queue. Queue administrators can change the status of the queue, assign users to the 
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queue or unassign users from the queue. Additionally, the administrator can specify the 
conditions for which the queue is used. 

To configure a work item queue, follow these steps.  

1. Click Organization administration > Setup > Workflow > Work item queues.  

 

2. Click New.  
3. In the Name field, enter a name for the queue.  
4. In the Description field, enter a description to help you identify the queue.  
5. In the Document field, select the type of document that will be sent to this 

queue for processing.  
6. In the Status field, select one of the following options.  

Status  Description  

Active Documents can be sent to the queue for 
processing. 

On 
hold 

Documents cannot be sent to the queue for 
processing. Use this status when you want to 
process all the documents in the queue before 
you set the status of the queue to Inactive.  

Inactive Documents cannot be sent to the queue.  

7. Expand the Users FastTab.  
8. To assign the user to the queue, click Add, and then follow these steps.  
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a. In the User field, select the user name of the Microsoft Dynamics AX 
user to assign to the queue.  

b. Select the Administrator check box if this user should be the 
administrator of the queue.  

i. A queue must have at least one administrator.  
9. Click Work item queue assignment rules. The Work item queue assignment 

rules form is displayed.  
10. Select a type of document from the Document list. This indicates that the 

rule applies to a queue that is configured for the selected type of document.  
11. Click New to create a new assignment rule.  

 

12. In the Create new work item queue assignment rule form that appears, 
follow these steps.  

a. In the Name field, enter a name for the assignment rule.  
b. In the Description field, enter a brief description to help identify the 

rule.  
c. In the Queue name field, select a queue. Documents that meet the 

specified conditions of the rule will be sent to this queue.  
d. Click Create rule to create the rule.  

13. To specify the conditions for which this rule applies, follow these steps.  
a. Select the rule in the left pane of the form.  
b. Expand the Conditions FastTab.  
c. Click Add condition.  
d. Enter a condition.  
e. Enter additional conditions, if they are required.  

14. To specify when this rule is evaluated, select the Move up or Move down 
buttons. 

To create a queue group, follow these steps.  
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1. Click Organization administration > Setup > Workflow > Work item queue 
groups.  

2. Click New.  
3. In the Name field, enter a name for the queue group.  
4. In the Description field, enter a description to help identify the queue group. 
5. Select the group to add queues to or remove queues from.  
6. To add a queue to the group, select the queue in the Available work item 

queues list, and then click the arrow button to move it to the Selected work 
item queues list.  

7. To remove a queue from the group, select the queue in the Selected work 
item queues list, and then click the arrow button to move it to the Available 
work item queues list 

8. To view the work items in the queues that you administer, go to  

Home > Common > Work items > Work items assigned to queues I 
administer. 

3.1.2 CREATE THE RETAIL WORKFLOW 

To create a retail workflow, follow these steps. 

1. Click Retail > Setup > Retail workflows.  
2. On the Action Pane, click New.  
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3. Select the type of workflow that you want to create, and then click Create 
workflow.  

4. The Workflow elements area of the workflow editor contains the elements that 
you can add to your workflow. Drag the elements that you want to use to the 
canvas. 

5. To connect one workflow element to another, hold the pointer over an element 
until connection points appear. Click a connection point and drag it to another 
element. Make sure that you connect all the elements. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

53 

 

3.1.3 CONFIGURE THE RETAIL WORKFLOW 

 

To configure the properties of a workflow, open the workflow in the workflow editor, by 
following these steps.  

1. Click the canvas of the workflow editor and then click Properties to open the 
Properties form. In the left pane, click Basic Settings.  
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2. In the Name field, enter a unique name for the workflow.  
3. From the Owner list, select the name of the person who will manage this 

workflow. 
4. From the Email template for workflow notifications list, select the template.  

You can provide instructions to users who submit documents for processing and 
approval. This documentation refers to these users as originators. To view 
instructions, the originator clicks the icon in the workflow message bar.  

5. In the Submission instructions box, enter the instructions.  
6. To personalize the instructions, you can insert placeholders. The placeholders 

are replaced with the appropriate data when they are displayed to users. To 
insert a placeholder, follow these steps.  

a. Click in the box to specify where the placeholder should appear.  
b. Click Insert placeholder.  
c. From the list that is displayed, select the placeholder to insert.  
d. Click Insert.  

7. To add translations for the instructions, click Translations. In the form that is 
displayed, follow these steps.  

a. Click the Add button.  
b. In the list that is displayed, select the language in which you will enter the 

text.  
c. In the Translated box, enter the text.  
d. To personalize the text, you can insert placeholders. Refer to previous 

step for instructions about how to enter a placeholder.  
e. Click Close.  

8. On the left pane, click Activation.  
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9. Select the Set the conditions for running this workflow check box.  
10. Click Add condition.  
11. Enter a condition.  
12. Enter additional conditions, if they are required.  
13. To make sure that the conditions that you entered are set correctly, click Test. 

The Test workflow condition form is displayed.  

i. Select a record in the Validate condition area of the form. Click 
Test. The system evaluates the record to determine whether it 
meets the conditions that you specified.  

 For example, if you create a purchase requisition workflow 
for Spain, the Validate condition area of the form displays 
a list of purchase requisitions. When you click Test, the 
system evaluates the selected purchase requisition to 
determine whether the country/region = ES.  

14. Click OK or Cancel to return to the Properties form.  

To configure notifications, follow these steps. 

1. On the left pane, click Notifications.  
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2. Select the check box for each event that will trigger notifications:  
o Started - Send notifications when a workflow instance starts.  
o Stopped - Send notifications when a workflow instance stops because of 

an error.  
o Completed - Send notifications when a workflow instance is completed.  
o Unrecoverable - Send notifications when a workflow instance stops 

because of an unrecoverable error.  
o Terminated - Send notifications when a workflow instance is terminated.  

3. Select the row of the event that you selected in step 2.  
4. Click the Notification text FastTab.  
5. In the text box, enter the text for the notification.  
6. To personalize the text, you can insert placeholders. The placeholders are 

replaced with the appropriate data when they are displayed to the users. To 
insert a placeholder, follow these steps.  

a. Click the text box to specify where the placeholder should appear.  
b. Click Insert placeholder.  
c. From the list that is displayed, select the placeholder to insert.  
d. Click Insert.  

VII. To add translations for the text, click Translations. In the form that is displayed, 
follow these steps.  

i. Click the Add button.  
ii. In the list that is displayed, select the language in which you will enter 

the text.  
iii. In the Translated text box, enter the text.  
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iv. To personalize the text, you can insert placeholders. Refer to step 6 
for instructions about how to enter a placeholder.  

v. Click Close.  
VIII. Click the Recipient tab.  

IX. Specify who receives the notifications from the following options.  

Option  Select this option to 
send notifications 

to…  

To send notifications, do this…  

Participant Users who are 
assigned to a 
specific group or 
role.  

On the Recipient tab, click Participant.  

Click the Role based tab.  

From the Type of participant list, select the 
type of group or role to send notifications 
to.  

From the Participant list, select the group 
or role to send notifications to.  

Workflow 
user 

Users who are 
participants in this 
workflow.  

On the Recipient tab, click Workflow user.  

Click the Workflow user tab.  

From the Workflow user list, select a 
participant in this workflow.  

User Specific Microsoft 
Dynamics AX users.  

On the Recipient tab, click User.  

Click the User tab.  

The Available users: The list includes all 
Microsoft Dynamics AX users. Select the 
users to send notifications to, and move 
the users to the Selected users: list.  

X. Repeat steps 3 through 9 for each event that you selected in step 2.  
XI. In the left pane, click Notes.  
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XII. In the Enter comments about the workflow text box, enter your comments.  
XIII. Review your comments. After you add comments, you cannot modify the 

comments.  
XIV. Click Add to add comments to the Comment history area.  

3.1.4 ACTIVATE THE RETAIL WORKFLOW 

After you activate a workflow, users can submit documents to the workflow for 
processing. There can be several versions of a specific workflow. However, only one 
version can be the active version.   

Note  

The workflow version that you want to activate must not include any errors and 
warnings.  

You can activate a valid workflow when you save it in the workflow editor. If there are 
multiple versions of the workflow, the older version is inactivated when you activate the 
new version.  

To activate a workflow in the workflow editor, follow these steps.  

1. Click Save and close to close the workflow editor. The Save workflow form is 
displayed.  

2. Enter comments about the changes that you made to the workflow.  
3. Click OK. The Activate workflow form is displayed.  
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4. Click Activate the new version.  

 

 

To activate the workflow from a list page, follow these steps.  

1. Click Retail > Setup > Retail workflows. A list page is displayed.  
2. Select the workflow to activate.  
3. On the Action Pane, click Versions to open the Workflow versions. 

 

4. Select the workflow version to activate.  
5. Click Make active.  
6. Click OK to close the Workflow versions form.  
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3.1.5 ASSOCIATE THE WORKFLOW WITH AN ORGANIZATION 

Some workflows are used to process documents that are associated with your whole 
organization. However, other workflows are used to process documents that are 
associated with a specific organization, such as a legal entity. For this kind of workflow, 
to select the specific organization that the documents in the workflow are associated 
with, follow these steps. 

1. Click Retail > Setup > Retail workflows.  
2. Select the workflow to associate with a specific organization.  
3. On the Action Pane, click Associate. The Workflow association form is displayed.  

 

4. Select the organization to use the selected workflow with.  
5. Click Associate.  

3.1.6 MONITOR THE STATUS OF WORKFLOWS 

To view the status and the history of a workflow instance, follow these steps.  

1. Click Home > Inquiries > Workflow > Workflow history.  
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2. To filter the list of workflow instances that is displayed in the form, select a 
workflow status in the Filter by status field:  

o All – Display all workflow instances.  
o Pending – Display only workflow instances that are currently processing.  
o Completed – Display only workflow instances that have completed the 

required processing.  
o Canceled – Display only workflow instances that are canceled.  
o Stopped (error) – Display only workflow instances that have stopped 

because of an error.  
o Unrecoverable – Display only workflow instances that have stopped 

because of an unrecoverable error.  
3. On the Overview tab in the upper part of the form, select a workflow instance.  

Details about the workflow instance are displayed on the following tabs in the 
lower part of the form:  

o Overview – This tab displays the status of the workflow instance and 
indicates where the submitted document is in the workflow.  

o Work items – Use this tab to assign a task or approval step to another 
user.  

o Tracking details – This tab displays the history of the workflow instance.  

To stop a workflow instance, follow these steps.  

1. Click Home > Inquiries > Workflow > Workflow history.  
2. From the Filter by status list, select one of the following statuses to filter the list:  

o Pending – Display only workflow instances that are currently processing.  
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o Stopped (error) – Display only workflow instances that have stopped 
because of an error.  

3. Select the workflow instance that you want to stop.  
4. Click Recall. The Cancel workflow dialog box is displayed.  
5. Enter a comment that explains why you are canceling the workflow instance.  
6. Click OK. 

To resume the processing of the workflow instance that is stopped because of an error, 
follow these steps.  

1. Click Home > Inquiries > Workflow > Workflow history.  
2. From the Filter by status list, select Stopped (error). All workflow instances that 

are stopped because of an error are listed in the form.  
3. Select the workflow instance to restart.  
4. Click Resume.  

Microsoft Dynamics AX includes reports that can help track the history and the current 
status of business processes in the organization. Therefore, you can more easily identify 
processes that have become inefficient. To view the reports, follow these steps.  

1. Click Organization administration > Reports > Workflow.  
2. The following reports are available:  

o Workflow automation report (WorkflowAutomationReport)  
o Workflow elements automation report 

(WorkflowElementsAutomationReport)  
o Workflow elements performance report 

(WorkflowElementsPerformanceReport)  
o Workflow instance by status report (WorkflowInstanceByStatusReport)  
o Workflow participants performance report 

(WorkflowParticipantPerformanceReport)  
o Workflow performance report (WorkflowPerformanceReport)  
o Workflow tracking report (WorkflowTrackingReport)  

3.1.7 RESPOND TO WORK ITEMS IN THE WORKFLOW 

Work items are workflow-related tasks that are assigned to you. For example, you might 
have to approve a document, make a decision about a document, or complete a task 
that is associated with a document. The following topics explain how to respond to the 
work items that are assigned to you. 

1. Click Home > Common > Work items > Work items assigned to me.  

http://technet.microsoft.com/EN-US/library/hh334493.aspx
http://technet.microsoft.com/EN-US/library/hh334507.aspx
http://technet.microsoft.com/EN-US/library/hh334507.aspx
http://technet.microsoft.com/EN-US/library/hh334487.aspx
http://technet.microsoft.com/EN-US/library/hh334487.aspx
http://technet.microsoft.com/EN-US/library/hh334478.aspx
http://technet.microsoft.com/EN-US/library/hh334506.aspx
http://technet.microsoft.com/EN-US/library/hh334506.aspx
http://technet.microsoft.com/EN-US/library/hh334481.aspx
http://technet.microsoft.com/EN-US/library/hh334474.aspx
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2. Review the list of work items.  

Processes that are available include the following: 

 Act on a task 

 Review a document assigned to you for approval 

 Make a decision 

 Delegate work items in a workflow 

3.1.7.1 Act on a task 

A task is a unit of work that is associated with a specific business document. For 
example, the workflow for a purchase requisition can have a task that requires you to 
perform the following:  

 Add a vendor to each line item on the purchase requisition.  
 Call the vendors that are listed on the purchase requisition.  

To act on a task that is assigned to you, follow these steps.  

1. Open the document that the task is associated with.  

http://technet.microsoft.com/EN-US/library/gg212774.aspx
http://technet.microsoft.com/EN-US/library/gg243087.aspx
http://technet.microsoft.com/EN-US/library/hh202072.aspx
http://technet.microsoft.com/EN-US/library/gg213581.aspx
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2. Review the message bar for information about the workflow process. To view 
detailed instructions, click the icon in the message bar.  

3. A task can be assigned to multiple people. However, only one person can 
complete the task. If this task is assigned to multiple people, and you want to 
complete it, click Actions > Accept. This indicates that you will complete the task.  

4. Click Actions and then click one of the options that are listed in the following 
table. The options that are visible can depend on how the task is configured.  

Option  Description  

Complete  Indicates that you have completed the task.  

A dialog box is displayed where you can enter a comment about the 
document.  

Reject  Reject the document.  

A dialog box is displayed where you can enter a comment about the 
document.  

Request 
change  

Request changes to the document.  

A dialog box is displayed where you can enter a comment about the 
changes that you are requesting and select the user who should make the 
changes.  

Delegate  Reassign the task to another user.  

A dialog box is displayed where you can enter a comment and select the 
user to delegate the task to.  

Reassign  Reassign the task to another work item queue.  
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A dialog box is displayed where you can enter a comment and select the 
queue to reassign the task to.  

Release  Reassign the task to the work item queue that it is originally assigned to. 
Select this option if you cannot complete the task. The task is returned to 
the queue so that another user can complete it.  

A dialog box is displayed where you can enter a comment.  

View 
history  

View the workflow status and the history of the document.  

The Workflow history form is displayed.  

3.1.7.2 Delegate work items in the workflow 

If you plan to be out of the office or otherwise unavailable to act on work items, you can 
delegate, or reassign, your work items to other users.  

You can configure the system to automatically delegate your work items, or you can 
manually delegate a specific work item to another user.  

3.1.7.2.1 Set up automatic delegation  

 

To configure Microsoft Dynamics AX to automatically delegate your work items to other 
users, you must create delegation rules. These rules must specify when certain types of 
work items are delegated. To create a delegation rule, follow these steps.  

1. Click File > Tools > Options.  
2. In the left pane, click Delegation.  

javascript:void(0)
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3. Click Add to create a delegation rule.  
4. In the Scope field, select one of the following options:  

o All – Delegate all work items that are assigned to you.  
o Module – Delegate only the work items that are related to a specific type 

of workflow. If you select this option, you must select the type of 
workflow in the Name field.  

o Workflow – Delegate only the work items that are related to a specific 
workflow. If you select this option, you must select the workflow in the 
Name field.  

5. In the Delegate field, select the user to delegate the work items to.  
6. Use the Start date/time field and the End date/time field to specify when you 

want the work items to be automatically delegated.  
7. Select the Enabled check box to activate the delegation rule.  
8. In the Comment field, enter a comment that explains why you are delegating the 

work items.  

3.1.7.2.2 Manually delegate a specific work item  

To manually delegate the work item when you view a document, follow these steps.  

1. Open the document that you are assigned the work item for.  
2. On the workflow message bar, click Actions > Delegate. A dialog box appears.  
3. Select the user to delegate the work item to.  
4. Enter a comment that explains why you are delegating the work item.  
5. Click Delegate. 

javascript:void(0)
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4 REASON CODES 

OVERVIEW 

In this module we will discuss how to use reason codes to capture data at the point-of-
sale (POS). Reason codes are information codes that capture additional information 
when a POS user performs several actions at the point-of-sale, such as an item sale, item 
return, or a customer selection. Microsoft Dynamics AX prompts the POS user that is at 
the register and asks for input that can be selected from a list or entered as a code, a 
numeric, a date or as text. Additionally, reason codes can be assigned to predefined 
store actions, retail items, tender types, customers, and specific POS activities. 

Consider the following:  

 When a business uses reason codes, the business can receive additional 
information that is needed at the time of the transaction, such as a flight 
number, reasons for returns, and so on. 

 Reason codes can be set up for specific item prices that prompt the POS user 
that is at the register to select one of many prices. 

 Reason codes can have a subcode that is linked to the reason codes that 
prompts the cashier at the register for input while he or she performs a specific 
activity. 

 Items can be sold through the reason code as a normal sale, discounted sale, or a 
free item. 

 CREATE THE REASON CODE  

To create the reason code, follow these steps. 

1. Click Retail > Setup > Reason Codes. 
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2. Click Reason Code to display the Reason codes form. 
 

3. In the Reason codes form, click New to create the new reason code. 

 

4. Enter the necessary information on the Reason codes form.  
1. The fields that are displayed on the Reason codes form are described in the 

following table. 

Overview 
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 Reason Code Number: Enter a unique identifier for the reason code. 

 Description:  Enter a brief description about the reason code. 

 Prompt: The title of the action that the POS user is requested to perform. 

 Input Type: The predefined input type. The type is used for the validation of the 
data that is entered by the POS cashier. 

o None - A prompt on POS as a text box. The cashier can either input any 
text in this field or save the transaction with a blank reason code record. 

o Sub code list: Prompts and calls the function as it is defined in the Trigger 
function field that is on the Sub code forms. Select this option if the 
prompts and the call number are more than five. The functions appear as 
a list. 

o Date - A prompt to enter the date. The format in which the order that the 
date must be filled is MM/DD/YY.  

o Numeric - A prompt to the cashier for numeric data input. This value is 
not displayed on POS. However, the value is saved in the database. The 
value attaches a number to an item that is sold on POS. 

o Item - A list of retail items is displayed on the POS. The POS cashier must 
select an item that is not displayed on POS. However, this item must be 
stored in the database as information.  

o Customer - A list of retail customers is displayed on the POS, and the 
cashier can select the customer. The selected customer is not displayed 
on POS. However, the customer must be stored in the database as 
information for that record.  

o Staff - A prompt to enter the cashier staff ID. The cashier staff ID is not 
displayed. However, the cashier staff ID is stored in the database.  

o Text - A prompt for the input of an information text message.  
o Sub code buttons - Prompts and calls the function as it is defined in the 

Trigger function field on the Sub code form. Select this option if the 
prompts and the call number are five or less. The functions appear as 
buttons.  

o Age limit - Enter an integer that represents the age that is required for a 
customer to purchase an item. 

General FastTab 

The fields on the General FastTab are described as follows:   

 Input 

o Input Required – Select whether the cashier is required to enter a 
response to the prompt for the reason code, and the frequency of that 
input. 
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o One time for each transaction.  

 Linking 

o Linked Reason Code – Displays the associated reason code when the 
reason code is closed. 

 Values 

o Minimum value – The minimum amount that staff can enter 
o Maximum value – The maximum amount that staff can enter 
o Minimum length – The minimum length of a reason code 
o Maximum length – The maximum length of a reason code 

 Interval 

o Frequency percent – Set the frequency that the prompt for a reason code 
appears. For example, you want the cashier to ask for the customer’s ZIP 
code or postal code before the start of every transaction. In this case, set 
Frequency percent to 100. 

 Store Inventory 

o Use for counting – Select the check box if the reason code can be used for 
counting. 

 

Printing FastTab 

The fields on the Printing FastTab are described as follows: 

 Print Prompt on receipt – Select the check box to print the prompt question on 
the receipt. 

 Print input on receipt – Select the check box to print the input that is provided by 
the customer for the prompt question on the receipt. 

 Print Input Name on receipt – Select the check box to print the input name of the 
information that is captured by the cashier on the receipt. 

Ribbon on the Reason code Creation Form 

 

5. Click Subcodes to create the subcodes for a selected reason code. Refer to the 
following topic to create subcodes. 
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4.1.1 CREATE THE SUBCODE 

You can set up the reason code to have a number of subcodes that are either displayed 
in a list or as buttons. The subcode triggers the action that is based on the reason codes 
that are static.  Typically, the subcode is used to present the point-of-sale user with a list 
of available responses. For example, you could set up a subcode to remind staff to check 
age requirements or you could remind the POS user to select the subcode when he or 
she provides the customer a discount on the sale.  

To create the subcode, follow these steps. 

1. Click Retail > Setup > Reason codes. 
 

2. On the Reason Code form, highlight the Reason code value in the left navigation 
pane that has an input type of Subcode buttons or the Subcode list for which 
the subcodes must be created. 

 
 
3. Click the Subcodes on the tool bar of the Reason Code form. 

 
4. Click New to create the new subcode or click Delete to delete the existing 

subcode. 
5. Enter the necessary information on the Subcodes form. The fields on the 

Subcodes form are described as follows: 
a. Sub-code number – The unique ID for the subcode. 
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b. Description – The description of the subcodes. The description should 
include all the options that are available in the subcode. The selected value 
among these options is taken as the input for the reason code trigger. 

c. Trigger function – Select an option that is responsible for taking action. 
d. Trigger Code – The trigger code should be filled with an item number. This 

number attaches the item that is referenced in the Trigger code column 
when it is selected. 

e. Price type – Select a price type from the drop-down list box. The price type 
defines where the price is selected from for the items that are attached to 
the reason code that is used for selling. The options that are available 
include the following: 

i. From product – The price will originate from the product. 
ii. Price – The price will be specified in the Amount/Percent field. 

iii. Percent – The discount percentage will be specified in the 
Amount/Percent field. 

f. Amount/Percent: 

i. Price – The corresponding value in the Amount/Percent column should 
have a value other than the sales price that is mentioned in the 
Price/Discount FastTab on the Retail items form or in the Trade 
agreement. 

ii. Percent – The item that is displayed in the Trigger code column is called 
with a reduced price. The price that is reflected on POS is the sales price of 
the item in the Retail item form, minus the discount percentage that is 
displayed in the Amount/Percent column. 

 From item – The charged price is taken from the Price/Discount tab 
on the Retail items form or in the Trade Agreement. 

 Price – The corresponding value in the Amount/Percent column 
should have a value other than the sales price that is mentioned in 
the Price/Discount tab on the Retail items form or in the Trade 
agreement. 

 Percent – The item that is displayed in the Trigger code column is 
called with a reduced price. The price reflected on POS is the sales 
price of the item in the Retail item form, minus the discount 
percentage that is displayed in the Amount/Percent column. 

You can use the Subcodes form to create and edit subcodes. All actions that are 
triggered by this subcode are based on the setup criteria. 
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4.1.2 REASON CODE TRANSACTIONS 

It helps to review the transactions at the POS that are assigned reason codes to 
understand the use and importance of the reason codes that are used from returns or 
from upselling.  

To review reason code transactions, follow these steps.  

6. Click Retail > Setup > Reason codes. 
7. Click Reason code transactions from the tool bar that is located at the top of the 

screen. The Reason code transactions form opens. 
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8. Click the General FastTab to review the details of the transaction header. 

 

The main sections to review the Reason code, Transaction identification, Statement, 
Amount and Transaction origin.  

 

9. To drill down to the transaction details, click the Transactions button on the 
right side of the form. 

 

The Overview tab displays the sales transactions that are associated with the reason 
code. 

10. Click the General tab to view transaction information about the following: 
a. Statement number to which the transaction is associated. 
b. Customer information if it is captured as part of the transaction. 
c. Loyalty card details if the customer is a loyalty customer. 
d. Transaction origin – This shows the details for the store where the 

transaction occurs. 
11. Click the Amount FastTab to review the total of the transaction and the discount 

value if any discounts are applied as part of the transaction. 
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12. Click the Details FastTab to view the total lines in the transaction and the 
transaction date and time. 

 

13. Click the Account FastTab to view the amount that will be posted on the 
account. 

 

 
 

14. Click the financial dimensions to view the default financial dimensions for the 
transaction that will be inherited from the customer. 
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15. To view transaction related sales and payment information, click the 
Transactions button on the right side of the form. 

 

 
 

Reason code table assignments 

You should review the retail tables and the reference fields that reference the reason 
codes.  

To review reason code transactions, follow these steps. 

16. Click Retail > Setup > Reason codes. 
17. Click Table assignments from the tool bar that is located at the top of the screen. 

The Reason code table assignment form opens. 
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The form provides information on the table name, field reference and the prompt 
question that is specified for the table value. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

78 

 

5 UNIT OF MEASURE 

I this module we will explain a unit of measure is a standard base or a derived division of 
quantity that is used for measurement or exchange. For example, when you enter an 
order in Microsoft Dynamics AX, you specify both a quantity and the unit of measure 
that the quantity represents. 

 CREATE THE UNIT 

Click Organization administration > Setup > Units > Units. 

To create the unit of measure, follow these steps.  

1. Use the Units form to create units of measure. For example, when you enter an 
order in Microsoft Dynamics AX, you specify a quantity and the unit of measure 
that the quantity represents. 

 

2. Click New to add the new unit of measure.  

The fields on the Units form are described in the following table.  
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Fields  Description  

Unit  Identification of the unit of measure. Notice that the unit field is mandatory 

when you create the new unit of measure. Example:  Each or Box 

Description  A descriptive name of the unit of measure that is specified in the system 

language.  

Fixed unit 

assignment  

If this check box is selected, you can identify the unit of measure as one of 

the fixed units of measure that is listed in the Fixed unit field.  

Fixed unit  The fixed unit association is used to identify a specific unit of measure. By 

using this association, specific units of measure can be identified by the 

business logic in Microsoft Dynamics AX and conversions between the 

units of measure can be completed.  

Unit class  The classification for the unit of measure. The unit class represents a logical 

grouping of units of measure such as area, mass, or quantity.  

System of 

units  

The metric system of the unit of measure. Units of measure in the same unit 

class such as liter and gallon can belong to different metric systems. You 

can select one of the following:  

Note 

Units of measure that do not belong to the metric or the typical United 

States system of units. 

Tip: Examples of units of measure that use the None category include box 

and pieces. 

 Metric units: The international system of measurement.  

 United States customary units: The most commonly used system 

of measurement in the United States.  

Base unit  If this check box is selected, the unit of measure is defined as the base unit 

in the unit’s unit class. The base unit helps streamline the conversion setup 

for the unit of measure. When a base unit is defined in the unit class, the 

number of conversion rules between units of measure in the class can be 

limited. 
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Fields  Description  

For example, you have a conversion rule that lets milliliters be converted to 

liters, and another conversion rule that lets liters be converted to gallons. If 

you have specified liters as the base unit in the Liquid volume unit class, 

you can convert from gallons to milliliters without a conversion rule 

between these two units.  

System unit  Unit of measure that is applied when a measurement or quantity is entered 

in fields in Microsoft Dynamics AX that are not associated with a specific 

unit of measure.  

For example, you have a company where kilogram (kg) is set as the system 

unit. In this company, any weight measurement in the Mass unit class, such 

as net weight, that is entered for an inventory item is identified as kg.  

Decimal 

precision  

The number of decimals that the converted unit of measure is rounded to 

when a calculation is completed for the unit of measure.  

The following topics describe the controls that are available for unit of measures.  

 

5.1.1 UNIT CONVERSIONS 

Click Organization administration > Setup > Units > Unit conversions. 

Use this Unit conversions form to set up conversion rules that control the conversion 
between units of measure.  

Important 

 You can set up standard or product-specific conversion rules. If both a product-
specific and a standard conversion rule exist for a unit of measure, the product-
specific conversion rule is used to convert units of measure for the product. 

 You must enter the EFT server name in the Server name field. 

Note 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

81 

 

 A unit conversion that is defined to convert minutes to days is also used by 
Microsoft Dynamics AX to convert days to minutes. Each unit of measure can 
have multiple units of conversions associated with it. 

A unit conversion supports three specific conversions. The three specific conversions are 
described in the following table.  

Links  Description  

Standard 

conversions  

Set up standard conversion rules that apply for all products. 

 Note: 

Standard conversion rules can only be set up for units of measure in the same 

unit class. 

Intra-class 

conversions  

Set up product-specific conversion rules for units of measure in the same unit 

class. For example, you can set up a conversion rule for a product that 

converts pieces to boxes. Pieces and boxes both reside in the Quantity unit 

class.  

Inter-class 

conversions  

Set up product-specific conversion rules for units of measure across unit 

classes. For example, you can set up a conversion rule for a product that 

converts kilograms to liters. Kilograms are in the Mass unit class and liters are 

in the Liquid volume unit class.  

For example, in a retail scenario, a box is always denoted as a collection of 24 items. This 
can be created by using the Unit conversion form that is shown in the following 
illustration. 
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The fields in the Unit conversion form are described in the following table.  

Fields  Description  

Factor  Conversion factor between the From unit and the To unit. For example, 

the conversion factor from each box is 24 because there will be 24 items 

in a box. 

Numerator  

and  

Denominator  

With the numerator and the denominator values, you can indicate 

whether the relation between the From unit and the To unit is a 1:1 

ratio or if it is a fraction.  

For example, when you want to create a conversion rule for a product 

where only 24 products fit into a box. In this case you can set up a 

conversion factor with From unit = ea and To unit = box, and then 

enter 1 in the Numerator field and 24 in the Denominator field.  

From unit  The unit of measure that will be converted.  

To unit  The unit of measure that is the target of the conversion.  
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Inner offset  With the inner offset value, you can indicate a number that is added to 

the From unit before the factor and the fraction are applied.  

 Note 

This field is only shown for standard conversions with units of measure 

that belong to the Temperature unit class. 

Outer offset  With the outer offset value, you can indicate a number that is added to 

the From unit after the factor and the fraction are applied.  

 Note 

This field is only shown for standard conversions with units of measure 

that belong to the Temperature unit class 

Rounding  Rounding type that is used when you calculate units of measure to the 

To unit.  

5.1.2 TRANSLATED UNIT DESCRIPTIONS 

To create language-specific descriptions for the unit of measure through translated unit 
descriptions, follow these steps.  

1. Click Translated unit descriptions from the tool bar that is located at the top of 
the screen. 

2.  Click New to create a new translated unit description. 
3. Select the language from the drop down list box. 
4. Enter the Description of the unit for the language that is selected. 
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5.1.3 UNIT TEXTS 

To create unit texts for external documents in customer - or vendor-specific languages, 
follow these steps.  

 Click Unit texts from the tool bar that is located at the top of the screen. 

 Click New to create new unit texts. 

 Select the language from the drop down list box. 

 Enter the Text of the unit for the language that is selected. 

Note 

In new installations of Microsoft Dynamics AX, both the standard units and the 
conversions are automatically created. 

 

5.1.4 EXTERNAL CODES 

External codes are used to view or maintain external codes for fields that are defined to 
send and receive documents electronically through the Microsoft Dynamics AX 
Application Integration Framework (AIF). 

To select the External codes from the tool bar that is located at the top of the screen, 
follow these steps. 

 Click New to create a new external code. 

 Enter the code, and the external code definition value in the grid. 

 If a default value exists for the code, then enter the Value of the code by clicking 
the Add button from the bottom grid. 
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5.1.5 UNIT CREATION WIZARD 

You can use unit creation wizards to create many standard units and conversions. By 
using the unit creation wizard, you can modify the existing standard units and the 
conversion factors. 
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6 RETAIL PARAMETERS 

OVERVIEW 

In this module we will focus on an organization with a retail business operation needs to 
set up retail and scheduler parameters as defaults per legal entity which will be 
applicable to the retail stores connected to that legal entity. Additional shared 
parameters are defined that are used across legal entities. 

The user can initiate the creation of base configuration data which acts as the default 
configuration to drive specific areas like: 

 Statement Posting 

 Customer Orders 

 Default store and terminal 

 Scheduler configuration 

 Shared parameters across legal entities etc. 

For new installations please ensure the below steps are performed: 

 Obtain the company ID and create a new legal entity. 

 In Microsoft Dynamics AX, click Retail > Setup > Retail scheduler > Table 
distribution to open the Table distribution form. When it is first opened, the 
form is empty. Click Insert default setup, and then click through the 
confirmations to insert default data in the form. This step is necessary to enable 
data transfers between AX Retail and the POS terminals. For more information, 
click the Help button in the form. 

6.1.1 RETAIL PARAMETERS 

The retail parameters allows a company to specify the default setting for their retail 
business which is used both in Microsoft Dynamics AX Retail and Dynamics AX POS to 
determine the action to be taken based on the settings.  

To put it in perspective we can set the customer minimum deposit % to be 25% 
providing the cashier to collect the minimum deposit amount as per the business policy 
at the POS level. For example if the customer wants to place an item worth $100 as a 
deposit order then they have to pay $25 as a minimum deposit. 

To open the retail parameters form click Retail > Setup > Parameters > Retail 
parameters.  

Let’s go through in detail each of the sections to see how the retail business can 
leverage the default configuration. 
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6.1.1.1 GENERAL 

On the Retail parameters form click on General on the left hand side navigation. The 
general section is used to specify store-wide parameters, such as the default item type 
and the European Article Number (EAN) license number.   

The Initialize button is on the top tool bar of the Retail parameters form. The Initialize 
button is used to create base configuration data for Retail operations for the legal 
entity. 

1. Enter the EAN license number that is used to create bar codes that are based 
on the EAN standard. 

2. Select the Default inventory journal that is used by default when an 
inventory journal is posted in the Point of sale (POS) system. 

3. Under the Email notification area select the default Email notification 
profile to be used to send email notifications to customer regarding the 
various status of the sales order. Ex. Order creation, Order confirmation, 
Order shipped etc. 
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 Note: In Microsoft Dynamics AX, click Retail > Setup > Parameters > Retail parameters 
to open the Retail parameters form. Click Initialize, this step initializes configuration 
data for Retail. For more information, click the Help button in the form. 

Posting 

The posting section in Retail parameters form is used to specify parameters that are 
used to post discounts, inventory updates, settlements, and other retail operations.  

Click Posting from the left hand navigation on the Retail Headquarters parameters 
form. 

Periodic discounts 

1. Select the Post periodic discount check box to enable periodic offers to be 
posted to the ledger accounts. Periodic discounts include mix and match 
discounts, multi-buy discounts, and discount offers. 

2. Select the ledger account type used to post periodic discounts. The options 
available are: 

 Standard – If the account type is standard then the ledger accounts are 
disabled. Microsoft Dynamics AX for Retail uses the ledger account that is 
defined for inventory posting in Microsoft Dynamics AX. 

 Periodic – If the account type is periodic then go to step 3 to specify the 
ledger accounts. 

3. Select the Discount general ledger account that is used to post discounts. 
4. Select the Quantity discount general ledger account that is used to post 

quantity discounts. 
5. Select the Mix and match number general ledger account that is used to 

post mix and match discounts. 

Important 

Post infocode discount feature is not implemented in this release and might be 
removed from future releases. 
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Gift card 

Select the item number from the product list which represents the Gift Card item 
that will be used as default at the stores. 

 

 
 
E-mail receipt 
 

1. Select the Receipt option from the drop down list to define how the receipts 
are delivered in Microsoft Dynamics AX for Retail POS. The options available 
to send receipts are by email, print at POS or both. 

2. Enter a Subject line for the email receipts. 

3. Type a File name for the receipt attachment. 

 

Inventory update 

Inventory update process is a process to update the inventory without posting the 
statement. This basically means that the physical inventory is reserved. Then at a later 
time when the end of day statement is posted, the financial side is posted (revenue, 
issue, consumption, tax and so on). 

1. Select the Detail level for inventory updates from the drop down list. The options 
available are: 

a. Summary: Inventory update will be generated by summarizing the 
inventory transactions until the point when the update is initiated by the 
user or a scheduled batch job. The transactions are summarized by store 
warehouse and product. 

b. Details: Inventory update will be generated for every inventory 
transaction until the point when the update is initiated by the user or a 
scheduled batch job. 
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Settlement 

1. Select the Automatic settlement check box to automatically settle open invoices 
when a payment or credit note is updated. If the check box is cleared, you must 
settle accounts manually, either when you enter payments or later, by using 
open transaction editing. 

 

Aggregation 

The section is used to select if aggregation should be applied to safe drops, bank drops 
and voucher transactions at POS. 

1. Select the Safe drop check box to aggregate safe drops at posting. 
2. Select the Bank drop check box to aggregate bank drops at posting. 
3. Select the Voucher transactions to aggregate voucher transactions at posting. 

Note 

If the Voucher transaction is checked then at the time of posting the transactions 
being posted will be aggregated. These include sales revenue, taxes, customers, 
inventory transactions and more. This option speeds up the posting process and 
lowers the volumes of transactions created. 

 

Invoice 

The invoice section is used to define the default journal name and account number to 
capture customer payments. 

1. Select the Journal name from the drop down list. 
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2. Select the Account name from the general ledger accounts list. 

 

6.1.1.2 PRODUCT CREATION 

The product creation section defines the default warehouses that will be used for 
purchase order, inventory and sales order processes.  

Click Product creation from the left hand navigation on the Retail Headquarters 
parameters form. 

Default warehouse 

1. Select the default Purchase order warehouse used for purchase orders is 
creation. 

2. Select the default Inventory warehouse used for inventory journals or orders 
when retail products are created. 

3. Select the default Sales order warehouse used for sales order creation. 

 

Price 

1. Always create trade agreement for variants – Select this check box to define 
trade agreements at the variant level. 

 

Note 

Product variants comprises of item dimension combination or unique combination of 
color, size and configuration.  Ex. Men shoes size 12, color black. 
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6.1.1.3 CUSTOMER ORDERS 

The customer orders section is used to assign default parameters for sales order, 
quotation, order cancellations and charge codes. 

To access customer orders click Customer orders from the left hand navigation on the 
Retail Headquarters parameters form. 

Default order type 

1. Select the default order type from the drop down list. The value selected will be 
defaulted when the user creates an order. The options available are: 

 Sales order 

 Quotation 

 

Sales order 

1. Enter the Default deposit percentage value of the order’s total for customer 
deposits. The value entered will be enforced at the Point of Sale (POS) when 
cashiers are receiving customer deposits. 

2. Select the Pickup mode of delivery from the drop down list. The pickup mode 
selected with will be the default delivery mode. 

3. Select the Disposition code from the drop down list. The disposition code 
defines the default code used for customer return orders. 

 

Quotations 

1. Enter the default number of days until the quotation expires in the Days 
quotation expires field. 
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Order cancellation 

1. Enter the default Cancellation charge percentage of the order’s total. 

 

Charge code 

1. Select the default Shipping charge code from the drop down list. 
2. Select the default Cancellation charge code from the drop down list. 

 

Card Payment 

1. Select the default Terms of payment from the drop down list. 
2. Select the default Method of payment from the drop down list. 

 

6.1.1.4 REPLENISHMENT 

Click Replenishment from the left hand navigation on the Retail Headquarters 
parameters form. 
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1. Select if assortments are respected during cross-docking process from the drop 
down list. The option selected will be enforced in the cross docking process. The 
options available are: 

 Never 

 Always 

 Manual 
2. Select if assortments are respected during inventory allocation from the drop 

down list. The option selected will be enforced in the buyer’s push process. The 
options available are: 

 Never 

 Always 

 Manual 
3. Enter the number of coverage days for replenishment.  Coverage days are the 

minimum days accounted by assortment and replenishment process to include 
the new changes in the organization hierarchy scheduled to be published. 

6.1.1.5 NUMBER SEQUENCES 

The number sequences are used to define unique numbers and codes for retail entities 
like: 

 Credit memo 

 Mix and match group 

 Loyalty customer 

 Buyer’s push etc. 

Click Number sequences from the left hand navigation on the Retail Headquarters 
parameters form. 
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The fields that define number sequences are: 

1. Reference: The name of the number sequence. 
2. Number sequence code: The ID number of the number sequence. 
3. Reuse numbers: Select this check box to reuse numbers in the sequence that is 

no longer used. 
4. Use same number as: The name of another number sequence that uses the 

same numbers. 

 

Note 

To create Number Sequences right click on the respective number sequence code to 
view details and set-up scope parameters, segments, references and general set-up 
details. 

 Caution 

If the number sequence is not assigned for Gift Cards, Loyalty Cards, etc.  Users are prompted 
to enter the respective numbers at the time of creation or sales, this could cause duplication 
of the numbers. 

 

6.1.2 RETAIL SCHEDULER PARAMETERS 

The retail scheduler parameters are used to set default scheduler values and the related 
batch jobs. The default setting will be applied for new records. The default values can be 
changed for individual records as required. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

96 

 

To open retail parameters form click Retail -> Setup -> Parameters -> Retail scheduler 
parameters.  

6.1.2.1 GENERAL 

In the General section the user can select whether the retail information is distributed 
to stores, and specify how many documents are processed by distribution batch jobs. 

1. Select the System in use check box to turn on the distribution system. If you 
clear the check box, pre-actions are not generated. 

 Caution 

If pre actions are not generated then changes to the retail information won’t flow 
down to the stores. 

2. Enter the largest number of documents that is processed in a single batch job in 
the Number of documents in batch task field. 

 

6.1.2.2 DATA DELETION 

The data deletion section defines the number of days the actions, scheduler log files, 
messages, and pre-action log files are retained and then deleted as part of the clean-up 
process. 

Click Data deletion from the left hand navigation on the Retail scheduler parameters 
form. 

1. Enter the number of days in Days actions exists field until an action is 
automatically deleted. Enter 0 (zero) to prevent automatic deletion. To delete 
actions immediately, enter -1. 
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2. Enter the number of days in Days scheduler logs exist field until a log file for 
Retail Scheduler is automatically deleted. Enter 0 (zero) to prevent automatic 
deletion. To delete log files immediately, enter -1. 
 

3. Enter the number of days in Days messages exist field until a message for 
Microsoft Dynamics AX for Commerce Data Exchange: Synch Service is 
automatically deleted. Enter 0 (zero) to prevent automatic deletion. To delete 
messages immediately, enter -1. 
 

4. Enter the number of days in Days pre-action logs exist field until pre-action logs 
are automatically deleted. Enter 0 (zero) to prevent automatic deletion. To 
delete log files immediately, enter -1. 

 

Caution 

The data deletion setting needs to be evaluated based on the volume on the database, 
performance and audit requirements of the customer. 

6.1.3 RETAIL SHARED PARAMETERS 

Some Retail parameters that were company-specific in Microsoft Dynamics AX 2009 
have been converted to shared or global, parameters in Microsoft Dynamics AX 2012 
R2. 

To view shared parameters form click Retail -> Setup -> Parameters -> Retail shared 
parameters. 
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6.1.3.1 GENERAL 

The general section allows the user to define the local store number and the default 
exchange rate used across all retail legal entities. 

1. Select the Local store number from the drop down list which contains all the 
stores in the system. 

2. Based on the local store selected, the Local store name field gets populated with 
the store name. 

3. Select the default Exchange rate type used across all stores from the drop down 
list. 

 

6.1.3.2 LABELS 

The Labels section defines the label generation permission for products and shelf labels. 

Click Labels from the left hand navigation on the Retail shared parameters form. 

1. Select the Create product labels for generation from the drop down list. The 
options available are: 

 All distribution members: Selecting this option will apply the creation of 
product labels to all the stores. 

 Default include list: Selecting this option will apply the product label 
creation to the stores defined in the distribution location list called 
default include list. 

 Local store only: Selecting this option will apply the creation of product 
labels to the local store selected. 
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 None: selecting this option has doesn’t have any impact on the creation 
of shelf labels. 

2. Select the Create shelf labels for generation from the drop down list. The 
options available are: 

 All distribution members: Selecting this option will apply the creation of 
shelf labels to all the stores. 

 Default include list: Selecting this option will apply the shelf label 
creation to the stores defined in the distribution location list called 
default include list. 

 Local store only: Selecting this option will apply the creation of product 
labels to the local store selected. 

 None: selecting this option has doesn’t have any impact on the creation 
of product labels. 

 

6.1.3.3 NUMBER SEQUENCES 

The number sequences are used to define unique numbers and codes for retail entities 
like: 

 Stores 

 POS Terminals or Registers 

 Assortments 

 Discount codes etc. 

Click Number sequences from the left hand navigation on the Retail shared parameters 
form. 
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The fields that define number sequences are: 

5. Reference: The name of the number sequence. 
6. Number sequence code: The ID number of the number sequence. 
7. Reuse numbers: Select this check box to reuse numbers in the sequence that is 

no longer used. 
8. Use same number as: The name of another number sequence that uses the 

same numbers. 

 

6.1.3.4 BAR CODE 

1. Select the default Bar code setup format used for discounts from the drop down 
list.  
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6.1.3.5 SECURITY 

1. Enter the EFT password encryption name for EFTPOS security encryption. 
2. Enter the TS password encryption name for the terminal services security 

encryption. 
3. Enter the Staff password hash name for encryption of the staff password. 
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6.1.3.6 MEDIA FILES 

Under the Root directory for media files enter the URL location for the media files 
repository used for product enhancement to attach additional media information like 
images, video and web description etc. 

 

6.1.3.7 FACEBOOK 

Enter the Application ID to integrate with Facebook application. 
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6.1.3.8 TWITTER 

1. Enter the Consumer key which is the user identification name for the twitter 
account. 

2. Enter the Consumer secret which is the twitter account password. 
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6.1.3.9 CATALOG 

Enter the Maximum number of rows allowed for editing attributes in Excel. 

 

 

6.1.4 RETAIL EMAIL NOTIFICATION PROFILE 

To view Email notification profiles form click on Retail > Setup > Parameters > Retail 
Email notification profile.  
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1. Click on New to create a new email notification profile. 
2. Enter the Email notification profile name. 
3. Enter a Description for the newly created email notification profile. 
4. Select the Active check box to make use the email notification profile to send 

notifications to customers. 
5. In the grid below click on New to attach notification types to the profile. 
6. Select the Email notification type from the drop down list. The options available 

are: 
a. Order created: An email notification can be sent when a new order gets 

created for a customer. 
b. Order confirmed: An email notification can be sent when an order gets 

confirmed. 
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c. Picking completed: An email notification can be sent when the order 
items are picked for packing at a store or a distribution location. 

d. Packing completed: An email notification can be sent when the packing is 
complete and the order item are ready to be shipped. 

e. Order shipped: An email notification can be sent when the order is 
shipped advising the customer on the delivery date and tracking 
information based on the shipping method selection. 

f. Payment failed: Email notification can be sent advising the customer 
regarding the payment failure for the order. 

g. Customer created: Email notification can be sent for new customers. 
h. Password reset: Email notifications to advise customers on password 

reset for their account. 
7. Select the E-mail ID template to be used for the email notification type from the 

drop down list. 
8. Set the Active check box to enable the email notification type for the newly created 

profile. 

Note: 

Default email templates have been included out of-box in AX 6.2 release; however 
retailers can add their own templates or modify the default templates to meet their 
requirements. 

One or more email notification profiles can be setup in AX; however only can be set as 
default profile in Retail parameters form. 

The existing AX email notification infrastructure has been leveraged for this feature. 

6.1.4.1 CREATE AN EMAIL TEMPLATE 

To open the E-mail templates form right click on the E-mail ID field of the email 
notification form and select View Details.  
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On click of View Details the E-mail templates form will open. 
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1. Click on File > New to create a new e-mail template. 
2. Click on General tab; enter the E-mail ID template name. 

 
 

3. Enter the E-mail description for the template. 
4. Select the Default language code from the drop down list. 
5. Enter the Sender name to be displayed in the email notification sent to the 

customer. 
6. Enter the Sender e-mail to be displayed in the email notification sent to the 

customer. 
7. Under the Sender section enter the Sender name to be displayed in the email 

notification sent to the customer. 
8. Enter the Sender e-mail to be displayed in the email notification sent to the 

customer. 
9. Under the Priority section select the Priority level to be set for the notification. 

The priority level options are: 
a. Low 
b. Normal 
c. High 

10. Under the Batch section select the Batch group the e-mail template belongs from 
the drop down list. 

11. Select the grid below and click on File > New to add a new record. 
12. The E-mail ID field is default with the e-mail template name. 
13. Select the Language from the drop down list. 
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14. Enter a Subject to be included as the subject line in the email notification. 
15. Select the Layout from the drop down list. The options available are: 

a. HTML: The email message template is designed using the HTML format. 
b. XLST: The email message template is designed using the XML 

transformation to generate XML documents. 
16. Click on the E-mail message button to define the body for the email template. 

 

 
 

17. Select the Tabs at the bottom to define the body of the e-mail template in a specific 
format. 

18. After the body for the email template is defined click on File > Save to confirm and 
save the changes. 

19. Close the form to return to the e-mail templates form. 
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7 RETAIL POINT OF SALE – SET-UP 

In this module we will discuss Microsoft Dynamics AX for Retail POS is the point-of-sale 
(POS) program for Microsoft Dynamics AX for Retail. You can use Microsoft Dynamics AX 
for Retail POS to perform the following tasks:  

 Process sales  

 Operate the cash drawer  

 Scan bar codes  

 Print customer receipts  

 Calculate the sales total  

 Calculate tax  

 Calculate the change that is due back from the amount that is paid  

The POS tasks are performed by using a POS register. Each POS register is uniquely 
identified by a register number. You can use the POS register to complete the following 
store transactions:  

 Process product sales  

 Issue product refunds  

 Suspend transactions  

 Process customer loyalty transactions  

 Issue credit memos  

 Issue gift cards 

 Scan bar codes  

 Receive payments  

 Print receipts  

 Track customer orders  

 Process debit cards and credit cards  

 Connect to other systems on the network  

 Check inventory  
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Retail POS is built on the Microsoft .NET Framework. The easy-to-use graphical user 
interface (GUI) can be set up to meet the needs of many industries, such as food service, 
fashion, and grocery.  

This section includes instructions for the following tasks:  

 POS Profiles 

o Offline profile 

o Functionality profile 

o Receipt profile 

o Hardware profile 

o Visual profile 

o Transaction service profile 

o Custom fields 

 Setting up POS terminals  

 Setting up receipt formats  

 Setting up screen layouts  

 Setting up  button grids 

 Adding images  

 Setting up keyboard mapping groups  

 Setting up Operations 

 Setting up the POS permission groups  

Changes made to the POS profiles and the layouts on Microsoft Dynamics AX for Retail 
POS do not take effect at a store until the registers are restarted.  
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 POS PROFILES 

7.1.1 OFFLINE PROFILE 

An offline profile is used to define the database structure that is synchronized between a 
store database and the offline databases at the registers. Each offline profile consists of 
several offline scopes. Offline scopes define the order in which data is synchronized, and 
the database tables that will be synchronized. Microsoft Dynamics AX for Retail POS 
includes a default offline profile that is named "Default pr." The offline scopes that are 
included in the default offline profile reflect the organization of jobs in Retail Scheduler. 

 Important 

You can modify the default offline profile that is included with Microsoft Dynamics AX 
for Retail POS. However, if you modify a store's offline profile after you have created the 
store's offline databases, you must run the Store Database Utility again on all the 
registers in the store to re-provision the offline databases for those registers. 

The default offline profile is generated during the initialization process to create base 
configuration data. 

To set up an offline profile, follow these steps. 

1. Click Retail > Setup > POS > Profiles > Offline profile.  

 

2. Click New to create a new offline profile, or select an existing profile.  

3. In the Name field, type a name for the profile. In the Offline scope description 
field, type a description.  
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4. On the Line details FastTab, click Add or select an existing offline scope.  

5. In the Offline scope description field, select an offline scope.  

To set up the new or existing offline scope, refer to the following procedure.  

6. Repeat steps 4 and 5 for each offline scope that is included in the offline profile.  

To set up an offline scope, follow these steps. 

1. Click Retail > Setup > POS > Profiles > Offline profile.  

2. In the Name field, select an offline profile.  

3. On the Line details FastTab, click Add or select an existing offline scope, and 
then click Offline scope.  

 

4. In the Offline scope form, in the Synchronization direction field, specify the 
direction in which data is moved during synchronization. Select one of the 
following options:  

o Download – Data is only downloaded from the store database to the 
offline databases.  

o Upload – Data is only uploaded from the offline databases to the store 
database.  

o Bidirectional – Data is downloaded from the store database and 
uploaded from the offline databases.  
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5. On the Line details FastTab, click Add to add a database table, or select a 
database table, and then click Remove.  

6. To view the fields in the selected table, click Field list.  

 

7. Repeat steps 3 through 6 for each offline scope that you want to set up.  
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Functionality profiles 

The functionality profile is used to configure the point-of-sale functionality for all 
registers in the store. The functionality profile contains settings that apply to all 
registers in a store, such as staff logon limitations, secondary currency information, item 
and payment aggregation, reason codes defaults for several operations, and being able 
to use X and Z reports and additional features that control policies at the POS level.  

After the functionality profile is set up, assign it to the appropriate store or stores. 

To set up functionality profiles, follow these steps.   

1. Click Retail > Setup > POS > Profiles > Functionality profile. 

 

2. Click New to enter a new profile or select an existing one. 

3. Enter information, and if it is necessary, refer to the following information.   

POS Functionality profile form 

Overview  

i. Profile – The name of the functionality profile. 

ii. Description – The description of the functionality profile. 

General FastTab 

iii. Locale 

 ISO – Select the locale for the store. 
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Important 

Selecting the incorrect location in this field can have an effect on the posting and tax 
calculations. 

Functions FastTab 

 

iv. Staff 

 Show staff list at logon – Select the check box so that a list of staff is displayed at 
the point-of-sale at the time of logon.  

 Staff bar code logon – This feature is not implemented in this release and might not 
appear in future releases. 

 Staff card logon – Select the check box so that only a MSR card swipe must be used 
for logon at the point-of-sale—no keyboard input is allowed. 

 Minimum password length – Enter the minimum length of the password that 
should be entered while logging on to the point-of-sale. 

 Must key in price if zero – Select the check box so that the point-of-sale cashier 
must enter the price of an item manually if the price of the item is zero. 

 Limit staff list to store – Select the check box to set the staff list based on the 
assignment of stores in the staff card. This option is only available when the Show 
staff list at logon check box is selected.  

v. POS 

 Log level – Select the level of event logging that is written to the POSIsLog table in 
the store or terminal database. 

 Trace – Most events are written to the database. This setting can substantially 
increase the size of the database. 
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 Debug – Key events, such as program startup (the initialization of the log file), 
employee logon and logoff, and failed logon attempts, are written to the 
database. 

 Error – Only error events are written to the database. 

 Terminal 

o Display secondary total currency – It displays the total amount in secondary 
currency.  

o Secondary total currency - Select the secondary currency for the 
transaction at the point-of-sale. 

o Print X/Z reports on POS – Select the check box so that X/Z reports can be 
printed at the point-of-sale. 

o Aggregate Products – Select the check box so that when a product is 
selected more than once at the point-of-sale, the first, existing line is 
updated.    

o Aggregate payments – Select the check box so that when multiple 
transaction payments are made with the same tender type, the first, 
existing line is updated. 

o Aggregate items for printing – Select the check box so that when the same 
item is sold more than once at the point-of-sale, it appears in a single line on 
the point-of-sale receipt.  

vi. Transactions  

o Days transactions exist – Feature not implemented. 

o Transaction delete reminder – Feature not implemented. 

o Backup training transactions – Feature not implemented. 

Amount FastTab 

o Maximum price – Enter the maximum transaction price.  

o Maximum quantity – Enter the maximum transaction quantity. 

 

Reasons Codes FastTab 

Reasons codes - Select the Reasons code that is visible to the cashiers during specific 
tasks. 

o Negative adjustment – This feature is not implemented in this release and 
might be removed from future releases. 

o Void Product – Select the Reason code number that runs when the Void 
button is pressed at the point-of-sale. 

o Void transaction – Select the Reason code number that runs when the Void 
Transaction button is pressed at the point-of-sale. 

o Void payment – Select the Reason code number that runs when the Void 
Payment button is pressed at the point-of-sale. 

o Return transaction – When a transaction is selected for return. 
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o Product discount – When a product discount is performed.  

o Mark up – This feature is not implemented in this release and might be 
removed from future releases. 

o Override price – Select the Reason code number that runs when the Price 
Override button is pressed at the point-of-sale.  

o Total discount – When a total discount is performed.  

o Tender declaration – Select the Reason code number that runs when the 
Tender Declaration button is pressed at the point-of-sale.  

o At start of transaction – Select the Reason code number that runs at the 
start of a transaction at the point-of-sale.  

o At end of transaction – Select the Reason code number that runs at the end 
of each transaction at the point-of-sale.  

o Serial number – When a serial number is entered.  

o Add sales person – This feature is not implemented in this release and 
might be removed from future releases. 

o The Product is not on file – Select the Reason code number that runs when 
a product is not in the point-of-sale database.  

o Return product – When a product is returned.  

o Transaction tax change – Select the Reason code number that runs when 
the cashier overrides the tax on a transaction. 

o Line product tax change – Select the Reason code number that runs when 
the cashier overrides the tax on a line item. 

 

vii. Receipt numbering  

 

Specify the formats for the receipt transaction type in the store. 
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The formats that you set up determine how receipts are numbered. By default, the 
five types of receipts—Sale, Return, Payment, Sales order and Quote —use the same 
number sequence, which is set to 1 when you create the Retail POS database. When 
you set up receipt number formats, you decide whether receipts are numbered from 
this default number sequence or from independent number sequences. Consider the 
following examples: 

viii. If you do not set up receipt number formats, or if you set up receipt number formats 
and do not select the Independent sequence check box described as follows, receipt 
numbers are incremented regardless of the type of receipt. You receive a sequence such 
as sale number 1, followed by return number 2, followed by sale number 3, followed by 
customer payment number 4. 

ix. If you set up receipt number formats and select the Independent sequence check box 
for all three types of receipts, the three types of receipt numbers are incremented in 
separate sequences. You start with sale number 1, return number 1, and customer 
payment number 1. 

x. If you set up receipt number formats and select the Independent sequence check box 
for only one type of receipt, such as Sale, that type of receipt is numbered in a separate 
sequence while the other two share the default number sequence. As a result, you 
receive a sequence such as sale number 1, sale number 2, sale number 3, return number 
1, and customer payment number 2. 

Important 

Set up formats so that receipt numbers are unique for each store, terminal, and receipt 
type. The easiest way to do this is to include the store number, the terminal number, 
and a unique character that represents the receipt type in each receipt number format.  

If you use the same format for each receipt type, we recommend clearing the 
Independent sequence check box for each receipt type. 

xi. Receipt transaction type – Select the format for the receipt from the following options. 

 Sale – Select this option to set a format for transactions where the total amount is 
positive or zero. 

 Return – Select this option to set a format for transactions where the total amount 
is negative. 

 Payment – Select this option to set a format for customer payments. 

 Sales order – Receipt number format for sales orders created at POS. 

 Quote – Receipt number format for quote orders created at POS. 

xii. Format – Type the mask for the receipt number. Use the mask characters shown in the 
following table. For the non-date mask characters, repeat each character as often as 
necessary to accommodate the data that you include in the receipt number. 
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Mask character Description 

# Receipt number 

S Store number 

T Terminal number 

C Staff ID 

ddd Day of the year (1 through 366) 

MM Two-digit month 

DD Two-digit day of the month 

YY Two-digit year 

Characters other than those in the table appear in the receipt number. If you scan the 
receipt bar codes, avoid the use of special characters in the mask. 

7.1.2 RECEIPT PROFILES 

A receipt profile is a group of form layouts that can be assigned to the point-of-sale 
(POS) printers by using a hardware profile. A receipt profile provides a set of receipt 
templates for the printers at the registers. Form layouts and receipt profiles must be set 
up to print receipts and other documents from Microsoft Dynamics AX for Retail POS.  

The receipt profiles must be set up to a hardware profile that will be used by the POS 
registers to print the receipt.  

To set up a receipt profile, follow these steps. 

1. Click Retail > Setup > POS > Profiles > Receipt profile.  
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2. In the Receipt profile form, click New to create a new receipt profile, or select an 
existing receipt profile.  

3. In the Receipt profile ID field, type a unique identifier for the profile.  

4. In the Description field, type a name for the profile.  

5. On the General FastTab, click Add to add a receipt format to the profile.  

6. In the Receipt type field, select the type of receipt that you are creating a profile for. 
The type of receipt that you create a profile for is the type that is printed from the POS 
register.  

7. In the Receipt format field, select the receipt format to add.  

8. Enter Description for the Receipt Type. 

9. Enter Title for the receipt type. 

10. Click Designer to view the selected receipt format. Refer to the following section to 
design a receipt format. 

 Note 

Assign a receipt profile to a hardware profile. 

The receipt profile that you select in a hardware profile assigns a set of receipt formats 
to the printers on the registers that use that hardware profile.  

To select a hardware profile, follow these steps. 
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1. Click Retail > Setup > POS > Profiles > Hardware profiles.  

2. In the POS hardware profile form, select the hardware profile from the list on 
the left side. 

3. In the Printer FastTab, select the Receipt profile ID from the drop down list box. 

7.1.3 HARDWARE PROFILES 

Hardware profiles are created to set preferences and properties for a register and for 
the peripheral devices that are connected to the register. These devices include receipt 
or document printers, customer displays, magnetic strip readers, cash drawers, bar code 
scanners, scales, key locks, keyboards; electronic funds transfer (EFT) hardware, and 
closed-circuit television (CCTV) cameras. 

Note 

 Microsoft Dynamics AX for Retail POS supports OPOS-compliant hardware. OPOS 
is a standard that the retail industry uses for the point-of-sale (POS) devices.  

 A hardware profile must be assigned for each set of hardware that is used for the 
registers. A single hardware profile can be assigned to all the terminals if a store 
uses same hardware peripherals. If each register has a unique set of peripherals, 
you must assign a unique hardware profile for each register. 

 

To set up hardware profiles, follow these steps. 

javascript:void(0)
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1. Click Retail > Setup > POS > Profiles > Hardware profiles.  

2. Click New to enter a new profile, or select an existing profile.  

3. On the following FastTabs, enter information about the appropriate hardware 
devices:  

o Printer – Specify the settings for the printer that is used to print receipts 
and other documents for customers.  

o Printer 2 – Specify the settings for a second print that can be used to print 
receipts or A4 size documents for customers. 

o Line display – You can set up an optional customer display. The customer 
can use this display to view transaction totals, payment amounts, and 
optional customized messages. The customer display can also display 
advertising.  

o Dual display – If a second monitor is set up in a Windows-based 
application, you can use the monitor as a line display. This monitor can 
also display advertising.  

o MSR – Specify the settings for a magnetic stripe reader (MSR). An MSR 
reads the information that is encoded in the magnetic stripe on the back 
of a plastic card. The stripe is read through physical contact and when the 
stripe is swiped past a reading head. Magnetic stripes are typically used 
on credit cards, identity cards, and transportation tickets.  

o Drawer – Specify the settings for the cash drawer. A valid signal from the 
computer or receipt printer opens the cash drawer.  

o Drawer 2 – Specify the settings for the second cash drawer. A valid signal 
from the computer or receipt printer opens the cash drawer. 

o Scanner – Specify the settings for a product scanner. Because of the 
constant flow of sales in retail stores, cashiers can scan items into the POS 
system more accurately than they can enter items manually.  

o Scanner 2 – Specify the settings for a second product scanner. Because of 
the constant flow of sales in retail stores, cashiers can scan items into the 
POS system more accurately than they can enter items manually. 

o Scale – Specify the settings for a scale. A scale is a weighing instrument 
that is connected to the POS hardware. If you sell items by a weighable 
unit of measure, the weight of an item is calculated by a POS scale and 
recorded in the register.  

 Caution 
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You must set the base unit of measure for a product to a unit of weight. 

o Keylock – Specify the settings for your key lock.  The key lock settings 
specify whether an OPOS key lock or a logon dialog box controls access to 
the register.  

o Keyboard – Specify the settings for keyboards. If you use a POS system 
that does not include a touch screen, the keyboard serves as the primary 
interface for the POS system. The keyboards that are used for a POS 
system can vary in complexity and technology. Examples include a 
standard 101-key keyboard and industry-specific POS keyboards. Grocery 
stores and restaurants might require special functions that only 
programmable keyboards can provide. When you select a keyboard, 
consider the size and your business’s requirements for programmable 
keys. 

 Caution 

The Keyboard FastTab does not display by default on the form. You must 
right-click on the form to personalize and add the keyboard mapping group 
assign values. 

o EFT service – Specify the settings for your EFT hardware. Use EFT for 
electronic payments and collections. EFT is based on a deferred net 
settlement (DNS), in which transactions are settled in batches at a specific 
time.  

o PIN pad – Specify the settings for the PIN pad.  

o Signature capture – Specify the settings to configure the device for 
signature capture during customer transactions and payments. 

To assign a hardware profile to a register, follow these steps. 

1. Click Retail > Setup > POS > POS terminals.  

2. On the POS terminals list page, select the terminal to assign a hardware profile 
to.  

3. On the Action Pane, in the Maintain group, click Edit.  

4. In the POS terminals form, on the General FastTab, in the Hardware profile field, 
select the appropriate hardware profile.  

POS hardware profile field details 
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Click Retail > Setup > POS > Profiles > Hardware profiles.  

Use the POS hardware profile form to create a hardware profile. Use a hardware profile 
to set preferences and properties for a register and peripherals of the register, such as 
the cash drawer and the receipt printer.  

 

The tabs and the fields that are used in the POS hardware profile form are described in 
the following tables.  

Tabs 

Tab Description 

General  Select a profile number and a description for the hardware profile.  
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Tab Description 

Printer  Specify settings for the printer.  

Printer 2 Specify settings for the second printer. 

Line 

display  

Specify settings for the line display.  

The customer display, or pole display, is an optional part of the point-

of-sale (POS) system. The customer display is a lighted display on 

which the customer can view transaction totals and payment amounts. 

Some customer displays can also display customized messages. The 

customer display can also be used to display advertisements.  

Dual 

display  

Specify settings for a dual display.  

A dual display has two sections—an advertisement area and a receipt 

area that displays the current transaction. If there is no current 

transaction, the advertisement section is expanded to fill the screen. In 

the advertisement area, you can display a static image, a series of 

changing images, or a webpage.  

MSR  

Specify settings for a magnetic stripe reader (MSR).  

An MSR device reads the information that is encoded in the magnetic 

stripe on the back of a plastic card. The stripe is read through physical 

contact and by swiping the card past a reading head. Magnetic stripes 

are frequently used on credit cards, identity cards, and transportation 

tickets.  

Drawer  

Specify settings for the cash drawer.  

The cash drawer is an important part of the POS system. Money, credit 

card receipts, and other paperwork are stored in a cash drawer. A valid 

signal from the computer or receipt printer opens the cash drawer.  
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Tab Description 

Drawer 2 

Specify settings for the second cash drawer.  

The cash drawer is an important part of the POS system. Money, credit 

card receipts, and other paperwork are stored in a cash drawer. A valid 

signal from the computer or receipt printer opens the cash drawer. 

Scanner  

Specify settings for the bar code scanner.  

Because of the constant flow of sales in a retail store, it is almost 

impossible to manually key in sales items at the point-of-sale with a 

high degree of accuracy.  

Scanner 2 

Specify settings for the second bar code scanner.  

Because of the constant flow of sales in a retail store, it is almost 

impossible to manually key in sales items at the point-of-sale with a 

high degree of accuracy. 

Scale 

Specify settings for the weight scale. 

A scale is a weighing instrument that is connected to the POS register. 

If you price and sell items in a weighable unit of measure, Microsoft 

Dynamics AX for Retail POS calculates and records the weight of an 

item when the item is put on the scale. 

 Caution 

You must set the base unit of an item to a unit of measure for weight.  

Key lock  

Specify settings for the key lock.  

The key lock determines whether an OPOS key lock or a logon dialog 

box is used to control access to the register.  
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Tab Description 

Keyboard Specify the keyboard mapping group to the hardware profile. 

EFT 

service  

Specify settings for the electronic funds transfer (EFT) service.  

EFT is used for electronic payments and collections. EFT operates on a 

deferred net settlement (DNS) basis. DNS settles transactions in 

batches at a specific time.  

PIN pad  Specify settings for the PIN pad.  

Signature 

capture 
Specify settings for the signature capture device. 

Fields 

TAB/Field Description 

General Below are the fields under the General Section. 

Profile number  The unique ID number of the hardware profile. After a profile is 
created, it must be linked to each register.  

Description  The name of the hardware profile.  

Printer  

Select the type of printer that is used at the register:  

 None – No printer is used. Receipts are not printed for any 
kind of transaction.  

 OPOS – An OPOS printer is used to print the POS receipts. 
An OPOS printer is a local printer that is installed at every 
register.  

 Windows driver – A Windows-based printer is used to print 
the POS receipts. If you select this option, you must specify 
the name of the Windows-based printer that is set up at the 
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TAB/Field Description 

POS register. Windows-based printers cannot print bar 
codes.  

Device name  Type the logical device name of the printer. This name must match 
the name that is defined in the operating system.  

Description  
Type a more detailed description of the printer. For example, the 
description of the printer that is installed at the entrance of the 
store is "Printer at entrance of store."  

Receipt profile 
ID  

Select the receipt profile for the hardware profile. The receipt 
profile specifies the set of form layouts that is used to print 
receipts.  

Logo settings  

This feature is not implemented in this release and might not 
appear in future releases.  

Select the Logo setting from the drop down list box. The options 
include the following: 

 None 

 Download 

 EPSON Flash 

Logo alignment 

Select the logo alignment from the drop down list box. The options 
include the following: 

 Left 

 Center 

 Right 

Character set  Type the character set that is used for the printer. The default 
character set is 850.  

Print binary 
conversion  

Select this check box to convert the printed text to binary text. In 
other words, each byte becomes two bytes.  

Doc. 
insert/removal 
timeout  

Type the maximum time, in seconds, that the system waits for a 
document, such as an invoice, to be inserted into or removed from 
the printer.  

Printer 2 Printer 2 section 
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TAB/Field Description 

Printer 

Select the type of printer that is used at the register:  

 None – No printer is used. Receipts are not printed for any 
kind of transaction.  

 OPOS – An OPOS printer is used to print the POS receipts. 
An OPOS printer is a local printer that is installed at every 
register.  

 Windows driver – A Windows-based printer is used to print 
POS receipts. If you select this option, you must specify the 
name of the Windows-based printer that is set up at the 
POS register. Windows-based printers cannot print bar 
codes.  

Device name  Type the logical device name of the printer. This name must match 
the name that is defined in the operating system.  

Description  
Type a more detailed description of the printer. For example, the 
description of the printer that is installed at the entrance of the 
store is "Printer at entrance of store."  

Receipt profile 
ID  

Select the receipt profile for the hardware profile. The receipt 
profile specifies the set of form layouts that is used to print 
receipts.  

Logo settings  

This feature is not implemented in this release and might not 
appear in future releases.  

Select the Logo setting from the drop down list box. The options 
include the following: 

 None 

 Download 

 EPSON Flash 

Logo alignment 

Select the logo alignment from the drop down list box. The options 
include the following: 

 Left 

 Center 

 Right 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

131 

 

TAB/Field Description 

Character set  Type the character set that is used for the printer. The default 
character set is 850.  

Print binary 
conversion  

Select this check box to convert the printed text to binary text. In 
other words, each byte becomes two bytes.  

Doc. 
insert/removal 
timeout  

Type the maximum time, in seconds, that the system waits for a 
document, such as an invoice, to be inserted into or removed from 
the printer.  

Line Display Line Display Section 

Display  

Select the type of line display that is used at the register:  

 None – No line display is used.  
 OPOS – The POS register includes a line display, and this 

display is used in the store.  
 Windows driver – A Windows-based display is used. If you 

select this option, you must specify the name of the 
Windows-based driver for the display.  

Display device 
name  Type the device name of the line display.  

Display 
description  Type the identification number of the display device.  

Display total 
text  

Type the text that appears on the customer display together with 
the total amount when the register displays the total amount of a 
transaction.  

Display balance 
text  

Type the text that appears on the customer display together with 
the balance amount.  

Display terminal 
closed 

Select the check box to display the terminal as closed in the line 
display. 

Display closed 
line 1  

Type the text that appears on the first of the two lines that are 
displayed when the register is closed.  

Display closed Type the text that appears on the second of the two lines that are 
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TAB/Field Description 

line 2  displayed when the register is closed.  

Display binary 
conversion  

Select this check box to convert the text that appears on the 
display to binary text. In other words, each byte becomes two 
bytes.  

Display 
character set  

Type the character set that is used for the display. The default 
character set is 850.  

Display 
additional 
products  

Select this check box to display other products on the display.  

Delay for 
additional 
products  

Type the interval, in seconds, at which other products appear on 
the display.  

Dual Display Dual Display Section 

Dual display in 
use Select this check box to indicate that a dual display is used. 

Receipt width 
percentage  Type the percentage of the display area that is used for the receipt.  

Advert type  

Select the type of advertisement that is displayed:  

 Logo – A static image is displayed.  
 Image rotator – A series of images is displayed. These 

images change, or rotate, periodically, at an interval that 
you specify.  

 Webpage – A webpage is displayed. You can also specify the 
URL for a web server that periodically changes images.  

Image rotator 
path  

Click the folder icon, and then select a folder that contains the 
images to rotate.  

Image rotator 
interval  Type the time, in seconds, that each image appears on the display.  

Web page URL  Click the Internet button, and then select a webpage.  
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TAB/Field Description 

MSR MSR Section 

MSR  

Select the type of MSR device that is used at the register:  

 None – No MSR device is used.  
 OPOS – The POS register includes an MSR device, and this 

MSR device is used in the store.  
 Windows driver – This feature is not implemented in this 

release and might not appear in future releases.  

Device name  Type the name of the MSR device.  

Description  Type a description of the MSR device.  

Start track 1  If this field is not empty, the track is cut starting from, and 
including, the position that you specify.  

Separator  Type the character that is used as a separator between card 
numbers.  

End track 1  
If this field is not empty, the track is cut ending, and including, the 
position that you specify.  

Drawer Drawer Section 

Drawer  

Select the type of cash drawer that is used at the register:  

 None – No cash drawer is used.  
 OPOS – The POS system includes a cash drawer, and this 

cash drawer is used in the store.  
 Windows driver – This feature is not implemented in this 

release and might not appear in future releases.  
 Manual 

Device name  Type the name of the cash drawer.  

Description  Type a description of the cash drawer.  

Drawer 2 Drawer 2 Section 
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TAB/Field Description 

Drawer  

Select the type of cash drawer that is used at the register:  

 None – No cash drawer is used.  
 OPOS – The POS system includes a cash drawer, and this 

cash drawer is used in the store.  
 Windows driver – This feature is not implemented in this 

release and might not appear in future releases.  
 Manual 

Device name  Type the name of the cash drawer.  

Description  Type a description of the cash drawer.  

Scanner Scanner Section 

Scanner  

Select the type of bar code scanner that is used at the register:  

 None – No bar code scanner is used.  
 OPOS – An OPOS bar code scanner is used.  
 Windows driver – This feature is not implemented in this 

release and might not appear in future releases.  

Device name  Type the name of the bar code scanner.  

Description  Type a description of the bar code scanner.  

Scanner 2 Scanner 2 Section 

Scanner 

Select the type of bar code scanner that is used at the register:  

 None – No bar code scanner is used.  
 OPOS – An OPOS bar code scanner is used.  
 Windows driver – This feature is not implemented in this 

release and might not appear in future releases.  

Device name  Type the name of the bar code scanner.  

Description  Type a description of the bar code scanner.  
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TAB/Field Description 

Scale Scale Section 

Scale  

Select the type of weight scale that is used at the register:  

 None – No weight scale is used.  
 OPOS – An OPOS weight scale is used.  
 Windows driver – This feature is not implemented in this 

release and might not appear in future releases.  

Device name  Type the name of the weight scale.  

Description  Type a description of the weight scale.  

Timeout in sec  Type the number of seconds that Retail POS waits for a weight 
from the scale.  

Manual input 
allowed  

Select this check box to allow cashiers to enter the weight 
manually.  

Keylock Keylock Section 

Keylock  

Select whether an OPOS key lock or a logon dialog box is used to 
control access to the register:  

 None – No key lock is used. A logon dialog box is used 
instead.  

 OPOS – An OPOS key lock device is used.  

Device name  Type the name of the keylock device.  

Description  Type a description of the keylock device.  

Keyboard Keyboard Section 

Keyboard 
mapping group  

Select the keyboard mapping group that includes all the keyboard 
shortcuts that are created for POS operations. For more 
information, refer to Set up keyboard mapping groups.  

EFT Service EFT Section 
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TAB/Field Description 

EFT service  

Select the type of EFT server that the register connects to:  

 None – The register does not connect to an EFT server.  
 External – The register connects to an external EFT server. If 

you select this option, you must enter the name of the EFT 
server in the Server name field.  

 Note 

Depending on the authorization system that the store uses, you 
might not have to enter the server name. 

 Payment Connector: The register uses the payment 
processing service that is offered by Payment Services for 
Microsoft Dynamics ERP. 

Service ID  If you selected External in the EFT service field, type the name of 
the EFT server.  

Merchant ID Enter the Merchant ID that is provided by the bank or the payment 
services operator. 

Username  Type the user ID.  

Password  Type the user password.  

Configuration Select the list of commerce services that provide the EFTPOS 
interface. 

Server Name Enter the server name of the location. 

Description  Type the description for the EFT service.  

EFT server port  Type the TCP/IP port for the EFT server.  

ABC code 

The options include the following: 

 None 

 A 

 B 
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TAB/Field Description 

 C 

Hardware 
profile version 

Select the hardware profile version that is used at the POS. The 
options include the following: 

 Microsoft Dynamics AX 2012 R2 

 Microsoft Dynamics AX 2012 Feature Pack 

 Microsoft Dynamics AX 2009 

PinPad Pin Pad Section 

PIN pad  

Select the type of PIN pad that is used at the register:  

 None – No PIN pad is used.  
 OPOS – An OPOS PIN pad is used.  
 Windows driver – This feature is not implemented in this 

release and might not appear in future releases.  

Device name  Type the name of the PIN pad. This name must match the name of 
the service object driver.  

Description  Type a description of the PIN pad.  

Signature 
Capture Signature Capture Section 

Signature 
Capture 

Select the type of Signature capture driver that is used at the 
register: 

 None – No Signature capture is used.  
 OPOS – An OPOS signature capture is used.  
 Windows driver – This feature is not implemented in this 

release and might not appear in future releases.  

Device name Type the name of the signature capture device. This name must 
match the name of the service object driver.  

Description Enter a description for the signature capture. 

Form name Enter the form name for the signature capture. 
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7.1.4 VISUAL PROFILES  

A visual profile contains basic information that determines the appearance of the Retail 
POS registers. Use the POS visual profiles form to select menus that appear on the 
register screen, and to define the colors and bars that are visible.  

You can create several visual profiles and select specific profiles to run on specific 
registers. You can also decide whether a store can modify the visual profile that is 
assigned to the register.  

Set up visual profiles 

To create and modify a visual profile, follow these steps.  

1. Click Retail > Setup > POS > Profiles > Visual profiles.  

2. In the POS visual profiles form, select an existing visual profile, or click New to 
create a new visual profile.  

3. In the Profile number field, enter a unique identifier for the profile.  

4. In the Description field, enter a brief description for the profile.  

5. In the Picture ID field, select a picture to be displayed as the background on the 
POS terminals that use the selected profile. If you select zero (0), no image is 
displayed.  

6. In the Screen section, select the settings for the POS terminals that use the 
selected profile. The screen height must be at least 768 pixels. The screen width 
must be at least 1024 pixels. Select the Design allowed on POS check box so that 
a store can modify the profile design on a terminal.  

 Note 

Assign a visual profile to a terminal 

To assign a visual profile to a POS terminal, follow these steps.  

1. Click Retail > Setup > POS > POS terminals.  

2. In the POS terminals list, select the terminal that you want to modify.  
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3. On the General FastTab, in the Visual profile field, select the appropriate visual 
profile.  

 

 

POS visual profiles  

Click Retail > Setup > POS > Profiles > Visual profiles.  

 

The POS visual profiles form can be used to set up visual profiles. You can create several 
visual profiles and select specific profiles to run on specific registers.  

The fields that are used in the POS visual profiles form are described in the following 
table.  

Fields 

Field  Description  

General General Section 

Profile number  Enter a unique number for the visual profile.  

Description  Enter a description of the visual profile.  

Full screen mode  Select whether to display the profile by using the full screen.  
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Field  Description  

Screen height  
Select a height for the profile. The screen height must be at least 

768 pixels.  

Screen width  
Select a width for the profile. The screen width must be at least 

1024 pixels.  

Design allowed on POS  Select whether a store can modify the profile design on a terminal.  

Hide cursor  Select whether to hide the pointer for this profile.  

Login Back ground Login Background Section 

Picture ID  
Select an image to display in the background of the screen for the 

selected profile.  

7.1.5 TRANSACTION SERVICE PROFILES 

Transaction service profiles are used to set up and configure the connection information 
for the transaction service that will be used by the retail stores to access Application 
Object Server (AOS) to retrieve or update information. 

The transaction service is an agent for Microsoft Dynamics AX for Retail POS. Microsoft 
Dynamics AX for Retail POS submits queries to the transaction service, and then it 
accesses the remote AOS instance to read or update the necessary data. However, 
Microsoft Dynamics AX for Retail POS does not access the remote AOS instance. Before 
Microsoft Dynamics AX for Retail POS can submit any queries, it must have access to a 
transaction service on the network.  

To set up the Commerce Data Exchange: Real-time Service profiles, follow these steps. 

1. Click Retail > Setup > POS > Profiles > Real-time service profiles.  

2. In the Commerce Data Exchange: Real-time Service profile form, select an existing 
profile, or click New to create a new profile.  

3. Enter a name and a description for the profile.  

4. Click the Connection FastTab, and then enter the following information:  

o In the Server field, enter the server name or the IP address where the transaction 
service is running.  
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o In the Port field, enter the number of the port that Commerce Data Exchange: 
Real-time Service listens to. The default port is 1239. However, you can specify 
another port.  

o In the Passphrase field, enter the configuration passphrase for Commerce Data 
Exchange: Real-time Service that is used to authenticate the point-of-sale (POS) 
connection.  

o In the Language field, select the language that is used by the AOS instance.  

5. Click the Settings FastTab, and then select the Commerce Data Exchange: Real-time 
Service staff check box so that Microsoft Dynamics AX for Retail POS can validate the 
operator logon through the transaction service.  

To assign the Commerce Data Exchange: Real-time Service profile to a terminal, follow 
these steps. 

1. Click Retail > Setup > POS > POS terminals.  

2. On the POS terminals list page, open the terminal to modify, or create a new 
terminal.  

3. In the POS terminals form, on the General FastTab, in Profiles, in the Commerce Data 
Exchange: Real-time Service profile field, select the appropriate Commerce Data 
Exchange: Real-time Service profile.  

4. In the remaining fields, enter the information that is required to set up the POS 
terminal. 

 

The tabs and the fields that are used in the POS terminals form are described in the 
following tables.  
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Tabs 

Tab  Description  

Overview  Enter a name and description for the profile.  

Connection  Enter the connection settings for the profile.  

Settings  
Make Microsoft Dynamics AX for Retail POS be available to 
validate access privileges for the transaction service.  

Fields 

Field  Description  

Profile  
The name of the Commerce Data Exchange: Real-time Service 
profile.  

Description  
The description of the Commerce Data Exchange: Real-time 
Service profile.  

Connection Connection Section 

Server  
The server name or the IP address where the transaction service is 
running.  

Port  
The port that Commerce Data Exchange: Real-time Service listens 
to. The default port is 1239. However, you can specify another 
port.  

Passphrase  
The configuration passphrase for Commerce Data Exchange: Real-
time Service that is used to authenticate the point-of-sale (POS) 
connection.  

Language  The language that is used by the AOS instance.  

Settings Settings Section 

Commerce Data 
Exchange: Real-time 
Service staff  

Select the check box so that Microsoft Dynamics AX for Retail POS 
can validate the operator logon through the transaction service.  
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7.1.6 CUSTOM FIELDS 

The custom fields can be used by Independent Service Vendors (ISVs) and partners to 
extend the display with additional fields in Microsoft Dynamics AX for Retail POS or for 
the customization that is built as vertical solutions. 

To add the Custom fields form, click Retail > Setup > POS > Profiles > Custom fields, and 
then follow these steps. 

 

1. Click New to create a new custom field. 
 

2. Enter the Name of the custom field. 
 

3. Select the Type from the drop down list box. The type defines the area where 
the custom field will be displayed at the point-of-sale. The options include the 
following: 
 

 Product receipt grid – Makes the custom field available to be added to 
the product receipt grid on the POS screen layout. 
 

 Payment grid – Makes the custom field available to be added to the 
payment grid on the POS screen layout. 
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 Total area – Makes the custom field available to be added to the totals 
area on the POS screen layout. 

 

 Receipt – Makes the custom field available to be added to a receipt 
format. 

 
4. Enter the Caption text ID for the custom field to display the text in local 

language. 

Add a custom field to the POS screen layout 

After the custom fields are added, the fields must be displayed on the POS screen 
layout.  

To open the Screen layout form, click Retail > Setup > POS > Screen layout, and then 
follow these steps.     

 

1. Select a screen layout from the list and click Designer from the tool bar at the 
top of the screen to open the Designer form. 
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2. To add the custom fields to the product receipt grid, right-click in the product 
receipt grid column header and then select Column chooser from the menu list. 
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3. The list of fields that can be added to the product receipt grid will be displayed. 
To add the custom fields to the product receipt grid, select the custom field from 
the list and drag the column and drop it on the product receipt grid. 

 

The custom field that is added will be displayed on the product receipt grid. 

 

4. Click OK to save the changes on the screen layout. 
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5. Run the A-1090 job from the Retail scheduler form to move the changes from 
the screen layout to the stores.  
 

 Caution 

By using the Custom fields form, the ISV can add only more fields to the POS screen 
layout. To have meaningful data display in the custom fields requires the efforts of 
both the ISV and partners.  

Extensible Interface for development 

The POS plug-in is used by ISVs and partners to extend the functionality in the point-of-
sale system.  

By using Microsoft Dynamics AX .Net 4.0, the POS plug-in shows the placeholder data 
that ISVs can use to populate data in custom fields.  

Three placeholders are available in the following areas:  

 POS Transaction header object 

 POS Transaction lines 

 POS Transaction payment 

The dynamic data type is called PartnerData. The syntax for populating the value for the 
custom field is: 

transactionObject.PartnerData.MyCustomField = "MyValue"; 

Refer to the section on POS extensibility for more information about how to install and 
develop custom code for ISV and partner customizations. 

 

 POS TERMINALS 

When you set up a terminal in Microsoft Dynamics AX for Retail POS, you select a 
hardware profile and a visual profile for the terminal. A hardware profile determines the 
physical configuration of a terminal and a visual profile determines the screen 
characteristics of a terminal.  

You can assign the profiles to a specific terminal or to a group of terminals. You can also 
modify the profiles that are assigned to a terminal. Certain configuration changes do 
not take effect at stores until the terminals in the store are restarted. Generally, if you 
modify something that affects the POS terminal setup or the configuration of one or 
more terminals, you must restart the affected terminal.  
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Before you set up terminals, complete the following prerequisites:  

 Create a store  

 Create the Retail POS functionality profiles and assign them to stores  

 Create a hardware profile  

 Create a visual profile  

 Create a screen layout  

To set up the terminal and assign profiles to the terminal, follow these steps.  

1. Click Retail > Setup > POS > POS terminals.  

2. In the POS terminals list, on the Action Pane, in the New group, click Terminal to 
create a new terminal.  

3. In the POS terminals form, on the General FastTab, in the Terminal number 
field, enter a unique number for the terminal.  

4. In the Reference field, select a store for the register.  

5. In the Hardware profile field, select a profile for the register.  

6. In the Visual profile field, select a profile for the register.  

7. On the General FastTab, enter values in the remaining fields.  

8. In the POS terminals form, enter values on the other FastTabs.  

 

Click Retail > Setup > POS > POS terminals. On the POS terminals list page, on the 
Action Pane, in the New group, click Terminal.  
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Tabs 

 

The tabs and the buttons that are used in the POS terminals – New Record form are 
described in the following tables.  

Tab  Description  

Terminal  
Configure the point-of-sale (POS) registers, and set up 
distribution locations and parameters to print receipts.  
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Tab  Description  

General  
Specify general settings for the register, such as the POS 
register's number, name, and placement, and the store number 
for the register.  

Setup  Specify a number sequence group.  

Display  Specify parameters for the register's customer-facing display.  

Financial 
dimensions  

View information about financial dimensions, such as the 
default dimensions and where the dimensions are used in 
account structures and advanced rule structures.  
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Buttons 

Button  Description  

Copy fields  Copy the setup fields from another register to this register.  

Copy top 
receipt text  

Copy, from another register to this register, the receipt text that 
is configured to appear at the top of the receipt. The receipt text 
is set up in the POS terminal receipt printing form.  

Copy 
bottom 
receipt text  

Copy, from another register to this register, the receipt text that 
is configured to appear at the bottom of the receipt. The receipt 
text is set up in the POS terminal receipt printing form.  

Copy all  Copy all settings from another register to this register.  

Terminal  Create a new register.  

Receipt 
printing  

Open the POS terminal receipt printing form. Here, you can 
configure the receipt settings for this register. You can also enter 
the receipt text that appears at the top and the bottom of the 
receipt when it is printed.  
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Fields 

The fields in the POS terminals – New Record form are described in the following table.  

 

 

Field  Description  

Terminal 
number  

The unique register number. Register numbers can be 
automatically generated or manually assigned. Number sequences 
must be assigned in the store card.  

You can enter a maximum of 10 alphanumeric characters, and 
each number must be unique.  

You can create as many registers as you require.  

Name  Type a name for the register.  

Placement  Type a description of the physical location of the register in the 
store.  
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Field  Description  

Reference  Select the store to which the register is assigned or linked. A 
register can be linked to only one store.  

Hardware 
profile  

Select the appropriate hardware profile. A hardware profile 
defines a set of properties for various hardware peripherals that 
are connected to a register. The profile can include settings for a 
printer, scanner, drawer, scale, display screen, key lock, keyboard, 
EFT, and other devices.  

Visual profile  Select the visual profile. A visual profile defines a set of properties 
for the colors, resolution, and menus for the Retail POS screen.  

Commerce 
Data 
Exchange: 
Real-time 
Service profile  

Select the Commerce Data Exchange: Real-time Service profile. 
The register uses the profile to connect to Application Object 
Server (AOS) to retrieve or update information.  

POS Configure POS Configure Section 

IP address Update the IP address for the POS register. 

Update Service 
Port Update the port details for the POS terminal. 

Stand Alone If the terminal is operating as a standalone. 

Receipt setup 
location  

Select whether the receipt layout is defined for each register or for 
each store.  

 Terminal – A different layout can be set for each register.  
 Store – The same layout is used for all registers in a store.  

Receipt bar 
code  

Select the check box to indicate that a bar code for the receipt 
number is printed at the bottom of each receipt at the POS 
terminal. A bar code is also printed for suspended transactions.  

Terminal 
statement  

Select the check box so that terminal statements can be 
generated.  

The method that is used to generate terminal statements is 
defined in the store setup. However, you can define a new 
statement method.  

Statement Select the statement method, based on the statement lines that 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

154 

 

Field  Description  

method  are created in the statement journal. This option is only available if 
the Terminal statement check box is selected.  

 Staff – Create a statement line for each tender by worker.  
 POS terminal – Create a statement line for each tender by 

the point-of-sale terminal.  
 Total – Create a statement line for each tender in the 

transactions.  

Reference  

The store number that is used for electronic funds transfer (EFT) 
transactions. Microsoft Dynamics AX for Retail POS populates this 
field automatically when the store number is assigned to the 
register. However, you can manually change the EFT store number.  

EFT POS 
register 
number  

The register number that is used for EFT transactions. Microsoft 
Dynamics AX for Retail POS populates this field automatically 
when the register is created. However, you must change the EFT 
register number so that it matches the number that you receive 
from your payment provider.  

Exit after each 
transaction  

Select the check box to indicate that Microsoft Dynamics AX for 
Retail POS logs off automatically after each transaction. This 
option is suitable for a highly secure environment, because 
cashiers must log on before they can process transactions.  

Auto logoff 
timeout 
(minutes)  

Enter the time, in minutes, after which a Microsoft Dynamics AX 
for Retail POS session ends if the computer is left unused. This 
setting can be used for terminals that have relatively few 
transactions and lots of idle time.  

Open drawer 
at logon/logoff  

Select the check box to indicate that the cash drawer is opened 
every time that Microsoft Dynamics AX for Retail POS users log on 
or log off.  

Post difference 
to vendor  

Select the concession vendor to post the counting difference to 
when the tender amount in the drawer differs from the tender 
amount that is counted.  

Maximum text 
length  

The maximum length of each line of text on the customer-facing 
display. The default length is 20 characters.  

Customer 
display text 1  

The first line of text that is displayed on the line display between 
customer transactions.  
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Field  Description  

Customer 
display text 2  

The second line of text that is displayed on the line display 
between customer transactions.  

Screen layout 
ID  Select the screen layout that is used for the register.  

Global Refunds  

Print Tax 
Refund Checks  

Financial 
Dimensions  

Customer 
Group 

A default group can be selected if users have not set the customer 
with the appropriate group. 

Department Select the default department from the drop down list. 

Item Group Select the Item group from the drop down list. 

Store Select the Store the terminal belongs to from the drop down list. 

Terminal Select the terminal from the drop down list. 

Worker Select the default worker using the terminal from the drop down 
list. 
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 RECEIPT FORMAT 

The Receipt format form is used to set up receipt formats. You can set up a receipt 
format for each printer at the point-of-sale. One or more receipt formats can then be 
assigned to a receipt profile. Then, this receipt profile is assigned to a hardware profile 
for a store's registers.  

Click Retail > Setup > POS > Receipt format.  

 

 

The tabs, buttons, and fields that are used in the Receipt format form are described in 
the following tables.  

Tabs 

Tab  Description  

General  Specify the print settings for the receipt format.  

Buttons 

Button  Description  

Designer  Open the selected receipt format in the Receipt format designer 
form.  
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Fields 

Field Description 

Receipt format  The ID number of the receipt format.  

Receipt type  Select the type of receipt that the receipt format is used for.  

Description  Type a description of the receipt format.  

Title  Type a name for the receipt format.  

Prompt 
question  

This feature is not implemented in this release and might not 
appear in future releases.  

Print as slip  Select this check box to print the receipt format as a slip.  

Use windows 
printer  

Select this check box to indicate that a Windows-based printer is 
used to print the receipt format in Microsoft Dynamics AX for 
Retail POS.  

Windows 
printer name  

Type the network host name of the Windows-based printer. The 
path must be in the Universal Naming Convention (UNC) format: 
\\servername\sharename.  

Print behavior  

Select one of the following print options:  

 Always print – Receipts are always printed in Retail POS.  
 Do not print – Receipts are not printed in Retail POS.  
 Prompt user – The cashier is prompted to select whether 

a receipt is printed at the register.  

 

7.3.1 SET UP RECEIPT FORMATS 

You can create and modify form layouts to control how receipts, invoices, and other 
documents are printed. Microsoft Dynamics AX for Retail POS includes a form layout 
designer that you can use to easily and graphically create and modify different kinds of 
form layouts.  

 Important 
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You must set up form layouts and receipt profiles to print receipts and other 
documents from Microsoft Dynamics AX for Retail POS. You can include multiple 
form layouts in a receipt profile, and then assign the receipt profile to a printer by 
modifying a hardware profile.  

To set up receipt profiles, follow these steps. 

1. Click Retail > Setup > POS > Receipt format.  

2. In the Receipt format form, click New to create a new form layout, or select 
an existing form layout.  

3. In the Receipt format field, enter an identifier for the form layout, and then 
select the type of receipt that this layout is used for. You can also enter a 
description and short name for the receipt in the Title field.  

4. On the General FastTab, set the following print options:  

o Print as slip – Select this check box to print a form as a slip.  

o Use windows printer – Select this check box to indicate that a Windows 
printer is used to print receipts from Retail POS.  

o Windows printer name – Type the name of the network host of the 
Windows printer. The path must be in the Universal Naming Convention 
(UNC) format: \\servername\sharename.  

o Print behavior – Select when the receipt is printed from Microsoft 
Dynamics AX for Retail POS. You can specify that a receipt is always 
printed or is never printed, or that the cashier selects whether a receipt is 
printed.  

Use the form layout designer to graphically create the layout of the form document. 
The Receipt format designer form has three sections—Header, Lines, and Footer. 
Some types of form layout use elements from all three sections, whereas other 
types use elements from only one or two sections. To view the elements that are 
available for each section, click the appropriate button in the navigation pane on the 
left side of the form.  
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Report Designer 

To design the form, follow these steps. 

1. Click Retail > Setup > POS > Receipt format.  

2. In the Receipt format form, select a form layout, and then click Designer.  

3. To create the elements of the form, select the Header, Lines, or Footer 
section, and then drag an element from the section to the workspace. Most 
elements contain variables, and usually these variables are automatically 
populated with data from the database. Other elements, such as Text, let 
you print custom text on the receipt. 

 

 Caution 

You can specify how many lines each of the three sections spans by adjusting the 
number in the lower-right corner of the section. To make it easier to modify a 
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section, increase the height of the section by dragging the sizing bar at the bottom 
of the section. The height of the section on the workspace does not affect the 
number of lines on the actual receipt. 

4. After you drag the element to the workspace, set the properties for the part 
in the Object information pane at the bottom of the form. Enter one or more 
of the following settings:  

o Align – Set the alignment of the field to either Left or Right.  

o Fill char – Specify the white-space character. By default, an empty space 
is used. However, you can enter any character.  

o Prefix – Type the value that appears at the beginning of the field. This 
setting only applies the Lines section of the layout.  

o Characters – Specify the maximum to the elements in the number of 
characters for the variable. If the text in the field is more than the number 
of character that you specify, the text is truncated to fit the field.  

o Variable – This check box is selected automatically if the element is a 
variable and the variable cannot be customized.  

o Font type – Set the font style to either Normal or Bold. Bold letters use 
two times the space that normal letters use. Therefore, some characters 
might be truncated.  

o Delete – Click this button to remove the selected part from the form 
layout.  
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 SCREEN LAYOUTS 

The graphical design of the interface for Microsoft Dynamics AX for Retail POS is 
controlled by the till layout. A layout controls the position of various objects. Examples 
include the total layout, item grid layout, customer layout, payment layout, and the 
layout of various menu buttons. Layouts also include how the sales interface will appear 
for Microsoft Dynamics AX for Retail POS when it is presented to workers. 

The screen layout for the point-of-sale register (till) contains information that controls 
the visual appearance of objects on the screen. This can include menus, submenus, tasks 
or action items that can be position on the screen based on business process 
requirements and the frequency of use by the cashier or the store manager. When you 
use the screen layout, you can define colors, images, layout by user or department and 
the screen layout can be controlled at the head-office level. 

You can design several screen layouts for a retail business operation, and then select the 
layout that can be used for specific register(s). The Screen layout ID field in the POS 
terminals form identifies the till layout that is used for the register. 

You can also assign a specific till layout to a specific register, worker, or store. When 
Microsoft Dynamics AX for Retail POS starts, it determines whether a specific layout is 
assigned to the worker who logged on, the register, or the store, in this order. 

After you set up a till layout, you must assign the layout to a store, register, or worker. 
You can also assign the layout to more than one of these entities. 

A till layout can optionally contain pictures and custom button grids. 

 Note 

Frequently, the Microsoft Dynamics AX for Retail POS screen layout is specified at the 
headquarters office by using Microsoft Dynamics AX for Retail Headquarters, and then 
sent to the stores. In this case, any local customizations that are performed at the stores 
are overridden by the HQ configuration. 

7.4.1 SET UP THE SCREEN LAYOUT 

The screen layout specifies how the screen is displayed on the point-of-sale (POS) 
register. Additionally, the screen layout specifies the position of several objects. For 
example, the screen layout specifies the total layout, product grid layout, customer 
layout, and payment layout. The screen layout also specifies the position of several 
menu buttons and how the sales interface screen layout will appear for Microsoft 
Dynamics AX for Retail POS when it is presented to the worker. You can configure a 
screen layout after all the button grids for the layout are created. 
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To set up the screen layout, follow these steps. 

 

 

1. Click Retail > Setup > POS > Screen layout. 

 

Use this form to set up a screen layout that is used by the point-of-sale (POS) 
registers. The screen layout specifies the position of several objects. For 
example, the screen layout specifies the total layout, item grid layout, customer 
layout, and payment layout. The screen layout also specifies the location of 
several menu buttons and the appearance of the sales interface for Microsoft 
Dynamics AX for Retail POS that is displayed to the worker. 

2. In the Screen layout form, click New to create a new layout, or select an existing 
screen layout to modify. 

 

3. In the Screen layout ID field, enter a unique ID for the screen layout, and then 
enter a name for the layout. 

4. In the Width and Height fields, enter a combination of a width and height to 
specify a screen resolution. This screen resolution is used in the Screen layout 
designer form to provide a workspace that closely resembles the screen 
resolution of the POS register. 

5. In the Button grid 1 through the Button grid 5 fields, select the button grids to 
display on the POS register that uses this layout. A button grid is a group of 
similar buttons, such as buttons for products, operations, or payments. 
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For example, you define one layout for a store and another layout for a manager 
who works in that store. The general store layout includes a standard set of 
button grids that is always displayed. The store manager layout includes an 
additional button grid for operations that only the store manager performs. For 
example, this layout includes buttons that are used for overrides or the approval 
of large transaction amounts. 

7.4.2 DESIGN A SCREEN LAYOUT 

To design a new screen layout, follow these steps. 

1. Click Retail > Setup > POS > Screen layout.  

2. To create a new layout, press CTRL+N, and then, in the Screen layout ID field, 
type an ID for the layout.  

 

3. Select the layout that is created or select another layout to modify an existing 
layout, and then click Designer.  
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 Note 

The POS layout has different parts that can be accessed through the submenu 
option by clicking the design mode.  The layout option includes the Main Layout, 
Customer Layout, Totals Layout, Product Grid Layout, Payment Grid layout and 
Cash changer layout. 

4. Click Design mode, and then click Main layout. The parts that are available 
include the following:  
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o Empty Space Item – Insert space between button grids.  

o Label – Insert a text label.  

o Separator – Insert a separator between parts.  

o Splitter – Insert a separator that you use to resize the screen layout grid 
in Microsoft Dynamics AX for Retail POS.  

o Button grid 1 to Button grid 5 – The button grids that are created and 
selected to appear when Microsoft Dynamics AX for Retail POS starts.  

o Cash changer – Insert a pane that displays information about a cash 
changer, if one is in use at the register.  

o Customer – Information about the customer.  

o Logo – An image box that displays the company’s logo.  

o Message – A pane that displays a message whenever a function is 
performed in Microsoft Dynamics AX for Retail POS.  

o Receipt – A pane that displays sales information, such as the item 
number, product name, price, and sales tax.  
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o Numpad – A pane that displays only numbers. This part can be used to 
enter item numbers, bar codes, and product quantities.   

o Totals – A pane that displays sales transactions. The information that is 
displayed includes discounts, taxes, line numbers, and balance amounts. 

5. Select a part, and then drag the part onto the layout designer. 

Examples 

 Click Receipt, and then drag this part to the layout designer. Receipt no 
longer appears in the Customization form, because each layout can have 
only one receipt part. 

 Select Label, and then drag this part to the layout designer. Label still 
appears in the Customization form, because each layout can have several 
label parts.  

 
 Note 

When you select a part, and then move the mouse pointer over the design 
window and to the edge of the part, a thick dashed black line appears. When you 
release the mouse button while the mouse pointer is over this line, the button 
grid appears there. After the button grid appears in the layout designer window, 
you can change the size of the button grid. 

To remove a part from the layout, drag the part back into the Customization 
form.  

6. After you finish designing the Main layout section, you can design the Customer 
layout section. Click Design mode, and then click Customer layout.  

The parts that are available include the following:  

o Empty Space Item – Insert space between button grids.  

o Splitter – Insert a separator that you use to resize the screen layout grid 
in Microsoft Dynamics AX for Retail POS.  

o Invoice Account – The customer account to which the invoice is 
addressed, if this account differs from the customer account number.  

o Invoice Name – The customer account name to which the invoice is 
addressed. 

o Invoice address – The customer account address to which the invoice is 
addressed. 
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o Shipping Name – The customer’s shipping address name. This might 
differ from Invoice Name. 

o Shipping Address – The customer’s shipping address. This might differ 
from Invoice Address. 

o Customer Id – The customer’s actual ID or account number. 

o Balance Status – The customer’s current balance status. 

o Balance – The customer’s balance. 

o Credit Limit – The customer’s credit limit. 

 Note 

You can add these parts only to the Customer layout section of a screen layout. 
When you drag a part, you will know whether you are in the correct section, 
because when you put the mouse pointer in the correct section, the X will be 
visible.  

7. Click Design mode, and then select Totals layout.  

The parts that are available include the following:  

o Empty space item – Insert space between button grids.  

o Splitter – Insert a separator that you use to resize the screen layout grid 
in Microsoft Dynamics AX for Retail POS. 

o Label – Insert a text label.  

o Separator – Insert a separator between parts.   

o Amount – The gross amount of the transaction.  

o Line discount – The amount of the discounts that are applied to line 
items.  

o Misc charge total – The total amount of miscellaneous charges. 

o Number of items – The total number of items in the transaction.  

o Number of line items – The number of line items in the transaction.  

o Payment – The payment applied to the transaction.  

o Rounded – The amount of rounding that is applied to the total.  

o Subtotal - The net amount of the transactions. 

o Tax – The tax amount of the transaction.  
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o Subtotal (without tax) – The net amount of the transaction's total, 
excluding tax.  

o Sum of discounts with tax – The total amount of discounts that are 
applied to the transaction, including tax.  

o Subtotal (with tax) – The net amount of the transaction's total, including 
tax.  

o Sum of discounts – The total amount of discounts that are applied to the 
transaction.  

o Total discount – The amount of the discount that is applied to the 
transaction's total.  

o Total discount with tax – The amount of the discount that is applied to 
the transaction's total, including tax.  

o Total – The total net amount of all the transactions including tax, 
discount and miscellaneous charges. 

o Balance – The total amount owed. 

 Note 

You can add these parts to, or remove them from, only the Totals layout section 
of a screen layout 

8. Click Design mode, and then select Product grid layout.  

The Customization form displays the columns that you can drag to and from the 
transaction's product grid (the pane that displays the line items that are added 
to the transaction).  

 Note 

You can add these parts to, or remove them from, only the Product grid layout 
section of a screen layout. 
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 BUTTON GRID 

You can use the Button grid to group similar buttons of the same type, such as buttons 
for products, operations, or payments. Microsoft Dynamics AX for Retail POS can display 
up to five button grids in a screen layout.  

When you create a new button grid, buttons are created based on the number of 
columns and rows that you specify. For example, if you create a grid that has four 
columns and five rows, 20 buttons are created. These buttons can then be configured for 
specific operations.  

The button grid keeps information about how the buttons appear on the register, such 
as the color of the buttons, and the features that are visible and hidden on the Microsoft 
Dynamics AX for Retail POS screen. The button grid also keeps information about the 
functions that the buttons are used for.   

To create a button grid, follow these steps.  

1. Click Retail > Setup > POS > Button Grid.  

 

2. In the Button grid form, click New to create a new grid.  

3. Enter a unique Button grid ID for the new button grid. 

4. Enter the Name of the button grid. 

5. On the General FastTab, select the Font that is used to display the button grid. 

6.  Select the Default font size for the button grid. 

7. Select the Default font style for the button grid. The options include the 
following: 
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 Regular 

 Bold 

 Italic 

 Bold Italic 

8. Select the Default color for the button grid. The options include the following: 

 Blue 

 Dark blue 

 Red 

 Green 

 Purple 

 Pink 

 Gold 

9. Enter the space between the buttons that shows the number of blank characters 
that are inserted between adjacent buttons in the selected button grid. 

10. In the Uses area, select the Uses button grid to select an existing button grid. 

11. Click Designer on the tool bar at the top of the screen. The Button grid design 
form will open.  
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12. On the Visual layout FastTab, click New design. 

13. In the Rows and Columns fields, enter the number of rows and columns of 
buttons that the button grid contains, and then click OK. 

 

The buttons are created according to how they are specified in the Rows field 
and the Columns field. 
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14.  Right-click each button, and then click the button properties. The configure 
button form will open. 

 

15. In the Actions area, select the Item that is the point-of-sale operation to perform 
when you click the button. 
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16. In the Configure button screen, enter the Text on button that will be displayed 
on the button. 

17. Enter the Font size for the text that will be displayed on the button. 

18. Select the Font style for the text on the button. The font style is inherited from 
the button grid settings. You can override the button grid settings, if this is 
necessary.   

19. Select the Image alignment from the drop down list box if an image is selected to 
be used on the button. The options include the following: 

 Default 

 Near 

 Center 

 Far 

20. Enter the Size in columns for the button. 

21. Enter the Size in rows for the button. 

22. The button color is inherited from the button grid settings. You can customize the 
button grid settings, if this is necessary.  Enter a checkmark so that Use Custom 
Theme is available and then select the following: 

o Back Color: The primary color of the button. Here, you can pick a color 
option. The options are Standard, Web and System. 
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 Back Color 2: The secondary color of the button. This is used for the 
second color for the gradient. 

 Border Color: The border color of the button. 

 Font Color: The color of the font for the button. 

 Gradient Mode: The direction of the gradient for the button colors. 

 

23. At the bottom, on the right-side, click the Select image button to add an image 
to the button. 

 

24. Click Clear image if you want to remove the image on the button. 

25. Click the OK button to confirm the changes. 

26. Right-click the button to provide more functionalities, such as the following: 
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 Delete button: To delete a button, select the button, and then click Delete 
button. 

 Add row: To add a row of buttons, right-click anywhere in the grid, and then 
click Add row. Microsoft Dynamics AX for Retail POS adds a new row at the 
bottom of the grid. 

 Add column: To add a column of buttons, right-click anywhere in the grid, 
and then click Add column. Microsoft Dynamics AX for Retail POS adds a new 
column on the right side of the grid. 

 Delete row: To delete a row of buttons, right-click a button in the row, and 
then click Delete row. 

 Delete column: To delete a column of buttons, right-click a button in the 
column, and then click Delete column. 

 

27. To add or delete a new button, use the buttons on the top of the Button design 
form. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

177 

 

  

 

 

 Note 

You can only use the Designer if you are granted special permissions to the database.  
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 IMAGES 

Images can be stored, and each image is assigned a unique ID. Images can also include 
logos, pictures of items, and icons. The images can be used in button grids that are 
displayed in Microsoft Dynamics AX for Retail POS. After the button grids are set up, 
they can be added to a screen layout, and then they can be displayed on a point-of-sale 
register at a store.  

To select and, or delete an image, follow these steps. 

1. Click Retail > Setup > POS > Images.  

2. In the Images form, click Select image to open a browser window where you can 
search for and select an image.  

When you select an image, the image is assigned a unique ID, and a preview of 
the image is displayed in the form.  

3. To delete an image from the list, select the image ID, and then click Remove 
image.  

7.6.1 SET UP IMAGES  

Click Retail > Setup > POS > Images.  

 

The Images form can be used to set up images that can be used in button grids that are 
displayed in Microsoft Dynamics AX for Retail POS.  
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The buttons and the fields that are used in the Images form are described in the following 
tables.   

Buttons 

Button  Description  

Select  Add a new image to the list.  

Remove  Remove the selected image from the list.  

Fields 

Field  Description  

Picture ID  The unique ID of the image.  
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 KEYBOARD MAPPING GROUPS 

The Keyboard mapping group form can be used to set up and view the keyboard 
mapping groups and the keyboard mappings that are used by the point-of-sale registers 
in a store. A keyboard mapping can include all the shortcut keys that are created for 
operations in Microsoft Dynamics AX for Retail POS. Therefore, Microsoft Dynamics AX 
for Retail POS can use several kinds of POS keyboards by mapping the keys to the codes 
for the regular PC keyboard. Additionally, you can disable specific keys on the PC 
keyboard, or map the keys to other key combinations. When you configure the hardware 
profile for Microsoft Dynamics AX for Retail POS, you reference the keyboard mapping 
group in the POS hardware profile form. 

To create keyboard mapping groups, follow these steps. 

1. Click Retail > Setup > POS > Keyboard mapping group.  

2. In the Keyboard mapping group form, click New to create a new mapping group, 
or select an existing keyboard mapping group in the list.  

3. Enter or view the name and description of the keyboard mapping group. 

To create keyboard mappings, follow these steps. 

1. Click Retail > Setup > POS > Keyboard mapping group.  

2. In the Keyboard mapping group form, select a keyboard mapping group, and 
then click Keyboard mapping.  

3. In the Keyboard mapping form, click New to create a new keyboard mapping.  

4. In the Key char field, enter the character to use as a shortcut key in Microsoft 
Dynamics AX for Retail POS. The ASCII value field is automatically populated with 
the ASCII value for the character.  

5. In the Operation ID field, select the operation that is performed by using the 
shortcut key. The Action property field is automatically populated with the 
appropriate action for the operation.  
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7.7.1 KEYBOARD MAPPING 

The Keyboard Mapping group form is used to set up a mapping between key 
combinations and operations in Microsoft Dynamics AX for Retail POS. In Microsoft 
Dynamics AX for Retail POS, several point-of-sale keyboards can be used by mapping the 
keys on the keyboards to the codes for regular computer keyboards. You can also 
disable specific keys on a computer keyboard or map the keys to other key 
combinations.  

Click Retail > Setup > POS > Keyboard mapping group.  

 

The buttons and the fields that are used in the Keyboard mapping group form are 
described in the following tables.   

Buttons 

Button  Description  

Keyboard 
mapping  

Opens the Keyboard mapping form. Here, you can configure keyboard 
mappings.  

Fields 

Field  Description  

Keyboard 
mapping group  

The unique identifier of the keyboard mapping group. This column includes 
the entire keyboard mapping groups that are assigned to hardware profiles.  

Description  The name of the keyboard mapping group.  
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In the Keyboard mapping group form, click Keyboard mapping.  

 

 

The fields in the Keyboard mapping group form are described in the following table. 

Field  Description  

Key char  
Type the character that is used as a shortcut key in Microsoft Dynamics AX 

for Retail POS.  

ASCII value  The ASCII value of the key that you specified in the Key char field.  

Operation ID  

Select the operation that is performed in Microsoft Dynamics AX for Retail 

POS when the character that you specified in the Key char field is pressed 

on the POS keyboard.   
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Field  Description  

Operation name  The name of the operation that you selected in the Operation ID field.  

Action property  
The action property of the operation that you selected in the Operation ID 

field.  

 

 OPERATIONS 

In Microsoft Dynamics AX for Retail POS, a series of safeguards are performed every 
time a staff member performs an operation to make sure that the staff member has 
permission to perform the operation.   

You can link a single permission to operations that are performed at the point-of-sale, or 
you can link a single permission to operations that are performed in the Operations 
form. Typically, a single permission is linked to one operation. However, you can also 
link a single permission to multiple operations.  

Staff members can be assigned to the POS permission groups. Permissions for staff 
members can be modified after the staff members are assigned to the POS permission 
group.  

To set up tasks and create permissions, follow these steps. 

1. Click Retail > Setup > POS > Operations.  
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2. In the Operations form, select an existing operation. Or, click New to add 
a new operation, and then enter an ID number and a name for the 
operation.  

3. In the Permission ID column, select the permissions to link the operation 
to.  

4. In the Permission ID2 column, select the permissions to link the 
operation to. 

5. In the Check user access column, select the check box to indicate that 
Microsoft Dynamics AX for Retail POS checks a user's permissions before 
the operation is performed. 

6.  In the User operation column, select the check box to indicate that the 
operation can be used. 

7.  In the Action lookup column, select one of the following options:  

 Retail product – The operation can be used only for retail products.  

 Payment method – The operation can be used only for payment 
methods.  

 Menu – The operation can be used only for menus.  

 None – Use of the operation is not limited.  

Now, you can create permissions and the Permissions form opens. 
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8. Click New to create a new permission. 
9. Enter a unique Permission ID for the new permission. 
10. Click the Permission name for a list of fields that are available to select. 

Double-click the field that will be populated in the Permission name 
field. 
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11. The new permission that is created can be selected on the operations 
that it is created for. 

 Note 

The Permissions field displays the field names from the POS permission group table. 
The POS permission group table defines the default settings that are associated with 
the cashier and the manager. 

The operations that a staff member can perform are described in the following table.  

Name Description 

Add Shipping Address Adds a shipping address for the customer on the 
transaction. 

Add to Gift Card Adds money to the specified gift card. 

Bank Drop Records the amount of money that is sent to the bank 
and other information, such as the bank bag number. 

Blank Operation Represents a button that can be customized and 
programmatically changed by a software developer for 
any specialized operation that is needed by the 
business. 

Change Unit of Measure Changes the scanned item's unit of measure. 

Clear Qty (quantity) Resets the quantity of an item to 1. 
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Name Description 

Clear Salesperson Clears any salesperson from the transaction. 

Close Shift Closes the current cashier shift. 

Customer Displays the on-screen keyboard so that the cashier can 
type a customer ID to search for. If a customer is found, 
the cashier can then add the customer to the 
transaction. 

Customer Account 
Deposit 

Makes a payment to a customer's account. 

Customer Add Displays the Customer Add dialog box. Here, the 
cashier can enter information about the new customer. 
Saving the information adds the new customer to the 
customer list. 

Customer Clear Clears the customer from the transaction. If any price 
agreements apply to the customer, prices and 
discounts in the transaction might change. 

Customer Search Searches for the customer when the customer is added 
to the transaction. 

Customer Transactions Displays the transactions for the selected customer. 

Customer Transactions 
Report 

Prints a report showing the transactions for the 
selected customer. 

Declare Start Amount Declares the amount in the drawer when the day or the 
shift is started. 

Design Mode Disable Prevents changes to the screen layout of the terminal. 
The functionality profile of the terminal specifies 
whether the cashier has access to this operation. 

Design Mode Enable Allows changes to the screen layout of the terminal. 
The functionality profile of the terminal specifies 
whether the cashier has access to this operation. 

Display Total Displays the balance of the transaction on the customer 
display. 

End of Day Performs an end-of-day procedure. 

End of Shift Performs an end-of-shift procedure. 

Expense Account Records money that is removed from the cash drawer 
for occasional expenses. 

Float Entry Registers a float entry to the drawer, such as an 
addition or change. 
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Name Description 

Gift Card Balance Displays the balance of a gift card. 

Income Account Records any money that is put in the cash drawer that 
is not from sales. 

Inventory Lookup Looks up on-hand inventory for the current store and 
other available locations. 

Invoice Comment Enters a comment about the transaction. The comment 
is saved with the transaction and printed on the receipt 
or invoice. 

Issue Credit Memo Issues a central credit memo through Commerce Data 
Exchange: Real-time Service, together with a printed 
copy. 

Issue Gift Card Issues a gift card through Commerce Data Exchange: 
Real-time Service, together with a printed copy. 

Item Comment Adds a comment to the selected line item in the 
transaction. The comment is saved with the transaction 
and the comment appears on the receipt. 

Item Sale Adds an item to the transaction. The button must be 
configured for the particular item. 

Item Search Searches for an item. You can search for an item by 
item ID, item description, or item category. Sorting the 
search results is also possible. 

Line Discount Amount Enters a discount amount for a line item in the 
transaction. This is for discountable items only and 
must be within specified discount limits. 

Line Discount Percent Enters a discount percentage for a line item in the 
transaction. This is for discountable items only and 
must be within specified discount limits. 

Lock Terminal Locks the terminal, when the cashier must leave the 
register. Unlock the terminal by logging on. 

Log Off Logs off the terminal, suspending any sales until the 
next logon. 

Loyalty Request Enters the customer's loyalty card number. This 
operation can also be started by swiping a loyalty card. 

The loyalty request can be performed at any time 
during the transaction. Microsoft Dynamics AX for 
Retail POS calculates loyalty points at the end of the 
transaction. 
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Name Description 

The number of loyalty points awarded for the items in 
the transaction depends on how the loyalty program is 
set up in Microsoft Dynamics AX Retail Headquarters. 

Minimize POS Window Minimizes the Microsoft Dynamics AX for Retail POS 
window. 

Open Drawer Opens the cash drawer without a sale. This operation is 
recorded in the database. 

Override line item tax Overrides the tax on the selected line item with a 
different tax. First, the different tax must be specified 
in Microsoft Dynamics AX Retail Headquarters. 

Override line item tax 
from list 

Overrides the tax on the selected line item with a tax 
that the cashier selects from a list. First, the list of taxes 
must be specified in Microsoft Dynamics AX Retail 
Headquarters. 

Override transaction tax Overrides the tax on a transaction with a different tax. 
First, the different tax must be specified in Microsoft 
Dynamics AX Retail Headquarters. 

Override transaction tax 
from list 

Overrides the tax on a transaction with a tax that the 
cashier selects from a list. First, the list of taxes must be 
specified in Microsoft Dynamics AX in Retail 
Headquarters. 

Pay Card Accepts a credit card or debit card as payment. The 
cashier types the card's number and the expiration 
date. Overpayment or underpayment can also be 
specified, if this is allowed by the store. 

This operation can also be started by swiping a credit 
card or debit card. If this occurs, Microsoft Dynamics AX 
for Retail POS automatically completes the transaction. 

Pay Cash Accepts cash as payment. The cashier can select to pay 
the transaction total, overpayment, or underpayment, 
if this is allowed by the store. 

If overpayment is allowed, Microsoft Dynamics AX for 
Retail POS displays the amount that exceeds the 
transaction total. 

Pay Cash Quick Completes the transaction with "one touch," and 
assumes that the customer paid the exact amount of 
the transaction total in cash.  

Pay Check Accepts a check as payment for the transaction. 
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Name Description 

Pay Corporate Card Accepts a corporate card as payment. The cashier types 
the card number and the expiration date. This 
operation can also be started by swiping a credit card 
or debit card. If this occurs, Microsoft Dynamics AX for 
Retail POS automatically completes the transaction. 

The authorization for corporate cards can differ from 
that of credit cards and debit cards. You can also 
specify restrictions for corporate cards, and allow or 
disallow the purchase of certain items.  

Pay Credit Memo Accepts a credit memo that is issued by the store. 

Pay Currency Accepts payment in many currencies. The cashier 
selects the payment currency, and Microsoft Dynamics 
AX for Retail POS calculates the transaction total in that 
currency. 

Overpayment or underpayment can also be specified, if 
this is allowed by the store. 

Pay Customer Account Charges a transaction to a customer account, and an 
underpayment or overpayment, if this allowed by the 
store. Microsoft Dynamics AX for Retail POS also checks 
whether the customer is blocked. 

If it is necessary, you can add the customer to the 
transaction at this time.   

You can also check a customer's credit before allowing 
the payment, if credit checking is set up in Microsoft 
Dynamics AX Retail Headquarters.   

Pay Gift Card Accepts a gift certificate or gift card that is issued by 
the store. 

 

Picking and Receiving Displays the Picking and receiving dialog box. You can 
use this dialog box to select a purchase order or 
transfer order to receive or pick merchandise for. 

Popup Menu Selects a button grid to be associated with the button.  

When the button is clicked, Microsoft Dynamics AX for 
Retail POS displays the selected button grid in its own 
window. 

Price Check Checks the price of an item. Microsoft Dynamics AX for 
Retail POS asks for the item number. You can scan the 
item or search for the item. 
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Name Description 

When the item is found, Microsoft Dynamics AX for 
Retail POS displays the price of the item with the option 
to add the item to the transaction. 

Price Override Overrides the price of an item if the item is set up to 
allow it. Microsoft Dynamics AX for Retail POS displays 
a number pad to enter the new price. 

Print X (X report) Prints an X report. 

Print Z (Z report) Prints a Z report. 

Recall Transaction Recalls a suspended transaction. 

Return Item Performs a return of individual items. The next scanned 
item is noted as a returned item with a negative 
quantity and price. 

Return Transaction Performs a return of an entire transaction. 

Safe Drop Performs a safe drop to move money from the register 
to a safe. 

Sales Invoice Displays information about a sales invoice for a specific 
customer. 

Sales Order Displays information about sales orders for a specific 
customer. 

Search Shipping Address Displays a form that is used to search for a shipping 
address. 

Set Qty (quantity) Changes the quantity of a line item in the transaction. 

Show Journal Views the register's journal. You can then view 
transactions, reprint receipts, or print invoices. 

Stock Count Displays the Stock Counting form for scanning or 
entering bar codes. 

Sub Menu Selects a button grid to be associated with the button.  

When the button is clicked, Microsoft Dynamics AX for 
Retail POS displays the selected button grid in place of 
the exiting button grid. 

Suspend Transaction Suspends a transaction that you can recall later. 

Tender Declaration Performs a tender declaration. 

Tender Removal Records removing money from the cash drawer. 

Total Discount Amount Enters a total discount amount that is divided between 
all items in the transaction. 

Total Discount Percent Enters a total discount percentage that is divided 
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Name Description 

between all items in the transaction. 

Transaction Comment Adds a comment to the transaction. The comment is 
saved with the transaction and appears on the receipt. 

Void Item Voids a line item in the transaction. The line item is 
removed from the transaction total and appears 
marked as voided. 

Void Payment Voids all payment methods that are applied to the 
transaction. 

Void Transaction Voids the transaction. Voided transactions are saved in 
the database with a voided status. 

 

 POS PERMISSION GROUP 

The POS Permission group is used to define the default set of permissions that apply to 
the cashiers and the managers at the retail store. 

To create a new permissions group, follow these steps. 

1. Click Retail > Setup > POS > POS permission groups.  
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2. Press CTRL+N or select the New button, to create a new permission group. Then, 
enter a group name and a description for the POS permission group.  

3. On the Permissions FastTab select the Manager Privileges check box to indicate 
that the cashier has managerial privileges in point-of-sale activities. For example, 
executing return transactions might be part of this privilege. 

4. Select the Allow blind close check box to indicate that the cashiers can blind 
close the shifts at the terminal. The proper tendering and Z-report generation 
will be performed from the back office. 

5. Select the Allow X-report printing check box if the cashier can print X reports. 

6. Select the Allow Z-report printing check box if the cashier can print Z reports. 

7. Select the Allow tender declaration check box if the cashier can declare 
collections at the end of the day or at the end of the shift. 

8. Select the Allow floating declaration check box if the cashier can enter float in 
point-of-sale. 

9. Select the Allow transaction suspension check box if the cashier can keep a 
transaction on hold and retrieve it later. 

10. Select the Allow transaction voiding check box if the cashier can declare a 
transaction void. 

11. Select the Allow change, no void check box if the cashier can modify a 
transaction but cannot void it. 

12. Select the Open drawer without sale check box if the cashier can open the cash 
drawer without a sale. 

13. Enter the Maximum line discount amount that a staff member can enter on a 
line. 

14. Enter the Maximum discount (%) percentage that a cashier can give in Microsoft 
Dynamics AX for Retail point-of-sale. 

15. Enter the Maximum total discount (%) percentage that a cashier can give in 
Microsoft Dynamics AX for Retail point-of-sale. 

16. Select the View time clock entries check box so that time entries can be viewed 
by the selected group. 
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17. Enter the Maximum total discount amount a staff member can enter for a 
transaction. 

18. Enter the Maximum line return amount that a staff member can enter on a line. 

19. Enter the Maximum total return amount that a staff member can enter for a 
transaction. 

20. Select the Allow create order check box so that point-of-sale users can create 
sales quotes and customer orders. 

21. Select the Allow edit order check box so that point-of-sale users can edit existing 
sales quotes and customer orders. 

22. Select the Allow retrieve order check box so that point-of-sale users can retrieve 
existing sales quotes and customer orders. 

23. Select an Allow price override from the drop down list box to manually change 
the product price. The options include the following: 

1. Higher and lower: The cashier can enter a price that is more than or less 
than the Microsoft Dynamics AX for Retail price for an item. 

2. Higher only: The cashier can only enter a price that is more than the 
Microsoft Dynamics AX for Retail price for an item. 

3. Lower only: The cashier can only enter a price that is less than the 
Microsoft Dynamics AX for Retail price for an item. 

4. None allowed: The cashier cannot change the system price. 

24. Select the Allow multiple logons check box if the cashier can log on to more than 
one point-of-sale terminal in the store at the same time. 

25. Select the Allow multiple shift logons check box if multiple cashiers can log on to 
a single shift at the retail store. 

26. Select the Allow sales tax change check box so that cashiers can make changes 
to the sales tax at the point-of-sale. 

Select the Store inventory user check box so that cashiers can perform inventory checks 
from the point-of-sale terminal. 
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8 CATEGORY HIERARCHIES 

OVERVIEW 

In this module we will explain retail category hierarchies are created to organize and 
group products sold through the retail channels. Default values for products created and 
attached to categories can be configured by category.  These default values may be 
modified by product at the time of creation. Category hierarchies can be utilized in 
different areas of the application which includes Managing Promotions by category, 
managing customer loyalty schemes, managing assortments and reporting. 

For example, only product hierarchies that are assigned the Retail vendor product 
hierarchy type are referenced when you import product data from retail vendors.  

The following table lists the types of retail category hierarchies that are available and 
the general purpose of each type.  

Category hierarchy 
Type 

Purpose 

Retail product 
hierarchy  

Use this hierarchy type to define the overall product hierarchy 
for your organization. You can use this hierarchy type for 
merchandising, pricing and promotions, reporting, and 
assortment planning. Only one retail product hierarchy can be 
assigned this hierarchy type.  

Supplemental retail 
hierarchy  

Use this hierarchy type for any additional retail category 
hierarchies that you want to create. For example, in the spring, 
you have a promotion for swimwear. Therefore, you include 
your swimwear products in a separate category hierarchy and 
apply the promotional pricing to the various product 
categories.  

Retail vendor product 
hierarchy  

Use this hierarchy type when you import product data from 
vendors. You can create a product category hierarchy for a 
vendor, and then map the product categories for the vendor to 
your retail product categories.  

Retail channel 
navigation hierarchy 

Use this hierarchy type for defining the navigation structure for 
online stores. Multiple navigation hierarchies can be defined 
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and assigned to an online store. 

Retail Hierarchy can be used to structure the product default attributes to ensure quick 
creation or maintenance of the products. These attributes and properties include 
settings for product dimensions and point of sale (POS) settings Products which are 
assigned to the categories automatically inherit the attributes and properties that you 
define. You can also copy the property settings for any product to multiple products in a 
selected category at the same time.  

Retail category hierarchies use the category hierarchy features in Microsoft Dynamics 
AX. 

 

8.1.1 CATEGORY HIERARCHY AND ASSIGN A HIERARCHY PURPOSE – SET 
UP 

Before the creation of the Retail Product Hierarchy the Category Hierarchy Types must 
be set-up by clicking Product information management  Category Category 
Hierarchy Types.  Then process with setting up the category hierarchies. 

 

1. Click Product information management > Setup > Categories > Category 
hierarchies. On the Category hierarchies’ list page, on the Action Pane, click 
Category hierarchy. 

 

2. In the Create a category hierarchy form, enter a unique name and an optional 
description for the hierarchy, and then click Create. By default, the new category 
hierarchy Active status is set to yes.  

javascript:void(0)
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3. In the Category hierarchy form, on the Action Pane, click New category node to 
add the parent and child categories that you use to categorize your products. The 
first category that you create for a new category hierarchy is always the parent 
category of all other categories in the hierarchy. Add as many categories and 
subcategories as your organization requires.  

 

 

4. On Category attribute groups FastTab; click Add to assign attribute groups to the 
category.  
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5. On the Commodity codes FastTab, add subcategories from imported commodity 
codes.  

6. Select the category level under which you wish to create new sub categories and 
click New category on the New group of the Category hierarchy tab. 

 

7. After you have finished setting up the category hierarchy, click Close to save the 
category hierarchy and return to the Category hierarchy’s list page.  

8. On the Category hierarchies’ list page, select the retail product hierarchy that 
you created, and then, on the Action Pane, in the Set up group, click Associate 
hierarchy type.  

 

9. In the Category hierarchy types form, click New to add a new row.  

10. In the Category hierarchy type field, select one of the following category 
hierarchy types in the list:  
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o Retail product hierarchy – Select this hierarchy type to create the main 
retail product hierarchy for your organization. You can assign this category 
type to only one category hierarchy.  

o Supplemental retail hierarchy – Select this hierarchy type to create an 
additional retail product hierarchy. For example, these hierarchies can be 
used for special pricing and promotions, or for loyalty programs. You do 
not have to create retail supplemental hierarchies. You can create as 
many retail supplemental hierarchies as you require.  

o Retail vendor product hierarchy – Select this hierarchy type if you 
import product data from retail vendors, and you have received a product 
category hierarchy from a vendor. You do not have to create retail vendor 
product hierarchies. You can create as many retail vendor product 
hierarchies as you require.  

o Retail channel navigation hierarchy – Select this hierarchy type to create 
additional online store navigation structure. The navigation hierarchy 
assigned to an online store will be used by the e-commerce website to 
group the products assigned to the category. 

11. In the Category hierarchy field, select the category hierarchy to assign to the 
selected category hierarchy type.  
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For detailed information about the fields in the Category hierarchy form, see Category 
hierarchy (form).  

8.1.2 ATTRIBUTE AND ATTRIBUTE GROUPS 

Attributes are additional information that can be associate either to a product or a 
category. Attributes can be used to search for products or as refiners in the online web 
searches. 

8.1.2.1 CREATE AN ATTRIBUTE 

To create an attribute go to Product information management > Setup > Attributes. 

Let’s quickly look at the attribute types to understand the various types that are 
available out of the box for users to define different attribute types. 

 

From an e-commerce perspective additional attribute types have been added to 
facilitate product related information to be readily available to the web users to search 
on the attributes. 

The attribute types that are newly added for online are: 
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 ProvisionedChannelAttributeBoolean: This attribute type of Boolean is made 
available through an attribute group by product by channel. Ex. New product 
and Customer favorites. 

 ProvisionedChannelAttributeDecimal: This attribute type of Decimal is made 
available through an attribute group by product by channel. Ex. Review rating 

 ProvisionedChannelAttributeReference: This attribute type picks the default 
value assigned to a product and allows the value to be modified for a channel. 
Ex. Product description can be different for an online store and retail store. 

 ProvisionedChannelAttributeText: This attribute type of text is made available 
through an attribute group by product by channel. Ex. Brand. 

Click on Product information management > Setup > Attributes > Attributes to open 
the attributes form. 

1. Click on New to create a new attribute. 
2. Enter the Name of the attribute. 
3. Enter a Friendly name for the new attribute being created. 
4. Enter a Description for the attribute. 
5. Enter a Help text for the attribute. 
6. Select the Attribute type from the drop down list. 
7. Depending on the attribute type selected, either you can select or enter a 

Default value for the attribute. 
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8.1.2.2 CREATE AN ATTRIBUTE GROUP 

Click on Product information management > Setup > Attributes > Attribute groups to 
open the attribute groups form. 

1. Click on New to create a new attribute group. 
2. Under the General section enter a Name for the attribute group. 
3. Enter a Friendly name for the attribute group. 
4. Enter the Description for the attribute group. 
5. Enter a Help text for the new attribute group. 
6. Under the Attributes section, click on Add to add attributes to the attribute 

group. 

 

7. Select the attributes by marking the check box from the list and click Select to 
add them to the below selected box. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

204 

 

 

8. Click OK to add the selected attributes to the attribute group. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

205 

 

 

9. Enter or select the Default value for the attribute based on the attribute type 
defined. 

 

8.1.3 MAINTAIN THE RETAIL PRODUCT HIERARCHY 

The retail product hierarchy can be created by following the steps outlined below:  

1. Click Retail > Setup > Category hierarchies > Retail product hierarchy.  

2. In the Retail product hierarchy form, in the left pane, review the tree structure 
of product categories. On the General FastTab, view the name, friendly name, 
status, and other details about the category.  
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3. Click Edit category hierarchy to open the Category hierarchy form, and then 
modify the structure of the category hierarchy.  Close the form to return back 
to the Retail product hierarchy form. 

 

4. Click on Edit in the Category hierarchy form to edit the tree structure of the 
retail hierarchy.  On completion of the edit close the form by clicking the close 
button at the bottom of the form. 

  

5. In order to Add or move Products to a category go to the Category Hierarchy 
Form and in the left pane, select a category in the tree structure. Then, on the 
Products FastTab 

 

I. Option 1 Click Add to add one or more products from the organization-
wide product list. 
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II. Option 2 alternatively, click Add products to open the Add products form, 
and then add one or more products to a selected category. If you use the 
Add products form to add products to the category, you can select 
products from any existing category hierarchies.  During the selection 
process if a wrong product is selected you can use the remove button 
placed on the top right hand side of the form to remove the product 
selected.  

 

6. Click the Retail product properties FastTab, and then enter default settings for 
the retail product properties. These settings are automatically inherited by all 
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products that are assigned to the category. However, you can override the 
settings for an individual product.  

I. Under the Groups area select the Tracking dimension group from the 
drop down list that would be defaulted to the product assigned to the 
category. 

II. Select the Storage dimension group from the drop down list that would 
be defaulted to the product assigned to the category. 

III. Select the Product dimension group from the drop down list that would 
be defaulted to the product assigned to the category. 

IV. Under the Variant groups area select the Size group from the drop down 
list that would be defaulted to the product assigned to the category. 

V. Select the Color group from the drop down list that would be defaulted 
to the product assigned to the category. 

VI. Select the Style group from the drop down list that would be defaulted to 
the product assigned to the category. 

VII. Under the Barcode area select the Use EAN standard bar code check box 
if the product should follow the International article number (EAN) 
standard for bar codes. 

VIII. Under the POS terminals area select the Keying in price from the drop 
down list. The options available are: 

1. Not mandatory: It is not required to key in the price. 

2. Must key in new price: It is necessary to key in the new price. 

3. Must key in higher/equal price: Must key in a price higher to or 
equal to the standard price. 

4. Must key in lower/equal price: Must key in a price lower or equal 
to the standard price. 

5. Must not key in price: The price must not be keyed in at the 
terminal. 

IX. Select the Keying in quantity from the drop down list. The options 
available are: 
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1. Not mandatory: It is not required to key in the quantity. 

2. Must key in quantity: It is necessary to key in the quantity. 

3. Must not key in quantity: The quantity must not be keyed in at the 
terminal. 

X. Select the Scale product check box to indicate the product in required to 
be weighed on the scale. 

XI. Select the Must key in comment check box to enforce the cashier to 
enter comment for the products during sales operations at the point of 
sale. 

XII. Select the Zero price valid check box to indicate the product can have 
zero pricing and can be sold at the point of sale. 

XIII. Select the Quantity becomes negative check box to indicate that the 
inventory can go negative. 

XIV. Check the No discount allowed check box to enforce cashiers not to 
provide discounts at the point of sale. 

XV. Under the Activation area select the Issue date for the product assigned 
to the category. 

XVI. Under the Blocking area select the Blocked at register check box to block 
the products assigned to a category from being sold at POS terminals. 

XVII. The Date blocked field will display the date the category / products were 
blocked. 

XVIII. Select the Date to be blocked field to assign a future date when the 
products needs to be blocked. 
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7. Click the Basic product properties FastTab, and then enter settings for the base 
product properties. These settings are automatically inherited by all products 
that are assigned to the category, across one or more legal entities. However, 
you can override the settings for an individual product.  

I. Select the Edit by legal entity button to set up default configuration by 
legal entity. Select the legal entity from the drop down list. 

II. Under the Units area enter the Purchase price unit. 

III.  Enter the Sales price unit. 

IV. Select the Purchase unit from the drop down list. 

V. Select the Inventory unit from the drop down list. 

VI. Select the Sales unit from the drop down list. 

VII. Select the BOM unit from the drop down list. 

VIII. Select the Base comparison unit from the drop down list. 

IX. Under the Groups area select the Item group from the drop down list. 

X. Select the Coverage group from the drop down list. 

XI. Select the Counting group from the drop down list. 
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XII. Select the Inventory model from the drop down list. 

XIII. Under the Sales tax area select the Purchase order sales tax group from 
the drop down list. 

XIV. Select the Sales order tax group from the drop down list. 

XV. Under the Default warehouses area select the default Site from the drop 
down list. 

XVI. Select the default Purchase warehouse from the drop down list. 

XVII. Select the default Inventory warehouse from the drop down list. 

XVIII. Select the Sales warehouse from the drop down list. 

XIX. Under the Default reports area select the Shelf label report from the 
drop down list that would be defaulted to the product assigned to the 
category. 

XX. Select the Product label report from the drop down list that would be 
defaulted to the product assigned to the category. 

XXI. Under the Location replenishment area select the Replenishment rule 
that will be applied to the products assigned to the category. 

XXII. Under the Bar code area select the Bar code setup format from the drop 
down list that would be defaulted to the product assigned to the 
category. 
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I. Select the Edit in grid button to configure the default settings using the 
table view grid. 

II. Select the Property group option to configure from the drop down list. 
The options available are: 

 Bar code: Configure the bar code set up for the category from the 
drop down list by legal entity. 

 Default reports: Configure the default shelf and product label 
reports for the category by legal entity. 

 Default warehouses: Configure the default warehouses for the 
products assigned to the category. 

 Fiscal information: The fiscal information currently doesn’t have 
any fields associated in the current release. 

 Groups: Configure the Item and coverage groups for the products 
assigned to the category. 
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 Location replenishment: Configure the default replenishment 
hierarchy for the category by legal entity. 

 Sales tax: Enter the sales tax groups for purchase order and sale 
orders. 

 Units: Select the unit of measure for the products assigned to the 
category. 

III. Enter the values based on the selection in the grid table by legal entity. 

 

8. Click the Product attribute groups FastTab to add other attribute groups to the 
products in the hierarchy.  

I. Click on Add to assign attribute groups to the category so that products 
assigned to the category automatically inherit the attributes from the 
selected group. The product attribute groups form opens. 

II. Select the check boxes next to the attribute group and click Select button 
to add the selected attribute groups to the bottom screen. 
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III. Click OK to confirm to add the selected attributes to the category. 

 

IV. Select the Inherit attributes from parent category check box to inherit 
attributes properties from parent attributes selected in the list. 

9. Click the Map vendor categories FastTab to map the vendor’s product 
categories to the retail product categories in which the vendor is authorized to 
supply products.  
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I. Click on Add to select a vendor and related vendor hierarchy to associate 
with the retail category. 

II. Select the Vendor account from the drop down list. 

III. Select the Vendor product category from the drop down list. 

 

 Click OK to confirm the selection. 

10. Click the Category attribute values FastTab to view values for the category 
attributes.  To add category attributes Click on the Edit Category hierarchy to 
go to the Category hierarchy form, then click on Edit, once the form is in edit 
mode highlight the category and click on the Add Attributes. 

 

Close the Category Hierarchy Form and then proceed to the next step. 
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11. Click on Edit presentation text to enter description for the category to be 
displayed on the e-commerce website. 

 

The Catalog product presentation form will open. Click Edit to open an editor to 
enter the presentation text. 

 

Click File > Save to save the changes to the presentation text. 
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Close the Catalog product presentation from to save the changes. 
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12. Click on Images to add multiple images for the selected category to display on 
the e-commerce website. 

 

The Images form will open. 
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 Click on New to link a new image to the category. 

 Enter the URL location of the new image. 

 Enter a Friendly name for the image. 

 Select the Default check box if you wish to set the image as the default 
image for the category. 

13. Click on Videos to add multiple videos for the selected category to display on 
the e-commerce website. 

 

The Videos form opens. 
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 Click on New to link a new image to the category. 

 Enter the URL location of the new image. 

 Select the Default check box if you wish to set the image as the default 
image for the category. 

14. Click on Update products on the top tool bar of the retail product hierarchy 
form on completion of the edit or add action on this operation. 
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 The update product form will open. 

 Select the Select All check box to update all fields listed below on the form. 

 Under the Retail group properties FastTab select the fields by marking the 
check boxes to update the products associated to the category. 

 Under the Basic product properties FastTab select the fields by marking the 
check boxes to update the products associated to the category. 
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 Select the Include products in all sub-categories check box to include 
products in sub category to update on the selected fields. 

 Select the Include products with overridden attributes to update products 
which have over-ridden attributes. 

 Click on Update to update the products with the selected fields. 

 If you wish to run the update as a schedule job then click on Schedule batch 
job button. An infolog appears with a confirmation dialog. 

 

 Note: The updates are made for the products based on the above selection across 
all legal entities. 

8.1.4 MAINTAIN A RETAIL SUPPLEMENTAL HIERARCHY 

Supplemental hierarchies can be created to categorize a subset of products for a specific 
purpose, such as special pricing, promotions, or special product discounts. 

1. Click Retail > Setup > Category hierarchies > Supplemental retail hierarchies.  

2. On the Supplemental retail hierarchies’ list page, in the New group, click 
Category hierarchy to create a new category hierarchy.  
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3. To modify a hierarchy highlight the line in the list view and then Click Edit 
category hierarchy or double click the highlighted line to open the Category 
hierarchy form, and then modify the structure of the category hierarchy.  

4. In the left pane, select a category in the tree structure. 

5. To Add a product on the Products FastTab, click Add to add one product at a time 
from the organization-wide product list. Alternatively, click Add products to open 
the Add products form, and then add one or more products or product variants 
to a selected category. If you use the Add products form to add products to the 
category, you can select products from any existing product hierarchies.  

 

The Add products button will open the add products form to allow selection of 
multiple products by category. Click OK to confirm and add the products to the 
retail category. 
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6. Click the Product attribute groups FastTab to add other attribute groups to the 
products in the hierarchy.  

1. Click on Add to assign attribute groups to the category so that products 
assigned to the category automatically inherit the attributes from the 
attribute groups. The product attribute groups form opens. 

2. Select the check boxes next to the attribute and click Select button to add 
the selected attributes to the bottom screen. 

 

3. Click OK to confirm to add the selected attribute groups to the category. 
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4. Select the Inherit attributes from parent category check box to inherit 
attributes properties from parent attributes selected in the list. 

7. Click the Map vendor categories FastTab to map the vendor’s product categories 
to the supplemental retail categories in which the vendor is authorized to supply 
products.  

1. Click on Add to select a vendor and related vendor hierarchy to associate 
with the retail category. 

2. Select the Vendor account from the drop down list. 

3. Select the Vendor product category from the drop down list. 

 

 Click OK to confirm the selection. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

226 

 

8. Click the Category attribute values FastTab to view values for the category 
attributes. You add category attributes in the Category hierarchy form. 

9. Click on Edit presentation text to enter description for the category to be 
displayed on the e-commerce website. 

 

The Catalog product presentation form will open. Click Edit to open an editor to 
enter the presentation text. 

 

Click File > Save to save the changes to the presentation text. 
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Close the Catalog product presentation from to save the changes. 
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10. Click on Images to add multiple images for the selected category to display on 
the e-commerce website. 

 

The Images form will open. 
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 Click on New to link a new image to the category. 

 Enter the URL location of the new image. 

 Enter a Friendly name for the image. 

 Select the Default check box if you wish to set the image as the default 
image for the category. 

11. Click on Videos to add multiple videos for the selected category to display on 
the e-commerce website. 

 

The Videos form opens. 
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 Click on New to link a new image to the category. 

 Enter the URL location of the new image. 

 Select the Default check box if you wish to set the image as the default 

image for the category. 

8.1.5 MAINTAIN A RETAIL CHANNEL NAVIGATION HIERARCHY 

Retail channel navigation hierarchies can be created to categorize all or a subset of 
products for online stores to define the navigation structure on how the products are 
grouped and displayed.  

Click Retail > Setup > Category hierarchies > Retail channel navigation hierarchies.  

12. On the Retail channel navigation hierarchies’ list page, in the New group, click 
Category hierarchy to create a new category hierarchy.  

13. To modify a hierarchy highlight the line in the list view and then Click Edit 
category hierarchy or double click the highlighted line to open the Category 
hierarchy form, and then modify the structure of the category hierarchy.  

14. In the left pane, select a category in the tree structure. 

15. To Add a product on the Products FastTab, click Add to add one product at a time 
from the organization-wide product list. Alternatively, click Add products to open 
the Add products form, and then add one or more products or product variants 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

231 

 

to a selected category. If you use the Add products form to add products to the 
category, you can select products from any existing product hierarchies.  

 

The Add products button will open the add products form to allow selection of 
multiple products by category. Click OK to confirm and add the products to the 
retail category. 

 

16. Click the Product attribute groups FastTab to add other attribute groups to the 
products in the hierarchy.  

1. Click on Add to assign attribute groups to the category so that products 
assigned to the category automatically inherit the attributes from the 
attribute groups. The product attribute groups form opens. 
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2. Select the check boxes next to the attribute and click Select button to add 
the selected attributes to the bottom screen. 

 

3. Click OK to confirm to add the selected attribute groups to the category. 

 

4. Select the Retail attribute group type from the drop down list. The 
options available are: 
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 Default: The attribute group and the associated attributes is 
stored as an individual attributes in the online database. 

 Specification: All the attributes within the attribute group are 
combined as one field and stored in the online database. 

5. Select the Inherit attributes from parent category check box to inherit 
attributes properties from parent attributes selected in the list. 

17. Click the Category attribute values FastTab to view values for the category 
attributes. You add category attributes in the Category hierarchy form. 

18. Click on Edit presentation text to enter description for the category to be 
displayed on the e-commerce website. 

 

The Catalog product presentation form will open. Click Edit to open an editor to 
enter the presentation text. 

 

Click File > Save to save the changes to the presentation text. 
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Close the Catalog product presentation from to save the changes. 
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19. Click on Images to add multiple images for the selected category to display on 
the e-commerce website. 

 

The Images form will open. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

236 

 

 

 Click on New to link a new image to the category. 

 Enter the URL location of the new image. 

 Enter a Friendly name for the image. 

 Select the Default check box if you wish to set the image as the default 
image for the category. 

20. Click on Videos to add multiple videos for the selected category to display on 
the e-commerce website. 

 

The Videos form opens. 
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 Click on New to link a new image to the category. 

 Enter the URL location of the new image. 

Select the Default check box if you wish to set the image as the default image for the 
category. 
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9 ASSORTMENTS 

OVERVIEW 

In this module we will describe that an assortment is a collection of retail categories 
and, or products that are allocated as a range that is offered by an individual store or 
retail channels. Multiple assortments can be assigned to each store or a group of stores. 

Range defines all the products that are offered by the store or the retail channel.  

Typically, assortments are created as geographical locations to group stores based on 
the business requirements. To use the assortment setup, organization hierarchies must 
be created and assigned a retail assortment purpose. 

 SET UP THE ASSORTMENT 

To set up the assortment, follow these steps. 

1. Click Retail Headquarters > Common > Assortments. 

 

2. To set up a new assortment, click Assortment in the New group of the Assortments 
FastTab. 

3. In the General FastTab, enter a unique assortment number.  

4. Enter the Assortment name for the newly created assortment. 

5. Enter the Effective date to display the date that the assortment will be effective in 
the retail stores that are identified. 

6. Enter the Expiration date to display the date that the assortment will expire. 

 The Status field displays the status of the assortment and it displays if the 
assortment is in draft mode or if the assortment is published. 

 The Submitted date and time shows the date and the time that the 
assortment is last submitted for publication. 
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 The Modified date and time shows the date and time that the assortment is 
last modified. 

 

 

7. In the Retail Channels FastTab, to add stores to the assortment, click the Add line 
button and then follow these steps.   

 

i. Select the Organization hierarchy from the drop down list box. 
 

 The Available organization nodes list is updated based on the selection. 
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ii. Select the stores or the business unit from the left pane list and click the Add 
button to add to the Selected organization nodes list. Follow steps i to iii to add 
more nodes to the assortments. 
 

iii. Click the Close button to confirm that more stores are added to the assortment. 

 

 

8. Under the Products FastTab, click the  Add line button to add products to the 
assortment by using one of the following ways: 

xiii. Click in the grid, press CTRL+N, and then select an item, variant, or group of 
items that is part of this assortment. Repeat this step for any additional items, 
variants, or groups of items. 

xiv. Click the Add line button on the grid. 

i. Select the retail product Category from the drop down list box if the 
assortment is obtained based on categories. 
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ii. Select the Product from the drop down list box if a specific product must 
be added to the assortment. 

iii. Select the Product variant from the drop down list box if only a specific 
variant must be added to the assortment. 

 The Name field is automatically populated based on the product 
selection. 

iv. Select the Line type from the drop down list box. The options include the 
following: 

 Include: Select to include the product or the category as part of 
the assortment. 

 Exclude: Select to exclude the product or the category as part of 
the assortment. 

v. Follow steps i. to v. to add more categories, products, variants, inclusions, 
and, or exclusions to the assortment. 

     

vi. Another way to add multiple products to the assortment is to click the 
Add products button. As soon as you do this, click the OK button to add 
the selected products to the assortment. 
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9. To activate the assortment, click Publish from the Maintain group on the 
Assortments FastTab. 

 Note 

Assortments will be effective at the retail stores based on the date that is set in the 
Effective date field. The assortment must be published for the changes to be sent to 
the retail stores.  

The assortment must be published at least one time to perform the revert operation. 

 

 A window opens to confirm that the assortment changes are published.  

10. Click Yes. 
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11. To revert the changes that are performed on the assortment, click the Revert button 
on the Maintain group of the Assortments FastTab. By doing this, all the changes 
that are made to the assortment are canceled, and the assortment is reverted to the 
last one that is published.   

 

 A window opens to confirm the revert operation.  

12. Click Yes. 

 

13. To view products that are assigned to the assortment, click View assortment 
products on the Inquiries group of the Assortments FastTab.  
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14. The Products list form opens with a list of products that are assigned to the 
assortment. 

 

15. To create a new assortment from an existing assortment, click the Copy assortment 
button from the New group under the Assortments FastTab. 
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The copy assortment functionality creates a new assortment with a new unique 
assortment number. The new assortment includes the retail channels and the 
products that are copied and will be modified and published.   
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10 VARIANT 

OVERVIEW 

In this module we will learn a variant is a product with specific attributes that are called 
dimensions. Microsoft Dynamics AX includes three dimensions—Size, Color and Style. 
After you set up the size, color, and style dimensions, you organize the dimensions into 
dimension groups. For example, you might have a size group named Men's Shoes with 
specific sizes that are assigned to the group, or a color group named Ladies Summer 

Colors with colors such as White, Pink, and Purple that are assigned to this group. 

You have products that are the Product or Product master subtype. After you define a 
product as a product master, you can create product variants that are based on the 
product master.  

Product dimensions are characteristics that differentiate a product variant, such as the 
size, color, and style. You can use combinations of product dimensions to define product 
variants. To create a product variant, you must define at least one product dimension for 
a product master. You can also rename dimensions.  

To create variants, follow these steps. 

1. Create sizes, colors, and styles. 

2. Create size, color and style groups. 

3. Assign sizes, colors and styles to groups. 

 

Note 

The variant group size, color and style can be assigned to a category as the 
default in the retail product hierarchy in the Retail product properties FastTab. 

 

The variant for a product master can be assigned in the Product details form in 
the Retail FastTab. 

 

To scan product variants at the Point-of-Sale (POS) level, each product variant 
must be set up with a bar code. However, if a variant is not set up with a bar 
code, the cashier can select the product by the variant so that the variant is 
processed at the POS level.  
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 SIZES, COLORS, AND STYLES 

To set up the size, follow these steps.  

1. To create sizes, click Retail > Setup > Variant groups > Sizes.  

 

2. In the Product dimension form, click New to create a new size. 

3. In the Size field, type the name of the size.  

To set up the color, follow these steps.  

1. To create color, click Retail > Setup > Variant groups > Color.  
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2. In the Product dimension form, click New to create a new color. 

3. In the Color field, type the name of the color. 

To set up the style, follow these steps.  

1. To create the style, click Retail > Setup > Variant groups > Style.  

 

2. In the Product dimension form, click New to create a new style. 

3. In the Style field, type the name of the style. 

 ASSIGN SIZES, COLORS AND STYLES TO THE DIMENSION 
GROUPS 

The dimension group (size, color or style) can be assigned directly to a product or to a 
category in a retail product hierarchy. After a new product is created and assigned to a 
category in the retail product hierarchy, the product inherits the variant that is assigned 
to the category. The variant setting can be edited at the product level.  

To edit the variant setting at the product level, follow these steps. 

1. Click Retail > Setup > Category hierarchies > Retail product hierarchy> Select 
Category and click the Retail product properties FastTab by hierarchy level. 
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2. Click Retail > Setup > Variant groups > Size group.  

 

3. In the Size groups form, click New to create a new group.  

4. In the Size group field, type an ID number for the group.  

5. In the Description field, type a description of the group.  
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6. Click Copy to copy an existing sizing group. This automatically copies the sizes in 
the size group that is being copied. It requires a unique size group name. 

7. Click Sizes to select sizes to add to the size group.  

 

8. Click New to create a new record.  

9. In the Size field, select the size that you want.  

The Name field displays the name of the size, color, or style.  

10. In the Replenishment weight field, specify how many of this variant are 
replenished in relation to the other variants. For example, you can order three 
size 8 shoes for every size 5 shoe you order.  

11. In the Number in bar code field, type the number that is automatically assigned 
to the group after the bar codes are created for the variants.  

12. In the Display order field, type the number that shows the order for the display.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                         

13. Repeat steps 6 through 11 to add other sizes, colors, or styles to the group. 

14. As soon as you receive the message to update all items in the group, click Yes.  

The Auto number bar code automatically numbers all the numbers in the Number in 
bar code column sequentially with as many leading zeros as might be required.  
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 ASSIGN DIMENSION GROUPS TO THE RETAIL CATEGORY 

Dimension groups can be assigned to retail categories. The dimension groups are 
inherited by the products after the dimension groups are assigned to a retail category. 

Based on the allocated dimensions for a product master, a variant suggestion can be 
used to create variant combinations.  

To create variant combinations, follow these steps. 

1. Click Retail > Setup > Category Hierarchies > Retail Product Hierarchy. 

2. Select the category in the hierarchy to allocate variants.  

3. On the Retail product properties FastTab, under Variant groups, select a group in 
the Size group, Color group, and Style group fields.  
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 ASSIGN VARIANT TO A PRODUCT 

In scenarios where the retail product hierarchy is not used or variant/dimension groups 
are not allocated to a retail category, the Variant (Dimensions) groups must be assigned 
directly to a product. The sizes, colors, and styles in the dimension groups are then 
automatically associated with the product. 

To add a dimension group, follow these steps.  

1. Click Retail > Common > Products > Released products by category.  

2. In the Released product details form, select the product to add a dimension 
group to. Then, on the Action Pane, in the Maintain group, click Edit.  

3. In the second Released product details form, on the Retail FastTab, in the 
Variant field, select an appropriate dimension group in the Size group:, Color 
group:, and Style group: fields.  

You can view or modify the sizes, colors, and styles of a product. On the General 
FastTab, view or modify the values in the Size, Color, and Style fields.  
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 DEFINE PRODUCTS AND CREATE PRODUCT VARIANTS 

You define products from the following locations:  

 Products – Use this list page to define products that are the Product subtype.  

 Product masters – Use this list page to define products that are the Product 
master subtype.  

 All products and product masters – Use this list page to define products that are 
both subtypes.  



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

254 

 

 Product details – Use this form to create a detailed product definition. For 
example, for a product master, you can specify new variants to be generated at 
the time when new dimensions are associated with the product master.  

Tip: To open the Product details form, define a product on the Products, 
Product masters, or All products and product masters list page. Then, on the 
Action Pane, in the Maintain group, click Edit. 

 Released products – Use this list page to create product definitions and release 
product definitions.  

Note 

If you use this list page to create a product definition, you can specify information, such 
as the item model group, when you create the product definition. However, for example, 
if you create a product definition in the Products list page, and then release the product 
definition to a company, you must add the item model group to the product after the 
product release. 
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11 PRODUCT - ORDER CREATION AND VENDOR 
SETUP 

OVERVIEW 

In this module we will describe the vendor sales margin, and vendor product numbers 
and the reasons why this set up in important. 

Vendor sales price margins 

The vendor sales price margin contains a formula that converts the vendor's suggested 
retail price or the vendor's purchase price into a sales price in local currency. This 
method is only used if an entry in the vendor's sales price points does not exist for the 
item. The sales price margin calculation is applicable to product catalogue import 
process and doesn’t get calculated during manual product creation.  

Note 

If no suggested retail price in the item line is being imported to the journal, the 
sales price can be calculated based on the purchase price. Retail uses this form to 
calculate the sales price. 

For vendor sales price margin set up to work, vendor category must be mapped 
to a retail category in the retail product hierarchy form. 

Set up a vendor sales price margin 

1. Click Retail > Setup > Product/Order creation > Vendor sales price margin setup.  

2. Click New to create a new vendor sales price margin setup. 

Vendor sales price margin setup form 

Overview tab 

 Vendor account – Select a vendor account from the drop down list. 

 Name – The name of the vendor selected in the Vendor account column. 

 Retail category – Select a category from the retail product hierarchy list. 

 Suggested contribution ratio – The suggested factor from the vendor that is used for 
calculating the sales price of a product. 
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 Contribution ratio – Enter a contribution ratio to be used to calculate the sales price for 
the product. 

 

 VENDOR SALES PRICE POINT SET-UP 

Vendor sales price points 

The vendor sales price point setup contains the conversion of the vendor's suggested 
retail price to the sales price in the local currency. The sales price point calculation is 
applicable to product catalogue import process and doesn’t get calculated during 
manual product creation. 

 Note 

For vendor sales price margin set up to work, vendor category must be mapped 
to a retail category in the retail product hierarchy form. 

Set up vendor sales price points 

1. Click Retail > Setup > Product/Order creation > Vendor sales price point setup.  

2. Click New to create a new vendor sales price points.  

Vendor sales price point setup form 

Overview tab 

i. Vendor account – Select the vendor account from the drop down list. 

 Name – The name of the vendor selected in the Vendor account column. 

 Retail category – Select the retail category from the drop down list. 

 Suggested retail price – The factor that is used for calculating the sales price. 

 Sales price –The price at which the product is sold. 
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 VENDORS PRODUCT NUMBERS  

Vendor item numbers 

The vendor product number is classified as an external number for products in Dynamics 
AX for Retail. This external item number is associated with the product number created 
in Dynamics AX for Retail. 

Invoices can be printed with item numbers and descriptions that are specific to a 
particular recipient.  

The external item number(s) can be set up for a specific vendor, including the variants 
associated with the product master. 

Set up a vendor's item number 

1. Click Retail > Setup > Product/Order creation > Vendor's product numbers.  
2. Select an external item number or click New to create a new vendor product 

number. 

Follow the steps below to enter create external item numbers: 

External item descriptions form 

Overview Tab 

 External item number – Enter the vendor product number to be assigned to an existing 
product in Dynamics AX for Retail. 

 Item number – Select a product from the drop down list that maps to the vendor 
external number. 

 Product name – The name of the product selected. 

 Vendor – Select the name of the vendor from the drop down list. 

 Name – The name field displays the name of the vendor selected. 
General Tab 

 Enter the External item text that will be printed on the vendor invoice. 

 Under Description area select an ABC code from the drop down list. 

 Enter a Description regarding the ABC classification. 
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 Under Inventory dimensions area product, tracking and storage dimension 
information are displayed. 

 Configuration – The configurations for on-hand inventory items and BOM items. 

 Size – Displays the size variant of the product. 

 Color – Displays the color variant of the product. 

 Style – Displays the style variant of the product. 

 Site – The default site number assigned to the product. 

 Warehouse – The default warehouse number assigned to the product. 

 Batch number – The batch number assigned if the item is a serialized product. 

 Location – The location of the product. 

 Pallet ID – The pallet ID the product belongs to. 

 Serial number – The serial number assigned to a product of type serialized product. 
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12 PRICING AND DISCOUNT GROUPS 

OVERVIEW 

In this module we will discuss that retail price group can be defined for retail channels. 
The retail price group includes the products that have defined retail prices or discounts. 
You can use price groups to offer an item at different prices to different groups of retail 
channels. 

Note 

Prices in price groups are distributed with trade agreements. 

12.1.1 CREATE A RETAIL PRICE GROUP 

To create a new retail price group, follow these steps. 

1. Click Retail > Setup > Pricing and discount > Retail price groups. The Retail price 
group form opens. 

2. Click New to create a new retail price group. 

3. In Price groups, enter the Price groups ID. This ID is a unique code for the retail 
price group. 

4. In Name, enter the Name of the retail price group. 

5. In Is retail group, select the check box to specify that the price group is a retail 
price group. 

The following topic describes how to add products and define pricing to the retail 
price group. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

260 

 

 

12.1.2 CREATE THE RETAIL TRADE AGREEMENT 

To create the retail trade agreement for a retail price group, follow these steps. 

 

1. Click Retail > Setup > Pricing and discount > Retail price groups. The Retail price 
group form opens. 
 

2. Select the price group to create the trade agreement. 
 

3. Click trade agreement and then click Trade agreements > Create trade 
agreements. 
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 The Price/discount agreement journals form opens. 
 

4. Select the Name of the agreement journal from the drop down list box. 
 

 The Price/discount journal number will be auto-generated based on the number 
sequence. 
 

5. Enter the Name of the agreement journal. 
 

 The Posted check box specifies if the agreement journal is posted. 
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6. Click Lines on the top tool bar to add lines to the agreement journal. The Journal 
lines form opens. 
 

7. On the Overview tab, select the Relation from the drop down list box. The 
relation defines the type of price that is being defined for the customer, vendor 
or products. The options include the following: 

i. Price (purch.): Use this relation to create standard vendor pricing for the 
vendor or vendor groups that are specific to products or price groups. 

ii. Line disc. (purch.): Use this relation to create line level discount pricing 
for the vendor or vendor groups that are specific to products or price 
groups. 

iii. Multiline disc. (purch.): Use this relation to create multi-line discount 
pricing for the vendor or vendor groups that are specific to products or 
price groups. 

iv. Total disc. (purch.): Use this relation to create total discount pricing for 
the vendor or vendor groups that are specific to products or price groups. 

v. Price (sales): Use this relation to create standard customer pricing for the 
customer or customer groups that are specific to products or price 
groups. 

vi. Line discount (sales): Use this relation to create line level discount pricing 
for the customer or customer groups that are specific to products or price 
groups. 

vii. Multiline disc. (sales): Use this relation to create multi-line discount 
pricing for the customer or customer groups that are specific to products 
or price groups. 

viii. Total disc. (sales): Use this relation to create total discount pricing for the 
customer or customer groups that are specific to products or price 
groups. 

8. Select the Account code from the drop down list box. The options include the 
following: 

i. Table: Used to select an individual customer or vendor based on the 
relation that is selected. 

ii. Group: Used to select a customer group or vendor group based on the 
relation that is selected. 

iii. All: Offers the price to all customers or vendors based on the relation 
that is selected. 

9. Select the Account selection from the drop down list box. The list differs based 
on the relation and the account code selection. 

10. Select the Item code from the drop down list box. The options include the 
following: 

i. Table: Used to select an individual product. 
ii. Group: Used to select price groups. 
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iii. All: Applies the price changes to all the products. 
11. Select the Item selection from the drop down list box. The list differs based on 

the item code selection. 
12. Select the Configuration product dimension value if the product selected is a 

variant. 
13. Select the Size product dimension value if the product selected is a variant. 
14. Select the Color product dimension value if the product selected is a variant. 
15. Select the Style product dimension value if the product selected is a variant. 
16. Select the Site from the drop down list box. 
17. Select the From quantity to specify the lower range to apply to the product 

pricing. 
18. Select the To quantity to specify the higher range to apply to the product pricing. 
19. Select the Unit of measure of the product from the drop down list box. 
20. Enter the Amount in currency for the price of the product. 
21. Select the Currency in which the amount is specified. 

 The Dimension validation field specifies if the dimensions for the product are 
valid. 

 The Trade agreement validation field specifies if the trade agreement is 
validated. 

 

22. Click Validate on the top tool bar to validate if all the mandatory fields are 
populated. A message is displayed and the message states if the validation is 
successful or it is not successful. 
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23. Click Post on the top tool bar to post the price group additions. 

 A message is displayed and the message confirms if the agreement journal 
posted. 
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12.1.3 VIEW TRADE AGREEMENTS 

To view trade agreements for both sales and purchasing for the retail price group, 
follow these steps. 

1. Click Retail -> Setup -> Pricing and discount -> Retail price groups. The retail 
price group form opens. 
 

2. Select the price group to create the trade agreement. 
 

3. Click Trade agreements > View trade agreements (Sales). 

 

 Note 

The discount trade agreements are not available because the retail price groups are 
created to define normal sales and purchase pricing for the retail stores. 

 The View trade agreements form opens. 
 

 The form displays a list of relations, item details and the pricing for the products. 
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 MIX MATCH LINE GROUPS 

The mix and match line groups is used to associate line groups with mix and match 
promotions. Additionally, the mix and match line groups are used to define the 
combination of products that are required to qualify for the discounted price at the 
retail channels. 

To link mix and match promotions with groups, follow these steps. 

1. Click Retail > Setup > Pricing and discount > Mix and match line 
group. The Mix and match line group form opens. 

2. Click New to create a new mix and match group. 
3. Select the mix and match Discount from the drop down list box. 
4. Select the Line group from the drop down list box. 
5. Enter the Number of products needed to specify the quantity that 

must be purchased by the customer to qualify for the discount 
offer. 

 The Line color is auto-populated based on the line group that is 
selected. 
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 Note 

Discounts are not affected by the Line color column if the discounts are not being used 
to visually differentiate the products that are allocated to specific line groups. 
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 MIX AND MATCH LINE GROUP SET UP 

The mix and match line group set up is used to create templates for the number of 
products that are required as a combination to qualify for discount offers. 

To set up mix and match line groups, click Retail > Setup > Pricing and discount > Mix 
and match line group set up. The Mix and match line group setup form opens. 

To create a new mix and match line group, follow these steps. 

1. Click New to create a new mix and match group. 
2. Enter the Line group number for the mix and match group. 
3. Enter the Number of products needed to qualify for the discount. 
4. Click the Line color to open the color cue list to select a color for the line 

group. 

 

 Note 

Discounts are not affected by the Line color column, if the discounts are not being used 
to visually differentiate between products that are allocated to specific line groups.   
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 DISCOUNT PERIOD 

Discount periods are used to define the specific time periods that the discounted prices 
can be offered at the retail channels. The discount periods that are created can be 
assigned to quantity discounts and mix and match promotions to define the period and 
time that the discount prices will be offered at the retail channels. 

The time period can be specified by using a start date and an end date, or specific days 
of the week and specific times in a day. 

To setup discount periods, follow these steps.  

1. Click Retail > Setup > Pricing and discount > Discount period. The Discount 
period form opens. 

2. Click New to create the new discount period. 
3. Enter the Discount period number for the new discount that is created. 
4. Enter a Description for the discount period. 
5. In the General FastTab, in the Period area, enter the Start Date to specify a 

starting date for the discount period. 
6. Enter the End date to specify an ending date for the discount period. 
7. Enter the Starting time to specify when the discount period will start.   
8. Enter the Ending time to specify when the discount period will finish. 
9. Select the Time within bounds check box to specify that the discount offer is 

within the time period of the start date and the end date. If the time in the 
Bounds check box is not selected, then the discount offer will continue to be 
offered after the start date and the end date that is specified. 

10. Select the Ending time after midnight check box to specify that the discount 
offer ends at midnight every day or on the end date that is specified. 

11. The Dates within bounds area is controlled by the section underneath. This 
section specifies if the offer is within the limits of the starting time and the 
specific end date.  

 
12. In the Monday area, enter the Starting time of the discount. 
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13. Enter the Ending time of the discount. 
14. Select the Time within bounds check box to include Monday in the period 

that will be within the limits of the time that is specified. 
15. Select the Ending time after midnight to specify that the discount period 

ends after midnight. 

 
16. In the Tuesday area, enter the Starting time of the discount. 
17. Enter the Ending time of the discount. 
18. Select the Time within bounds check box to include Tuesday in the period 

that will be within the limits of the time that is specified. 
 
19. Select the Ending time after midnight to specify the discount period ends 

after midnight. 

 
20. In the Wednesday area, enter the Starting time of the discount. 
21. Enter the Ending time of the discount. 
22. Select the Time within bounds check box to include Wednesday in the period 

that will be within the limits of the time that is specified. 
23. Select the Ending time after midnight to specify that the discount period 

ends after midnight. 

 
24. In the Thursday area, enter the Starting time of the discount. 
25. Enter the Ending time of the discount. 
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26. Select the Time within bounds check box to include Thursday in the period 
that will be within the limits of the time that is specified. 

27. Select the Ending time after midnight to specify that the discount period 
ends after midnight. 

 
28. In the Friday area, enter the Starting time of the discount. 
29. Enter the Ending time of the discount. 
30. Select the Time within bounds check box to include Friday in the period that 

will be within the limits of the time that is specified. 
31. Check the Ending time after midnight to specify the discount period ends 

after midnight. 

 
32. In the Saturday area, enter the Starting time of the discount. 
33. Enter the Ending time of the discount. 
34. Select the Time within bounds check box to include Saturday in the period 

that will be within the limits of the time that are specified. 
35. Select the Ending time after midnight to specify the discount period ends 

after midnight. 

 
36. In the Sunday area, enter the Starting time of the discount. 
37. Enter the Ending time of the discount. 
38. Select the Time within bounds check box to include Sunday in the period 

that will be within the limits of the time that is specified. 
39. Select the Ending time after midnight to specify the discount period ends 

after midnight. 
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 ROUNDING METHOD GROUP 

The Rounding Method Group is used to group different types of rounding methods for 
pricing and discounts. 

To set up discount periods, follow these steps.  

1. Click Retail > Setup > Pricing and discount > Rounding 
Method Group. The Rounding method group form opens. 

2. Click New to create a new round method groups. 
3. Enter the Rounding group number for the new group that 

is created. 
4. Enter a Description for the rounding method group. 
5. Click Rounding Method to add rounding methods to the 

group. 
6. Click New to create the new record. 
7. Enter the Minimum amount that is required for the 

rounding to take effect. 
8. Enter the value in Added before for a transaction to which 

the rounded method is rounded. For example, if you want 
Microsoft Dynamics AX for Retail to round an amount to a 
number that has no decimal places, enter 1.0 in this field. 
If you want Microsoft Dynamics AX for Retail to round an 
amount to two decimal places, enter 0.01 in this field. 

9. Enter the Type of rounding. The options include Up, Down 
and Nearest. 

10. Enter the Precision amount that is required for the 
rounding. 

11. Enter the value in Added after that a transaction for the 
rounded method is rounded to. 

12. Repeat steps 3 through 11 to add other rounding methods 
for this rounding method group. 

  

   



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

273 

 

 PRICE POINT GROUP 

Price Point Groups are used to define specific price points, if rounding occurs.  

To set up Price Point groups, follow these steps. 

1. Click Retail > Setup > Pricing and discount > Price 
Point Group. The Price Point Group form opens. 

2. Click New to create the new Price Point Group. 
3. Enter the Price Point Group Number for the new 

discount that is created. 
4. Enter a Description for the Price Point Group. 
5. Enter the Default rounding to specify how to round 

the Price Point Group. The options include Up, 
Down, and Nearest. 

6. Enter the Price points to specify when the Price 
Point Group will be affected. 
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13 BAR CODES AND LABELS 

OVERVIEW 

In this module we will learn how bar codes are unique codes allocated to products that 
are used to assist cashiers to sell, track and replenish products at a retail channel. You 
can also use bar codes to issue and endorse coupons, gift cards and credit memos. 

Bar codes can be set up to have standard or custom formats based on the business 
requirements. Bar codes can represent the unique codes of a product that is assigned by 
various manufacturers or by the variant information, based on size, color or style. 
Additionally, bar codes can include the weight or the price of a product. 

In Microsoft Dynamics AX for Retail products can be assigned to multiple bar codes. Bar 
code masks are defined and specify the template that is used to generate bar codes. 

Note 

For product variants to be scanned at the Microsoft Dynamics AX for Retail Point-of-
Sale (POS) level each product variant must be set up with a bar code. If no bar code 
is set up by variant, the cashier can search and select the product by each variant so 
that the product can be processed at the POS level. 

Each size, color, and style group can be assigned a unique number that identifies that 
group in the bar code. Microsoft Dynamics AX for Retail uses the bar code mask to 
generate bar codes automatically for each variant combination. This functionality can 
be useful if there are many sizes, colors, and styles.  Additionally, this increases the 
number of combinations significantly as each variant code is added.  

If bar code masks are not used, then bar codes must be manually assigned to each 
product variant combination. 

 

 SET UP 

Bar codes can be generated automatically or bar codes can be manually assigned to a 
product. To set up and configure bar codes, follow these steps. 

1. Set up bar code mask characters.  

2. Set up bar code masks. 

3. Set up bar code setups. 
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4. Create bar codes for specific items. 

 

13.1.1 MASK CHARACTERS 

Set up bar code mask characters  

Bar code mask characters are alphabetic characters that are replaced with numbers when 
Microsoft Dynamics AX for Retail uses a bar code mask to generate a bar code.  

Unique bar code masks can be assigned to create unique types of bar codes that are 
created for products, customers and workers.  

 Note  

To automate how a bar code is generated for a product variant and other entities, 
bar code masks must be set up. If there is no requirement about how to 
automatically generate the bar code, then the bar code can be assigned manually 
when the product is created. 

If a bar code is manually assigned for a product that has a bar code mask set up, then 
all the mask validations are bypassed except for check digits. If the check digit 
comparison fails, then an error message is displayed. For example: “Expecting check 
digit 8 but found 3.”  

To create a new bar code mask character, follow these steps. 

1. To open the Mask characters form, click Retail > Setup > Bar codes and labels > 
Mask characters.  



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

276 

 

 

 

2. Click New to create a new bar code mask character.  

 

3. In the Type field, select the type of mask character.  The options include the 
following: 
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1. Product 

2. Any number 

3. Check digit 

4. Size digit 

5. Color digit 

6. Style digit 

7. EAN license code 

8. Price 

9. Quantity 

10. Employee 

11. Customer 

12. Data entry 

13. Discount code 

4. Enter the Character that represents the mask type. It can be any character from 
A through Z.  

5. In the Description field, type a description of the mask character.  

13.1.2 SET UP BAR CODE MASKS 

Bar code masks are used to create and check bar codes and reduce bar code errors. Bar 
code masks can be set up for both standard bar codes and in-house bar codes.  

In-house bar code masks 

If you set up the custom bar code masks, you must be familiar with the requirements of 
the scanners that are used at the retail store. Some scanners only validate bar codes 
with a specific format and check digit. 

Bar code masks for an item with variants can be set up to generate the bar codes for 
each size, color, and style combination. 

Standard bar code masks 
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Bar codes often have a fixed structure; for example, European Article Number (EAN) 
standard bar codes have a modulus check digit as the last digit. Microsoft Dynamics AX 
for Retail determines if the bar code is input is valid and, if necessary, calculates the 
check digit and changes the input into a standard EAN bar code. 

Supported standards 

Bar code masks can be based on any of the following bar code standards:  

ii. No bar code 

iii. EAN128/UCC128 

iv. Code 39 

v. Interleaved 2 of 5 

vi. Code 128 

vii. UPC A 

viii. UPC E 

ix. EAN13 

x. EAN8 

xi. PDF397 

xii. Maxicode 

13.1.3 BAR CODE MASK SET UP 

To create a new bar code mask, follow these steps. 

1. Click Retail > Setup > Bar codes and labels > Bar code mask setup.  
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2. Click New to create a new bar code mask.  

3. In the Mask ID field, type an ID number, and then, in the Description field, type a 
description for the bar code mask.  

4. In the Type field, select the type of bar code mask. The options include the 
following: 

1. Product: Set up a bar code mask for products. 

2. Customer: Set up a bar code mask for customers. 

3. Employee: Set up a bar code mask for employees. 

4. Coupon: Set up a bar code mask for coupons. 

5. Data entry: Set up a bar code mask for data entry. 

6. Discount code: Set up a bar code mask for discounts. 

5. On the General FastTab, in the Bar code standard field, select the bar code 
standard for the mask.  

6. Under the Mask area, enter the unique ID for the Mask for the bar code. This is 
the result of the segments that are defined in the Bar code mask segment Fast 
Tab, together with the prefix. 

7. Prefix – The first character that is used in the bar code mask. The recommended 
setting is to set a prefix for each bar code mask to avoid overlapping sets of bar 
codes. 

8. Length – The required length of the bar code. The value in this column is 
calculated by Microsoft Dynamics AX for Retail, and is the total for the characters 
in the prefix and all segments. 
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9. Under the Bar code mask segment FastTab, click Add to create a new segment 
and then specify information about the segment. 

10. Enter the Segment number for the bar code mask. 

11. Select the Type from the drop down list box. The list displays the bar code masks 
that are created to assign a unique character to each bar code type. 

12. Enter the Length of the mask segment. 

13. Enter the Character that represents the mask segment. This can be any character 
from A through Z.  

14. Enter the Decimals that represent the mask segment.  
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13.1.4 CONFIGURE BAR CODE SETUPS 

To configure bar codes, follow these steps. 

1. Click Organization administration > Setup > Bar codes to open the Bar codes 
form.  

 

2. Click New to create a new setup for bar codes.  

 

3. In the Bar code setup field, type an ID for the setup.  

4. Enter a Description for the bar code setup. 

5. On the General FastTab, in the Bar code type field, select a standard type for the 
bar code.  
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6. Select a Mask for the bar code from the drop down list box.   

7. In the Font and Size fields, select a font for the bar code, and type a size for the 
font.  

8. In the Minimum length and Maximum length fields, type the minimum and 
maximum number of characters that the bar code can contain.  

For example, a bar code of the EAN-8 type always contains eight characters 
when it is printed. Therefore, for an EAN-8 bar code, both the minimum length 
and the maximum length are eight. For a bar code that contains a fixed string of 
five characters plus a number from 1 to 100, the minimum length is six, and the 
maximum length is eight. 

 

13.1.5 CREATE BAR CODES FOR SPECIFIC PRODUCTS 

To assign barcodes to products and variants, follow these steps. 

1. Click Retail > Setup > Bar codes and labels > Bar codes.  

 

2. Click New to create a new bar code for the product.  

3. On the General tab, under Item, select the item number from the drop down list 
box. 

4. Select an inventory dimension number from the drop down list box. 

5. Enter a Quantity for the selected product.  

6. Select a Unit of measure for the product for which the bar code is assigned. 
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7. Under Bar code, select the bar code format that is being assigned for the 
product.  

 

8. Under Setup, select the setup for the bar code from the drop down list box. 

9. To be printed – Select the check box if the bar code that is generated must be 
printed.  

10. Scanning – Select the check box if the bar code will be used for scanning at the 
retail stores. 
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11. If the bar code number must be displayed on the Retail FastTab of the Released 
product details form, select the Show for product check box. If this check box is 
not selected for any bar code number, Microsoft Dynamics AX for Retail 
automatically displays the smallest bar code number for the item.  

12. Under Product dimensions, specify the variant’s dimensions.  

The Overview tab displays the information that is entered from the General FastTab. 

 

Set up button 

To assign the store and section to the product, follow these steps. 

 Click Setup > Product section location to assign the store and section to the 
selected product. 
 

 The Item number displays the product number for the selected product from the 
Item – bar code form. 
 

 The Name displays the description of the selected product. 
 

 Select the Store number from the drop down list box. 
 

 Select the Section number from the drop down list box. 
 

 The Name field displays the name of the selected section. 
 

 Select the Shelf label from the drop down list box. 
 

 The Name field displays the name of the selected shelf. 
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 Shows sales statistics – The Shows sales statistics field has no functionality 
associated in the current version of Microsoft Dynamics AX for Retail. 

 

Functions button 

 Click Functions > Create bar codes to create or update the bar code for the selected 
item. 

Note 

This feature cannot be used for bar codes that have items with configuration 
variants. 

 Item number – The item selected on the Item – bar code form. This field cannot be 
edited.  

 Product name – The item selected on the Item – bar code form. This field cannot 
be edited.  

 Unit – The default value in this field is updated when the item is selected. 

 Bar code setup – Select the bar code setup that contains the bar code type, font, 
size, and mask information that you want. 

 Create bar code in all legal entities where this product is released – Select this 
check box to generate the bar code for all the legal entities to which the selected 
product is released.  
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 Create bar codes from number sequence – Use to create a bar code for 
imported items. This is required when a vendor does not provide a bar code for 
an item. 

 Item number – The item selected on the Item – bar code form. This field cannot be 
edited.  

 Product name – The item selected on the Item – bar code form. This field cannot 
be edited.  

 Use product – The default value in this field is the same as the Item number. 
However, you can select another value. 

 Vendor account – Select the vendor account number for the items that are 
imported. 

 Unit – The default value in this field is updated when the item is selected. 

 Bar code setup – Select the bar code setup that contains the bar code type, font, 
size, and mask information that you want. 

 Create – Click the Create button to generate the bar code for the selected product. 

 

13.1.6 VIEW THE BAR CODES FOR A PRODUCT 

To view the bar codes for a product, follow these steps. 

1. Click Retail > Common Forms > Products > Released Product by category. 
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2. Select the product from the list and double-click to open the Product details form. 
Expand the Retail FastTab. 
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13.1.7 PRODUCT LABEL REPORTS 

Product labels are placed on a product which provides information on pricing, unit of 
measure and bar code that are used to scan the product. The label can also have the 
batch number, serial number, and expiration date.  

In Microsoft Dynamics AX for Retail, product label reports can be created and selected 
to have a specific size based on the business requirements. 

You can configure Microsoft Dynamics AX for Retail to create product labels whenever 
the price or the comparison price of a product changes at the retail store.  

Products must be assigned to the label reports to print the label reports as price 
changes occur in Microsoft Dynamics AX for Retail. 

Product labels can be created and manually assigned to the products. An easy way is to 
assign a default label report to a category so all the products assigned to the specific 
category can inherit the label printing settings.   

After the labels are printed, you can view the quantity in the Quantity column and the 
number of labels that printed in the Printed quantity column of the Product label 
printing form. 

To set up parameters for product label reports, follow these steps. 
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1. Click Retail > Setup > Bar codes and labels > Product label reports.  

 

2. In the Product label report setup form, in the Report name field, select the 
product label report to use. The Report name field contains a list of the reports 
that are available in the Application Object Tree (AOT).  

 

3. Add as many product label reports as you require for your products.  

 

 Note 
Custom reports can be created based on the business requirements and the 
reports can be added to the Product label report setup form. 

To print product labels, follow these steps. 

1. Click Retail > Periodic > Bar codes and labels > Print product labels.  

javascript:void(0)
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2. In the Product label printing form, in the Store number field, select a store. Then 
select the date that the labels become valid.  

3. Click Create > Create label by product to generate labels. In the Create labels 
form, enter the filter information to filter the list of products.  

 

4. Click OK to confirm the settings.  

Microsoft Dynamics AX for Retail creates product label entries for items for 
which the registered price on the product label has changed.  

5. In the Product label printing form, change the values in the Quantity column if 
you require different quantities.  

6. Click Print, and then click Print labels. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

291 

 

7. Select the printer to use to print the product labels, and then click OK.  

View product labels 

Before you print product labels, you can view a list of labels for which printing is 
pending. You can also view a list of labels that are already printed.  

1. Click Retail > Periodic > Bar codes and labels > Print product labels.  

2. In the Product label printing form, click Transactions. Then click Labels to print 
to view the list of labels that are set up to be printed. Or, click Printed labels to 
view the list of labels that are already printed.  

 

 

Create and print labels overview 

Use Microsoft Dynamics AX for Retail to generate labels for use at retail stores. A label is 
a piece of paper, polymer, cloth, metal, or other material that is attached to a container 
or an item. A label can also be printed directly on a container or a product.  

Labels have many uses, such as the following:  



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

292 

 

 Product identification  

 Name tags  

 Bar codes  

 Pricing  

 Warnings  

 Batch numbers  

 Expiration dates  

Microsoft Dynamics AX for Retail offers two types of labels for product at retail store—
shelf labels and item labels.  

Product labels are always variant-specific. However, shelf labels are not required to be 
variant specific.  

13.1.8 PRINT SHELF LABELS 

Shelf labels are put on a store rack or shelf where items are displayed or stored. A shelf 
label can include all the information about the product, except the batch number, serial 
number, expiration date, and so on.  

Microsoft Dynamics AX for Retail can be set up to create shelf labels whenever the price 
or the comparison price of the product changes in the store.  

To create shelf labels, following these steps.  

 Determine the shelf label configuration to use.  
 Set up the shelf label parameters in the Shelf label report setup form. In the list 

of shelf label reports that are available in the Application Object Tree (AOT), 
select the reports to use.  

 Shelf label reports must be assigned to the products. An easy way is to assign the 
default shelf label report to a category so that products that are assigned to the 
specific category can inherit the shelf label settings. 

 Print the labels by using the Shelf label printing form.  

Set up parameters for shelf label reports 

To set up shelf labels, follow these steps. 

1. Click Retail > Setup > Bar codes and labels > Shelf label reports.  

javascript:void(0)
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2. In the Shelf label report setup form, on the Overview tab, in the Report name 
field, select the shelf label report to use. The Report name field contains a list of 
the reports that are available in the AOT.  

3. Add as many shelf label reports as you require for your products.  

 

 Note 
Custom reports can be created based on the business requirements and the custom 
reports can be added to the Shelf label report setup form. 

To print shelf labels, follow these steps. 

1. Click Retail > Periodic > Bar codes and labels > Print shelf labels.  

javascript:void(0)
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2. In the Shelf label printing form, in the Store number field, select a store. Select 
the date that the labels become valid.  

3. Click Create, and then click Create label by product.  

4. In the Create labels form, enter information about the store and the products, if 
this information is required.  
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5. Click OK.  

6. In the Shelf label printing form, in the Quantity field, change the number of 
labels to print for the product, if multiple copies are required.  

Microsoft Dynamics AX for Retail creates shelf label entries for products for 
which the registered shelf label price has changed.  

7. Click Print, and then click Print labels.  

8. Select the printer to use to print the shelf labels, and then click OK.  

After the labels are printed, the number of labels that printed is displayed in the 
Printed quantity field.  

 

View shelf labels 

Before you print shelf labels, you can view a list of labels for which printing is pending, 
or you can print a list of labels that you already printed.  

1. Click Retail > Periodic > Bar codes and labels > Print shelf labels.  

2. In the Shelf label printing form, click Transactions, and then click Labels to print 
to view a list of labels that are set up to be printed. Click Printed labels to view a 
list of labels that you already printed.  

javascript:void(0)
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The buttons and fields on the Label form are described in the following tables. 

 

 

Buttons 

Button  Description 

Transactions  

Open a menu with the following items:  

 Click Labels to print to view the labels that are ready to print.  
 Click Printed labels to view information about labels you already 

printed.  

Create  Click Create label by product to create shelf labels for a specific 
product.  

Print  

Open a menu with the following items:  

 Click Print labels to print shelf labels.  
 Click Reprint labels to reprint labels that you already printed.  

Fields 
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Field  Description 

Store number  Select the store for which to print labels.  

Label valid on 
date  

Select the date that the information on the label, such as pricing, 
becomes valid.  

Report name  Select the name of the report for the labels you want to print. Set up 
the report in Shelf label report setup.  

Quantity  If multiple copies of the labels are required, enter the number of labels 
to print for the product.  

Printed 
quantity  The number of labels that are printed.  
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14 SALES TAXES 

 

OVERVIEW 

In this module we will describe sales tax codes, item sales tax groups and sales tax 
groups must be set up under the General ledger module. 

To assign override taxes in Microsoft Dynamics AX for Retail operations, you must set up 
the following:  

 Required: Assign sales tax groups to stores.  

 Required: Specify inclusive or exclusive tax.  

 Optional: Set up sales tax overrides. 

 Optional: Set other tax options for stores.  

In Microsoft Dynamics AX for Retail, two types of tax groups are used. Sales tax groups 
are assigned to customers, and item sales tax groups are assigned to products. For each 
product that is sold, Microsoft Dynamics AX for Retails calculates tax by determining the 
sales tax codes that apply to both the product and the customer to whom the product is 
sold. If a tax group is not assigned to either the product or the customer, no tax is 
applied.  

In Microsoft Dynamics AX for Retail, sales tax groups must be assigned to stores. For 
each product that is sold, Microsoft Dynamics AX for Retail calculates tax by determining 
the sales tax codes that apply to both the product and the store where the product is 
sold. If an item sales tax group is not assigned to the product, no tax is applied.  

Microsoft Dynamics AX for Retail calculates taxes for return transactions by using the 
schedules for sales tax rates that are assigned to each sales tax code. Set up these 
schedules to guarantee that you do not refund more tax than you collected.  

Note 

 Microsoft Dynamics AX for Retail Point -of-Sales (POS) uses only tax settings that 
are related to retail tax calculation.  
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 If a customer is added to the transaction, the sales tax group for the customer is 
used in tax calculations only if the tax options for the store require that the sales 
tax group be used. 

 Microsoft Dynamics AX for Retail POS does not support the Check sales tax 
group’s option in the General ledger parameters form.  
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Assign sales tax groups to stores 

A sales tax group is mandatory for every retail channel. 

To assign the sales tax group, follow these steps.  

1. Click Retail > Common > Retail channels > Retail stores.  

 

2. In the Retail stores list, select the store to modify by double-clicking the retail 
store. 

3. In the Stores form, on the General FastTab, under Sales tax, in the Sales tax 
group field, select the sales tax group for the store. 
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4. Prices include sales tax: – Select the check box if the product retail price is 
inclusive of tax. 

5. Use destination-based tax: – Select the check box if tax is calculated based on 
the shipping address of the customer. 

6. Use customer-based taxes: – Select the check box if tax needs to be calculated 
based on the tax settings for customers. 

The following section describes how to set up sales tax overrides. 

Note 

Inclusive taxes are included in product prices. Value-added tax (VAT) is one example of 
inclusive tax. Exclusive taxes are not included in product prices. 

When tax is calculated, the settings for inclusive and exclusive tax that are specified for 
a customer override the settings that are specified for a store.  

 

 SET UP SALES TAX OVERRIDES 

Sales tax overrides are set up for cashiers to modify the amount of tax on a sales 
transaction. Sales tax overrides are useful in several scenarios. Consider the following 
examples:  

 Specific customers, such as charitable organizations, children, and indigenous 
people, are subject to different tax rates.  

 Some products are subject to different tax rates under certain conditions. For 
example, food items that are consumed in the store are taxed differently than 
food items that are carried out of the store.  

Each sales tax override specifies the sales tax group or item sales tax group that is 
overridden, and the sales tax group or item sales tax group that is used instead. Sales 
tax overrides are organized into sales tax override groups, so that several overrides can 
be available at each store.  

Sales tax overrides are applied by cashiers. For example, the item sales tax group for an 
item includes a Food sales tax code, but the customer is exempt from taxes on food 
items. Therefore, the cashier overrides the item sales tax group by using an item sales 
tax group that does not include the Food sales tax code.  

To set up sales tax overrides, follow these steps. 
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1. Click Retail > Setup > Sales taxes > Sales tax overrides.  

 

2. In the Sales tax overrides form, click New to create the new sales tax override.  

3. In the Sales tax override field, type the unique identifier for the override. Then, 
in the Description field, type the name for the sales tax override.  

4. In the Status field, select Enable.  

Note 

If you select Disable in the Status field, the override is not used when an 
override group that includes the override is applied to the transaction.  

5. On the Override FastTab, in the Type field, select the type of sales tax code that 
is overridden at the point of sale. The options include the following: 
 

 Item sales tax group – Select this type if the override tax must be from 
the item sales tax group. 

 Sales tax group – Select this type if the override tax must be from sales 
the tax group. 

6. In the From field, select the tax group that is overridden at the point of sale. The 
options include the following: 
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 No tax group – Select this option not to override a tax group. 

 Any tax group – Select this option to override from any tax group. 

 Specified tax group – Select this option if the specific tax group must be 
overridden. 

 Note 

Depending on the option that is selected in the Type field, the Product sales tax or 
Sales tax FastTab will be available to select the specific tax group that will be 
overridden at retail stores. 

7.  Now, in the To field, select the tax group that is used instead. The options 
include the following: 

 No tax group – Select this option not to apply tax overrides. 

 Specified tax group – Select this option to apply the specific tax override 
group. 

 Note 

Depending on the option that is selected in the Type field, the Product sales tax or 
Sales tax FastTab can be selected for the specific tax group that will be applied at 
the retail store. 

8. In the Override by field, select whether the tax override is applied to the 
products on specific lines or to the whole transaction. 
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In addition to setting up sales tax overrides, before you can use the sales tax overrides 
at the point of sale, you must complete the following steps.  

o Set up sales tax override groups at Retail > Setup > Sales taxes > Sales 
tax override groups. 

 

o Select sales tax override groups for stores at Retail > Common > Retail 
channels > Retail stores. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

305 

 

 

o To set up reason codes for sales tax overrides browse to Retail > Setup > 
Reason codes. 

 

o Set permissions so that specific cashiers can apply overrides at Retail > 
Setup > POS > Profiles > POS permission groups.  
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o Allow sales tax change: – Select this option to apply sales tax overrides at 
retail stores. 

 SET UP SALES TAX OVERRIDE GROUPS 

When you set up sales taxes for retail stores, you can specify several settings. For 
example, you can assign sales tax groups to stores, specify inclusive taxes or exclusive 
taxes, and set up overrides. 

To set up sales tax override groups, follow these steps.  

1. Click Retail > Setup > Sales taxes > Sales tax override group.  
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2. Click New to create the new sales tax override group. 

3. On the General FastTab, in the Identification area, enter a unique name for 
Sales tax override group. 

4. In the Description area, enter the Description for the sales tax override group. 

5. In the Setup FastTab, click Add to add sales tax overrides to the group. 

6. Select the Sales tax override from the drop down list box. 

 The Description field displays the name of the selected sales tax override. 

 The Type field displays the type of sales tax override. 

 The Override by field displays if the selected sales tax override will be 
applied at the product or transaction level. 
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15 PAYMENT METHODS 

In this module we will discuss payment methods. Retail Business Operations accept 
different methods of payment in exchange for the products and services they sell to 
their customers. Cash is the most common form of payment. However, retailers can 
receive payment in the form of checks, credit cards, vouchers, gift cards, redemption 
points, and so. The methods of payment accepted by the retailer must be configured in 
Microsoft Dynamics AX for Retail Point of Sales (POS) when the system is set up.  

In Microsoft Dynamics AX for Retail POS, different payment methods can be configured 
as follows:   

 Cash – Money in the physical form of currency, such as banknotes and coins. This 
currency can be either the company currency or the store's local currency. 
Typically, the denomination break down of the selected currency is required to 
be configured. 

 Check – A negotiable instrument that instructs payment for a specific amount of 
a specific currency, and that is drawn on a specific bank. A check is typically valid 
for six months after the date of issue, unless another period of validity is 
specified. This period differs, depending on the bank that the check is drawn. 
There are many kinds of checks, such as order checks, counter checks, bearer 
checks, and account payee checks.  

Checks can be set up as a payment method for each store and checks can be 
accepted in the currency that is defined either at the company level or the store 
level.  

 Currency – The primary form of payment other than the company's default 
currency. Coins and paper money are both forms of currency.  

The currency payment method represents all currency that is used in Microsoft 
Dynamics AX for Retail POS. To use this payment method, you must configure this 
payment type and set up related foreign currencies with the required exchange 
rates. 

 Card – In Microsoft Dynamics AX for Retail POS, all types of credit cards or card 
types can be configured, such as debit cards and credit cards. At the organization 
level, it is recommended to create one card payment method to represent every 
type of card.  At the store level, a payment method can be configured for 
different card types by using the one card payment method.  Cards that are 
supported by the retailer as a method of payment must be configured and 
allocated to a store to make sure that the card can be used as a tender at the 
point of sale (POS) level. 
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 Credit memo – Credit memos are issued or redeemed at the point of sale. The 
credit memo is a credit or a return credit memo issued against a return sale. If 
credit memos are only partially redeemed, the program issues a new credit 
memo for the new balance. The new credit memo has a new number. A credit 
memo can be used only one time, and the system keeps a record of all the 
numbers that are used. The record can be viewed in the Credit memo table 
form. Click Retail > Inquiries > Credit memo. A customer cannot redeem more 
than the value of the credit memo.  

 Gift Card – Gift cards are issued and redeemed at the point of sale. Most retailers 
sell gift cards with different values that are loaded on the gift card. Then, the 
values are attached to a serial number, which provides an effective way to track 
the balance and the expiry date. Overpayment is not allowed on gift cards. 

 Customer account – Customer account payment method typically is a tender 
type that is used by cashiers to charge an account for which a customer has an 
established credit limit. 

To set up payment methods in Microsoft Dynamics AX for Retail POS, follow these steps.  

1. Set up organization-wide payment methods. Create the payment methods that 
are accepted by the whole organization.  

2. Create card types and card numbers. If credit cards or debit cards are accepted, 
create at least one payment method for the cards, and then create the 
organization-wide card types and card numbers. 

3. Set up store payment methods. Associate payment methods with each store, and 
then enter the store-specific settings for each payment method.  

 ORGANIZATION-WIDE PAYMENT METHODS 

Your business might accept payment in forms other than cash. If you accept payments 
that are made by using checks, credit cards, debit cards, corporate charge cards, gift 
cards, customer credit, and other forms of payment, you must set up each payment 
method for your organization in Retail. You can assign specific payment methods to 
each store and then set up store-specific settings for each payment method.  

To set up payment methods, follow these steps. 

1. Click Retail > Setup > Payment methods > Payment methods.  
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2. In the Payment methods form, press CTRL+N to create a new payment method.  
3. In the Payment method field, enter a unique name for the payment method.  
4. In the Payment method name, enter a brief description of the payment method.  
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5. In the Default function field, select a function. The payment methods that are 
described for the following functions are examples of typical retail payment 
methods:  

o Normal – Use this function for currency.  
o Card – Use this function for debit cards, credit cards, corporate cards, and 

other forms of card payment.  
o Check – Use this function for personal checks and other negotiable 

documents.  
o Customer – Use this function if you extend credit to customers and then 

collect payment later.  
o Tender remove/float – Use this function if you add cash to, or remove 

cash from, the point of sale (POS) register drawer.  

Note  

Each default function applies special settings to the store-specific payment methods 
that are based on the organization-wide payment methods.  
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 CARD TYPES 

Create a card type for each type of card that is accepted by the retail business 
operations, such as debit cards, credit cards, loyalty cards, and corporate cards. 

To set up new card types, follow these steps.  

1. Click Retail > Setup > Payment methods > Card types. 

 

2. Click New to set up a new card type.  

3. Enter the following information:  

o Card ID – The card ID that is assigned to the store to use as a store 
payment type. You must create card IDs for all cards that your business 
accepts.  

o Card type name – The name of the card.  

o Card types – Select a type of card from the following types: International 
credit card, International debit card, Loyalty card, or Corporate card. 
Each card ID must be assigned a card type.  

o Card issuer – The card-issuing authority. 

  CARD NUMBER 

Card number validation is required for payment processing when a customer presents a 
card. For certain types of cards, the length and range of card numbers that are 
acceptable for each card type can be set up.  
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For example, the numbers for a credit card and a corporate card both start with the 
number four. The credit card number has 16 digits and the corporate card number has 
four digits. For the credit card, you set up a card number with a range of 4000 through 
4999 and a length of 16. For the corporate card, you set up the range of numbers that 
the cards are issued in, such as 3900 through 3999, and a length of four digits. These 
card types can be assigned to a store. When a card is swiped at a store register and the 
card number starts with the number four, the cashier is prompted to identify the type of 
card that is being used. The card number is automatically validated according to the 
settings for that card type. 

To open the Card number form, follow these steps. 

1. Click Card number to open the Card number form.  

 

2. Type a starting number in the Card number from field and an ending number in 
the Card number to field.  

3. In the Length of card number field, enter the number of acceptable digits in the 
card number. For example, if a validation is required for a card that is four digits 
in length, type 4 in this column.  

4. To add card numbers to this card type, click New, and then repeat steps 2 and 3. 

 Note 

Payment Methods can be allocated by store. 
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16 REPLENISHMENT – SET-UP 

OVERVIEW 

In this module we will discuss four key areas in setting up replenishments 

 Product Packages 

 Replenishments Rules 

 Replenishment Hierarchies 

 Replenishment Service Categories 
 

 REPLENISHMENT RULES  

A product package is a group of products that are ordered from a vendor. Packages can 
help to create purchase orders, because you do not have to select products individually. 
Instead, you can select a package that includes the products that are grouped together 
that will be used to order from a vendor. Order lines are automatically updated when 
the items in a package are changed.  

The same product can be included in several packages for one or more vendors. After 
you add a package to a purchase order, you cannot remove a product from the order 
line if that product is part of a package. Instead, you must remove the whole package 
and add the products to the purchase order individually. 

To set up product packages, follow these steps.  

1. Click Retail > Setup > Replenishment > Product packages.  
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2. In the Packages form, click New to create a new package.  

3. Enter a package number and a description.  

4. Select the vendor account that supplies the products in the package. This field is 
used to filter the list of available packages. To limit the availability of this 
package to a specific vendor, you can select the vendor account. Otherwise you 
can leave this field blank.  

5. On the Line details FastTab, click Add to add a product to the package, and then 
enter settings for the new product.  

6. To add groups of products to the package at the same time, follow these steps.  

i. Click Add products at the top of the form.  

 

ii. In the Add products form, select the products to add to the package.  

You can filter the list of products by selecting a category hierarchy. You can 
then select all products that are assigned to a specific category, and add those 
products to the package.  

7. Select the Variant number if the selected product is a product master. 

 The Configuration field displays the configuration dimension for the 
selected variant. 

 The Size field displays the size dimension for the selected variant. 

 The Color field displays the color dimension for the selected variant. 

 The Style field displays the style dimension for the selected variant. 

The tabs, buttons, and fields for the Packages form are described in the following tables.  
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Tabs 

Tab  Description  

Line details  Specify line details for the package.  

Buttons 

Button  Description  

Dimensions 
display  

Open the Dimensions display form. Here, you can select the 
dimensions that will be displayed in the Line details grid.  

Add 
products  

Open the Add products form. Here, you can select products to add to 
the package. You can filter the product list by selecting a category 
hierarchy, and then by selecting the products to add to the package.  

Fields 

Field  Description  

Package 
number  

The unique identification number of the package. This number can be 
created either manually or automatically. This depends on the setup 
for the number sequences.  

Description  A description of the package.  

Vendor 
account  

The vendor that supplies the products in the package. This field is 
used to filter the list of available packages. To limit the availability of 
this package to a specific vendor, you can select the vendor account. 
Otherwise, you can leave this field blank.  

Item number  Select a product in the list.  

Variant 
number  

If the product has variants, such as sizes, colors, or styles, select a 
variant number.  

Configuration  If the product has a configuration, select the configuration.  

Size  If the product has a size, select the size.  

Color  If the product has a color, select the color.  
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Field  Description  

Style  If the product has a style, select the style.  

Quantity  The quantity of the product to order.  

Unit  The unit type of the product.  

Product 
name  

Microsoft Dynamics AX for Retail POS automatically populates this 
column with the name of the product that is selected in the Item 
number field.  

Assign Product packages to a purchase order 

To create purchase orders, follow these steps. 

1.  Click Retail > Common > Replenishment > Purchase orders. 
2. To create a new purchase order, click Purchase order from the New group of the 

Purchase order FastTab. 

 

3. Select the Vendor account from the list and click OK. 
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4. In the Purchase order lines FastTab, click Purchase order line > Create lines 
from package. 

 

5. Select the Package number from the drop down list box.  
 

 The Name field displays the name of the selected product package. 
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6. Enter the total Quantity to be ordered from the vendor. The quantity that is 
specified will be distributed to the products that are defined in the packages. 
 

7. Click Create to add the product lines to the purchase order. 
 

8. Confirm and finalize the purchase order. 
 

 REPLENISHMENT RULES  

Replenishment rules are used to automatically distribute stock to retail channels based 
on the settings that are defined by the retail channel or the retail product hierarchy. The 
default weight and the default percentage that are used in the replenishment rules are 
based on the replenishment weight that is defined on the Retail FastTab in the 
Warehouses form.  

New weight and percentage can be defined for replenishment rules for each channel or 
hierarchy. The new values take precedence over the default values. 

Note 

Retail channels can be used to define replenishment rules. If a retail channel that is 
selected does not have a retail warehouse created, then the retail channel will be 
excluded from the distribution calculation. 

To identify a warehouse as a store, select the Store check box on the Retail FastTab in 
the Warehouses form. 

To create replenishment rules, follow these steps. 

1. Click Retail > Setup > Replenishment > Replenishment rules.  
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2. In the Replenishment rules form, select a replenishment rule, or click New to 
create the new rule.  

3. If you are creating the new replenishment rule, type a name in the 
Replenishment rule field and a description in the Description field.  

4. On the Lines FastTab, click Add to define replenishment rules.  

5. In the Type field, select one of the following options:  

o Replenishment hierarchy – Select this option if the replenishment rule 
applies to a replenishment hierarchy. Then, in the Name field, select a 
category.  

o Channel – Select this option if the replenishment rule applies to a retail 
channel. Then, in the Name field, select a channel.  

6. In the Weight field, enter the weight for the selected hierarchy or channel.   

The Percent field is updated automatically based on the value that is entered in 
the Weight field. 

7. The default weight for the hierarchy or the channel is automatically updated, 
depending on the value that you selected in the Type field.  

 Note 

The value in this field reflects the proportional weight that is specified for the 
variants.  
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8. The default weight field is automatically updated, and all lines are recalculated, 
based on the value that is selected in the Type field. 

9. Repeat steps 4 through 9 to add more replenishment rules. 

 Note 

Assign the default replenishment hierarchy for categories in the Retail product 
hierarchy form. The default replenishment rule that is assigned will be used if buyers 
push or if cross docking is used to distribute quantities to the retail channels. 

 

 REPLENISHMENT HIERARCHIES 

Replenishment hierarchies are set up to group the stores that must be replenished. The 
groupings can be based on the organization, size, turnover, or the type of stores. 

To set up the replenishment hierarchy, follow these steps. 

1. Click Organization administration > Setup > Organization > Organization 
hierarchies.  

2. Select the hierarchy.  

3. In the Name field, enter the unique name for the replenishment hierarchy.  

4. On the Purposes FastTab, click Assign purpose.  
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5. In the Purposes field, select Retail replenishment, and then click Add. Then, 
select the organization hierarchy that you created in step 3.  

6. Close the Organization hierarchy purposes form, and then, in the Organization 
hierarchies form, click View.  

Microsoft Dynamics AX for Retail POS displays the Hierarchy designer form. You 
can use this form to create a visual representation of the retail hierarchy.  
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7. In the Save as draft group, click Edit.  

8. In the Modify group, click Insert, click the type of organization to which the retail 
hierarchy corresponds, and then click the organization to insert.  

9. In the Modify group, click Insert, click Retail channel, and then click the channel 
to insert.  

10. If you want to save the hierarchy so that you can complete it later, click Save as 
draft. Or, if you finish designing the hierarchy, click Publish and close.  



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

324 

 

 

 REPLENISHMENT SERVICE CATEGORIES 

Service categories are used to define replenishment rules and the availability calculation 
that will be used for cross docking to distribute products from a planned purchase 
order. 

The service category is linked to the vendor on the Retail FastTab in the Vendors form.  
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The service category provides information about the availability of the goods that are 
for sale and the delivery time. The service category also supports automatic and manual 
cross docking. 

To set up a service category, follow these steps. 

1. Click Retail > Setup > Replenishment > Service category.  

 

2. In the Service category form, select the service category, or click New to create 
the new service category.  

3. In the Service category field, type an ID number.  

4. Enter the Description for the newly created service category. 

5. Enter the Sale date for the service category. This date is dynamic and is based on 
the planned purchase order.  

6. Enter the Local delivery date that will be calculated based on the planned 
purchase order that is associated with the service category. 

7. Select the Calendar type from the drop down list box. 
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8. Select the Cross docking warehouse from the drop down list box. 

9. Select the default Replenishment rule that will be used by cross docking to 
distribute stock to the retail channels. 

10. Select the Warehouse where the products will be stocked. 

The fields on the Service category form are described in the following table. 

Fields 

Field  Description  

Service 

category  
The unique identification code of the service category.  

Description  The name or description of the service category.  

Sales date  
The number of days that are added to the delivery date when the 

sales date is calculated for a new purchase order.  

Local delivery 

date  

The number of days that are added to the delivery date when the 

local delivery date is calculated for a new purchase order.  

Calendar  

The calendar that defines the capacity and work time in the 

production system. The whole calendar is listed in this field after 

the calendar is created in Microsoft Dynamics AX for Retail POS.  

Cross docking 

warehouse  

The cross docking warehouse. If a cross docking warehouse is 

defined for a service category, cross docking is automatically 

performed when a planned order is finalized in the master planning 

system. If the cross docking warehouse is the same as the 

warehouse that is used for the planned purchase order, no cross 

docking is performed.  

Replenishment 

rule  
The rule that is defined for automatic replenishment.  

Warehouse  

The location of the warehouse. If automatic replenishment is 

required, the warehouse must not be the same as the cross docking 

warehouse.  
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17 Charge Code 

OVERVIEW 

In this module we will discuss Charge Codes. For instance if you have to track sales 
amounts or purchase amounts in addition to line items, you can use charges codes. For 
example, you might pay freight and insurance on a purchase order, and these amounts 
might be itemized separately on the purchase order. You can specify whether these 
amounts are posted to expense accounts, or whether they are added to the cost of the 
items.  

You can create charges codes for Accounts receivable, Accounts payable and Retail. 

To create charges codes, follow these steps. 

1. Use one of the following menu paths: 

 Click Retail > Setup > Charges > Charges code.  

 Click Accounts receivable > Setup > Charges > Charges code. 

 Click Accounts payable > Setup > Charges > Charges code. 

2. Click New to create the new charge code. 

 

3. In the Charges code field, type the code for the charge.  

4. In the Description field, type the description of the charge.  

 5. In the Item sales tax group field, select the sales tax group. This is optional. 
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6. On the Posting FastTab, specify how the charge is automatically debited and 
credited.  

I. Select the Type of posting.  

 

II. If you selected Ledger account as the debit type or the credit type, the 
Posting type must be specified in the Posting fields, and the main 
account must be specified in the Account fields. 

Example 

Your customer pays the charge. Therefore, the charge is added to the sales order totals. 
You set up the following posting information:  

 In the Type: field in the Debit field group, select Customer/Vendor to add the 
invoice charge to the customer's account.  

 In the Type: field in the Credit field group, select Ledger account. Then, in the 
Account field, select the main account for the revenue from the invoice charges.  

NOTE: 

 You can enter a different currency for the charge transaction if the debit type or 
the credit type is either Ledger account or Item for the selected code.  

 You can print the text for charges in the language that is assigned to the 
customer. Click Translations to specify text for the charges code in other 
languages. 

 DELIVERY CHARGES GROUPS 

Use this form to create delivery charges groups. If you open the form from Retail, you can specify the 

charges groups to use for customer delivery. You can also open the Charges groups form from 

Accounts receivable to specify the charges groups to use in sales orders. Charges groups help you do 

the following:  

 Set up group charges in the Charges code form.  

 Set up automatic charges in the Auto charges form.  
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If a charges group is assigned to a customer or vendor, the charges codes that are set up in the 

specified charges group are calculated when you create orders.  

To create delivery charges groups, follow these steps. 

1. Click Accounts receivable > Setup > Charges > Delivery charges groups, or click Retail > 

Setup > Charges > Delivery charges groups.  

Note  

The Delivery charges groups form is available only if Microsoft Dynamics AX 2012 R2 is installed.  

2. Click New to create the new delivery charge group. 

 

3. Enter a code for the charges group. Both letters and numbers can be used to identify the 

group 

4. Enter a description that describes the charges group.  
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5. Close the form. 

 AUTO CHARGES 

You can open the Auto charges form from Microsoft Dynamics AX for Retail POS only if 
Microsoft Dynamics AX 2012 R2 is installed.  

Use the Auto charges form to specify the sales or purchase charges that you want the 
system to assign to orders. 

To set up auto charges, follow these steps. 

1. To start, use one of the following menu paths:  

   

 Click Accounts receivable > Setup > Charges > Auto charges. 

 Click Accounts payable > Setup > Charges > Automatic charges.  

 Click Procurement and sourcing > Setup > Charges > Automatic charges.  

 Click Retail > Setup > Charges > Auto charges.  

  
2. Select Main or Line to indicate the level at which the charges should be 

calculated. 
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3. Click New to create a new record. 
4. Select an Account code to specify whether the charge is to be calculated for a 

specific account, a specific account group, or all accounts.  

 If you set the value in the Account code field to Table, specify the account 
number for which the charge is being created. 

 If you select Group, specify the charge group for which the charge is being 
created. 

 If you select All, the charge is calculated on the order line, regardless of the item 
number that is selected. 

  

Note  

If you open the form from Accounts receivable or Retail, the Customer relation field is 
displayed. If you open the form from Accounts payable or Procurement and sourcing, 
the Vendor relation field is displayed.  

5. Specify whether the shipping charge for the sales orders is to be calculated for a 
specific mode of delivery, a specific mode-of-delivery group, or all modes of 
delivery.  

  

 When the value in the Mode of delivery code field is Table or Group, the 
shipping charges are applied only when you create sales orders, not when you 
create sales quotations.  

  
6. Specify the mode of delivery relation. 

 If the value in the Mode of delivery code field is Table, specify the mode of 
delivery for which the shipping charge is created.  

 If the value in the Mode of delivery code field is Group, specify the mode of 
delivery group for which the shipping charge is created.  

 If the value in the Mode of delivery code field is All, the shipping charge is 
calculated for all modes of delivery. 
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7. On the Lines FastTab, enter the following information: 

  
a. Specify the currency code for the charges transaction. 
b. Select one of the charges that are defined in the Charges code form. 
c. For Category, select the method by which the charge should be 

calculated:  
i. Fixed – The charge is entered as a fixed amount on the line. Fixed 

charges can be used on charges in the order header and the order 
lines.  

ii. Pcs. – The charge is based on the unit. These charges can be used 
only on order lines.  

iii. Percent – The charge is entered as a percentage on the line. 
Percent charges can be used on charges in the order header and 
the order lines. 

d. Intercompany percent – The charge is entered as a percentage on the line 
for intercompany orders. Intercompany percent charges can be used only 
on order lines.  

e. External – The charge is calculated by a third-party service that is 
associated with one or more shipping carriers.  

8. Enter the Charge Value. If you want to validate charges for Accounts payable, 
and if the charges are calculated as a fixed amount instead of a percentage, this 
value must be less than the maximum amount that is specified in the Charges 
code form. 

9. Select the Charges currency Code. 

  
10. For sales orders, specify the from amount for a range of transaction totals in 

which the shipping charge is applied.  

 For example, to specify free shipping for orders over 100.00 United States dollars 
(USD), enter 100 in the From amount field, 0 in the To amount field, and 0.00 in 
the Charges value field. 

  
11. For sales orders, enter the ending or To amount for a range of transaction totals 

in which the shipping charge is applied. 
12. Specify the Sales tax group for the charges transaction. 
13. Make available the Keep field if you want to keep the charges transaction after 

invoicing. This means that the charge is applied every time that you create a new 
invoice for the selected customer account. 
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18 SET-UP RETAIL SCHEDULER 

Overview 

In this module we will learn that in Microsoft Dynamics® AX for Retail, the Retail 
Scheduler features are used to manage the distribution of data through Retail 
Commerce Data Exchange: Synch Service, starting from the headquarters office 
database to the appropriate store databases. Retail Scheduler can also be used to do 
the following: 

 Manage updates of the headquarters office database with sales and inventory 
data that received from the stores  

 Create distribution locations  

 Set up table distribution  

 Schedule the jobs and subjobs that send information to stores 

 SCHEDULER JOB 

Jobs are used to distribute data to the locations. Each job has a location filter. The 
location filter is the set of distribution locations to which the data is distributed by the 
job. Jobs are made up of subjobs. Subjobs are specific instructions that are used to 
distribute data in selected tables and selected table fields. 

 

To run jobs, follow these steps.  

i. Set up distribution locations and distribution schedules. 
ii. Initialize jobs and subjobs. 

iii. Configure subjobs. 
iv. Configure jobs. 
v. Change pre-actions to actions. 

vi. Run jobs or batches of jobs. 

 

Types of jobs 

In Microsoft Dynamics AX for Retail, three types of jobs are available: 

• Action (A) jobs – Use A jobs to send data from the headquarters office to stores. 
The data in the jobs includes the modifications to records that are tracked by the 
action filters. The locations that receive the data are determined by the 
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distribution settings that are specified for the changed records or their parent 
records. 

 
• Normal (N) jobs – N jobs are not dependent on actions. N jobs delete all existing 

data in the destination tables and then inserts the whole set of data. Use N jobs 
to send data from the headquarters office to the locations that are specified in 
the job. 

 
• Pull (P) jobs – Use P jobs to update the data in the Microsoft Dynamics AX for 

Retail database by extracting data, such as sales and inventory transactions, from 
the locations that are specified in the job. 

 SCHEDULER SUBJOB 

Microsoft Dynamics AX for Retail includes predefined scheduler jobs and subjobs that 
meet the replication needs of most organizations. To populate these jobs and the 
subjobs, you must start Microsoft Dynamics AX for Retail.  
 
New jobs can be added or existing jobs can be customized based on the business 
requirements. 

 

Note 

The following procedure is performed during the deployment of Microsoft AX for 
Retail. This deployment creates the base configuration data that includes the scheduler 
jobs and the subjobs. 
 
To create the base configuration data including the scheduler jobs and subjobs, follow 
these steps. 
 

1. Click Retail > Setup > Parameters > Retail Parameters. 
2. On the Retail Headquarters parameters forms, on the General FastTab, click 

Initialize. 
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18.2.1 CONFIGURE SUBJOBS 

To create, configure and, or modify the subjob, follow these steps. 

1. Click Retail > Setup > Retail scheduler > Scheduler subjobs. 
2. Click New to create a new subjob, or select the subjob that you want to modify 

from the left side list.  
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3. Enter the Subjob number. This number is a unique ID provided to identify the 
subjob. 

4. Enter the Description of the subjob. 
5. On the Setup FastTab and the Table mapping area, enable the Pull data check 

box to indicate the job needs to extract data from retail stores to the 
headquarters office. 

6. Select the Retail channel schema from where you want to extract the 
information in the headquarters office. 

7. Select the Channel table name from the drop-down list box. This box provides a 
list of tables to retrieve information from a retail channel.  

8. Select the Microsoft Dynamics AX table name from the drop-down list box. This 
box provides a list of tables to populate information in at the retail channel. 

9. Enter the name of the Temporary table that will be used as the staging table to 
upload the data when the data is extracted. 

10. Enable the Replicate DataAreaid check box to indicate that the legal entity ID 
must be replicated at the retail channel or the headquarters office. 
Caution 
Use the Replicate dataareaid field with caution because it can result in invalid 
data being populated in incorrect fields. 

11. Select the Field for DataAreaid field from the drop-down list box. 
 

12. On the Replication area, select the Replication method: from the drop-down list 
box. The options include the following: 

a. Normal – Select normal if the subjob created is for a normal job to send 
all the data to the retail store. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

338 

 

b. By actions – Select by actions if the subjob created is for sending 
differential data to the retail store. 

 
13. Select the Delete check box if the replication is performed when a record is 

deleted. 
 

14. Select the Insert check box if the replication is performed when a record is 
created. 
 

15. Select the Enabled check box to start the subjob. 
 
The Transfer field list exists check box is automatically selected if transfer fields 
are specified for the table that is replicated to the retail store. 
 
The From/To filters exist check box is automatically selected if filters are 
specified for the tables that are selected in the subjob.  
 

16. On the Replication FastTab, in the Actions area, enter the Action counter 
interval. A value in this field can only be entered if the Replication method is 
selected by the actions in the Replication area. 
 

17. On the Replication counters area, enter the Replication counter value. 
 

18. Select the Replication counter interval value. 

Note 

A subjob can be assigned to more than one job. 
 
 
To select fields to be distributed to stores, follow these steps. 

1. Click Retail > Setup > Retail scheduler > Scheduler subjob. 

 

2. Select the subjob from the left side list and click Transfer 
field list to select the fields that will be distributed to the 
retail stores. 

 

 
 

The Transfer field list form opens. 
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3. Select the From field on the Field list window. 
 
The Field type will be automatically selected based on the field selection. 

 
4. Select the To field from the drop-down list box. 

 
The Field type will be automatically selected based on the To field selection. 

 
5. Select the Conversion type from the drop-down list box. The options include 

the following: 
 

a. None: Select the option not to apply any conversion rules. 
 

b. Equals (=): Select this option to specify the filter value in the Value field. 
 

c. Substring: Enter the substring value in the Value field. 
 

d. Today(): Select this option if the filter is based on the current date 
timestamp. 

 
e. TimeNow(): The time will populate the current time. 

 
f. Skip text conversion: Select this option to skip the conversion process. 

 
g. Time to integer: Select this option to convert the time value to an 

integer. 
 

h. Integer to time: Select this option to convert the integer to a time value. 
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To open the scheduler subjob from table filters, follow these steps. 

1. Click Retail > Setup > Retail scheduler > Scheduler subjob. 

 

2. Select the subjob from the left side list and click From table filters to set filters 
on the from table that is selected. 

 

 
 

The From table filters form opens. 

3. Click New to create a new filter. 
 

4. Select the field name from the drop-down list box. A new window opens with a 
list of fields to select. 
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5. Select a Filter from the drop-down list box. 
 

6. Enter the filter value in the Value1 field. 
 

7. Enter the filter value in the Value2 field. 
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To copy the scheduler subjob, follow these steps. 

1. Open the Scheduler subjob by clicking Retail > Setup > Retail scheduler > 
Scheduler subjob. 

 

2. Select the subjob from the left side list and click Copy scheduler subjob to copy 
an existing job to create a new subjob. 

 

 
 

A new scheduler subjob will be created. 
 

To create the staging table, follow these steps. 

1. Open the Scheduler subjob and create the temporary staging table by clicking 
Retail > Setup > Retail scheduler > Scheduler subjob. 
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2. Select the subjob from the left side list and click Create staging table to create 
the temporary table that is described in the Temporary table field. 

 
 

 
 

A new staging table will be created. 
 
To use scheduled by, follow these steps. 
 

1. Open the Scheduler subjob and view the scheduled jobs that run the subjob by 
clicking Retail > Setup > Retail scheduler > Scheduler subjob. 

 

2. Select the subjob from the left side list and click Scheduled by to view the 
scheduler job that runs the subjob. 

 

 
 

The Scheduled by form opens. 

 

18.2.2 CONFIGURE JOBS 

Jobs should contain subjobs that are related. For example, the Currency job contains 
the subjobs that update currencies and exchange rates. Jobs should also contain 
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subjobs that use replication methods that are consistent with the type of job. As a 
general rule, N jobs and P jobs should contain subjobs with Normal replication, and A 
jobs should contain subjobs with By actions replication. 

To create a new job or modify an existing job, follow these steps. 

1. Click Retail > Setup > Retail scheduler > Scheduler job. 
2. Click New to create a new job, or select the job that you want to modify. 
3. Enter a unique Job number for the new scheduler job. 
4. Enter the Description of the job. 
5. On the General FastTab, select the Retail channel schema. 
6. Select the Execution class that will be running. 
7. Select the Data processing class if the job will be processing data. 

 

 

8. On the Subjobs FastTab, click Add to assign subjobs to the scheduler job. 
9. Select the Subjob number from the drop-down list box. 

The Description field displays the name of the subjob that is selected. 
10. Select the Enabled check box to enable the subjob to be started. 

The Subjob replication method displays the replication method of the subjob 
that is selected. 
The Table name displays the table name from the subjob that is selected. 

 

11. On the Object setup FastTab, select the Type from the drop-down list box. 

Caution 
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The selection menu displays all Application Object Tree (AOT) object types, but only 
Class is supported. 

12. On the Free variables area, enter the Text for the scheduler job. 

Note 

Free variable: Enter additional data to be passed to the application object to provide 
context for the job that is being started. This feature is not used as a default 
feature in Microsoft Dynamics AX. This feature  is made available to facilitate 
partner customizations. 

13. Enter the Integer value for the scheduler job. 
14. Enter the Real value for the scheduler job. 
15. Enter the Date value for the scheduler job. 
16. Enter the Time value for the scheduler job. 
17. Select the Boolean value for the scheduler job. 

 

 

To create the staging table for P jobs, follow these steps. 

1. Open the Scheduler job by clicking Retail > Setup > Retail scheduler > 
Scheduler job. 

 

2. Select the P job from the left side list and click Create staging table to create the 
staging database for P job tables. 

 

 
 

By clicking the button, the TempDB staging tables are created for the specified P job 
target table. Microsoft Dynamics AX for Retail Commerce Data Exchange: Synch 
Service uses temporary tables before writing point-of-sale (POS) transactions to 
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Microsoft Dynamics AX. You must create a staging table each time you change a P 
Job definition. Then, a window opens with a list of steps that are performed to create 
the temporary database. 

Copy scheduler job 

To copy an existing job to create a new scheduler job, follow these steps. 

1. Open the Scheduler job by clicking Retail > Setup > Retail scheduler > Scheduler 
job. 

 

2. Select the job from the left side list and click Copy scheduler job to copy an 
existing job to create a new scheduler job. 

 

 
 

Scheduler log 

To view historic information on the job execution, follow these steps. 

 

1. Open the Scheduler job by clicking Retail > Setup > Retail scheduler > Scheduler 
job. 

 

2. Select the job from the left side list and click Scheduler log to view the historic 
information on the job execution. 

 

 

 

The Scheduler job form opens. 
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 DATA DISTRIBUTION 

Data distribution settings are created and specify how data in the headquarters office 
database is sent to store databases. You can specify that certain records are sent only to 
the locations where the records apply. You can also specify how changes to some tables 
and table fields are distributed. 

Data distribution starts and ends with a record that is changed.  

To perform data distribution, follow these steps.   

1. Set up data distribution locations for stores. 
2. Set up action filters to specify which tables and fields, if any, are monitored for 

changes. 
3. Set up table distributions. When a record in one of the selected tables is 

modified, the distribution settings for the table determine whether that 
modified record is distributed, and whether records in parent or child tables 
should be distributed with it. 

4. When a record is modified, the appropriate data is sent to the appropriate 
locations by means of jobs. The settings of the jobs provide more information 
about the specifics of the distribution. 
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 DISTRIBUTION LOCATIONS 

A distribution location is a record that represents the destination for distributed data. 
When you create a store, a corresponding distribution location is automatically created. 
Generally, you must have a distribution location for each store location that has its own 
database. 

Create distribution locations 

Typically, the distribution locations that are automatically created when you create 
stores are sufficient. However, you can also create new distribution locations.  

Note 

If you manually create a distribution location, make sure that the distribution location ID 
matches the ID for the store that the distribution location represents. 

To create distribution locations, follow these steps. 

1. Click Retail > Setup > Retail scheduler > Distribution locations. 
2. In the Distribution locations form, click New. 
3. Complete the following information for each distribution location. 

 

 

Fields 
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 Location number – Enter a unique ID for the distribution location. 

 Description – Enter a description of the distribution location. 

 Channel – Select the channel. For a store location select the store. 

 Database profile – Select the database connection profile for this location.  

 Channel Profile – Select the channel or store profile for this location. 

 Retail Channel Schema – Select the retail channel schema for this location. 

 Send data – Enable whether you will send data from the headquarters office to 
the location. 

 Receive data  - Enable whether you will receive data from the location. 

 Continuous data transfer schedule - Select the job or all jobs for the schedule. 

Buttons 

 

Functions – Open a menu where you can select from the following options: 

• Test connection – Test the connection to the instance of Retail Commerce Data 
Exchange: Synch Service that is selected in the connection profile for this 
location. 
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• Read schema – Read the database schema for the selected location, and create 
the list of location tables. The design must be read only for locations that are 
used to define the database design in jobs. By default, all jobs are set up to use 
the design of the default store, location S0001. As soon as Microsoft Dynamics 
AX for Retail is installed, this default location is created. 

Note 

Do not use this function if the selected location is the headquarters office location. 

For store locations, use this function only to read third-party tables from the store 
database. You might prefer to manually set up the function to read third-party point of 
sale (POS) databases instead of location tables. 

 

• Send configuration – Send the Commerce Data Exchange: Real-time Service 
profile that is selected in the connection profile for this location to the instance 
of Commerce Data Exchange: Synch Service that is selected in the connection 
profile. The Commerce Data Exchange: Real-time Service profile uses the upload 
of Commerce Data Exchange: Synch Service status messages from the store to 
the headquarters office. 
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 Deploy initial dataset – Deploy initial dataset is a mechanism for sending all 
necessary data for provisioning a new database for use as a channel database. 

Deploy initial dataset depends on A jobs and table distribution. By default, when 
the deployment is first started, certain jobs are started because they are linked 
to the A-0001_OC schedule in default seed-data. These jobs include the 
following: 

o         All A jobs ending with _OC 
o         N-1080_OC 
o         N-1100_OC 
o         N-1110_OC 
o         N-1115_OC 

Identifying rows to replicate 

Each distribution location is mapped to a channel. Only the data that is mapped 
to that channel is replicated when deploy initial dataset is started for the 
distribution location. To determine the set of rows to be replicated from each 
table, a pre-action is created for the RetailConnDistributionLocation table. This is 
the root table in the table distribution. The first internal dataset deployment 
starts the change from the pre-action to the action that results in a set of 
actions. Typically, there is one action for each table that is present in 
RetailConnDistributionLocation in the table distribution. All jobs in A-0001_OC 
are scheduled to be started, and all the A jobs process the necessary actions and 
replicate data to the destination distribution location. To prevent unnecessary 
data transfer, the N jobs in A-0001_OC are scheduled so that they only send data 
to the distribution location for which initial deployment is being run, regardless 
of the distribution list that is associated with the N jobs. 

How to customize 

To add a new table to the set of tables to be replicated during the first 
deployment, you can perform one of the following options: 

 Add the table to one of the A jobs ending with _OC 
o Must add the table in table distribution in 

RetailConnDistributionLocation. 

 Add the table to one of the N jobs that are started during the first deployment 
(refer to the previous list). 
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The first option is the recommended option to use.  However, if there are cases where 
the table cannot be linked to a location, then you can use the second option.  

 DISTRIBUTION LOCATION LIST 

In Microsoft Dynamics AX 2012 for Retail, you can create a distribution schedule that 
connects one or many locations (distribution location lists) with one or many scheduler 
jobs. 

To add a new retail channel to the distribution location list, follow these steps. 

1. Click Retail > Setup > Retail scheduler > Distribution location list. 
2. In the Distribution location list form, click New. 
3. Click Add to add a new retail channel to the distribution location list. 
4. Select the Location number from the drop-down list box. 

 

 FILTER ON ACTION CREATIONS 

When you set up an action filter, you should consider whether any transactions affect 
specific fields in tables. If an employee creates, modifies, or deletes a record in a 
selected table, the action filter automatically gathers the changed information in a pre-
action. A pre-action is a data record that has information about the data that changed, 
when it changed, and who made the change. A pre-action contains a set of instructions 
that inform you about the corresponding changes that you must make at the locations 
affected by the table modifications. 
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If you want to view modifications that are only specific to fields in a table, you can select 
those fields in the action filter. Do not select specific fields if you want to monitor all 
changes to a table. 

To create action filters for specific stores, follow these steps. 

1. Click Retail > Setup > Retail scheduler > Filter on action creations. 
2. On the Filter on action creations form, click New to create a new action 

filter. 
3. Complete the information in the Filter on action creations form. For help 

completing the form, open the form, and then press F1. 
4. On the Field FastTab, click Add to add a new field. 
5. Select the field number from the drop-down list box. 

 

The Field name displays the name of the field that is selected. 
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 TABLE DISTRIBUTION 

A table distribution is the hierarchy that is used to distribute data from the 
headquarters office database to store locations. For each table that is included in the 
table distribution, you can specify the type of distribution that occurs. You can also 
define the parent and, or child relationships for the tables in the table distribution. 

The way that you distribute changes that are made to the data in a table depends on the 
purpose of the table. For example, you want to distribute the Product Posting Group 
table to all store locations. However, you want to distribute the Item table only to 
selected store locations, because your organization sells items only in specific stores. 

If you create an action filter for a table that is not included in the table distribution, the 
changes that are made to the records in the table are automatically sent to all locations. 
For example, you want to distribute all the changes in the Product Posting Group table 
to all stores. Therefore, you do not add that table to the table distribution. However, if 
the table is already included in the table distribution, you must select a distribution type 
for the table. 
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18.7.1 DISTRIBUTION TYPES 

The distribution type for the table determines how the table is distributed. The 
distribution types that are available include the following: 

• All distribution locations – Distribute modifications to the records in a table to 
all locations. This is the default distribution type. 

• Same as parent distribution – Distribute modifications based on the 
distribution type of the parent table. Select this distribution type for records 
that must always be accompanied by other records. For example, the items and 
the bar codes for the items that must have the same data distribution. 

(Note: If you select this distribution type, you must set up table links that 
describe the relationship between the child table and its parent table.) 

• By distribution groups – Distribute modifications based on the distribution list 
for the record that is changed in the table. For example, changes made to an 
item are sent only to the stores that sell that item. 

(Note: Typically, you select this distribution type only for tables at the top of 
the table distribution hierarchy.) 

• No distribution – Do not distribute modifications. If a table of this distribution 
type is the parent of another table, and the distribution type of the child table 
is set to “Same as parent distribution,” changes to the child table are not 
distributed. 

Parent/child relationships 

If you use a table distribution to establish a parent/child relationship between two 
tables, you must complete the following steps.  

1. For the child table, set up table links to describe the 
relationship between the child table and its parent table. 
For more information, refer to the "Set up table links," 
later in this section. 

2. For the parent table, specify the types of actions (insert, 
update, or delete) that cause any child tables to be 
distributed together with the parent table. These linked 
settings also include any linked child tables of the child 
tables. 

Create a New Distribution 
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To create a new distribution, follow these steps: 

1. Click Retail > Setup > Retail scheduler > Table distribution. The Table 
distribution form opens. 

 

2. In the Table distribution form, click New. 
3. Select the Parent distribution from the drop-down list box. 

 

The Record ID will be automatically populated based on the assigned number 
sequence. 

4. Select the Table ID from the window that opens. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

357 

 

 

The Table name displays the name of the table that is selected. 
5. Select the Distribution type from the drop-down list box. The options include the 

following:   
a. All distribution locations 
b. Same as parent distribution 
c. By distribution group 
d. No distribution 

The Parent to another table check box is automatically marked if the selected 
parent table is also a parent table to other tables. 
The Table links check box indicates if a parent and, or child link is created 
between the two tables. The table link must be created if the distribution type 
that is selected is the same as the parent distribution. 
The No actions check box is marked to indicate that no action is required for 
changes that occur to the selected table. To use No actions the parent table 
must be empty or set to zero. 

6. Select the Linked actions on insert check box to indicate that the distribution 
occurs when new records are created in the selected table. 

7. Select the Linked actions on update check box to indicate that the distribution 
occurs when existing records are updated in the selected table. 

8. Select the Linked actions on delete check box to indicate that the distribution 
occurs when a record is deleted. 

9. The General FastTab displays the information entered in the Overview FastTab. 
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Insert the default table distribution 

Generally, the default setup for table distribution is used by most organizations. 
However, if you want to customize the table distribution and save time, you can insert 
the default setup.  

Note 

If you insert the default setup during deployment of Microsoft Dynamics AX for Retail, 
you can skip this procedure. 

To insert the default setup, follow these steps. 

1. Click Retail > Setup > Retail scheduler > Table distribution. 
2. In the Table distribution form, click Insert default setup. 

 

View the table hierarchy 

You can view the hierarchy for the parent and, or child relationships between tables in 
the Table distribution form. 

To view the hierarchy for the parent and, or child relationships, follow these steps.  

1. Click Retail > Setup > Retail scheduler > Table distribution. 
2. In the Table distribution form, select the Tree control check box. 
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3. Complete one of the following steps: 

 To expand a parent table to view or modify its child tables, click the plus 
sign (+) next to the table name. 

 To view or modify the settings for a table, select the table. 

Note 

A table can be the child of more than one parent table. In this case, the child table is 
displayed in the hierarchy more than one time. Depending on the settings, changes to a 
record in the child table might be distributed through multiple parent tables. 

To delete a table distribution entry, follow these steps. 

1. Click Retail > Setup > Retail scheduler > Table distribution. 
2. On the Table distribution form, clear the Tree control check box. 
3. Select the table entry that you want to delete, and then click Delete on the 

toolbar. 
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Set up table links 

Table links define the conditions that must be met for the records in the child table to 
be distributed according to the distribution type of the parent table. The effect of 
setting up a table link is comparable to the effect of setting up a link between a primary 
key and a foreign key in SQL Server. 

However, a table link applies only to data distribution. Table links are required only for 
tables for which you select a distribution type of “Same as parent distribution.” 

There must be a logical relation between the tables that you link. For example, you 
cannot link the Item table to the Customer table, because there is no logical relation 
between the two tables. 

For parent fields, you must select fields that are part of the primary key for the parent 
table. 

For child fields, we recommend that you select fields that are either part of the primary 
key or part of a properly indexed foreign key for the child table. 

 
How table links work 

When a record in a child table is modified, and the resulting pre-action changes to an 
action, Retail Scheduler checks whether the modified record is in a table for which 
distribution is controlled by the settings of the parent table. If the modified table is 
linked to the parent table for data distribution, Retail Scheduler checks whether the 
modified record meets the criteria for distribution that are specified in the parent 
table's settings. 

If a table link includes multiple criteria, all the criteria must be met for distribution to 
occur based on that link. If a modified record does not meet the criteria of any of the 
links to the parent table, distribution does not occur. 
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To set up table links, follow these steps. 

1. On the Table distribution form, select the table that you want to link to its 
parent table.  

Note 

The parent table must already be listed in the table distribution. 

2. Click Table links. The Table links form opens. 

 

3. On the Table links form, click New. 
4. On the General FastTab, the child table information is populated in the 

Table ID and Parent table ID with descriptions. 
5. In the Parent distribution field, select a parent table ID. (Note: If there are 

multiple entries in the list, meeting the criteria of any one table link creates 
the link (SQL OR operation).  

6. In the Field ID field, select the field that you want to link to a field in the 
parent table. The field name is displayed automatically. (Note: If there are 
multiple entries in the list, all the criteria must be met for the link to be 
created. 

7. In the Parent field, select the field in the parent table that you want the child 
field to be linked to. The parent field name is displayed automatically. 

8. Select the Type to specify the type of check that is required from the drop-
down list box. The options include the following: 
a. Field: The field specifies that the distribution will occur if the logical 

relation between the fields specified in the parent and child table 
matches. 

b. Filter: The Filter version is not supported in the current version of 
Microsoft Dynamics AX for Retail. 

c. Equals (=): Specify the value in the Value field to make sure that the field 
value during distribution is correct. 

9. If the parent field must contain a specific value, type that value in the Value 
field. 

10. Repeat steps 4 through 7 for any additional criteria for this table link. 
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To check the parent table setup, follow these steps. 

1. Click Retail > Setup > Retail scheduler > Table 
distribution.  

2. Select the table distribution record and click the Check 
parent table setup button on the top toolbar. 

 

3. You will receive a confirmation message on the status of 
the set up.  Click OK. 

 

 RETAIL CHANNEL SCHEMAS 

To set up the retail channel schemas, use the Retail Channel Schemas form. 

To create a new retail channel schema, follow these steps.  

1. Click Retail > Setup > Retail Scheduler > Retail Channel Schema. 
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2. Click New to create a new schema. 
3. Enter the Schema name. 
4. Select the Schema type.  The channel types include the following:  

1. AX 2009 POS – A point of sale (POS) channel in Microsoft Dynamics AX 

2009.  

2. AX 2012 Feature Pack POS – A POS channel in Microsoft Dynamics AX 

2012 Feature Pack.  

3. AX 2012 R2 Online Channel – An online channel in Microsoft Dynamics AX 

2012 R2.  

4. AX 2012 R2 POS – A POS channel in Microsoft Dynamics AX 2012 R2.  

5. To associate the Location Table for the retail channel schema, click the Location 

Table button. 
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6.  Enter the table and the associated fields by clicking the Location Fields button. 

 

7. Close the form after all the Location table and field information is entered.   
8. Click the Read Schema button and select the distribution location that the 

schema will be read from. 
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19 STORE INTEGRATION 

OVERVIEW 

In this module we will discuss the Synch Service Upload Options and Profiles. 

COMMERCE DATA EXCHANGE: SYNCH SERVICE OPTIONS 

Microsoft Dynamics AX Retail includes resources that can be used to monitor Commerce 
Data Exchange: Synch Service. These resources include the following: 

 Commerce Data Exchange: Synch Service Messages 

 Windows Event Log 

Commerce Data Exchange: Synch Service Messages 

Commerce Data Exchange: Synch Service status and error messages can be viewed in the 
Commerce Data Exchange: Synch Service messages form.  

To open the Commerce Data Exchange: Synch Service form, click Retail > Inquiries > 
Commerce Data Exchange: Synch Service messages. 

You can trace the history of a message by selecting the message and then clicking View 
message tree. This opens the Commerce Data Exchange: Synch Service message tree form. 
Here, you view the message’s origin and routing. 

 



 

 

 

Note 

You must configure an upload profile before the messages will be available in Microsoft 
Dynamics AX.  

 

 

Profiles are created by using the Commerce Data Exchange: Synch Service upload options 
form. 

To open the Commerce Data Exchange: Synch Service upload options form, follow these 
steps.    

 

1. Click Retail > Setup > Retail scheduler > Store integration > Commerce Data 
Exchange: Synch Service upload options. 

 

 

 

2. Click New to create a new upload option. 
 
3. Enter the Name of the store connect upload option. 

 



 

 

4. Select the Upload enabled check box to indicate that the Commerce Data Exchange: 
Synch Service upload option is active. 
 

5. Select the Error message only check box to upload only error messages to the retail 
headquarters. 
 

6. Enter the Interval (minutes) to indicate the time when the upload will be performed. 

 

Windows Event Log 

Full logging of Commerce Data Exchange: Synch Service events can be viewed in the 
Windows event log of the host computer. 

 

 COMMERCE DATA EXCHANGE: SYNCH SERVICE PROFILES 

A Commerce Data Exchange: Synch Service profile in the headquarters office of Microsoft 
Dynamics AX provides the connection string that lets Microsoft Dynamics AX Retail 
Headquarters communicate with an instance of Commerce Data Exchange: Synch Service. 

To create a new Commerce Data Exchange: Synch profile, follow these steps. 

1. Click Retail > Setup > Retail Scheduler > Store integration > Commerce 
Data Exchange: Synch Service profiles. 

2. Click New to create a new Commerce Data Exchange: Synch Service profile. 
3. Type the following information: 

 Service name – The name of the service as it is specified in the 
Commerce Data Exchange: Synch Service Settings (Start > All Programs 
> Microsoft Dynamics AX 2012 > Commerce Data Exchange: Synch 
Service > Commerce Data Exchange: Synch Service Settings). 

 Server name – The name of the server where Commerce Data 
Exchange: Synch Service is installed. 

 Port – The port used by this instance of Commerce Data Exchange: Synch 
Service. 

 Disable IPsec – Select the check box to disable IPsec. IPec is a framework 
of open standards that are used to protect communications over Internet 
Protocol (IP) networks through the use of cryptographic security services. 
(Important : IPsec should only be disabled if there are other means in 
place to provide secure communication channels for Commerce Data 
Exchange: Synch Service.) 

 Force IPV4 – Select to stop connections that use IPV6. 
 Timeout (seconds) – Type the time in seconds. 



 

 

 Commerce Data Exchange: Real-time Service profile – The name of a 
Commerce Data Exchange: Real-time Service profile. 
o Commerce Data Exchange: Synch Service uses this profile to connect 

to Commerce Data Exchange: Real-time Service to monitor the status 
of jobs. If you do not want this instance of Commerce Data Exchange: 
Synch Service to monitor status, leave this field blank. 

 Commerce Data Exchange: Synch Service upload options – The names of 
the upload options that are used by Retail. 
o Store Connect: If you configure upload options, you must post the 

configuration to Commerce Data Exchange: Synch Service and restart the 
service for the settings to take effect. 

4. Click Test connection to confirm that the connection string for the selected 
Commerce Data Exchange: Synch Service profile is correct. 

 

 AOS PROFILES 

An AOS profile provides the connection string that is used for Microsoft Dynamics AX Retail 
Headquarters to communicate with the headquarters office database. 
To create a new AOS profile, follow these steps. 

1. To open the AOS profiles form, click Setup > Retail Scheduler > Store 
integration > AOS profiles. 
 

2. Click New to create a new AOS profile. 
 

3. Type the following information: 
 

i. Name – A unique name for the profile. 



 

 

ii. Server name – The name of the AOS server. 
iii. Instance name – The name of the AOS instance. 
iv. TCP/IP port – The TCP/IP port for the AOS instance. 
v. Commerce Data Exchange: Synch Service – Select the profile for the 

correct instance of Commerce Data Exchange: Synch Service. 
4. Click Test connection to confirm that the connection string for the selected AOS 

profile is correct. 

 

 

  



 

 

 DATABASE PROFILES 

A database profile provides the connection string that is used for Microsoft 
Dynamics AX Retail Headquarters to communicate with a store database. 

To create a new database profile, follow these steps. 

1. To open the Database profiles form, click Setup > Retail Scheduler > Store 
integration > Database profiles. 

2. Press New to create a new database profile. Optionally, you can click 
Duplicate to create a new profile that is based on a currently selected profile. 

3. Enter the following information: 
 Name – Type a name for the profile. 
 Version – Select the SQL Server version for the database. 
 Server name – Type the name of the database server. 
 Database name – Type the name of the database. 
 Encrypt database connection – Select the check box to 

encrypt the database connection. 
 Commerce Data Exchange: Synch Service – Select the profile for the 

correct instance of Commerce Data Exchange: Synch Service. 
4. Click Test connection to confirm that the connection string for the selected 

database profile is correct. 
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ASSORTMENT  

OVERVIEW 

In this module, we will discuss how an assortment is a collection of related products that 
the retail business assigns to the retail channel, such as a brick and mortar store or an 
online store.  

Assortments are used to identify the products that are available in each store. An 
assortment can include categories of products. Therefore, all products that are assigned 
to a specific category are included in the assortment. An assortment can also include 
specific products and specific variants of products. By setting up an assortment, you can 
assign thousands of products to the retail channels at the same time, in any 
combination that the stores require.  

Multiple assortments can be set up for the retail store. Each product can be included in 
one or more assortments, and each assortment can be assigned to one or more retail 
channels.  

For example, you can define one assortment that includes a base set of products that all 
stores receive. You can then define another assortment that includes only large sporting 
equipment that only larger stores receive.  

The following diagram illustrates how products can be assigned to assortments, and 
how those assortments can be assigned to retail channels.  
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 PROCESS ASSORTMENT 

Retail assortments job 

The retail assortments job periodically aggregates and then de-normalizes all of the 
valid assortments into a flattened list of products and variants for each channel. This 
improves data replication performance and provides the data necessary for the 
improved visibility features. 

The process assortment helps to improve the performance of the batch job. When you 
use the process assortment, consider the following: 

 Only published assortments are processed 

 Only the delta is processed 

 Only the relevant pre-actions are created 

javascript:void(0)
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You can run jobs manually, and you can set up a batch to create a schedule so 
that jobs are run automatically. 

 

Run a job manually 

To manually run a job, follow these steps. 

1. To run the Process assortment, click Retail > Periodic > Process Assortment. 

2. In the Retail assortments job form, click OK. 

Set up and run a batch 

A batch job is a scheduled job. When you create a batch job, you set up a timer in the 
AOS instance to run the job automatically on the server. 

Note 
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To run batch jobs, you must configure the batch server. For more information, refer 

to Microsoft Dynamics AX Help. 

To automatically run a job, follow these steps. 

1. Click Retail > Periodic > Process Assortment. 
2. On the Retail assortments job form, click Batch processing. 
3. Optional: In the Batch dialog box, in the Task description field, enter a 

name for the job.  
4. Click Recurrence. In the Recurrence form, enter the schedule details for 

the batch. For information about the settings in the Recurrence form, 
press F1. 

5. Close the Recurrence form and click OK. 

Set Recurrence for Process Assortment 

To set the recurrence for the process assortment, follow these steps. 

1. To open the retail assortment job form, click the Retail > Periodic > Process 
Assortment. 

 

 

2. Click the Recurrence button to set the frequency of the batch job execution. 
3. Select the Time zone from the drop down list box. 
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4. In the Range of recurrence area, select the Starting time for the batch job. 
 

5. Enter the Starting date for the batch job. 
 

6. Select the No end date option if the job needs to run without any end date. 
 

7. To limit the job executions to certain tries, select the End after option and 
then enter the Count value. 
 

8. Select the End by option to specify the end date for the batch job execution. 
 

9. In the Recurring pattern areas, select the time period (Minutes, Hours, Days 
and more) and then enter the Count that specifies the time value. 
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RETAIL CHANNELS  

OVERVIEW 

This module focuses on how Microsoft Dynamics® AX for Retail Headquarters is used by 
retail stores for the point of sales (POS) terminals, and for the business accounting 
setup. It is used to control the basic requirements for the retail business, such as items, 
prices, staff and customers. Additionally, Microsoft Dynamics AX for Retail Headquarters 
is used to exchange data between the headquarters office and the point of sale 
terminals.  Microsoft Dynamics AX for Retail Headquarters includes data distribution 
management. A retail store can use data distribution management to control the exact 
data that is available on the point of sale terminals, set a price for an item and 
determine whether the discounts that are offered in each store are valid.  

Microsoft Dynamics AX for Retail Headquarters manages the replication of data 
between databases and supports the headquarters office point of sale structure. 
Replication is scheduled by the user and can be set up so that only the information that 
is changed is replicated. It makes extensive use of the distribution principles.  

The Retail Channel is the subtype of the operating unit. Three channel types are 
available in Microsoft Dynamics AX 2012. They include the following: 

 Retail stores 

 Online stores 

 Online marketplaces 

 RETAIL STORES  

The store is one of the main units in Microsoft Dynamics AX for Retail Headquarters. The 
store includes the distribution location, its own tender types, point of sale functionality, 
income and expense accounts and staff. Additionally, the store can be divided into 
sections and shelves. Typically, setting up the stores and the headquarters office in the 
business are the first steps when Microsoft Dynamics AX for Retail Headquarters is 
being set up. 

After you create the new store, you assign the products that you want the store to 
carry. You assign products to stores by using assortments. You can either add the new 
store to an existing assortment, or you can create a new assortment specifically for the 
new store. You also must assign employees, registers, and customers to the store. 
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Important 

In Microsoft Dynamics AX, a retail store is considered a type of warehouse. Before you 
create a new store, you first create a warehouse and define it as a store. You then 
create a new store and assign the warehouse to it. 

20.2.1 CREATE A WAREHOUSE 

Retail stores are considered a type of warehouse. The retail understanding on 
warehouses is to create a warehouse of the type store that uses all the inventory 
management processes. This includes stock control and accounting from the Microsoft 
Dynamics AX. 

To create a new warehouse, click Inventory and warehouse management > Setup > 
Inventory breakdown > Warehouses.  The Warehouses form opens. 

To create a warehouse, follow these steps. 

1. Click the New button on the top toolbar to create a new warehouse. 
2. Enter the Warehouse code that is unique to the warehouse. 
3. Enter the Name of the store warehouse. 

 
 

4. On the General FastTab, select the Site from the drop-down list box. A site is a 
building or a location where the inventory is managed. 
 

 
 

5. On the Retail FastTab, select the Store check box to indicate that the newly 
created warehouse is a retail store. 

6. Enter the default Weight that is used by the store for replenishment. 
7. The Replenishment hierarchies display the hierarchies of the replenishments 

that are available in Microsoft Dynamics AX for Retail. Expand each of the 
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hierarchies to view the business units and the stores that are associated to the 
hierarchy. 

8. Check the Financial negative inventory check box if negative inventory is 
allowed from a financial perspective. 

9. Check the Physical negative inventory check box if negative inventory is allowed 
at warehouses and stores. This check box defines if the cashiers at the store can 
sell items even if Microsoft Dynamics AX for Retail is showing negative physical 
inventory. 

10. Select the Default location for storage of items for the store. 
11. Select the Default pallet ID for storage of items for the store. 

 

20.2.2 CREATE A RETAIL STORE 

This section discusses the steps that are required to create a new retail store. Click 
Retail > Retail channels > Retail stores. The Retail stores form opens. 
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To create a new retail store, click Retail store in the New group. The Stores form opens. 

General 

On the General FastTab, follow these steps. 

1. On the General FastTab, enter the Name of the retail store. 
2. Enter the unique Store number of the retail store. The store number will be filled 

automatically based on the number sequence that is specified in the Shared 
retail parameters form. 

3. Select the Company the retail store will belong to from the drop-down list box. 
The current company where the store is being created will be set as the default. 

4. Select the default Warehouse from the drop-down list box. The drop-down list 
box is filtered to contain all the store warehouses that have the retail check box 
marked. 

5. Select the default Shipping warehouse from the drop-down list box. 
6. In the POS terminal area, select the default Screen layout ID from the drop-

down list box.  The selected screen layout will be the default layout of the POS 
terminals for cashiers and manager. 

7. Select the Functionality profile for the retail store from the drop-down list box. 
The Functionality profile defines the operations that cashiers and managers can 
perform at the retail store. Default reason codes can be assigned to the profile 
for return orders, discounts and many other operations. 
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8. Select the Offline profile for the retail store from the drop-down list box. The 
Offline profile can be used to define the entities and their corresponding fields 
that will be maintained in the offline database. When the connection to the POS 
terminal comes online all the offline transactions are synced back to the store 
database. 
Inventory lookup: This feature is not implemented in this release and might be 
removed from future releases. 

9. In the Regional settings area, select the default Language from the drop-down 
list box. 

10. Select the primary Currency the retail store will use from the drop-down list box. 
11. In Sales tax area, enter the Tax identification number (TIN) for the retail store. 

The tax identification number can differ based on the country where the retail 
store is being setup. 

12. Select the default Sales tax group from the drop-down list box. The sales tax that 
is selected will define the how the tax is calculated at the point of sale terminal 
when cashiers perform sales transactions. 

13. Check the Price include sales tax check box if the Recommended Retail Price 
(RRP) is inclusive of tax.  

14. Check the Use destination-based tax to apply the tax calculation that is based on 
the shipping address of the order. The tax rate that applies to the geographical 
location of the address is taken into consideration for tax calculation. For 
example, if the retail store is based in Washington state, where the sales tax is 5 
percent, and the shipping address is in California state, where the tax rate is 7.5 
percent, then when the use destination based tax is marked, the tax calculation 
is performed by using the California state sales tax of 7.5 percent. 

15. Check the Use customer-based tax to apply the tax calculation that is set at the 
customer level. During a sales transaction, if the casher selects a customer and if 
the customer based tax is marked, then the tax that is allocated to the customer 
will be applied to the transaction.  

Note 

If both the Use customer-based tax and the Use destination-based tax check box are 
marked, taxes will be calculated based on the shipping address (if any) rather than the 
customer's sales tax group. 

16. Select the default Sale tax override group from the drop-down list box. 
 

17. In Address book area, select the Customer address book for the retail store. All 
the new customers that are created by using point of sale will be assigned to the 
address book that is assigned to the retail store. 
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18. Select the Employee address book for the retail store. All the workers that are 
created can be assigned to the same address book that maps the workers to the 
retail store. 
 

19. In the Default customer area, select the Default customer from the drop-down 
list box. A default customer is used to associate all the statements that are 
created as part of End of day (EOD) procedure. 
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Statement/Closing 

When all transactions from the point of sale terminals are received in Microsoft 
Dynamics AX, a statement can be created, calculated and posted. 

A statement calculates the amounts in all transactions that are created in the special 
date range or in any other filter that is set, on the point of sale terminal or other criteria, 
and then registers the counted tender types. The statement includes the transaction for 
the period in that specific statement. When all the information is gathered and the 
counted amounts are registered, then the statement is ready to be posted. 

Note 

Microsoft Dynamics AX 2012 AX for Retail POS supports a single method for the end of 
day procedure that includes by date and time.  

When a cashier closes a shift by date and time, the typical process is to count the tender 
types with the declaration either while the cashier is on the point of sale terminal or 
when the cashier is in the back office, he or she can enter the counted amounts in the 
statements.  

If the shift is closed by date and time, the statement can include many days and time, or 
have one for each day based on the operation policy that exists at the retail store. 
However, you must be aware that this decision has an influence on how detailed the 
ledger entries are maintained in Microsoft Dynamics AX 2012 Retail Headquarters. 

To close a statement, follow these steps. 

1. In the Statement area, select the Statement method type that is used to group the 
statement for posting. The options include the following: 

 Staff: Select this option to view payment results for each staff member. The 
results of the statement calculations show one line for each payment that is 
used in the transactions, for each staff member. This is the payments 
declaration for each cashier. 

 POS terminal: Select this option to view the payment results for each 
register. Microsoft Dynamics AX Retail Headquarters calculates one line for 
each payment type that is used in the transactions of that register. 

 Total: Microsoft Dynamics AX Retail Headquarters calculates one line for 
each payment type that is used, with the amount totaled for all the 
transactions that are completed in that payment. 

2. Check the One statement per day check box to indicate that only one statement will 
be created each day for the retail store. 

3. Select the Tender declaration calculation type from the drop-down list box. The 
options include the following: 
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 Last: Indicates one tender declaration for each day. 

 Sum: Indicates multiple tender declarations for each day with the totals 
being added at the end of the day. 

4. In the Rounding area, select the Rounding account from the drop-down list box. The 
rounding account includes the difference between the total sales amount and the 
total payment amount for statement transactions. 

5. Enter the Maximum rounding amount allowed as a difference when posting a 
statement. 

6. In the Maximum difference area, enter the maximum Posting difference that is 
allowed between the transaction amount and the counted amount for each tender 
in a statement to allow posting. 
Shift: This feature is not implemented in this release and might be removed from 
future releases. 

7. Enter the maximum Transaction amount that is allowed in the Sales/Payment 
difference box that shows the difference between sales and payment for each 
transaction. This limit helps to recognize errors in the transactions. 

8. In the Closing area, select the Closing method from the drop-down list box. The 
options include the following: 

 Date and time: Select this option to calculate and post statements for the 
date and time range that you specify in the statement. A single statement is 
created for the whole store. It can include many days (and times), or you can 
create multiple statements for each day. 

 Shift: Select this option to calculate and post statements whenever a Retail 
shift is closed. A statement is created for each shift on each register. Totals 
are for each shift, and for each terminal. Transactions in a shift do not post 
until the shift is closed. 

9. The Batch area is used to control how statements are processed by the batch 
framework. Enter the Transaction end time for the 24-hour batch period for the 
statement calculation. For example, to set the batch period as 2:00 A.M. to 2:00 
A.M. type 02:00:00. To set the batch period as midnight to midnight, type 00:00:00. 

10. Select the Staff/Terminal check box if the business encounters performance issues 
during the statement posting. If the check box is marked, then one statement for 
each staff member or terminal is created. 

Miscellaneous 

1. In the Payment method area, select the Remove/Add payment method from 
the drop-down list box. The tender type that is selected will be used for Float 
Entry operations in the Microsoft Dynamics AX for Retail POS for balancing 
removing and adding transactions on the registers. 

2. In the Opening hours area, enter the From start time when the store will open 
every day. 
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3. Enter the To end time when the store will close every day. 
4. In the Labels area, select the Prints shelf labels check box to include this retail 

store in the shelf label printing operations. 
5. Select the Prints item labels check box to include this store in the item label 

printing operations. 
6. Select the Create label for zero price check box to print labels for store items 

even if the price of the items is zero. 
7. In the Purchase area, select the PO product filter check box to filter the items 

that can be ordered for this store to those items that are available in the store 
warehouse. 

8. In the Training mode area, select the Hide training mode check box to hide the 
Training mode option from the retail POS terminal. 

Financial dimensions 

To create financial dimensions, follow these steps. 

1. In the Default financial dimensions area, select the CustomerGroup dimension 
for the retail store from the drop-down list box. 

2. Select the Department dimension for the retail store from the drop-down list 
box. 

3. Select the ItemGroup dimension for the retail store from the drop-down list box. 
Store: The Store number is added as a default dimension for reporting purposes. 

4. Select the default Terminal dimension for the retail store from the drop-down 
list box. 

5. Select the Worker dimension for the retail store from the drop-down list box. 

Store inventory 

To store inventory, in the Planned order area, select the Master plan from the drop-
down list box that applies to the inventory for the retail store. 

Setup a Retail store 

After you create a new retail store, you must set up the following:  

 Payment methods 

 Cash declarations 

 Income and Expense account 

 Sections 

 Distribution locations 

The next section discusses each area so that related retail store information can be set 
up and configured.  
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Setup payment methods 

Payment methods are the payment types that are used for goods and services that are 
received and sold at a retail store. 
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To create the payment methods, follow these steps.  

1. Click Retail > Setup > Retail channels > Retail stores.  
2. Double-click and open the retail store to setup the payment methods.  
3. Click the Setup FastTab from the top toolbar to view the retail store setup 

options. 

 

The Stores form is an easier option to use to copy payment methods from existing 
stores to new stores.   

To copy payment methods from the existing store to the new store, follow these steps. 

1. On the Setup FastTab, click Payment method to store from the Copy group. 
2. Select the From store from the drop-down list box. 

The To store is defaulted to the current store. 
3. Click OK to confirm and copy the payment methods from the new store that is 

created.   
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After copying the payment method, the user can modify the values that are specific 
to the retail store. 

4. On the Setup FastTab, to modify the payment methods, click Payment methods 
in Set up group. 

 

The Payment methods form opens. 

 

The fields in payment methods for modifications include the following: 

General 

On the General FastTab, follow these steps. 

1. In the Identification area, if a new payment method is being created, select the 
Payment method type from the drop-down list box. 

2. Select the Terms of payment for the tender type from the drop-down list box. 
3. In the Description area, enter the Payment method name for the store tender 

type. 
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4. In the Function area, the Function field of the tender type is auto-populated 
when a payment method is selected. This setting comes from the organization 
wide tender type and cannot be changed. 

5. In the POS area, select the Operation ID this is used by cashiers to accept 
payment of this type. 

Note 

Do not set noncash tender types to the Pay Cash operation. 

When cashiers perform a Float Operation at the point-of-sale, if more than one tender 
type is available that has the Pay Cash operation, Microsoft Dynamics AX for Retail POS 
uses the tender type that is set up first to create a payment transaction. 

6. In the Open drawer area, select the Open drawer check box to open the cash 
drawer every time the selected tender is used at the point of sale. 

7. Select the POS count entries check box to indicate that the program counts the 
number of payment entries made with this tender. These entries are used to 
create X and Z reports at the point of sale. 

 

Amount 

On the Amount form, follow these steps. 

1. In the Overtender and Undertender area, select the Allow overtender check box 
to indicate that the tender type might be tendered over the transaction amount 
and that change will be returned to customer. 

2. Enter the Overtender maximum amount that is allowed in over tendering. 
3. Select the Allow Undertender check box to indicate that the tender type might 

be under tendered, meaning that payment is applied as a partial payment. 
4. Enter the Undertender maximum amount that is allowed in under tendering. 
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5. In the Tender declaration area, select the Maximum counting difference 
amount between daily transactions and the actual cash count for each tender 
type. 

6. Enter the Maximum recounts performed if a counting difference exists. 
7. In the Rounding area, select the Rounding method from the drop-down list box. 

The options include the following: 

 None: The number is not rounded up or down. 

 Nearest:  The number is rounded up or down to the digit that is specified 
in the Round-off field. 

 Up: The number is rounded up to the digit that is specified in the Round-
off field. 

 Down: The number is rounded up to the digit that is specified in the 
Round-off field. 

8. Enter the Round-off value to which a tender type is rounded based on the 
Rounding method. For example, if you want Microsoft Dynamics AX Retail 
Headquarters to round-off an amount without decimals, enter 1.0 in this field. If 
you want Microsoft Dynamics AX Retail Headquarters to round-off to two 
decimal places, enter 0.01 in this field. 

9. In the Amounts area, enter the Minimum amount entered in the selected 
tender type in a transaction at the point of sale (POS). Anything less than this 
amount is not allowed. If you enter zero or leave the field blank, no minimum 
amount is specified. If this is the case, the transaction can be finalized by 
pressing the correct tender key at the point of sale.  

10. Enter the Maximum amount entered in the selected tender type in a transaction 
at the point of sale. The recommendation is to set an amount that will not be 
reached. If you enter zero or leave the field blank, no maximum amount is 
specified. If this is the case, the transaction can be finalized by pressing the 
correct tender key. 

11. Enter the Minimum amount allowed when trying to finalize a transaction by 
using only the tender key at the point of sale without entering the amount. If you 
enter zero or leave the field blank, the transaction can be finalized by pressing 
the correct tender key. 

12. Enter the Maximum amount allowed when trying to finalize a transaction by 
using only the tender key at the point of sale without entering the amount. If you 
enter zero or leave the field blank, the transaction can be finalized by pressing 
the correct tender key. 
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Posting 

After successful posting, amounts in the Transaction Sales Amount account will match 
the total amount in the Tender Type Posting account and the Tender Type Post 
Difference account. 

To post tender, follow these steps. 

1. In the Account area, select the Account type from the drop-down list box where 
the tender type will be posted. The selected account type determines the 
accounts that can be selected in the Account number field. The options include 
the following: 

 Ledger account: The tender is posted to a General Ledger account. 

 Bank account: The tender is posted to a bank account. 
2. Select the Account number from the drop-down list box. The selected account is 

updated when the statement is posted in Microsoft Dynamics AX Retail 
Headquarters. 

3. In the Difference account area, select the general ledger Difference account 
from the drop-down list box. The difference between the counted amount and 
the transaction amount in the statement line will be posted to the selected 
account. 
The Account name field displays the name of the Difference account that is 
selected. 

4. Enter the Maximum normal difference amount for a tender to be posted to the 
difference account. 

5. Select the General Ledger Big difference account to which the difference 
between the counted amount and the transaction amount in the statement line 
will be posted. This account is updated only if the difference is more than the 
difference amount that is entered in the Maximum normal difference field. 
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The Account name field displays the name of the Big difference account that is 
selected. 

6. In the Tender declaration options area, select the Compress payment entries 
check box for Microsoft Dynamics AX Retail Headquarters to compress all 
payment entries with the same tender into one payment entry. 

7. Select the Counting required check box to apply the counting of the tender. If 
the check box is left clear, Microsoft Dynamics AX Retail Headquarters 
automatically enters the contents of the Transaction amount field in the 
statement line in the Counted amount field when a statement is calculated. 

8. Select the Multiply in tender operations check box for point of sale to 
automatically multiply the amounts that are entered for the tender in tender 
operations. The tender operations include the following: 

 Tender declaration 

 Float 

 Remove tender and so on 
9. Select the Allow float check box for the tender to be used as floating cash. When 

running the registers during a shift or a specific date and time, tender can be put 
in the register drawers and set up as a floating transaction. 

10. Select the Taken to bank check box to indicate that the tender type will be 
deposited in the bank. 

11. Select the Taken to safe check box to indicate that the tender type is deposited 
in the safe. Only tender types that have this check box selected are available for 
safe drop operations in Microsoft Dynamics AX Retail POS. 

12. In the Bank transaction area, select the Use bank account check box to make 
available the bank transaction settings. Set up the Bank transaction if Taken to 
bank is marked. 

13. Select the Account type that the tender is posted from in the drop-down list box. 
The selected account type determines the accounts that can be selected in the 
Account number field. The options include the following: 

 Ledger account: The tender is posted to a General Ledger account. 

 Bank account: The tender is posted to a bank account. 
14. Select the Account number for the tender to update when the statement is 

posted in the Microsoft Dynamics AX Retail Headquarters. 
15. In the Safe transaction area, select the Use safe account check box to enable 

safe transaction settings. Set up the Safe transaction if the Taken to safe is 
marked. 

16. Select the Account type the tender is posted from in the drop-down list box. The 
selected account type determines the accounts that can be selected in the Safe 
account field. The options include the following: 

 Ledger account: The tender is posted to a General Ledger account. 

 Bank account: The tender is posted to a bank account. 
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17. Select the Safe account for the tender to update when the statement is posted 
in Microsoft Dynamics AX Retail Headquarters. 

 

Change  

To use the change tender, follow these steps. 

1. In the Change setup area, the Change line on receipt feature is not implemented 
in this release and might be removed from future releases. 
 

2. Select the Above minimum change tender (other than the tender selected on 
the payment method form) from the drop-down list box. The tender selected 
will be used to provide change to the customer if the value of the change is 
higher than the amount specified in the Minimum change field. If the amount in 
Minimum change field is zero or blank, this field has no effect. 

Note 

Tender types that are used for foreign currencies cannot be used as Above minimum 
change tender. 
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To enter minimum change, follow these steps. 

1. Enter the Minimum change that is allowed as change in this tender type. If the 
amount to be given as change is less than the amount that is entered in the 
Minimum change field, the amount will be returned in the tender type that is 
selected in the Change tender field. If you enter zero or leave the field blank, 
change can always be given in the tender type that is  defined in the Above 
minimum change tender field. 

2. Select the Change tender (other than the tender that is selected on the Payment 
method form) from the drop-down list box. The tender that is selected will be 
used to provide change to the customer if the value of the change is less than 
the amount that is specified in the Minimum change field. This field should be 
left blank if the change can always be rendered in the actual tender type. 

Financial dimensions 

To use financial dimensions, follow these steps. 

1. In the Default financial dimensions area, select the CustomerGroup dimension 
for the payment method from the drop-down list box. 

2. Select the Department dimension for the payment method from the drop-down 
list box. 

3. Select the ItemGroup dimension for the payment method from the drop-down 
list box. 

4. Select the Store dimension for the payment method from the drop-down list 
box. 

5. Select the default Terminal dimension for the payment method from the drop-
down list box. 

6. Select the Worker dimension for the payment method from the drop-down list 
box. 

 

Payment method reason codes 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

24 

 

You can setup reason codes for specific payment methods to be included at the Point of 
Sale (POS). Click Reason codes from the top toolbar on the Payment method form. 

To associate a new reason code to the payment method, follow these steps. 

 

1. Click New to associate a new reason code to the payment method. 
2. Select the Reason code number from the drop-down list box. 

The Prompt field will display the message that is associated with the reason code 
that is selected. The prompt message will be displayed to the cashier on the 
point of sale register when the payment method is selected. 

3. Check the Input required check box so that the cashier can provide information 
when the reason code is prompted on the point of sale terminal. 

4. Select When required to indicate when the reason code should be selected for 
the payment method from the drop-down list box. The options include the 
following: 

 Always: Prompt for the reason code every time the payment method is 
used. 

 Positive: Prompt for the reason code when the amount is positive and 
the payment method is used. 

 Negative: Prompt for the reason code when the amount is negative and 
the payment method is used. 

5. Select the Sequence number for the reason code to indicate the sequence in 
which it should appear on the point of sale  terminal if multiple reason codes are 
associated with the payment method. 
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Payment transactions 

To view payment transactions that are associated with the payment method, click 
Payment transactions from the top toolbar on the Payment methods form. 

 

The Payment transactions form opens.  
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The Overview FastTab displays the transaction number, payment method, tendered 
amount, and the transaction date and time. 

To view this information, follow these steps. 

1. Click the General FastTab to view payment details, payment origin and 
statement information. 

 

2. Click the Financial dimensions FastTab to view the dimension that is associated 
with the transaction header. 
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3. To view transaction details or reason code transactions, click Transactions on the 
right side of the Payment transactions form.  

Setup Cash Declarations 

This section describes how to setup cash declarations for a retail store that defines the 
currency denominations that are used at the point of sale terminal. 

To create cash declarations, follow these steps.  

1. Click Retail > Setup > Retail channels > Retail stores.  
2. Double-click and open the retail store to setup the cash declarations.  
3. Click the Setup FastTab from the top toolbar to view the retail store setup 

options. 
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The Stores form provides an easier option to copy cash declarations from existing stores 
to new retail stores.   

To copy cash declarations from an existing store to the new store, follow these steps.  

1. On the Setup FastTab, in the Copy group, click Cash declaration. 
2. Select the From store from the drop-down list box. 

The To store is defaulted to the current store. 
3. Click OK to confirm and copy the cash declaration from the new retail store.  

 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

29 

 

After copying the cash declaration, the user can modify the values that are specific to 
the retail store. 

To modify the cash declaration, on the Setup FastTab, click Cash declaration in the Set 
up group. 

 

The Cash declaration form opens: 

 

To enter information in the Cash declaration setup form, follow these steps.  

1. Click New to create a new cash declaration. 
2. Select the Type of declaration from the drop-down list box. The options include 

the following: 

 Coin: The type of cash declaration is in coins. 

 Note: The type of cash declaration is in notes. 
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3. Enter the Amount in transaction currency to define the denomination of the 
cash. 

4. Select the Currency of the declaration amount from the drop-down list box. 

Income/expense account 

The Income/expense account setup defines how to track both income and expenses at 
the point of sale. All store income should be linked with income accounts and store 
expenses with expense accounts. 

To create cash declarations, follow these steps.  

1. Click Retail > Setup > Retail channels > Retail stores.  
2. Double-click and open the retail store to setup the income/expense account. 
3. Click the Setup FastTab from the top toolbar to view the retail store setup 

options. 

 

The Stores form provides easier option to copy the income/expense account from the 
existing stores to new stores. 

To copy the income/expense account from the existing store to the new store, follow 
these steps.  
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1. On the Setup FastTab, in the Copy group, click Income/expense account. 
2. Select the From store from the drop-down list box. 
3. The To store is defaulted to the current store. 
4. Click OK to confirm and copy the income/expense account from the existing 

store to the new retail store. 

 

After copying the income/expense account, the user can modify the values that 
are specific to the retail store. 

5. To modify the income/expense account, on the Setup FastTab, click 
Income/expense account. 

 

The Income/expense account form opens: 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

32 

 

 

 

General 

For the fields in the General area, in the Income/expense account for modifications, 
enter the following information. 

1. In the Identification area, enter the Account number when a new 
income/expense account is created. 

2. In the Description area, enter the Name of the account. 
3. Enter the Search name for the account. 
4. In the Account area, select the Account type from the drop-down list box. The 

options include the following: 

 Income: Specifies that the account type is an income account. 

 Expense: Specified that the account type is an expense account. 
5. In the Message lines area, enter information in the Message line 1. 
6. Enter information in the Message line 2. 
7. In the Slip text area, enter information in the Slip text 1. 
8. Enter information in the Slip text 2. 
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Posting 

In the Ledger account area, select the General Ledger account for posting. The Name 
field displays the name of the ledger account that is selected. 

 

Income/expense reason codes 

Reason codes can be assigned to the income/expense account so that cashiers can enter 
details or the staff member’s name that performed the income or expense operation. 

To associate a new reason code to the income/expense account, follow these steps. 

1. Click Reason codes on the top toolbar of the Income/expense form. The Reason 
codes form opens.  

2. Click New to associate a new reason code to the income/expense account. 
3. Select the Reason code number from the drop-down list box. 
4. The Prompt field will display the message that is associated with the reason code 

selected. The prompt message will be displayed to the cashier on the point of 
sale register when the income/expense account is selected. 

5. Check the Input required check box so that the cashier can provide information 
when the reason code is prompted on the point of sale terminal. 

6. Select When required to indicate when the reason code should be selected for 
the income/expense from the drop-down list box. The options include the 
following: 

 Always: Prompt for the reason code every time the income/expense 
account is used. 
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 Positive: Prompt for the reason code when the amount is positive and 
the income/expense is used. 

 Negative: Prompt for the reason code when the amount is negative and 
the income/expense account is used. 

7. Select the Sequence number for the reason code to indicate the sequence in 
which it should appear on the point of sale  terminal if multiple reason codes are 
associated with the income/expense account. 

 

Income/expense transactions 

To view income/expense transactions that are associated with the income/expense 
account, follow these steps.  

1. Click Transactions from the top toolbar on the Income/expense form. 
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The Transactions form opens.  

 

The Overview tab displays the transaction number, receipt number, account 
type, amount and transaction date and time. 

2. Click the General FastTab to view the transaction origin, shift details and 
statement information. 
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3. To view transaction details or reason code transactions, click Transactions on the 
right side of the Transactions form. 

Sections 

Sections and shelves represent the physical structure in each store. You can create the 
size of each section and assign retail items to different sections in each store. By doing 
this, the retail store can gather section-level sales statistics. 

To create sections, follow these steps.  

1. Click Retail > Setup > Retail channels > Retail stores.  
2. Double-click and open the retail store to setup the store sections. 
3. Click the Setup FastTab from the top toolbar to view the retail store setup 

options. 
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The Stores form provides an easier option to copy sections from existing stores to new 
stores.   

To copy sections from the existing store to the new store, follow these steps. 

1. On the Setup FastTab, in the Copy group click Sections. 
2. Select the From store from the drop-down list box. 

The To store is defaulted to the current store. 
3. Click OK to confirm and copy the sections from the existing store to the new 

retail store. 
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After copying the sections, the user can modify the values that are specific to the 
retail store. 

4. To modify the sections, on the Setup FastTab, in the Set up group, click Sections. 

 

The Sections form opens. 

 

For the Sections form, to enter information in the fields, follow these steps.   

1. The Name field will display the retail store name.  Click New on the top toolbar 
to create a new section for the retail store.  

2. Enter the Section number of the section for the retail store. 
3. Enter the Description of the section. 
4. Enter the Section size of the retail store. 
5. Select the Size unit of the section from the drop-down list box. For example,  the 

size unit can be in meters or centimeters. 
6. In the General area, enter the Last checked stock date to indicate when the last 

stock take is performed for the retail store. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

39 

 

In the Sales statistics area, the Totals fields will display the sales figures based on 
the products sold that belong the section. 
The Sold quantity field will display the total sold quantity of all the products sold 
that belong to the section. 
The Net amount field will display the total net amount of sales for the products 
that belong to the section. 
The Discount amount field will display the total discount amount for the 
products that belong to the section. 

Create Shelves 

To create shelves, follow these steps. 

1. Click Shelves on the top toolbar from the Sections form. The Shelves form 
opens. 

2. Click New to create a new shelf. 
3. In the Identification area, select the Store number from the drop-down list box. 
4. Select the Section number the shelf will belong to from the drop-down list box. 

 
5. Enter the Shelf number of the shelf. 
6. In the Description area, enter the Description of the shelf. 
7. In Shelf size area, enter the Section percent that is consumed by the shelf. 

 

Section product list 

To view products that are assigned to the sections, click Product list on the top toolbar 
from the Sections form. 
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The Product section location form opens. The form displays the item number, name and 
the shelf to which the product is allocated. 

 

Setup Distribution locations 

Distribution locations are used to define the application object server (AOS) connection 
profile that is created to communicate with the retail store. 

To create distribution locations, follow these steps. 

1. Click Retail > Setup > Retail channels > Retail stores.  
2. Double-click and open the retail store to setup the store sections. 
3. Click the Setup FastTab from the top toolbar to view the retail store setup 

options. 
4. On the Setup FastTab, in the Setup group, click Distribution locations. 

 

The Distributions locations form opens. 

1. Click New to create a new distribution location. 
2. Enter the Location number for the retail store. 
3. Enter the Description of the location for the retail store. 
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4. Select the retail Store from the drop-down list box. 
5. Select the Connection profile that is used to communicate with the retail store. 

 

After you create the distribution location, click Functions > Test connection to 
confirm that the connection profile can successfully establish a connection with the 
retail store. 

If the connection is successful, an Infolog message dialog box is displayed.  

 

Store Workers 
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Workers are cashiers and managers are assigned to a store. To view the list of workers, 
follow these steps. 

1. Click Retail > Setup > Retail channels > Retail stores.  
2. Double-click and open the retail store to setup the store sections. 
3. Click the Setup FastTab from the top toolbar to view the retail store setup 

options. 
4. On the Setup FastTab, in the Workers group, click Workers. 

This will open the Workers form. The Workers form displays the list of cashiers 
and managers that are assigned to the retail store. 

 

 

Store Work shifts 

To set up work the shift list for a retail store, follow these steps. 

1. Click Retail > Setup > Retail channels > Retail stores.  
2. Double-click and open the retail store to setup the store sections. 
3. Click the Setup FastTab from the top toolbar to view the retail store setup 

options. 
4. On the Setup FastTab, in the Workers group, click Work shift list. 

The Work shift list form opens. 

1. Click New to create a new work shift list. 
2. Enter the Shift date for the retail store. 
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3. Select the Work shift from the drop-down list box. A work shift consists of the 
start time and the end time for a shift that is assigned to specific retail stores. 

4. Enter the Description of the shift. 
The Starting time will be auto-populated from the work shift settings. 
The Ending time will be auto-populated from the work shift settings. 

 

 Note 

The Work shift table is not completely implemented in the current version of Microsoft 
Dynamics AX for Retail. The setting does not have any affect at the point of sale. 

20.2.3 MANAGE A RETAIL STORE 

After a retail store is setup, the store manager must perform certain actions. These 
actions include the following: 

 Assign price groups to the retail store. 

 Review the price list for the products that are assigned to the retail store. 

 Review assortments that are assigned to the retail store. 

 Review channel products that are assigned to the retail store. 

Assign price groups 

A price group is a list of items with specific pricing for specific customers. You can use 
price groups to offer an item at different prices to different groups of customers. 

To assign price groups, follow these steps. 

1. Click Retail > Setup > Retail channels > Retail stores.  
2. Double-click and open the retail store to setup the store sections. 
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3. Click the Store FastTab from the top toolbar to view the retail store setup 
options. 

4. On the Store FastTab, in the Pricing group, click Price groups. 

 

The Price groups form opens. 

To create a new price group, follow these steps. 

1. Click New to create a new price group. 
2. Select the retail Price groups from the drop-down list box. 

The Name field will display the name of the price group that is selected. 

 

View price list 
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The price list is used by store managers to review the recommended retail price (RRP) 
and the discounts that are currently offered on the products that are assigned to the 
retail store. 

To view the price list, follow these steps. 

1. Click Retail > Setup > Retail channels > Retail stores.  
2. Double-click and open the retail store to setup the store sections. 
3. Click the Store FastTab from the top toolbar to view the retail store setup 

options. 
4. On the Store FastTab, in the Pricing group, click Price list. 

 

The Price list form opens. The Price list form displays the following information: 

1. The Item number of the product that is currently carried by the retail store. 
2. The Price of the product that is the recommended retail price (RRP). 
3. The Price adjustments numbers that indicate the price discounts are currently 

active for the product at the retail store. 
4. The Discount offers numbers that indicate the promotions are currently active 

for the product at the retail store. 
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View store assortments 

An assortment is a collection of related items that a merchandising manager assigns to a 
retail store or retail channel. 

To view assortments, follow these steps. 

1. Click Retail > Setup > Retail channels > Retail stores.  
2. Double-click and open the retail store to setup the store sections. 
3. Click the Store FastTab from the top toolbar to view the retail store setup 

options. 
4. On the Store FastTab, in the Inventory group, click View assortments. 

 

The View assortments form opens. The View assortments form displays the list 
of assortments that are assigned to the retail store. 

 

View channel products 

The channel products are the list of products that are assigned to a retail store that use 
assortments. 

To view channel products, follow these steps. 

1. Click Retail > Setup > Retail channels > Retail stores.  
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2. Double-click and open the retail store to setup the store sections. 
3. Click the Store FastTab from the top toolbar to view the retail store setup 

options. 
4. On the Store FastTab, in the Inventory group, click View channel products. 

 

The Channel products form opens. The Channel products form lists the set of 
products that are assigned to the store that uses assortments. 

 

20.2.4 CREATE AN ONLINE STORE 

This section discusses the steps required to create a new online store.  

To create a new online store, follow these steps. 

1. Click Retail > Retail channels > Online stores. The Online store form opens. 
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2. To create a new online store, click Online store in the New group. The Online 
store form opens. 

General 

On the General FastTab, follow these steps. 

1. On the General FastTab, enter the Name of the online store. 
The Operating unit number gets populated automatically. Notice that the 
number sequence needs to be set for operating unit. 

2. Select the Company the online store will belong to from the drop-down list box. 
The current company where the store is being created will be set as the default. 

3. Select the default Warehouse from the drop-down list box. The drop-down list 
box is filtered to contain all the store warehouses that have the retail check box 
marked. 

4. Enter the Search name for the online store. 
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The Publishing status is automatically set to “Draft” while a new online store is 
being created. The online store must be published to be hosted on an  
e-commerce website. 
The Publishing status message displays the publishing status for the online 
store. 

5. In the Category hierarchy area, select the Category hierarchy from the drop-
down list box. The list displays the category hierarchy of type retail channel 
navigation hierarchy. 
In the Updates area, the Last updated field displays the date and time when the 
online store is updated. 

6. In the Orders area, select the primary Currency field from the drop-down list 
box. 

7. Select the Default customer for the online store from the drop-down list box. 
8. Select the Customer address book for the online store. 
9. In the Profiles area, select the Real-time Service profile from the drop-down list 

box. 
10. In the Sales tax area, check the Prices include sales tax if the product RRP price 

is inclusive of tax. 
11. In the Email notification area, select the Email notification profile that is used by 

the online store to send email notification to customers. 

 

Payment accounts 

To set up connectors, follow these steps. 

1. On the Channel FastTab, click Edit in the Maintain section on the top toolbar of 
the Online store form. 
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2. Select the Connectors from the drop-down list box. The connectors are available 
only in the United States and Canada in the current release. If the fields in the 
Details section differ according to the selected Connector, and if a user selects 
TestConnector, then enter the following information: 

a. Click Add to add the selected connector as a payment account for the 
online store. 
In the Details section the Assembly Name will display the name of the 
connector and the current version number. 

b. Enter the Service account ID for the payment connector. 
c. Enter the Merchant ID that is used by the payment connector. 
d. Enter the Provider ID for the selected payment connector.  
e. Enter the Supported Currencies that are allowed for transaction through 

the payment connector. Enter the currencies in a comma (;) separated 
list. 

f. Enter the Supported Tender Types that are supported by the payment 
connector. Enter the tender types in a comma (;) separated list. 

g. Enter the Test String to test the payment connector. 
h. Enter the Test Decimal amount to test the payment connector. 
i. Select a Test Date when the payment connector will be verified. 

 

3. If the user selects Dynamics Payment Connector, and then enter the following 
information: 
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a. Click Add to add the selected connector as a payment account for the 
online store. 
In the Details section, the Assembly Name will display the name of the 
connector and the current version number. 

b. Enter the Merchant account ID that is used by the payment connector. 
c. Enter the Service account ID for the payment connector. 
d. Enter the Microsoft account name for the selected payment connector.  
e. Enter the Microsoft account password for the selected payment 

connector. 
f. Enter the Environment name where the payment connector will be used. 

The Public key field displays the public key that is used to encrypt the 
information that is communicated by using the payment connector. 
The Portal URL displays the web link used to connect to the payment 
connector. 

g. Enter the Supported Currencies that are allowed for the transaction 
through the payment connector. Enter the currencies in a comma (;) 
separated list. 

h. Enter the Supported Tender Types that are supported by the payment 
connector. Enter the tender types in a comma (;) separated list. 
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Note 

Payment accounts are available only in the United States and Canada in the current 
release of Microsoft Dynamics AX 2012 R2 Retail. 
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Languages 

To add languages, follow these steps. 

1. Click Add to add languages that are supported by the online store. 
2. Select the Language from the drop-down list box. 

The Description field is auto-populated with the name of the language selected. 
3. Select the Default check box if you want the language to be the default language 

for the online store. 

 

Financial dimensions 

To use dimensions, follow these steps. 

1. In the Default financial dimensions area, select the ConstCenter dimension 
for the online store from the drop-down list box. 

2. Select the Department dimension for the online store from the drop-down 
list box. 

3. Select the ExpensePurpose dimension for the online store from the drop-
down list box. 

Setup a Retail store 

After you create a new online store, you must set up the following:  

 Modes of delivery 

 Payment methods 

 Cash declarations 

 Income and Expense account 

 Sections 
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 Distribution locations 

The follow section discusses the areas that are used to set up and configure the retail 
store related information. 

Set up Modes of delivery 

The modes of delivery defines the shipping carriers that are supported for the delivery 
of the online order. One of the modes available is customer pick-up. The customer can 
order online and pick-up from any store based on the stock availability. 

To assign modes of delivery, follow these steps. 

1. Click Retail > Setup > Retail channels > Online stores.  
2. Double-click and open the online store to setup the modes of delivery.  
3. Click the Setup FastTab from the top toolbar to view the modes of delivery that 

are assigned to the online store. 
4. Click Modes of delivery to open the Modes of delivery form. 
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5. Click Manage modes of delivery on the top toolbar to setup modes of delivery 
and assign channels to the delivery modes. 

The Modes of delivery form opens. 
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6. Click New to create a new mode of delivery or select and existing one to modify. 
7. Enter the Mode of delivery code for new records. 
8. Enter a Description for the new mode of delivery. 
9. Select a Charges group that applies to the mode of delivery from the drop-down 

list box. 
10. On the Setup FastTab, select the Service that is used for the mode of delivery. 

The options include the following: 
a. Miscellaneous: Select this service if the mode of transportation can be 

ground, air or pickup. 
b. Ground: Select this service if the mode of transportation is by ground. 
c. Air: Select this service if the mode of transportation is by air. 
d. Pickup: Select this service if the customer is going to pick up the ordered 

items. 
11. Select the Carrier ID from the drop-down list box for the mode of delivery. 

The Carrier Company is auto-populated with the name of the carrier company 
based on the carrier ID selection. 

12. Select the Account code of the carrier company from the drop-down list box. 
13. On the Retail channels FastTab, click Add line to assign online channels to the 

mode of delivery. The Choose organization nodes form opens. 
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14. Select the Organization hierarchy from the drop-down list box. 
15. Select the Available organization nodes to add to the mode of delivery. 
16. Click Add to select the organization nodes / online channels. 
17. Click Close to add the selected online channels to the mode of delivery. 
18. On the Products FastTab, click Add line to add a category or product / variant to 

be assigned to the mode of delivery. 
19. Select the Category from the drop-down list box. 

 

 
 

20. Select the Product that belongs to the category from the drop-down list box. 
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21. Select the Product variant if the selected product is a master product or leave 
the selection blank if all the variants need to be assigned to the mode of 
delivery. 
The Name field will display the description of the product / variant if it is 
selected. 

22. Select the Line type from the drop-down list box. The options include the 
following: 

a. Include: Include the category / product / variant and assign them to the 
mode of delivery. 

b. Exclude: Exclude the category / product / variant from using the selected 
mode of delivery. 

23. On the Addresses FastTab, click Add line to add a country, state and province 
that will be covered by the selected mode of delivery. 

24. Select the Country/region from the drop-down list box. 
25. Select the State/province from the drop-down list box. 
26. Select the Line type from the drop-down list box. The options include the 

following: 
a. Include: The mode of delivery that covers the country / state / province 

that is selected in the Addresses FastTab. 
b. Exclude: The mode of delivery that excludes the country / state / 

province that is selected in the Addresses FastTab. 

 

27. Close the Modes of delivery form to return to the Online store form. 

Setup payment methods 

Payment methods are the payment types that are received for goods and services that 
are sold in the online store. 

To assign payment methods to the online store, follow these steps. 
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1. Click Retail > Setup > Retail channels > Online stores.  
2. Double-click and open the retail store to setup the payment methods.  
3. Click the Setup FastTab from the top toolbar to view the retail store setup 

options. 

 

4. To modify the payment methods, on the Setup FastTab, in the Set up group, click 
Payment methods. 

 

The Payment methods form opens. 
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The fields in the payment methods that can be modified are described as follows:  

General 

To enter information in the General area, follow these steps. 

4. In the Identification area, if a new payment method is being created, select the 
Payment method type from the drop-down list box. 

5. Select the Terms of payment for the tender type from the drop-down list box. 
6. In the Description area, enter the Payment method name for the store tender 

type. 
In the Function area, the Function field of the tender type is auto-populated 
when a payment method is selected. This setting comes from the organization-
wide tender type and cannot be changed. 

Financial dimensions 

To enter information in the Financial dimensions area, follow these steps. 

8. In the Default financial dimensions area, select the CostCenter dimension for 
the payment method from the drop-down list box. 

9. Select the Department dimension for the payment method from the drop-down 
list box. 

10. Select the ExpensePurpose dimension for the payment method from the drop-
down list box.  
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Store locator group assignment 

Store locator group assignment is used to assign the list of stores that can be viewed for 
customer pick up during check out of online items. 

To assign the store locator group, follow these steps.  

1. Click Retail > Setup > Retail channels > Online stores.  
2. Double-click and open the online store to setup the store locator group. 
3. Click the Setup FastTab from the top toolbar to view the online store setup 

options. 

 

To assign, and or modify the store locator group assignment, follow these steps. 

1. On the Setup FastTab, in Set up group, click Store locator group assignment. 
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The Store locator group assignment form opens. 

 

2. Click New on the top toolbar to create a new store group locator assignment for 
the online store.  

3. Select the Locator group from the drop-down list box. 
The Description field will get auto-populated based on the locator group that is 
selected. 

Store locator groups 

Click Store locator groups on the top toolbar from the Store locator group assignment 
form. The Store locator groups form opens. 

To create a new store locator group, follow these steps. 

1. Click New to create a new store locator group. 
2. Enter the unique Name of the store locator group. 
3. Enter the Description of the store locator group. 
4. In the Setup FastTab, click Add to add the retail stores that are available to be 

selected for in-store pick-ups. 
5. Select the retail Store from the drop-down list box. 
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Setup Distribution locations 

Distribution locations are used to define the application object server (AOS) connection 
profile that is created to communicate with the retail store. 

To create distribution locations, follow these steps. 

1. Click Retail > Setup > Retail channels > Online stores.  
2. Double-click and open the online store to setup the store sections. 
3. Click the Setup FastTab from the top toolbar to view the online store setup 

options. 
4. On the Setup FastTab, in the Setup group, click Distribution locations. 

 

The Distributions locations form opens. 

6. Click New to create a new distribution location. 
7. Enter the Location number for the retail store. 
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8. Enter the Description of the location for the retail store. 
9. Select the Channel from the drop-down list box. 
10. On the General FastTab, in the Database profiles section, select the Profile 

name from the drop-down list box. 
11. On the Channel profile FastTab, select the Profile name from the drop-down list 

box. 
12. In the Data exchange FastTab, select the Retail channel schema from the drop-

down list box. 
13. Select the Send data check box to send the information from Microsoft 

Dynamics AX headquarters to the retail stores or to the online stores. 
14. Select the Receive data check box to receive the sales and inventory information 

from retail stores or from the online stores into Microsoft Dynamics AX 
headquarters. 

15. Select the Continuous data transfer schedule that will be used to communicate 
data changes from Microsoft Dynamics AX headquarters to retail stores or online 
stores. 

 

16. After you create the distribution location, click Functions > Test connection to 
confirm that the connection profile can successfully establish a connection with 
the retail store. 
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If the connection is successful, an Infolog message box is displayed. 

 

Channel attributes 

Attribute groups can be assigned to an online store to capture store specific information 
on the e-commerce website.  

To assign and view channel attributes, follow these steps. 

1. Click Retail > Setup > Retail channels > Online stores.  
2. Double-click and open the online store to setup the channel attributes. 
3. Click the Setup FastTab from the top toolbar to view the online store setup 

options. 
4. On the Setup FastTab, in the Attribute groups section, click Channel attributes.  

 

The Channel attribute groups form opens. 
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5. Click New to add an attribute group to the online channel. 
6. Select the Name of the attribute group from the drop-down list box. 

The Description field is auto-populated with the description of the attribute 
group that is selected from the drop-down list box. 

7. To view the attributes that are associated with the selected attribute group, 
select the attribute group and click View attributes on the top toolbar of the 
form. 
The Channel attribute values form opens. 

Note: The channel attributes will be available in the online database. However, the 
channel attributes require some development to display the attribute values on the e-
commerce website. 
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8. Close the forms to return to the Online store form. 

Channel product attributes 

Attribute groups can be assigned to products that are assigned to an online channel by 
creating catalogs.  

To assign and view channel product attributes, follow these steps. 

1. Click Retail > Setup > Retail channels > Online stores.  
2. Double-click and open the online store to setup the channel product attributes. 
3. Click the Setup FastTab from the top toolbar to view the online store setup 

options. 
4. On the Setup FastTab, in the Attribute groups section, click Channel product 

attributes. 

 

The Channel product attribute groups form opens. 
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5. Click New to add an attribute group to the online channel. 
6. Select the Name of the attribute group from the drop-down list box. 

The Description field is auto-populated with the description of the attribute 
group that is selected from the drop-down list box. 

7. Close the form to return to the Online store form. 

Note: The SharePointProvisionedProductAttributeGroup will be available as part of the 
source data for the customer to use as the default set of attributes for channel 
products. 

Sales order attributes 

Attribute groups can be used to provide additional information when sales orders are 
being created.  

To assign and view sales order attributes, follow these steps. 

1. Click Retail > Setup > Retail channels > Online stores.  
2. Double-click and open the online store to setup the sales order attributes. 
3. Click the Setup FastTab from the top toolbar to view the online store setup 

options. 
4. On the Setup FastTab, in the Attribute groups section, click Sales order 

attributes. 
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The Channel attribute groups form opens. 

 

5. Click New to add an attribute group to the online channel. 
6. Select the Name of the attribute group from the drop-down list box. 

The Description field is auto-populated with the description of the attribute 
group that is selected from the drop-down list box. 

7. Close the form to return to the Online store form. 

20.2.5 MANAGE THE ONLINE STORE 

After the online store is setup, the web manager must perform the following actions:   

 Publish an online store. 

 Assign price groups to the retail store. 

 Review price list for the products that are assigned to the retail store. 

 Create and manage catalogs for the online channel. 

 Review assortments that are assigned to the retail store. 
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 Review assortment products that are assigned to the retail store. 

 Review the listing of products that are assigned to the catalog and the publish 
status. 

Publish online store 

After setting up and configuring the online store, the online channel must be published 
so that the online channels can be hosted and made available on the e-commerce 
website. 

To publish the online channel, follow these steps. 

1. Click Retail > Setup > Retail channels > Online stores.  
2. Double-click and open the online store to setup the store sections. 
3. Click the Channel FastTab from the top toolbar to view the online store 

maintenance options. 
4. On the Channel FastTab, in the Publish group, click Publish. 

 

5. You will receive a message asking to confirm the publish action. Click Yes to 
publish the online channel. 

 

If the publish is successful, the Publishing status changes from “Draft” to “In progress” 
and the Publish button on the top toolbar is disabled. 

Note: You must run Create actions and Distribution schedule job A-1075_OC to publish 
the online channel.  
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Assign price groups 

A price group is a list of items with specific pricing for specific customers. You can use 
price groups to offer an item at different prices to different groups of customers. 

To assign price groups, follow these steps. 

1. Click Retail > Setup > Retail channels > Online stores.  
2. Double-click and open the online store to setup the price groups. 
3. Click the Channel FastTab from the top toolbar to view the online store 

maintenance options. 
4. On the Channel FastTab, in the Pricing group, click Price groups.  

 

The Retail channel price groups form opens. 

5. Click New to create a new price group. 
6. Select the retail Price groups from the drop-down list box. 

The Name field will display the name of the price group that is selected. 
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View price list 

The price list is used by web managers to review the recommended retail price (RRP). 
The price list is also used to review the discounts that are currently offered on the 
products that are assigned to the online store. 

To view the price list, follow these steps. 

1. Click Retail > Setup > Retail channels > Online stores.  
2. Double-click and open the online store to view the price list. 
3. Click the Channel FastTab from the top toolbar to view the online store 

maintenance options. 
4. On the Channel FastTab, in the Pricing group, click Price list. 
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The Price list form opens. 

5. Select the Date to view the price list. The following information is displayed: 

 The Item number of the product that is currently carried by the online 
store. 

 The Product name of the product. 

 The Currency in which the product is priced. 

 The Price of the product that is the recommended retail price (RRP). 

 The Price adjustments numbers that indicate that the price discounts are 
currently active for the product at the retail store. 

 The Discount offers numbers that indicate that the promotions are 
currently active for the product at the retail store. 

 

View and manage catalogs 

An online channel can have multiple catalogs in which products can be added to a 
catalog so the product can be available online or it can be removed from a catalog so it 
is unavailable. Catalogs are a good way to manage the standard and seasonal product 
listing for the online channel. 

To view and manage catalogs, follow these steps. 

1. Click Retail > Setup > Retail channels > Online stores.  
2. Double-click and open the online store to view and manage the catalogs. 
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3. Click the Channel FastTab from the top toolbar to view the online store 
maintenance options. 

4. On the Channel FastTab, in the Inventory group, click Catalogs. 

 

The Catalogs form opens. The Catalogs form displays the catalogs that are 
created for the online channel.  

 

 

View store assortments 

An assortment is a collection of related items that a merchandising manager assigns to 
the online channel. 
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To view assortments, follow these steps. 

1. Click Retail > Setup > Retail channels > Online stores.  
2. Double-click and open the online store to view assortments. 
3. Click the Channel FastTab from the top toolbar to view the online store 

maintenance options. 
4. On the Channel FastTab, in the Inventory group, click View assortments. 

 

The View assortments form opens. The View assortments form displays the list 
of assortments that are assigned to the online store. 

 

View channel products 

The channel products are the list of products that are assigned to an online store by 
using assortments. 
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To view channel products, follow these steps. 

1. Click Retail > Setup > Retail channels > Online stores.  
2. Double-click and open the online store to view the channel products. 
3. Click the Channel FastTab from the top toolbar to view the online store 

maintenance options. 
4. On the Channel FastTab, in the Inventory group, click View assortment 

products. 

 

The Assortment products form opens. The Assortment products form lists the 
set of products that are assigned to the store by using assortments. 

 

View listing status 

The listing provides information on the publish status of the catalogs and the products 
that are associated with the online channel.   

To view the listing status, follow these steps. 
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1. Click Retail > Setup > Retail channels > Online stores.  
2. Double-click and open the online store to view the channel products. 
3. Click the Channel FastTab from the top toolbar to view the online store 

maintenance options. 
4. On the Channel FastTab, in the Listings group, click Listings. 

 

The Listings form opens. 

 

5. Select the Listing status from the drop-down list box. The options include the 
following: 

a. Published: Select this option to view the published catalog and the 
associated products. 

b. Error: Select this option to view the catalog and the products that created 
an error and are not published to the website. For error items, Listing 
status details on the top toolbar will be activated to view additional error 
information. 

c. In progress: Select this option to view the catalog and the products that 
are in progress to be published. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

78 

 

The grid displays the Catalog name, Product ID, Dimension number, 
Effective date, Expiration, Requested listing action, Listing status and 
the Channel list ID. 
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CATALOGS 

OVERVIEW 

This module describes how catalogs are created to associate products to an online 
channel. Multiple catalogs can be created and managed to define the standard and 
seasonal product ranges that are available on the e-commerce website. 

 CATALOGS 

A catalog manager can create product catalogs and categorization schemes that can be 
targeted or shared between channels. 

Attribution can be defined per channel to support product enrichment that is specific to 
the needs to individual channels. 

Catalogs can be validated, by using Microsoft Dynamics AX workflow, published, and 
synchronized with target channels. 

In this section we address the following areas: 

 Creation of a catalog 

 Modification of a catalog 

 Catalog validation 

 Catalog approval 

 Publishing a catalog 

 Maintaining a catalog 

20.3.1 CREATE A CATALOG 

A catalog can be created by using one of the following options: 

 Manually create catalog 

 Copy another catalog 

To create a new catalog click Retail > Common > Catalogs > Catalogs.  The Catalogs 
form opens. 

1. Click New on the top tool bar to create a new catalog. 
2. Enter the Catalog name for the new catalog. 
3. Enter the Description for the catalog. 
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4. Click Ok to create a new catalog. The newly created catalog form opens. 

 

5. Select the Owner from the drop-down list who will be managing the catalog. 
6. The Status field will be Draft as it’s a new catalog. 
7. Select the Effective date for the catalog to be active on the online store front. 
8. Select the Expiration date for the catalog to be pulled back from the online store 

front. 
9. The Last published date will display the date when it was last published. 
10. The Last modified date will display the date when it was last modified. 
11. Under the Retail channels section click Add to add online channels to the 

catalog. 
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12. Select the Organization hierarchy from the drop-down list. 
13. Select the online stores from the Available organization nodes and click Add  to 

add them to the Selected organization nodes. 
14. Click Close to return to the catalog form. 

 

15. The left hand navigation is automatically populated with the navigation 
hierarchy being assigned to the online channel when selected. 

16. An alternative method is to copy an existing catalog. 
17. Select the catalog from the list, and click Copy from the Maintain section of the 

Catalogs tab. 
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18. The catalog form opens with the copy of the information from the selected 
catalog. 

 

19. Refer to step 4 to populate the information and create a new catalog. 

20.3.2 MODIFY A CATALOG 

To modify a catalog click Retail > Common > Catalogs > Catalogs.  The Catalogs form 
opens. 

Select the catalog to open it from the list and double-click to open. 

Click Edit to modify the catalog. 
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20.3.2.1 ADD PRODUCTS 

To add products to the catalog, click Add products from the Products section in the 
Catalogs tab. 

 

1. The Add products form opens. 
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2. Select the Retail channel filter for which the products are being added. 
3. Select the Assortment filter to display the products belonging to the selected 

assortment. 
4. Select the Retail product category to filter the products by category grouping. 
5. Under the Available products section, select the products that you want to add 

to the catalog for the selected channel. 
6. Click Add to add the selected products into the Add selected products section.  
7. Click OK  to confirm the product selection. 

The next step is to categorize the products if any uncategorized ones exist in the catalog. 

8. Select the Uncategorized node from the category hierarchy for the selected 
channel. 

 

9. The form on the right-hand side displays the uncategorized products. 
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10. Click Categorize products to assign the selected products to a category. The 
Deploy initial dataset form opens. 

 

11. Select the category node from the Available categories section. Click Add  to add 
the selected nodes to the Selected categories section. 

12. Click OK  to update the product categorization. 

20.3.2.2 REMOVE PRODUCTS 

1. Click Remove products from the Products section in the Catalogs tab for the 
selected channel. 
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2. The Remove products form opens. 

 

3. Select the product by selecting the check box next to the products. 
4. Click OK to confirm and remove the products from the catalog assigned to the 

selected channel. 
5. A message confirms the removal of the products from the catalog. Click Yes to 

confirm the action. 

 

20.3.2.3 MANAGE ATTRIBUTE VALUES 

1. Select the channel and the product category hierarchy node for which products 
have been assigned. 
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2. The right-hand form changes to display the list of products that belong to the 
selected category. 

 

3. Select the product from the list, and click Attributes  under the Products FastTab 
area. 

4. The Product attribute values form opens. The form opens in Show details mode. 

Note: The attribute listing is determined by the attribute groups assigned to the 
navigation category, product attributes and channel product attributes. 
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5. Click the Show list to view the attributes in the list mode. 
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6. Click the individual attribute and, if permitted based on the Attribute source 
type, enter the Value for the attribute. 

7. Click Close to confirm the changes. 

Note: Few of the attributes are picked from the product setting, which can be over-
ridden at the channel level. 

8. An alternative method to assign attributes to the products by channel is through 
Excel edits. Select the products from the list, and click Edit in Excel  on the List 
section of the Catalogs tab. 
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9. The product and associated attributes opens in an Excel sheet. 

 

10. Through Excel, the user can filter on the product number, attribute name and 
modify the Text column to assign values to the attribute based on type. To 
publish back changes to the catalog, click the Microsoft Dynamics AX tab on the 
Excel sheet. 

 

11. Click Publish > Publish All to publish the changes to the catalog for the selected 
products. 
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12. To view listing information for the products, select the product from the list and 
click Listings  from the Products FastTab area. The Listings form opens. 

 

13. The Listings form displays the channel the product belongs to and the listing 
information derived from the catalog and publish status. 

 

 

20.3.3 VALIDATE A CATALOG 

To validate a catalog, click Retail > Common > Catalogs > Catalogs.  The Catalogs form 
opens. 

Select the catalog to open from the list and double-click to open. 

1. Click Validate catalog under the Publish section of the Catalog tab. 
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2. The Validate catalog form opens. Click Validate catalog on the top tool bar to 
start the validation process. 

 

3. The validation process displays results in three different sections. 
4. The channel summary section appears if the channel associated with the catalog 

is published.  
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Otherwise, an error message is displayed as below. 

 

5. Under the Product summary section, select the Channel from the drop-down 
list. 

6. The Products with alerts displays the errors and warning messages associated 
with products. For example, an alert appears when a product is not associated 
with a navigation hierarchy. 
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7. Click Close to close the form. 

20.3.4 CATALOG APPROVAL 

To validate a catalog, click Retail > Common > Catalogs > Catalogs.  The Catalogs form 
opens. 

Select the catalog to open from the list, and double-click to open. 
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1. Click Submit  with a heading Retail catalog approval workflow. 

 

2. On submitting the workflow, the catalog workflow changes as below. 

 

3. The nominated user or users assigned to a role receives notification on the 
pending approvals. Once approved, the catalog status changes to approved. 
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20.3.5 PUBLISH A CATALOG 

To publish a catalog, click Retail > Common > Catalogs > Catalogs.  The Catalogs form 
opens. 

Select the catalog to open from the list, and double-click to open. 

 

1. Click Publish from the Publish section of the Catalogs area. 

 

2. The Publish catalog form opens. 
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3. Select the Publish option from the drop-down list. The following options are 
available: 

a. Only products that have changed: Select this option if you have modified 
an existing catalog and want to publish just the changes. Note: We 
recommend that you use this option to save time if only changes must be 
published. 

b. All products: Select this option if you are publishing a new catalog. 
4. Notice that the Product totals by channel section displays the number of 

products added, updated, or deleted from the catalog by channel. 
5. Notice that the Validation summary appears if all the products were successfully 

validated. 
6. Click View full report  to view the Validate catalog form. 
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7. Click Close to close the form. 
8. Click OK on the Publish catalog form to run the Retail catalog publishing job. 
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9. Click OK to confirm and publish the catalog. 
10. The catalog status changes to published as shown below. 

 

 

20.3.6 MAINTAIN A CATALOG 

To manage a catalog, click Retail > Common > Catalogs > Catalogs.  The Catalogs form 
opens. 

Select the catalog to open from the list, and double-click to open. 

 

20.3.6.1 RETRACT A CATALOG 

1. To retract a catalog, click Retract from the Publish section of the Catalogs tab. 
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2. A confirmation message appears. Click Yes to confirm the retract process. 

 

3. The status of the catalog changes to Retracted as shown below. 

 

20.3.6.2 INACTIVATE A CATALOG 

1. To inactivate a catalog, click Inactivate from the Publish section of the Catalogs 
tab. 

 

2. The status of the catalog is set to Inactive as shown below. 
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Note: A catalog can be set to inactive only when the catalog is in Draft mode. 

20.3.6.3 ACTIVATE A CATALOG 

3. To activate a catalog, click Activate from the Publish section of the Catalogs tab. 

 

4. The status of the catalog is set to Draft as shown below. 
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PRODUCTS 

OVERVIEW 

This module explains why products must be created and configured in Microsoft 
Dynamics AX before they can be made available for resale at the retail channels. 

Microsoft Dynamics AX for Retail uses the product features in Microsoft Dynamics AX 
core to do the following: 

 Create organization-wide products in a product master. 

 Define the product properties and attributes, and assign the product to retail 
category hierarchies. 

 Release the products to the legal entities to make them available to retail channels 
and add them to active assortments. 

 PRODUCTS BY CATEGORY 

The products by category are an extension to the products features with products 
filtered by retail categories. 

As a prerequisite to managing products by category, complete the following tasks: 

 Define a retail product hierarchy. By using the category hierarchy features in 
Microsoft Dynamics AX, the merchandising manager can assign retail category 
hierarchies to group and categorize the products that get distributed to the retail 
channels.  

 Define user and system attributes at the category level. Then, all products that 
are assigned to the category inherit those attributes.  

 Define multiple category hierarchies. Then, each product can be assigned to 
multiple hierarchies. However, in a single hierarchy, each product can be 
assigned to only one category. 

To view products by category, click Retail > Common > Products > Products by 
category. 

The Product details form opens. 
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The Category hierarchy section in the diagram above provides a list of retail hierarchies 
available in the system. From the drop-down list, the user can select a retail hierarchy 
and the associated categories are displayed on the form. 

20.4.1 CREATE A PRODUCT 

To create a new product under a specific category, select the category from the left-
hand category hierarchies list and click Product from the New group of the Product tab. 

 

The New product form opens. 
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1. In the Create product area, select the Product type from the drop-down list. 
The options available are as follows: 

 Item: A product type of item represents a physical item that requires 
inventory control. So a product is a tangible item. 

 Service: A product type of service represents a service or offering 
provided by the retail business and does not require inventory control. 

2. Select a Product subtype from the drop-down list. The options available are as 
follows: 

 Product: A product is a master product with no variants attached. 

 Product master: A product master has variants of size, color, and 
configuration. 

Select Product as the product type. 

3. In the Identification area, enter the Product number or the product number 
will be auto populated if a number sequence is associated to be auto 
generated. 

4. Enter the Product name. 
5. Enter the Search name for the product. 
6. Select the Retail Category for the product from the drop-down list. 
7. In the Catch weight area, select the CW product check box to indicate the 

product is a weighted product. 
8. Click OK to create a new product. 
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20.4.2 ASSIGN DIMENSION GROUPS 

Select the product newly created from the Products by category form. Now double-click 
the product to open the Product details form. 

On the Product details form, click Dimension groups on the Set up group from the 
Product tab. 

 

From the drop-down list, enter the following details. 

1. Select the Storage dimension group from the drop-down list. The storage 
dimension defines the site and warehouse information for the product. 
 

2. Select the Tracking dimension group from the drop-down list. The tracking 
dimension defines the batch number or the serial number for the product. 

 

20.4.3 ASSIGN PRODUCT CATEGORIES 

Select the product newly created from the Products by category form. Now double-click 
the product to open the Product details form. 

On the Product details form, click Product categories on the Set up group from the 
Product tab. 
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The Product categories form opens. 

1. Click New to assign a new category. 
2. Select the Category hierarchy from the drop-down list that contains both 

standard and supplementary retail hierarchies. 
3. Select the Category from the drop-down list that belongs to the category 

hierarchy selected. 

 

20.4.4 ASSIGN PRODUCT ATTRIBUTES 

Product attributes are attributes assigned to a category. When a product is created and 
assigned a retail product category, the attributes associated with the category are 
inherited by the product.  
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To view product attributes associated with the product, click Product attributes on the 
Set up group of the Product tab. 

 

The Product attribute values form opens and displays a list of attributes and the default 
value associated with the product. 

The values can be modified for each attribute to suit the product. 

 

Under the General tab, select the Value of the attribute for the product from the drop-
down list. 

20.4.5 ASSIGN PRODUCT IMAGES 

Select the product newly created from the Products by category form. Now double-click 
the product to open the Product details form. 

On the product details form, click Product image on the Set up group from the Product 
tab. 
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The Product image form opens. 

1. Click New to assign a new image to the product. 
 

2. Select the Type of document from the drop-down list. The options to choose 
from are as follows: 

 Document: Generates a Microsoft Word document file to hold the 
medium-sized and thumbnail images. 

 File: Allows the user to associate an image or a file with the retail 
product. 

 Note: Allows an extended description for the product in the Description 
field. 

 URL: Links the product image or documentation that is specified in the 
Description field. 

3. Depending on the Type selected, enter relevant information in the Description 
field. 

4. Select the Media usage from the drop-down list. This indicates whether the 
image or document attached is used internally or available externally. 

5. Select the Default image check box to indicate the image attached is the 
default image for the retail product. 

 

 Note 
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As a part of the setup process, you must set up the default document archive 
directory in the Document management parameters form. To set up the archive 
directory, follow these steps: 

1. Click Organization administration > Setup > Document management > 
Document management parameters.  

2. In the General area of the form, in the Archive directory field, enter the path 
to the archive directory.  

3.  Click Number sequences, and then select the ID reference.  
4.  In the Number sequence code field, select the number sequence code to use 

for naming the documents. 

20.4.6 ASSIGN RELATED PRODUCTS 

Select the product newly created from the Products by category form. Now double-click 
the product to open the Product details form. 

On the product details form, click Related products on the Set up group from the 
Product tab. 

 

The Related products form opens. 

1. Click New to create a new related product. 
2. Select the Product number from the retail product list.  
3. Notice the Product name displays the name of the product that has been 

selected. 
4. Select the Relation type from the drop-down list. The Product relationship 

types can be created and maintained by the merchandising team to assign 
meaningful relationships between retail products. 
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20.4.7 ASSIGN UNIT CONVERSIONS 

Select the product newly created from the Products by category form. Now double-click 
the product to open the Product details form. 

On the product details form, click Unit conversions on the Set up group from the 
Product tab. 

 

The Unit conversions form opens. 

1. Click New to create a new unit conversion. By default, the Product field 
displays the product number selected to assign the unit conversion. 

2. Enter the Factor by which the unit conversion is going to be calculated. For 
example, a box is 24 of each. 

3. Select the From unit from the drop-down list. 
4. Select the To unit from the drop-down list. 
5. Click Close to close the form after all the unit conversions are defined. 
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20.4.8 PRODUCT TRANSLATIONS 

Select the product newly created from the products by category form. Now double-click 
the product to open the Product details form. 

On the product details form, click Transactions on the Languages group from the 
Product tab. 

 

The Text transaction form opens. 

1. Select the Language from the drop-down list. To add additional languages, 
click the plus sign (+) drop-down list to view a list of languages supported by 
the system. 

2. Enter the translated text in the Description field.  
3. Enter the Product name in the language selected. 
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20.4.9 RELEASE PRODUCTS 

To release products to the legal entities, select the product newly created from the 
Products by category form. Now double-click the product to open the Product details 
form. 

On the product details form, click Release products on the Product authorization group 
from the Product tab. 

 

 

The Release products form opens. 

1. In the Select products area in the form select the product in the grid to include 
releasing it to a legal entity. Click Add button on the top to add additional 
products to the list. 
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2. In the Select companies area of the form select the legal entities that will be 
authorized to use the retail product. 

 

3. Click OK to confirm and release the retail products to the legal entities 
selected. A release session batch form opens displaying the selected products 
and companies. 

 

4. Click OK to confirm. 
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20.4.10 CREATE PRODUCT MASTER 

To create a new product master under a specific category, select the category from the 
left-hand category hierarchies list and click Product from the New group of the Product 
tab. 

 

The New product form opens. 

1. In the Create product area, select the Product type from the drop-down list. 
The options available are as follows: 

 Item: A product type of item represents a physical item that requires 
inventory control. So product is a tangible item. 

 Service: A product type of service represents a service or offering 
provided by the retail business and doesn’t require inventory control. 

2. Select a Product subtype from the drop-down list. The options available are as 
follows: 

 Product: A product is a master product with no variants attached. 

 Product master: A product master has variants of size, color and 
configuration. 

Select Product master as the product type. 

3. In the Identification area, enter the Product number or the product number 
will be auto populated if a number sequence is associated to be auto 
generated. 

4. Enter the Product name. 
5. Enter the Search name for the product. 
6. Select the Retail Category for the product from the drop-down list. 
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7. In the Product variants area select the Product dimension group from the 
drop-down list. The product dimension group defines what variants will be 
used to define the product, for example, size, color, or just color. 

8. In the Catch weight area select the CW product check box to indicate the 
product is a weighted product. 

9. Click OK to create a new product. 
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20.4.11 ASSIGN PRODUCT DIMENSIONS 

Select the product master newly created from the products by category form. Now 
double-click the product to open the Product details form. 

On the product details form, click Product dimensions on the Product master group 
from the Product tab. 

 

The Product dimensions form opens.  Depending on the product dimension group 
selected, the form will only display the dimension part of the selected dimension group. 
For example, if size and color was selected as the product dimension group, then only 
size and color are listed in the Product dimensions form. 

1. In the Colors area of the form, click New to create color variants. 
2. Select the Color variant from the drop-down list. 
3. Enter the Name of the color variant. 
4. Enter a Replenishment weight if the retail product is a weighted item. 
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5. In the Styles area of the form, click New to create styles. 
6. Select a Style from the drop-down list. 
7. Enter the Name of the style variant for the retail product. 
8. Enter a Weight if the retail product is a weighted item. 
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9. Click Close to close the form. 
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20.4.12 CREATE PRODUCT VARIANTS 

Select the product master newly created from the Products by category form. Now 
double-click the product to open the Product details form. 

On the product details form, click Product variants on the Product master group from 
the Product tab. 

 

The Product variants form opens. The Product variant form displays the weight 
associated with each dimension value. The total weight field displays the sum of all the 
weights of the dimensions associated with the product. 

Click Variant suggestions from the top tool bar. 

 

The Variant suggestions form opens and displays all the combinations available based 
on the product dimension created. 
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As shown in the screen above, the product master contains two colors and two styles. 
So a total of four product combinations is suggested. 

Click Create to create the product variants. The products will be created and listed in the 
Product variants form. 

 

Close the form after you review the product variants. 
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20.4.13 RELEASE PRODUCT MASTER AND VARIANTS 

To release product master and variants to the legal entities, select the product newly 
created from the Products by category form. Now double-click the product to open the 
Product details form. 

On the Product details form, click Release products on the Product authorization group 
from the Product tab. 

 

The Release products form opens. 

1. In the Select products area in the form, select the product in the grid to 
include releasing it to a legal entity. Click Add on the top to add more products 
to the list. On the right-hand side of the form, the product variants related to 
the product master are automatically selected. 
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2. In the Select companies’ area of the form, select the legal entities that will be 
authorized to use the retail product. 

 

3. Click OK to confirm and release the retail products to the legal entities 
selected. A release session batch form opens, displaying the selected products 
and companies. 
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4. Click OK to confirm. 
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 RELEASED PRODUCTS BY CATEGORY 

The Released products by category are an extension to the Released products features 
with products filtered by retail categories. 

As a prerequisite to managing products by category, complete the following tasks: 

 Define a retail product hierarchy. By using the category hierarchy features in 
Microsoft Dynamics AX, the merchandising manager can define retail category 
hierarchies to group and categorize the products that get distributed to the retail 
channels.  

 Define user and system attributes at the category level. Then, all products that 
are assigned to the category inherit those attributes.  

 Define multiple category hierarchies, and then each product can be assigned to 
multiple hierarchies. However, in a single hierarchy, each product can be 
assigned to only one category. 

To view Released products by category click Retail > Common > Products > Released 
products by category. 

The Released product details form opens. 

Click the Retail tab to view the retail set up and functions available for the retail 
products. 

 

 

20.5.1 RETAIL-SPECIFIC PRODUCT DETAILS 

Select the product newly created from the Products by category form that has been 
released. Now double-click the product to open the Released products by category 
details form. 

Note 

The item must be an item of product subtype Product Master as these are the type of 
items that the specifics are set up on. 

The Released product details form opens. 
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Open the Retail FastTab. 

1. In the Variant area, select the Color group for the retail product. If the product is 
not a variant product then the Color group is disabled. 

2. Select the Size group for the retail product. If the product is not a variant product, 
then the Size group is disabled. 

3. Select the Style group for the retail product. If the product us not a variant, then the 
Style group is disabled. 

4. Select the Print variants shelf label check box to print one shelf label per variant. For 
example, if you have an item that comes in two colors and two sizes, you print four 
labels, one for each combination. Clear this check box to print one label for the item, 
regardless of variants. 

5. In the Comparison price, select the Base comparison unit from the drop-down list. 
Price comparison can be done for items of different brands or packaging based on a 
base comparison unit of measure, for example, price per ounce. This price can also 
appear on shelf and item labels.  It can be automatically calculated, based on the 
base comparison unit and its unit conversion. 

Note 

Units of measure and unit conversions must have been set up previously in Microsoft 
Dynamics AX. 

6. In the Blocking area, select the Blocked at register check box to block the product 
from being sold at the retail channels. 

7. By default, the Date blocked will automatically display the current system date. 
Enter the Date to be blocked to block an item in the future date. 

8. In the Bar code area, select the Bar code setup format from the drop-down list. 
Retail items can be represented by one or more bar codes. Multiple bar codes are 
essential if the same item comes from different manufacturers or suppliers, or if the 
item has different size, style, or color variants. 

9. Notice the Bar code field displays the bar code that has been marked Show for 
product in the Item – Bar codes form. 

10. In the Activation area, select the Issue date to indicate when a blocked item will be 
activated. 

11. In the Product life cycle area, select the Season information from the drop-down 
list. 

12. Enter the Valid from date for the start date of the season. 
13. Enter the Valid to date for the end date of the season. 
14. In the POS register area, select the Scale product check box to indicate the product 

item is a scale item. Scale items will be measured on a weighing scale at the register 
before sale. The weight unit of measure must be set as a weight-type of measure.  
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15. Select the Keying in price for the retail product from the drop-down list. The options 
available are as follows: 

 Not mandatory:  The price key in is not mandatory at the register. 

 Must key in new price: The new price for the retail product should be keyed in 
at the register. 

 Must key in higher/equal price: A price higher or equal to the recommended 
retail price should be keyed in at the register. 

 Must key in lower/equal price: A price lower or equal to the recommended 
retail price should be keyed in at the register. 

 Must not key in price: The price must not be keyed in at the register. 
16. Select the Keying in quantity for the retail product from the drop-down list. The 

options available are as follows: 

 Not mandatory: The quantity key is not mandatory at the register. 

 Must key in quantity: The quantity for the retail product should be keyed in at 
the register. 

 Must not key in quantity: The quantity must not be keyed in at the register. 
17. Select the Must key in comment check box to require the cashier to enter item 

comments at the terminal. 
18. Select the Zero price valid check box, to allow products to be sold at zero pricing. 
19. Select the Quantity becomes negative check box to indicate the product quantity 

can be negative. 
20. Select the No discount allowed check box to limit cashiers from providing discounts 

on the product. 
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20.5.2 SET UP REASON CODES 

Select the product from the Released products by category form. Now double-click the 
product to open the Released product details form. 

On the product details form, click Reason codes on the Set up group from the Retail 
tab. 

 

The Reason codes form opens. 

6. Click New to associate a new reason code to the retail product. 
7. Select the Reason code number from the drop-down list. 
8. The Prompt field will display the message associated with the reason code 

selected. The prompt message will be displayed to the cashier on the Point of 
Sale (POS) when the retail product is selected in a sales transaction. 

9. Select the Input required check box to require the cashier to provide input when 
the reason code is prompted on the Point of Sale (POS) terminal. 
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10. Select When required to indicate that the reason code should be selected for 
the retail product from the drop-down list. The options available are as follows: 

 Always: Prompt for the reason code every time the retail product is used. 

 Positive: Use for specific reason codes where a threshold triggers the 
reason code based on the value specified. 

 Negative: Use for specific reason codes where a threshold triggers the 
reason code based on the valued specified. 

11. Select the Sequence number for the reason code to indicate the sequence in 
which it should appear on the Point of Sale (POS) terminal if multiple reason 
codes are associated with the retail product. 

 

20.5.3 SET UP SHELF LABEL 

Select the product from the Released products by category form. Now double-click the 
product to open the Released product details form. 

On the product details form, click Shelf label on the Set up group from the Retail tab. 

 

The Shelf label report setup form opens. 

1. Click New to create a set up a new shelf label report. 
2. Select the Report name from the drop-down list. 
3. Select the Text 1 is product description check box to confirm the text on the 

shelf label will be printed with a product description. 
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4. If the Text 1 is product description check box is selected, then the Text 1 field 
will be is populated with the product description. If not, enter a description to 
print on the shelf label. 

5. Enter information on Text 2 to be printed on the shelf label. 
6. Select the Distribution group for the shelf label from the drop-down list. 
7. Select the Distribution subgroup for the shelf label from the drop-down list. 
8. Click Close to close the form. 

 

20.5.4 SET UP A PRODUCT LABEL 

Select the product from the Released products by category form. Now double-click the 
product to open the Released product details form. 

On the product details form, click Product label on the Set up group from the Retail tab. 

 

The Product label report setup form opens. 

1. Click New to create a set up a new product label report. 
2. Select the Report name from the drop-down list. 
3. Select the Text 1 is product description check box to confirm the text on the 

product label will be printed with product description. 
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4. If the Text 1 is product description check box is selected then the Text 1 field will 
be populated with the product description. If not, enter a description to print on 
the product label. 

5. Enter information on Text 2 to be printed on the product label. 
6. Select the Distribution group for the shelf label from the drop-down list. 
7. Select the Distribution subgroup for the shelf label from the drop-down list. 
8. Click Close to close the form. 
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20.5.5 SET UP LINKED PRODUCTS 

Select the product from the Released products by category form. Now double-click the 
product to open the Released product details form. 

On the product details form, click Linked Product on the Set up group from the Retail 
tab. 

 

The Linked products form opens. 

1. Click New to create a new linked product. 
2. Select the Unit of measure of the linked product from the drop-down list. 
3. Select the Linked product number from the drop-down list. The Product name 

field is populated by the selected product. 
4. Enter the Quantity of the product that links to the retail item. 
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20.5.6 VIEW LINKED PRODUCTS 

Select the product from the Released products by category form. Now double-click the 
product to open the Released product details form. 

On the product details form, click Where-linked products on the Set up group from the 
Retail tab. 

 

The where-linked products form opens.  

The form displays the products that are linked to the retail item. 
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20.5.7 SET UP A PRODUCT SECTION LOCATION 

Select the product from the Released products by category form. Now double-click the 
product to open the Released product details form. 

On the product details form, click Product section location on the Set up group from the 
Retail tab.  

 

The Product section location form opens. 

1. Click New to create a new product section for the retail item. 
2. Select the Store number from the drop-down list.  
3. Select the Section number from the drop-down list. The Name field is populated 

with the section name based on the selection. 
4. Select the Shelf number from the drop-down list. The Name field is populated 

with the shelf name based on the selection. 
T
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5. Check the ShShow sales statistics check box to display sales statistics on the 
retail product. 
 

 Note 
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The Show sales statistics field is not implemented in the current version of Microsoft 
Dynamics AX for Retail. 

20.5.8 PRINT A SHELF LABEL 

Select the product from the Released products by category form. Now double-click the 
product to open the Released Product details form. 

On the product details form, click Print specific shelf label on the Functions group from 
the Retail tab.  

 

The Print specific shelf label form opens. 

1. Notice the following:  

 The Item number is populated based on the selected retail item. 

 The Store number is populated based on distribution group selection in 
the shelf label set up section. 

 The Variant number is populated if the retail item selected is a variant 
item. 

2. Select the Unit of measure from the drop-down list. 
3. Enter the Label valid on date to specify the date when the label can be used at 

the stores. 
4. Enter the Quantity to be printed on the shelf label. 
5. Select the Report name from the drop-down list, specifying the format of the 

shelf label to be printed. 
6. Notice the following: 

 The Description field is populated by the product description selected. 

 The Description field is a second text field available to enter information 
required to be printed on the shelf label. 

7. Click OK to confirm and print the shelf label. 
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20.5.9 PRINT A PRODUCT LABEL 

Select the product from the Released products by category form. Now double-click the 
product to open the Released product details form. 

On the product details form, click Print specific product label on the Functions group 
from the Retail tab.  

 

The Print specific product label form opens. 

1. Notice the following: 

 The Item number is populated based on the selected retail item. 

 The Store number is populated based on the distribution group selection in 
the product label set up section. 

 The Variant number is populated if the retail item selected is a variant item. 
2. Select the Unit of measure from the drop-down list. 
3. Enter the Label valid on date to specify the date when the label can be used at 

the stores. 
4. Enter the Quantity to be printed on the product label. 
5. Select the Report name from the drop-down list specifying the format of the 

product label to be printed. 

 The Description field will be populated with the product description selected. 
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 The Description field is a second text field available for entering information 
that must be printed on the product label. 

6. Click OK to confirm and print the product label. 

 

20.5.10 MANDATORY CHECK SETUP 

Mandatory check setup is used to define additional fields as for retail products to be 
mandatory or have default values depending on the retail business requirements. 

On the product details form, click Mandatory check setup on the Functions group from 
the Retail tab.  

 

The Mandatory check setup form opens. 

1. Click New to create a new mandatory check record. 

2. Select the Field number from the drop-down list. A window appears with a field 
listing for the retail product. Select a field from the list. 
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3. Note the Field name is automatically populated with the name of the field 
selected. 

4. Select the Check for option from the drop-down list. The option available are as 
follows: 

 Blank: Check if the field selected is blank and has no value assigned. 

 Not blank: Check if the field selected has a value and is not blank. 

 Zero: Check if the field selected has a value of zero assigned. 

 Not zero: Check if the field selected has a value other than zero assigned. 

 Constant: Check if the field selected has a constant value as specified in 
the value field. 

 One of: Check if the field selected has a specific value specified in the 
value field. 

5. Enter whether the Value of the check for selection is a constant or one of the 
values specified in the field. 

6. Click Close to close the form. 
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20.5.11 CHECK PRODUCT 

The Check product function is used to check if the retail product meets all the 
mandatory check settings and validates that they have been set up properly. 

Select the product from the Released products by category form.  

On the Released product details form, click Check product on the Functions group from 
the Retail tab.  

 

The function checks for all mandatory settings and displays confirmation or warning 
messages with specific details as shown in the following figure: 
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20.5.12 BUYERS PUSH 

The Buyers push function is used to generate a store transfer or blast stock from 
warehouse to multiple stores for a selected retail item. 

Select the product from the Released products by category form.  

On the Released product details form, click Buyer’s push on the Functions group from 
the Retail tab.  

 

The buyers push form opens with the selected retail item added to the list and ready to 
be distributed to the retail stores.  Click Calculate to apply the replenishment rule or 
mange the distribution manually. 
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20.5.13 INQUIRE COMPETITOR PRICES 

Select the product from the Released products by category form.  

On the Released product details form, click Competitor prices on the Inquires group 
from the Retail tab.  

 

The Competitor prices form opens. 

1. Select the retail Item number from the drop-down list. By default, the item 
number is that of the selected item. 

2. Notice the Product name field is populated based on the retail item selected. 

3. Select the Competitor group from the drop-down list. 

4. Enter the Price offered by the competitor for the retail product. 

5. Enter the Last checked date for the price of the retail product. 
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6. In the General area, enter the Date of price when the price of the retail product 
was first entered. 

 

20.5.14 INQUIRE SALES TRANSACTIONS 

Select the product from the Released products by category form.  

On the Released product details form, click Sales transactions on the Inquires group 
from the Retail tab.  

 

The Sales transactions form opens.  

The Overview tab lists all the transactions associated with the retail product. Basic 
information like the entry status, receipt number, and transaction date and time are 
displayed. 
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The General tab provides information regarding the product, the statement number, 
sales origin, shift the transaction belongs to, and the details of the sale. 

 

The Amounts tab provides monetary details with totals on quantity, net amount, price, 
and tax. Information regarding discounts applied on the items is also provided. 
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The Financial dimensions tab displays the financial dimensions associated with the 
transaction header. 

 

Click Transactions on the top of the form the view transaction details.  

To view the reason code transaction and variant transactions, click the Reason code 
transaction and Variant transactions buttons. 

Click Items to open the item form. 
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20.5.15 INQUIRE PRICE LIST 

Select the product from the Released products by category form.  

On the Released product details form, click Price list on the Inquires group from the 
Retail tab.  

 

The price list form opens displaying the following information: 

 The name of the stores that carry the retail product. 

 The Operating unit number of the stores. 

 The Currency of the store. 

 The Price of the product, which is the recommended retail price (RRP). 

 The Price adjustments numbers, indicating that price discounts are currently 
active for the product at the retail store. 

 The Discount offers numbers, indicating that promotions are currently active 
for the product at the retail store. 
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PRICING AND DISCOUNTS 

OVERVIEW 

This module describes how price adjustments and discounts can be applied to products, 
variants, retail hierarchies, or all items in the store. If more than one discount applies to 
a product, a customer may receive either one discount or a combined discount. 
Microsoft Dynamics AX for Retail POS automatically applies the discount or combination 
of discounts that gives the best price to the customer.  

Price and discounts can be for set up to a line item or a transaction at the point of sale.  
Both price adjustments and discounts can be based on specific price groups or 
currencies. You can also to specify start dates and end dates.  

 Note 

 Before you set up a price adjustment or a discount, confirm that price groups are 
assigned to the correct stores. 

 You can delete a price adjustment or a discount. However, the statistical 
information is lost. 

 DISCOUNT SETUP 

This procedure can be used for both price adjustments and discounts, because the same 
options and the same possible settings apply to both.  

If you want to create a new discount that resembles an existing discount, you can save 
time by clicking Copy from. All the settings and products are then copied from one 
discount to the other.  

1. Click Retail > Common > Pricing and discounts > Discount.  

On this screen, promotion can be set for all items or for any of the hierarchy 
levels, division departments, and category or retail groups. 
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2. Click New to create a new price adjustment or discount. Then, in the Discount 
field, type an ID number for the price adjustment or discount.  

3. Enter the Name of the discount or the price adjustment. 

4. On the General FastTab, in the Status field, select Enabled or Disabled to enable 
or disable the price adjustment or discount.  

5. Under the Currency area, select the currency from the drop-down list. 

6. Under the Concurrency area, select the Discount concurrency mode from the 
drop-down list. The options available are as follows: 

 Exclusive: The Exclusive option will apply just a single discount that is 
exclusive to the promotion. 

 Best price: The best price option picks the best price from multiple 
discounts available. 

 Compounded: The compounded discount will apply the multiple 
discounts one after another in progression. 

7. Under the Retail price group area select the Price group from the drop-down list 
for stores that the price adjustment or discount applies to.  

8. Depending on your version of the program, do one of the following:  
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o In Microsoft Dynamics AX 2012 R2: In the Discount code field, enter a 
discount code. This code is used to apply the discount offer to purchases. 
The discount code can be used for promotions in Sites Services for 
Microsoft Dynamics ERP, retail stores, and online stores.  

In the Bar code field, a bar code is automatically generated for the 
discount code. This bar code must be entered or scanned in the point of 
sale (POS) system to apply the discount to the purchase.  

Note 

For promotions, if you enter a value in the Discount code field, the value that you enter 
is the discount code that is published to the customer. Leave this field blank to use 
number sequences and bar codes to automatically generate a discount code that is 
published to the customer 

o Otherwise, select the Discount code required check box to indicate that 
the discount code must be entered to apply the discount.  

 

9. On the Details FastTab, in the Description field, type a description. Then, in the 
Disclaimer field, type any disclaimer that is required. This disclaimer is used 
when the discount is published through Sites Services.  

 

10. On the Price/Discount FastTab, in the Discount type field, type the percentage of 
the price reduction. This value is used as a template when new lines are added.  
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11. On the Validation period FastTab, select Standard to specify an Effective date 
and an expiry date, or select Advanced to select a predefined discount period.  

 

12. On the Lines FastTab, click Add to add a single product to the price adjustment or 
discount. To add multiple products, click Add products.  

13. Select the Category hierarchy from the Category drop-down list. 

14. Select the Product from the drop-down list. 

15. Select the Product variant from the drop-down list if the product selected is a 
product master. 

16. The Name field will display the description of the product selected. 

17. Select the Unit of measure for the product from the drop-down list. 

18. On each line, in the Discount method field, select one of the following methods. 
Then specify a value in the corresponding column.  

o Discount percentage – A percentage is deducted from the price of the 
product.  

o Cash discount amount – An amount is deducted from the price of the 
product.  

o Discount price – A new price is used for the product.  

o Discount price incl. tax – A new price that includes sales tax is used for 
the product.  

19. On the Line details FastTab, in the Description field, type a description of the line 
that is selected on the Lines FastTab. 

20. Enter the Discount percentage if the discount method selected is discount 
percent. 
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21. Enter the Cash discount amount value if the discount method selected is 
discount amount. 

22. Enter the Discount price value if the discount method selected is discount price 
value. 

23. Enter the Discount price incl. tax value if the discount method selected is 
discount price including tax. 

24. Click Add all variants to automatically add a row for each variant associated with 
the product. 

 

 DISCOUNT PERIODS 

A discount period defines the period during which a price adjustment or discount is 
valid. For example, if multiple discounts are in effect during a particular period, you can 
assign one discount period to all the discounts.  

1. Click Retail > Setup > Pricing and discounts > Discount period.  
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2. Click New to create a new discount period.  

3. In the Discount period number field, type a unique ID number, and then, in the 
Description field, type a brief description.  

4. On the General FastTab, enter the following information, as necessary:  

o Start date – Enter the date that the discount period starts.  

o End date – Enter the date that the discount period ends.  

o Starting time – Enter the time that the discount period starts.  

o Ending time – Enter the time that the discount period ends.  

o Time within bounds – Select this check box if the start date and end date 
are included in the discount period.  

o Ending time after midnight – Select this check box if the end time of the 
discount period is after midnight, or on in the next day.  
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o Dates within bounds – Select the check box for each day that is included 
in the discount period.  

5. On the FastTab for each day of the week, enter the following information, as 
necessary. For example, you might want the discount period to be in effect 
during different hours on different days.  

o Starting time – Enter the time that the discount period starts on this day.  

o Ending time – Enter the time that the discount period ends on this day.  

o Time within bounds – Select this check box if the start time and end time 
are included in the discount period.  

o Ending time after midnight – Select this check box if the end time of the 
discount period is after midnight, or on the next day.  

 QUANTITY DISCOUNT  

A quantity discount is a discount that is given to customers when they purchase a 
particular quantity of a product.  

If you want to create a new discount that resembles an existing discount, you can save 
time by clicking Copy from. All the settings and products are then copied from one 
discount to the other.  

1. Click Retail > Common > Pricing and discounts > Quantity discount.  



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

153 

 

 

2. Click New to create a new quantity discount. Then, in the Discount field, type an 
ID number for the discount.  

3. Enter the Name of the quantity discount. 

4. On the General FastTab, in the Status field, select Enabled or Disabled to enable 
or disable the discount.  

5. Under the Currency area select the Currency from the drop-down list. 

6. Under the Concurrency area select the Discount concurrency mode from the 
drop-down list. The options available are as follows: 

 Exclusive: The Exclusive option will apply just a single discount, which is 
exclusive to the promotion. 

 Best price: The Best price option picks the best price from multiple 
discounts available. 

 Compounded: The Compounded discount option will apply the multiple 
discounts one after another. 
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7. In the Price group field, select the price group for the stores that the discount 
applies to.  

8. Depending on your version of the program, do one of the following:  
1. In Microsoft Dynamics AX 2012 R2: In the Discount code field, enter a 

discount code. This code is used to apply the discount offer to purchases. 
The discount code can be used for promotions in Sites Services for 
Microsoft Dynamics ERP, retail stores, and online stores.  

In the Bar code field, a bar code is automatically generated for the 
discount code. This bar code must be entered or scanned in the point of 
sale (POS) system to apply the discount to the purchase.  

Note 

For promotions, if you enter a value in the Discount code field, the value that you enter 
is the discount code that is published to the customer. Leave this field blank to use 
number sequences and bar codes to automatically generate a discount code that is 
published to the customer. 

2. Otherwise, select the Discount code required check box to indicate that 
the discount code must be entered to apply the discount.  

 

9. On the Details FastTab, in the Description field, type a description of the quantity 
discount. Then, in the Disclaimer field, type any disclaimer that is required. This 
disclaimer is used when the discount is published through Sites Services.  
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10. On the Price/Discount FastTab, in the Discount type field, select Discount % to 
calculate the discount prices as percentage discounts. To enter specific prices for 
quantities of the item, select Unit price.  

 

11. On the Validation period FastTab, select Standard to specify an effective date 
and expiration date for the discount. To select a predefined discount period, 
select Advanced.  

 

12. On the Lines FastTab, click Add to add a single product to the discount. To add 
multiple products, click Add products.  

 

13. Click Configuration from the top tool bar.  

 

14. Enter the Minimum quantity that the customer must buy to qualify for the 
discount. 
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15. In the Disc. % field, enter the percentage of the discount.  

16. If you want the discount that is given to increase as the quantities that are 
purchased increase, press CTRL+N to create another minimum quantity. Then, 
enter the amount or percentage of the discount for that quantity. 

 

On the Line details FastTab, in the Description field, type a description of the line that is 
selected on the Lines FastTab.  
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 MIX AND MATCH DISCOUNT 

A mix and match discount gives customers a discount when they purchase a specific 
combination of products. For example, a customer purchases two boxes of tea and 
receives 50 percent off the price of a third box. Products and variants can be included in 
mix and match discounts.  

If you want to create a new discount that resembles an existing discount, you can save 
time by clicking Copy from. All the settings and products are then copied from one 
discount to the other discount.  

1. Click Retail > Common > Pricing and discounts > Mix and match.  

 

2. Click New to create a new mix and match discount. Then, in the Discount field, 
type an ID number for the discount. 

3. Enter the Name of the mix and match discount. 
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4. On the General FastTab, in the Status field, select Enabled or Disabled to enable 
or disable the discount.  

5. Under the Currency area, select the Currency from the drop-down list. 

6. Under the Concurrency area, select the Discount concurrency mode and set it to 
Exclusive. 

7. In the Price group field, select the price group for the stores that the discount 
applies to.  

8. Depending on your version of the program, do one of the following:  
o In Microsoft Dynamics AX 2012 R2, in the Discount code field, enter a 

discount code. This code is used to apply the discount offer to purchases. 
The discount code can be used for promotions in Sites Services for 
Microsoft Dynamics ERP, retail stores, and online stores.  

In the Bar code field, a bar code is automatically generated for the 
discount code. This bar code must be entered or scanned in the point of 
sale (POS) system to apply the discount to the purchase.  

Note 
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For promotions, if you enter a value in the Discount code field, the value that you enter 
is the discount code that is published to the customer. Leave this field blank to use 
number sequences and bar codes to automatically generate a discount code that is 
published to the customer 

o Otherwise, select the Discount code required check box to indicate that 
the discount code must be entered to apply the discount.  

 

 

9. On the Details FastTab, in the Description field, type a description for the 
discount. Then, in the Disclaimer field, type any disclaimer that is required. This 
disclaimer is used when the discount is published through Sites Services.  

 

10. On the Price/Discount FastTab, in the Discount type field, follow one of these 
steps:  

o Select Deal price. Then, in the Deal price value incl. VAT field, type the 
specific price of the discounted total. The Deal price value incl. VAT field 
is used for both tax-inclusive and tax-exclusive configurations. Depending 
on store settings, the price either includes or excludes tax.  

o Select Discount %. Then, in the Discount % value field, type the 
percentage of the discount. For example, the usual price of product A is 
40.00, and the usual price of product B is 60.00. A mix and match 
discount of 30 percent applies to these products. Therefore, if a customer 
buys product A and product B together, the cost is 70.00 instead of 
100.00.  
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o Select Discount amount. Then, in the Discount amount value incl. VAT 
field, type the specific amount of the discount.  

o Select Least expensive. Then, in the Number of least expensive lines 
field, type the number of least-expensive products that are free.  

o Select Line spec. Then specify the discount or price per product.  

11. In the Number of times applicable field, type the number of times that the 
discount can be applied to the items.  

 

12. On the Validation period FastTab, select Standard to specify an Effective date 
and Expiration date for the discount. Or, select Advanced to select a predefined 
discount period.  

 

13. On the Lines FastTab, click Add to add a single category, product, or variant to 
the discount. Or, click Add products to add multiple categories and products. 

14. Click Add all variants to automatically add a row for each variant associated with 
the product. 
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15. Click Mix and match line groups, and then select among the predefined line 
groups. Then, in the Number of products needed field, type the quantity of the 
product that the customer must purchase to qualify for the discount.  

 

16. Select the Line group from the drop-down list. 

17. Enter the Number of products needed in the line group to qualify for the 
discount. 

18. In the Line color field, select a color. 

 

 Tip 

Select a different color for each line group, so that you can easily distinguish the 
various line groups at the point of sale. 

19. For each line that is added to the mix and match discount, if the product must be 
included in a line group, select the line group.  



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

162 

 

 

On the Line details FastTab, in the Description field, type a description of the line that is 
selected on the Lines FastTab.  

 PRICE ADJUSTMENT  

If you want to create a new price adjustment that resembles an existing one, you can 
save time by clicking Copy from. All the settings and products are then copied from one 
discount to the other.  

25. Click Retail > Common > Pricing and discounts > Price adjustment.  

On this screen, promotion can be set for all items or for any of the hierarchy 
levels, division departments, and category or retail groups. 
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26. Click New to create a new price adjustment or discount. Then, in the Discount 
field, type an ID number for the price adjustment or discount.  

27. Enter the Name of the discount or the price adjustment. 

28. On the General FastTab, in the Status field, select Enabled or Disabled to enable 
or disable the price adjustment or discount.  

29. In the Currency area, select the Currency from the drop-down list. 

30. In the Concurrency area, select the Discount concurrency mode from the drop-
down list. The options available are as follows: 

 Exclusive: The Exclusive option will apply just a single discount that is 
exclusive to the promotion. 

 Best price: The Best price option picks the best price from multiple 
discounts available. 

 Compounded: The Compounded discount applies the multiple 
discounts one after another. 
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31. In the Retail price group area, select the Price group from the drop-down list for 
stores that the price adjustment or discount applies to.  

32. On the Details FastTab, in the Description field, type a description. Then, in the 
Disclaimer field, type any disclaimer that is required. This disclaimer is used 
when the discount is published through Sites Services.  

 

33. On the Price/Discount FastTab, in the Discount type field, type the percentage of 
the price reduction. This value is used as a template when new lines are added.  

 

34. On the Validation period FastTab, select Standard to specify an Effective date 
and an Expiration date, or select Advanced to select a predefined discount 
period.  

 

35. On the Lines FastTab, click Add to add a single product to the price adjustment or 
discount. To add multiple products, click Add products.  

36. Select the Category hierarchy from the Category drop-down list. 

37. Select the Product from the drop-down list. 

38. Select the Product variant from the drop-down list if the product selected is a 
product master. 

39. Be aware that the Name field will display the description of the product selected. 

40. Select the Unit of measure for the product from the drop-down list. 

41. On each line, in the Discount method field, select one of the following methods. 
Then specify a value in the corresponding column.  
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o Discount percentage. A percentage is deducted from the price of the 
product.  

o Cash Discount amount. An amount is deducted from the price of the 
product.  

o Discount price. A new price is used for the product.  

o Discount price incl. tax. A new price that includes sales tax is used for the 
product.  

42. On the Line details FastTab, in the Description field, type a description of the line 
that is selected on the Lines FastTab. 

43. Enter the Discount percentage if the discount method selected is discount 
percent. 

44. Enter the Cash Discount amount value if the discount method selected is 
discount amount. 

45. Enter the Discount price value if the discount method selected is discount price 
value. 

46. Enter the Discount price incl. tax value if the discount method selected is 
discount price including tax. 

47. Click Add all variants to automatically add a row for each variant associated with 
the product. 
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PRICING AND DISCOUNTS 

OVERVIEW 

In this module, we will discuss how price adjustments and discounts can be applied to 
products, variants, retail hierarchies, or all items in the store. If more than one discount 
applies to a product, a customer may receive either one discount or a combined 
discount. Microsoft Dynamics AX for Retail POS automatically applies the discount or 
combination of discounts that gives the best price to the customer.  

Price and discounts can be for set up to a line item or a transaction at the point of sale.  
Both price adjustments and discounts can be based on specific price groups or 
currencies. You can also to specify start dates and end dates.  

 Note 

 Before you set up a price adjustment or a discount, confirm that price groups are 
assigned to the correct stores. 

 You can delete a price adjustment or a discount. However, the statistical 
information is lost. 

 DISCOUNT SETUP 

This procedure can be used for both price adjustments and discounts, because the same 
options and the same possible settings apply to both.  

If you want to create a new discount that resembles an existing discount, you can save 
time by clicking Copy from. All the settings and products are then copied from one 
discount to the other.  

48. Click Retail > Common > Pricing and discounts > Discount.  

On this screen, promotion can be set for all items or for any of the hierarchy 
levels, division departments, and category or retail groups. 
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49. Click New to create a new price adjustment or discount. Then, in the Discount 
field, type an ID number for the price adjustment or discount.  

50. Enter the Name of the discount or the price adjustment. 

51. On the General FastTab, in the Status field, select Enabled or Disabled to enable 
or disable the price adjustment or discount.  

52. Under the Currency area, select the currency from the drop-down list. 

53. Under the Concurrency area, select the Discount concurrency mode from the 
drop-down list. The options available are as follows: 

 Exclusive: The Exclusive option will apply just a single discount that is 
exclusive to the promotion. 

 Best price: The best price option picks the best price from multiple 
discounts available. 

 Compounded: The compounded discount will apply the multiple 
discounts one after another in progression. 

54. Under the Retail price group area select the Price group from the drop-down list 
for stores that the price adjustment or discount applies to.  

55. Depending on your version of the program, do one of the following:  
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o In Microsoft Dynamics AX 2012 R2: In the Discount code field, enter a 
discount code. This code is used to apply the discount offer to purchases. 
The discount code can be used for promotions in Sites Services for 
Microsoft Dynamics ERP, retail stores, and online stores.  

In the Bar code field, a bar code is automatically generated for the 
discount code. This bar code must be entered or scanned in the point of 
sale (POS) system to apply the discount to the purchase.  

Note 

For promotions, if you enter a value in the Discount code field, the value that you enter 
is the discount code that is published to the customer. Leave this field blank to use 
number sequences and bar codes to automatically generate a discount code that is 
published to the customer 

o Otherwise, select the Discount code required check box to indicate that 
the discount code must be entered to apply the discount.  

 

56. On the Details FastTab, in the Description field, type a description. Then, in the 
Disclaimer field, type any disclaimer that is required. This disclaimer is used 
when the discount is published through Sites Services.  

 

57. On the Price/Discount FastTab, in the Discount type field, type the percentage of 
the price reduction. This value is used as a template when new lines are added.  
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58. On the Validation period FastTab, select Standard to specify an Effective date 
and an expiry date, or select Advanced to select a predefined discount period.  

 

59. On the Lines FastTab, click Add to add a single product to the price adjustment or 
discount. To add multiple products, click Add products.  

60. Select the Category hierarchy from the Category drop-down list. 

61. Select the Product from the drop-down list. 

62. Select the Product variant from the drop-down list if the product selected is a 
product master. 

63. The Name field will display the description of the product selected. 

64. Select the Unit of measure for the product from the drop-down list. 

65. On each line, in the Discount method field, select one of the following methods. 
Then specify a value in the corresponding column.  

o Discount percentage – A percentage is deducted from the price of the 
product.  

o Cash discount amount – An amount is deducted from the price of the 
product.  

o Discount price – A new price is used for the product.  

o Discount price incl. tax – A new price that includes sales tax is used for 
the product.  

66. On the Line details FastTab, in the Description field, type a description of the line 
that is selected on the Lines FastTab. 

67. Enter the Discount percentage if the discount method selected is discount 
percent. 
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68. Enter the Cash discount amount value if the discount method selected is 
discount amount. 

69. Enter the Discount price value if the discount method selected is discount price 
value. 

70. Enter the Discount price incl. tax value if the discount method selected is 
discount price including tax. 

71. Click Add all variants to automatically add a row for each variant associated with 
the product. 

 

 DISCOUNT PERIODS 

A discount period defines the period during which a price adjustment or discount is 
valid. For example, if multiple discounts are in effect during a particular period, you can 
assign one discount period to all the discounts.  

6. Click Retail > Setup > Pricing and discounts > Discount period.  
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7. Click New to create a new discount period.  

8. In the Discount period number field, type a unique ID number, and then, in the 
Description field, type a brief description.  

9. On the General FastTab, enter the following information, as necessary:  

o Start date – Enter the date that the discount period starts.  

o End date – Enter the date that the discount period ends.  

o Starting time – Enter the time that the discount period starts.  

o Ending time – Enter the time that the discount period ends.  

o Time within bounds – Select this check box if the start date and end date 
are included in the discount period.  

o Ending time after midnight – Select this check box if the end time of the 
discount period is after midnight, or on in the next day.  
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o Dates within bounds – Select the check box for each day that is included 
in the discount period.  

10. On the FastTab for each day of the week, enter the following information, as 
necessary. For example, you might want the discount period to be in effect 
during different hours on different days.  

o Starting time – Enter the time that the discount period starts on this day.  

o Ending time – Enter the time that the discount period ends on this day.  

o Time within bounds – Select this check box if the start time and end time 
are included in the discount period.  

o Ending time after midnight – Select this check box if the end time of the 
discount period is after midnight, or on the next day.  

 QUANTITY DISCOUNT  

A quantity discount is a discount that is given to customers when they purchase a 
particular quantity of a product.  

If you want to create a new discount that resembles an existing discount, you can save 
time by clicking Copy from. All the settings and products are then copied from one 
discount to the other.  

17. Click Retail > Common > Pricing and discounts > Quantity discount.  
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18. Click New to create a new quantity discount. Then, in the Discount field, type an 
ID number for the discount.  

19. Enter the Name of the quantity discount. 

20. On the General FastTab, in the Status field, select Enabled or Disabled to enable 
or disable the discount.  

21. Under the Currency area select the Currency from the drop-down list. 

22. Under the Concurrency area select the Discount concurrency mode from the 
drop-down list. The options available are as follows: 

 Exclusive: The Exclusive option will apply just a single discount, which is 
exclusive to the promotion. 

 Best price: The Best price option picks the best price from multiple 
discounts available. 

 Compounded: The Compounded discount option will apply the multiple 
discounts one after another. 
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23. In the Price group field, select the price group for the stores that the discount 
applies to.  

24. Depending on your version of the program, do one of the following:  
1. In Microsoft Dynamics AX 2012 R2: In the Discount code field, enter a 

discount code. This code is used to apply the discount offer to purchases. 
The discount code can be used for promotions in Sites Services for 
Microsoft Dynamics ERP, retail stores, and online stores.  

In the Bar code field, a bar code is automatically generated for the 
discount code. This bar code must be entered or scanned in the point of 
sale (POS) system to apply the discount to the purchase.  

Note 

For promotions, if you enter a value in the Discount code field, the value that you enter 
is the discount code that is published to the customer. Leave this field blank to use 
number sequences and bar codes to automatically generate a discount code that is 
published to the customer. 

2. Otherwise, select the Discount code required check box to indicate that 
the discount code must be entered to apply the discount.  

 

25. On the Details FastTab, in the Description field, type a description of the quantity 
discount. Then, in the Disclaimer field, type any disclaimer that is required. This 
disclaimer is used when the discount is published through Sites Services.  
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26. On the Price/Discount FastTab, in the Discount type field, select Discount % to 
calculate the discount prices as percentage discounts. To enter specific prices for 
quantities of the item, select Unit price.  

 

27. On the Validation period FastTab, select Standard to specify an effective date 
and expiration date for the discount. To select a predefined discount period, 
select Advanced.  

 

28. On the Lines FastTab, click Add to add a single product to the discount. To add 
multiple products, click Add products.  

 

29. Click Configuration from the top tool bar.  

 

30. Enter the Minimum quantity that the customer must buy to qualify for the 
discount. 
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31. In the Disc. % field, enter the percentage of the discount.  

32. If you want the discount that is given to increase as the quantities that are 
purchased increase, press CTRL+N to create another minimum quantity. Then, 
enter the amount or percentage of the discount for that quantity. 

 

On the Line details FastTab, in the Description field, type a description of the line that is 
selected on the Lines FastTab.  
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 MIX AND MATCH DISCOUNT 

A mix and match discount gives customers a discount when they purchase a specific 
combination of products. For example, a customer purchases two boxes of tea and 
receives 50 percent off the price of a third box. Products and variants can be included in 
mix and match discounts.  

If you want to create a new discount that resembles an existing discount, you can save 
time by clicking Copy from. All the settings and products are then copied from one 
discount to the other discount.  

20. Click Retail > Common > Pricing and discounts > Mix and match.  

 

21. Click New to create a new mix and match discount. Then, in the Discount field, 
type an ID number for the discount. 

22. Enter the Name of the mix and match discount. 
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23. On the General FastTab, in the Status field, select Enabled or Disabled to enable 
or disable the discount.  

24. Under the Currency area, select the Currency from the drop-down list. 

25. Under the Concurrency area, select the Discount concurrency mode and set it to 
Exclusive. 

26. In the Price group field, select the price group for the stores that the discount 
applies to.  

27. Depending on your version of the program, do one of the following:  
o In Microsoft Dynamics AX 2012 R2, in the Discount code field, enter a 

discount code. This code is used to apply the discount offer to purchases. 
The discount code can be used for promotions in Sites Services for 
Microsoft Dynamics ERP, retail stores, and online stores.  

In the Bar code field, a bar code is automatically generated for the 
discount code. This bar code must be entered or scanned in the point of 
sale (POS) system to apply the discount to the purchase.  

Note 
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For promotions, if you enter a value in the Discount code field, the value that you enter 
is the discount code that is published to the customer. Leave this field blank to use 
number sequences and bar codes to automatically generate a discount code that is 
published to the customer 

o Otherwise, select the Discount code required check box to indicate that 
the discount code must be entered to apply the discount.  

 

 

28. On the Details FastTab, in the Description field, type a description for the 
discount. Then, in the Disclaimer field, type any disclaimer that is required. This 
disclaimer is used when the discount is published through Sites Services.  

 

29. On the Price/Discount FastTab, in the Discount type field, follow one of these 
steps:  

o Select Deal price. Then, in the Deal price value incl. VAT field, type the 
specific price of the discounted total. The Deal price value incl. VAT field 
is used for both tax-inclusive and tax-exclusive configurations. Depending 
on store settings, the price either includes or excludes tax.  

o Select Discount %. Then, in the Discount % value field, type the 
percentage of the discount. For example, the usual price of product A is 
40.00, and the usual price of product B is 60.00. A mix and match 
discount of 30 percent applies to these products. Therefore, if a customer 
buys product A and product B together, the cost is 70.00 instead of 
100.00.  
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o Select Discount amount. Then, in the Discount amount value incl. VAT 
field, type the specific amount of the discount.  

o Select Least expensive. Then, in the Number of least expensive lines 
field, type the number of least-expensive products that are free.  

o Select Line spec. Then specify the discount or price per product.  

30. In the Number of times applicable field, type the number of times that the 
discount can be applied to the items.  

 

31. On the Validation period FastTab, select Standard to specify an Effective date 
and Expiration date for the discount. Or, select Advanced to select a predefined 
discount period.  

 

32. On the Lines FastTab, click Add to add a single category, product, or variant to 
the discount. Or, click Add products to add multiple categories and products. 

33. Click Add all variants to automatically add a row for each variant associated with 
the product. 
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34. Click Mix and match line groups, and then select among the predefined line 
groups. Then, in the Number of products needed field, type the quantity of the 
product that the customer must purchase to qualify for the discount.  

 

35. Select the Line group from the drop-down list. 

36. Enter the Number of products needed in the line group to qualify for the 
discount. 

37. In the Line color field, select a color. 

 

 Tip 

Select a different color for each line group, so that you can easily distinguish the 
various line groups at the point of sale. 

38. For each line that is added to the mix and match discount, if the product must be 
included in a line group, select the line group.  
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On the Line details FastTab, in the Description field, type a description of the line that is 
selected on the Lines FastTab.  

 PRICE ADJUSTMENT  

If you want to create a new price adjustment that resembles an existing one, you can 
save time by clicking Copy from. All the settings and products are then copied from one 
discount to the other.  

72. Click Retail > Common > Pricing and discounts > Price adjustment.  

On this screen, promotion can be set for all items or for any of the hierarchy 
levels, division departments, and category or retail groups. 
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73. Click New to create a new price adjustment or discount. Then, in the Discount 
field, type an ID number for the price adjustment or discount.  

74. Enter the Name of the discount or the price adjustment. 

75. On the General FastTab, in the Status field, select Enabled or Disabled to enable 
or disable the price adjustment or discount.  

76. In the Currency area, select the Currency from the drop-down list. 

77. In the Concurrency area, select the Discount concurrency mode from the drop-
down list. The options available are as follows: 

 Exclusive: The Exclusive option will apply just a single discount that is 
exclusive to the promotion. 

 Best price: The Best price option picks the best price from multiple 
discounts available. 

 Compounded: The Compounded discount applies the multiple 
discounts one after another. 
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78. In the Retail price group area, select the Price group from the drop-down list for 
stores that the price adjustment or discount applies to.  

79. On the Details FastTab, in the Description field, type a description. Then, in the 
Disclaimer field, type any disclaimer that is required. This disclaimer is used 
when the discount is published through Sites Services.  

 

80. On the Price/Discount FastTab, in the Discount type field, type the percentage of 
the price reduction. This value is used as a template when new lines are added.  

 

81. On the Validation period FastTab, select Standard to specify an Effective date 
and an Expiration date, or select Advanced to select a predefined discount 
period.  

 

82. On the Lines FastTab, click Add to add a single product to the price adjustment or 
discount. To add multiple products, click Add products.  

83. Select the Category hierarchy from the Category drop-down list. 

84. Select the Product from the drop-down list. 

85. Select the Product variant from the drop-down list if the product selected is a 
product master. 

86. Be aware that the Name field will display the description of the product selected. 

87. Select the Unit of measure for the product from the drop-down list. 

88. On each line, in the Discount method field, select one of the following methods. 
Then specify a value in the corresponding column.  
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o Discount percentage. A percentage is deducted from the price of the 
product.  

o Cash Discount amount. An amount is deducted from the price of the 
product.  

o Discount price. A new price is used for the product.  

o Discount price incl. tax. A new price that includes sales tax is used for the 
product.  

89. On the Line details FastTab, in the Description field, type a description of the line 
that is selected on the Lines FastTab. 

90. Enter the Discount percentage if the discount method selected is discount 
percent. 

91. Enter the Cash Discount amount value if the discount method selected is 
discount amount. 

92. Enter the Discount price value if the discount method selected is discount price 
value. 

93. Enter the Discount price incl. tax value if the discount method selected is 
discount price including tax. 

94. Click Add all variants to automatically add a row for each variant associated with 
the product. 
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LOYALTY 

OVERVIEW 

This module explains how loyalty programs are structured marketing efforts that 
reward, and therefore, encourage loyal buying behavior—behavior that can be 
profitable for the company. 

In marketing generally, and in retailing more specifically, a loyalty card, rewards card, 
points card, advantage card, or club card is a plastic card or paper card that identifies 
the cardholder as a member of a loyalty program. 

A retail establishment or a retail group may issue a loyalty card to a consumer who can 
then use it as a form of identification when dealing with that retailer. By presenting the 
card, a customer is typically entitled to either a discount on the current purchase or an 
allotment of points that can be used for future purchases. The card issuer requests or 
requires customers seeking the issuance of a loyalty card to provide a usually minimal 
amount of identifying or demographic data, such as name and address. 

Retail Headquarters can be set up so that customers collect points for the items that 
they are buying, depending on some criteria. The point calculation can be done in 
numerous ways. Swiping a card collects loyalty points. From the card number, from the 
items bought, and from how the transaction was paid, the program can calculate how 
many points were earned.  

The following processes are required to set up a loyalty program: 

i. Set up loyalty customers 

ii. Set up loyalty schemes 

 LOYALTY CUSTOMERS 

The loyalty system is based mainly on two operations: 

 Accruing points when the customer buys products. 

 Spending points when the accrued points are used to pay for the purchased 
items. 

Accruing points requires a loyalty customer to be created.  Each loyalty customer can 
have a reference (optional) to a real customer in the system.  More than one loyalty 
customer can have a reference to the same real customer.   



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

187 

 

After the loyalty customer has been created, one or more loyalty cards can be issued to 
this loyalty customer.   

Each of those loyalty cards have a reference to a loyalty scheme, which specify the 
points accruement rule, which defines how many points can be accrued and the range 
of products that qualify for the accrual.  Each loyalty card is also identified in what way it 
is intended to be used-- accruing only, accruing and spending, and so on. 

When a loyalty customer is created, the customer number sequence is retrieved from 
the store. 

Note 

Make sure a customer name is linked to the customer record in Microsoft Dynamics AX 
to get the types of discounts that are already linked to a customer. 

To view loyalty customers, click Retail > Common > Loyalty > Loyalty customer.  

The loyalty customer form opens. 

 

The loyalty customer form displays the customer number, name, the customer account 
with which the loyalty customer is associated, and information on the point status. 
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20.16.1 CREATE LOYALTY CUSTOMER 

To create a loyalty customer, click Retail > Common > Loyalty > Loyalty customer. 

The customer loyalty form opens.  

1. Click Loyalty customer from the New group on the Loyalty customer tab.  
2. In the Loyalty schemes area, select a Customer account to associate with the 

loyalty customer. 

 

 

3. Notice the following: 

 In the Loyalty customer FastTab, the Loyalty customer number is populated 
automatically if the number sequence is defined.  

 In the Customer area, the Name field is populated based on the customer 
account selected. 

 In the Points area, the Used points displays the statistics on the loyalty points 
used by the customer. 

 The Issued points displays the statistics on the loyalty points issued to the 
customer. 

 The Points status displays the point’s status of the loyalty customer. 

 

1. Under the Lines FastTab click Add line to add a new loyalty card to the customer. 

2. Notice that the Loyalty card number is a unique number that is generated either 
automatically or manually. 
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3. Select the Loyalty card type from the drop-down list. The options available are as 
follows: 

 As card tender – This type of card is considered the primary card that can earn or 
redeem the points for the primary card owner and added card members. The 
customer can only use points for payment that have been collected with the 
same card. 

 As contact tender – This type of card is considered a secondary card that can earn 
or redeem the points only for the card member. The customer can use points for 
payment that have been collected by all cards for that loyalty contract. 

 No tender – This type of card is considered a secondary card that can only earn 
points, but not redeem them.  

 Blocked – A loyalty card that is blocked and cannot collect or use points. 

4. Select the Scheme ID the loyalty customer belongs to accrue points. Notice the 
following: 

 The Used points field shows the total points used by a loyalty card assigned to a 
loyalty customer. 

 The Issued point’s field shows the total points issued to a loyalty card assigned 
to a loyalty customer. 

 The Point status field shows the total points available after use and expiry. This 
displays the total points available on each loyalty card issued to a loyalty 
customer. 

 The Expired point’s field shows the total expired points of a loyalty card assigned 
to a loyalty customer. 

 

Click Inquiries > Loyalty card transactions to view the transactions associated with the 
loyalty card. 
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20.16.2 VIEW CUSTOMER TRANASCTIONS 

To view loyalty customer transactions, click Retail > Common > Loyalty > Loyalty 
customer. 

The Customer loyalty form opens. Select the loyalty customer from the list to view 
transaction information. 

Click Customer transactions from the Inquiries group on the Loyalty customer tab. 

 

The Loyalty point transactions form opens. The Overview tab displays the transaction 
number, loyalty points accrued, store details, loyalty card number, and scheme 
information. 

 

The General tab provides information on the Payment origin, issued points, and the 
statement number details. 
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20.16.3 VIEW LOYALTY SCHEMES 

To view loyalty schemes for a customer, click Retail > Common > Loyalty > Loyalty 
customer. 

The Customer loyalty form opens. Select the loyalty customer from the list to view 
loyalty schemes. 

Click Customer transactions from the Inquiries group on the Loyalty customer tab. 

 

The Loyalty schemes form related to the loyalty customer selected opens. 
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 LOYALTY SCHEMES 

To view loyalty schemes, click Retail > Common > Loyalty > Loyalty schemes.  

The Loyalty schemes form opens. 

 

The Loyalty schemes form displays the list of schemes with information on the point’s 
status. 

 CREATE A LOYALTY SCHEME 

To create a loyalty scheme, click Retail > Common > Loyalty > Loyalty schemes. 

The Customer schemes form opens. Click Loyalty scheme from the New group on the 
Loyalty scheme tab. 

 

  



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

195 

 

The Loyalty schemes creation form opens. 

1. In the Loyalty scheme FastTab, enter the Scheme ID. This should be a unique 
number to identify the loyalty scheme. 

2. In the Description area, enter the Description of the loyalty scheme. 

3. In the Expiration calculation, enter the Expiration time value of the loyalty 
scheme. It is an integer that defines the number of days/months/years to be 
added to the issue date of the loyalty points before expiration. 

4. Select the Expiration time unit (Day/Month/Years) that defines the expiration 
time value from the drop-down list.  

5. Be aware of the following: 

 In the Points area, the Point status displays the sum of the available points 
for the whole scheme. 

 The Issued points display the total issued points for the selected scheme. 

 The Used points display the total used points for the selected scheme. 

 The Expired points display the total expired points for the selected scheme. 

6. Under the Multiplier type, select the Default multiplier type from the drop-
down list. The options available are as follows: 

 Quantity: Loyalty points are calculated based on the number of units or quantity 
sold for an item. 

 Amount: Loyalty points are calculated based on the total value of sales for a 
transaction. 

 

7. Under the Lines FastTab, click Add line to add a new point accrual rule. 

8. Select the Type from the drop-down list. The options available are as follows: 
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 Product: The accrual rule is based on merchandising hierarchy or specific 
products. A type selection creates a points rule for an item or a 
merchandising category.  

 Tender: The accrual rule is based on the payment method. The tender 
type can accrue points for the use of specific tender type (cash) or, in case 
of a payment, the can rule can take points for use of specific tender type 
(loyalty card). 

9. Select the Payment method if the selected type is tendered from the drop-down list. 

10. Select the Retail merchandising category from the drop-down list if the type selected 
is product. 

11. Select the Product from the drop-down list if you wish to run loyalty schemes specific 
to a retail product. 

12. Select the Product variant from the drop-down list if the product selected is a product 
master. 

13. Notice that the Name field is auto populated with the product description. 

14. Enter the Start date for the loyalty scheme. 

15. Enter the End date for the loyalty scheme. 

16. Enter the Quantity/Amount the customer has to purchase to accrue loyalty points 
based on the multiplier settings. 

17. Select the Multiplier type from the drop-down list. The options available are Amounts 
or Quantity. 

18. Enter the Loyalty points accrued. 
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20.18.1 ADD PRODUCTS TO LOYALTY SCHEMES 

To add products to an existing loyalty scheme, click Retail > Common > Loyalty > 
Loyalty schemes. 

Select the loyalty scheme to modify, and double-click to open the Loyalty scheme form. 

Click Add products from the Maintain group on the Loyalty scheme tab. 

 

The Add products form opens. 

 

1. In the Filters area, select the Hierarchy, Item group, Buyer group or Vendor account 
to filter products. 

2. Select the products from the Available products grid. 
3. Click Add to add the selected products to the Add products grid. 
4. Select the products from the Add products grid, and click OK to confirm the addition 

of products to the loyalty scheme. 

20.18.2 VIEW LOYALTY CARD TRANSACTIONS 

To view loyalty card transactions for an existing loyalty scheme, click Retail > Common > 
Loyalty > Loyalty schemes. 
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Select the loyalty scheme, and double-click to open the Loyalty scheme form. 

Click Loyalty card transactions from the Inquiries group on the Loyalty scheme tab. 

 

The Loyalty point transactions form opens. 

The Overview tab displays the transaction number, loyalty points accrued, store details, 
loyalty card number, and scheme information. 

 

The General tab provides information on the payment origin, issued points, and the 
statement number. 

 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

199 

 

20.18.3 VIEW LOYALTY CARDS 

To view loyalty card transactions for an existing loyalty scheme, click Retail > Common > 
Loyalty > Loyalty schemes. 

Select the loyalty scheme and double-click to open the Loyalty scheme form. 

Click Loyalty card transactions from the Inquiries group on the Loyalty scheme tab. 

 

The Loyalty point transactions form opens. 

This displays the transaction number, loyalty points accrued, store details, loyalty card 
number, and scheme information.  It reflects all transactions, including calculation of 
points accrued, points used, and even points taken off when the item is returned. 

 

20.18.4 VIEW LOYALTY CUSTOMERS 

To view loyalty customers associated with an existing loyalty scheme, click Retail > 
Common > Loyalty > Loyalty schemes. 

Select the loyalty scheme, and double-click to open the Loyalty scheme form. 

Click Loyalty cards from the Inquiries group on the Loyalty scheme tab. 
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The Loyalty customer form opens. 

 

The form displays the list of loyalty customers associated with a loyalty scheme. Double-click 
to open and view detailed loyalty customer information. 
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PERIODIC ACTIVITIES 

 SEND EMAIL RECEIPTS 

Email receipts are an environmentally friendly option when processing retail sales. The 
customer can decide whether to receive a printed receipt, an email receipt, or both. 

 Note 

The E-mail parameters need to be set up for sending the receipts to the customers. To 
open the E-mail parameters form, click System administration > Setup > System > E-
mail parameters. Enter the SMTP details and default values to be used for sending 
email. 

Registered customers 

Customers that have been set up in Microsoft Dynamics AX can choose which settings 
should apply to them. Specify the settings as follows: 

1. Click Accounts receivable > Common Forms > All Customers. 

2. Select a customer, and then click Edit. Go to Retail FastTab, under Receipt, 
and select an option in the Receipt option field: 

 POS – Select this option if the customer wants printed receipts only. 

 Email – Select this option if the customer wants email receipts only. 

 Both – Select this option if the customer wants both printed and email 
receipts. 

3. In the Receipt email field, enter the email address if the customer wants 
email receipts. 
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Unregistered customers 

The default receipt options for customers that have not been set up in Microsoft 
Dynamics AX can be entered in Retail Headquarters parameters. 

1. Click Retail > Setup > Retail Parameters. 

2. On the Posting, under Email receipt FastTab, select a receipt option: 

 POS – Select this option to print receipts by default. 

 Email – Select this option to email receipts by default. 

 Both – Select this option to both print and email receipts by default. 

3. In the Subject field, type the text that you want to appear by default in the 
Subject line of the emailed receipts. 
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Email Body Text 

The text to be displayed in the email message body can be set up as form notes. This 
way, you can send email messages in different languages, depending on the language of 
the particular customer or, if no customer is chosen, your company's language. The 
form note must be a Retail Headquarters receipt type. 

1. Click Accounts receivable > Setup > Forms > Form notes. 

2. Click New to create a new form note, and select the form as a Retail 
Headquarters Receipt and specify a language. 

3. On the Form note FastTab, enter the text that you want for the body of the 
email message. 

 

Send e-mail receipts 

To email receipts using a batch job, click Retail > Periodic > Send e-mail receipts.  
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1. Select the Batch processing check box to run the job as a batch. 
 

2. Enter the Task description for the job. 
 

3. Select the Batch group from the drop-down list. 
 

4. Select the Private check box if you wish to run the job as a private job. 
 

5. Click Recurrence to set the frequency of the job execution. 
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6. Click Alerts to configure an alert mechanism to receive notification on job 

completion or failures. 

 SEND EMAIL NOTIFICATIONS 

The send email notification is used to send email updates to the customers on the status 
of their order details. 

Customer can be notified for the following activities: 

a. Order created: An email notification can be sent when a new order is 
created for a customer. 

b. Order confirmed: An email notification can be sent when an order is 
confirmed. 

c. Picking completed: An email notification can be sent when the order 
items are picked for packing at a store or a distribution location. 
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d. Packing completed: An email notification can be sent when the packing is 
complete and order items are ready to be shipped. 

e. Order shipped: An email notification can be sent when the order is 
shipped, advising the customer of the delivery date and tracking 
information based on the shipping method selected. 

f. Payment failed: Email notification can be sent advising the customer 
regarding payment failure for the order. 

g. Customer created: Email notification can be sent for new customers. 
h. Password reset: Email notifications can be sent to advise customers 

when their account password is reset. 

To open the Process order email notifications form, click Retail > Periodic > Send email 
notifications. 

 

1. Select the Batch processing check box to run the job as a batch. 
 

2. Enter the Task description for the job. 
 

3. Select the Batch group from the drop-down list. 
 

4. Select the Private check box if you wish to run the job as a private job. 
 

5. Click OK to run the job to send notifications to the customer. 

Note: 
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Default email templates have been included out-of-box since the Microsoft 
Dynamics AX 6.2 release. However, retailers can add their own templates or modify 
the default templates to meet their requirements. 

One or more email notification profiles can be setup in Microsoft Dynamics AX. 
However, the default profile can be set up only in Retail parameters form. 

The existing Microsoft Dynamics AX email notification infrastructure has been 
leveraged for this feature. 

 

 MASS UPDATE WORKSHEET 

The mass update worksheet allows a user to apply bulk product updates across product 
categories on products selected in a worksheet.  

A worksheet can be saved and recalled for later editing before validating and posting it 
to update the applicable products. Worksheet history is retained to allow users to 
review previous sets of changes. 

Worksheet Creation 

Create a mass update worksheet as follows: 

1. Click Retail > Periodic > Mass update worksheet. 
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2. Click New. On the form, the Properties that can be bulk updated are shown.  

3. Select the applicable Properties from different Areas by selecting the Selection 
check box. 

4. Click OK to generate the worksheet. 
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Add Products to the Worksheet 

Add products to the worksheet as follows: 

1. On the Mass update worksheet form, enter the Description for the worksheet. 

 

2. Click Add Products on the worksheet. 
3. Apply the Filters, and select the products to be updated. Various filters are present 

on the Add products form: 

 Hierarchy Products can be filtered on Category hierarchies, such as retail 
product hierarchy or procurement hierarchy. 

 Item Group – Select the Item group from the drop-down list. 

 Buyer Group – Select the vendor buyer group from the drop-down list. 

 Vendor account – Select the vendor account from the drop-down list. 
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4. Applicable Products shows the product list on the basis of filter criteria. In this 
section, select all or individual products to the Add Products section.  

5. Click Ok to add products to the worksheet for update. 

 

6. On the worksheet, the items are added to the Product Name column with values for 
reference. The remaining columns are blank and are updated only if a value is 
provided. 
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7. For the ease of data entry, update the first row with applicable values in the 
applicable columns, and then click Paste first row. Select the columns that have to 
be copied to all rows from the first row, and then click OK. 

 

8. If the field type is Price, then it can be updated by using a price formula. Select the 
Apply price formula to open the following form: 

 
On the Set the value in the selected column to area, follow these steps: 
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1. Select the price type. The options are Purchase Price, Purchase price 
charges, Sales price, Sales price charges, and Cost price. 

  
2. Chose the calculation type. The options are addition (+), subtraction (-), 

multiplication (*), and division (/). 

  
3. Enter the amount of the calculation value. 

  
4. Choose whether to Round calculate value or Do not round calculated value. 

  
5. Select whether to Apply the formula to this row only or Apply the formula 

to all rows. 

  
6. Click OK to apply the formula. 
 

9. If the field is of type Date, then it can be updated by a date formula. Select the Apply 
date formula to open the following form: 
 

 
 

On the Set the value in the selected column to area, follow these steps:  
 

1. Select the date type. The options are Date of Purchase Price, Date of 
Sales price, Date of Cost price, and Issue Date 

  
2. Choose the calculation type. The options are addition (+) and subtraction 

(-). 

  
3. Enter the calculation value. 
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4. Select whether the calculation value is in Days, Weeks, Months, or Years. 

  
5. Select whether to Apply the formula to this row only or Apply the 

formula to all rows. 

  
6. Click OK to apply the formula. 

 

Validate the worksheet and post it. Once posted, the worksheet will be available for 
future reference. 

 UPDATE LISTING STATUS 

The update listing status is used to get an update from the online channel to verify if the 
catalog and the related products were successfully listed on the Commerce run-time 
(CRT) database. 

The job even gets the status and any error details associated with the publishing 
process. 

To open the Update listing status form, click Retail > Periodic > Update listing status. 

 

6. Select the Batch processing check box to run the job as a batch. 
 

7. Enter the Task description for the job. 
 

8. Select the Batch group from the drop-down list. 
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9. Select the Private check box if you wish to run the job as a private job. 
 

10. Click OK to run the job to send notifications to the customer. 

Note: 

The listing information can be viewed from the Retail > Common > Retail channels > 
Online stores. Select an online store, and click Listings to view the listing status by 
product. 

 

 PROCESS DELIVERY MODES 

Process delivery modes are used to explode the changes to a delivery mode when new 
online channels or products are associated with a delivery mode. 

To open the Process delivery modes form, click Retail > Periodic > Process delivery 
modes. 
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1. Select the Batch processing check box to run the job as a batch. 
 

2. Enter the Task description for the job. 
 

3. Select the Batch group from the drop-down list. 
 

4. Select the Private check box if you wish to run the job as a private job. 
 

5. Click OK to run the job to send notifications to the customer. 

Note: 

The delivery modes can be viewed by clicking Retail > Common > Retail channels > 
Online stores. Select an online store, and then click Setup > Modes of delivery to view 
the modes of delivery settings. 

 

 SYNCHRONIZE ONLINE ORDERS 

Orders generated through Omni-channel are online stores with either delivery or store 
pick-up. These will be synchronized from various online channels to the Microsoft 
Dynamics AX headquarters. 

To open the Synchronize online orders form, click Retail > Periodic > Synchronize 
online orders. 
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1. Select the Batch processing check box to run the job as a batch. 
 

2. Enter the Task description for the job. 
 

3. Select the Batch group from the drop-down list. 
 

4. Select the Private check box if you wish to run the job as a private job. 
 

5. Click OK to run the job to send notifications to the customer. 
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SEND EMAIL RECEIPTS 

OVERVIEW 

This module discusses email receipts, which are known as an environmentally friendly 
option when processing retail sales. The customer can decide whether to receive a 
printed receipt, an email receipt, or both. 

 Note 

The E-mail parameters need to be set up for sending the receipts to the customers. To 
open the E-mail parameters form, click System administration > Setup > System > E-
mail parameters. Enter the SMTP details and default values to be used for sending 
email. 

Registered customers 

Customers that have been set up in Microsoft Dynamics AX can choose which settings 
should apply to them. Specify the settings as follows: 

4. Click Accounts receivable > Common Forms > All Customers. 

5. Select a customer, and then click Edit. Go to Retail FastTab, under Receipt, 
and select an option in the Receipt option field: 

 POS – Select this option if the customer wants printed receipts only. 

 Email – Select this option if the customer wants email receipts only. 

 Both – Select this option if the customer wants both printed and email 
receipts. 

6. In the Receipt email field, enter the email address if the customer wants 
email receipts. 
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Unregistered customers 

The default receipt options for customers that have not been set up in Microsoft 
Dynamics AX can be entered in Retail Headquarters parameters. 

4. Click Retail > Setup > Retail Parameters. 

5. On the Posting, under Email receipt FastTab, select a receipt option: 

 POS – Select this option to print receipts by default. 

 Email – Select this option to email receipts by default. 

 Both – Select this option to both print and email receipts by default. 

6. In the Subject field, type the text that you want to appear by default in the 
Subject line of the emailed receipts. 

 

  



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

219 

 

Email Body Text 

The text to be displayed in the email message body can be set up as form notes. This 
way, you can send email messages in different languages, depending on the language of 
the particular customer or, if no customer is chosen, your company's language. The 
form note must be a Retail Headquarters receipt type. 

4. Click Accounts receivable > Setup > Forms > Form notes. 

5. Click New to create a new form note, and select the form as a Retail 
Headquarters Receipt and specify a language. 

6. On the Form note FastTab, enter the text that you want for the body of the 
email message. 

 

Send e-mail receipts 

To email receipts using a batch job, click Retail > Periodic > Send e-mail receipts.  
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7. Select the Batch processing check box to run the job as a batch. 
 

8. Enter the Task description for the job. 
 

9. Select the Batch group from the drop-down list. 
 

10. Select the Private check box if you wish to run the job as a private job. 
 

11. Click Recurrence to set the frequency of the job execution. 
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12. Click Alerts to configure an alert mechanism to receive notification on job 

completion or failures. 

 SEND EMAIL NOTIFICATIONS 

The send email notification is used to send email updates to the customers on the status 
of their order details. 

Customer can be notified for the following activities: 

i. Order created: An email notification can be sent when a new order is 
created for a customer. 

j. Order confirmed: An email notification can be sent when an order is 
confirmed. 

k. Picking completed: An email notification can be sent when the order 
items are picked for packing at a store or a distribution location. 
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l. Packing completed: An email notification can be sent when the packing is 
complete and order items are ready to be shipped. 

m. Order shipped: An email notification can be sent when the order is 
shipped, advising the customer of the delivery date and tracking 
information based on the shipping method selected. 

n. Payment failed: Email notification can be sent advising the customer 
regarding payment failure for the order. 

o. Customer created: Email notification can be sent for new customers. 
p. Password reset: Email notifications can be sent to advise customers 

when their account password is reset. 

To open the Process order email notifications form, click Retail > Periodic > Send email 
notifications. 

 

11. Select the Batch processing check box to run the job as a batch. 
 

12. Enter the Task description for the job. 
 

13. Select the Batch group from the drop-down list. 
 

14. Select the Private check box if you wish to run the job as a private job. 
 

15. Click OK to run the job to send notifications to the customer. 

Note: 
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Default email templates have been included out-of-box since the Microsoft 
Dynamics AX 6.2 release. However, retailers can add their own templates or modify 
the default templates to meet their requirements. 

One or more email notification profiles can be setup in Microsoft Dynamics AX. 
However, the default profile can be set up only in Retail parameters form. 

The existing Microsoft Dynamics AX email notification infrastructure has been 
leveraged for this feature. 

 

29.3 MASS UPDATE WORKSHEET 

The mass update worksheet allows a user to apply bulk product updates across product 
categories on products selected in a worksheet.  

A worksheet can be saved and recalled for later editing before validating and posting it 
to update the applicable products. Worksheet history is retained to allow users to 
review previous sets of changes. 

Worksheet Creation 

Create a mass update worksheet as follows: 

5. Click Retail > Periodic > Mass update worksheet. 
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6. Click New. On the form, the Properties that can be bulk updated are shown.  

7. Select the applicable Properties from different Areas by selecting the Selection 
check box. 

8. Click OK to generate the worksheet. 
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Add Products to the Worksheet 

Add products to the worksheet as follows: 

10. On the Mass update worksheet form, enter the Description for the worksheet. 

 

11. Click Add Products on the worksheet. 
12. Apply the Filters, and select the products to be updated. Various filters are present 

on the Add products form: 

 Hierarchy Products can be filtered on Category hierarchies, such as retail 
product hierarchy or procurement hierarchy. 

 Item Group – Select the Item group from the drop-down list. 

 Buyer Group – Select the vendor buyer group from the drop-down list. 

 Vendor account – Select the vendor account from the drop-down list. 
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13. Applicable Products shows the product list on the basis of filter criteria. In this 
section, select all or individual products to the Add Products section.  

14. Click Ok to add products to the worksheet for update. 

 

15. On the worksheet, the items are added to the Product Name column with values for 
reference. The remaining columns are blank and are updated only if a value is 
provided. 
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16. For the ease of data entry, update the first row with applicable values in the 
applicable columns, and then click Paste first row. Select the columns that have to 
be copied to all rows from the first row, and then click OK. 

 

17. If the field type is Price, then it can be updated by using a price formula. Select the 
Apply price formula to open the following form: 

 
On the Set the value in the selected column to area, follow these steps: 
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7. Select the price type. The options are Purchase Price, Purchase price 
charges, Sales price, Sales price charges, and Cost price. 

  
8. Chose the calculation type. The options are addition (+), subtraction (-), 

multiplication (*), and division (/). 

  
9. Enter the amount of the calculation value. 

  
10. Choose whether to Round calculate value or Do not round calculated value. 

  
11. Select whether to Apply the formula to this row only or Apply the formula 

to all rows. 

  
12. Click OK to apply the formula. 
 

18. If the field is of type Date, then it can be updated by a date formula. Select the Apply 
date formula to open the following form: 
 

 
 

On the Set the value in the selected column to area, follow these steps:  
 

7. Select the date type. The options are Date of Purchase Price, Date of 
Sales price, Date of Cost price, and Issue Date 

  
8. Choose the calculation type. The options are addition (+) and subtraction 

(-). 

  
9. Enter the calculation value. 
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10. Select whether the calculation value is in Days, Weeks, Months, or Years. 

  
11. Select whether to Apply the formula to this row only or Apply the 

formula to all rows. 

  
12. Click OK to apply the formula. 

 

Validate the worksheet and post it. Once posted, the worksheet will be available for 
future reference. 

29.4 UPDATE LISTING STATUS 

The update listing status is used to get an update from the online channel to verify if the 
catalog and the related products were successfully listed on the Commerce run-time 
(CRT) database. 

The job even gets the status and any error details associated with the publishing 
process. 

To open the Update listing status form, click Retail > Periodic > Update listing status. 

 

16. Select the Batch processing check box to run the job as a batch. 
 

17. Enter the Task description for the job. 
 

18. Select the Batch group from the drop-down list. 
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19. Select the Private check box if you wish to run the job as a private job. 
 

20. Click OK to run the job to send notifications to the customer. 

Note: 

The listing information can be viewed from the Retail > Common > Retail channels > 
Online stores. Select an online store, and click Listings to view the listing status by 
product. 

 

29.5 PROCESS DELIVERY MODES 

Process delivery modes are used to explode the changes to a delivery mode when new 
online channels or products are associated with a delivery mode. 

To open the Process delivery modes form, click Retail > Periodic > Process delivery 
modes. 
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6. Select the Batch processing check box to run the job as a batch. 
 

7. Enter the Task description for the job. 
 

8. Select the Batch group from the drop-down list. 
 

9. Select the Private check box if you wish to run the job as a private job. 
 

10. Click OK to run the job to send notifications to the customer. 

Note: 

The delivery modes can be viewed by clicking Retail > Common > Retail channels > 
Online stores. Select an online store, and then click Setup > Modes of delivery to view 
the modes of delivery settings. 

 

29.6 SYNCHRONIZE ONLINE ORDERS 

Orders generated through Omni-channel are online stores with either delivery or store 
pick-up. These will be synchronized from various online channels to the Microsoft 
Dynamics AX headquarters. 

To open the Synchronize online orders form, click Retail > Periodic > Synchronize 
online orders. 
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6. Select the Batch processing check box to run the job as a batch. 
 

7. Enter the Task description for the job. 
 

8. Select the Batch group from the drop-down list. 
 

9. Select the Private check box if you wish to run the job as a private job. 
 

10. Click OK to run the job to send notifications to the customer. 
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POST INVENTORY 

In Microsoft Dynamics AX for Retail, statements are used to group the retail transactions 
from the store. Statements contain a collection of inventory and financial transactions 
from the POS for a given store over a specified period of time. Processing of these 
statements results in posting of financial inventory transactions in Microsoft Dynamics 
AX. 

However, to account for the physical inventory in the system, there is a process to 
update the physical inventory without posting the statement. This basically means that 
the physical inventory is reserved. Then at a later time when the end-of-day statement 
is posted, the financial inventory is posted (revenue, issue, consumption, tax, and so on) 
and the inventory status changes to sold from reserved. 

Reserving Physical Inventory 

1. To update the POS transactions, ensure that P-Job in Retail > Periodic > Retail 
Scheduler > Distribution Schedule is running.  

 

2. Run the Retail > Periodic > POS posting > Post Inventory job. Select the store(s), 
and then click OK.  This reserves the physical inventory for the products sold 
against the statement. 
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3. To verify, click Retail > Inquiries > Retail Transactions and view the open 
transactions.  

 

4. On Inventory Transactions, the status is Reserved Physical, if there is sufficient 
on-hand inventory in system. Otherwise the status is On order (if working with 
physical negative inventory). 
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WORKERS 

OVERVIEW 

This module discusses workers, cashiers, and store managers created and managed 
within Dynamics AX for Retail.  

The workers in retail are an uptake from the Human resources module in AX 2012. 

The workers associated to a position. A position is always assigned to a job which drives 
the default POS permission associated to a user. The POS permissions can be overridden 
at a worker level. 

 

A job can be associated to multiple positions and a worker is associated to a position. 

The diagram below display the conceptual model depicting the connection between POS 
permission groups, jobs and workers. 
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 SET UP A JOB 

Before workers can perform their job duties in the retail store, you must set up the 
workers in Microsoft Dynamics AX. You must also assign appropriate permissions to the 
workers, so that they can log on and perform tasks by using the Microsoft Dynamics AX 
for Retail POS system. You must also set up the jobs and positions that are used in your 
retail stores, and then link workers to those jobs and positions.  

After you set up POS permissions to specify the tasks that workers can perform by using 
the POS system, you must define the jobs that the workers can perform. You must then 
link POS permissions to those jobs.  

1. Click Human resources > Common > Organization > Jobs.  

 

2. On the Jobs list page, on the Action Pane, in the New group, click Job to create a 
new job.  
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3. Enter a job title and description.  

 

4. Click the Job classification FastTab.  

5. Then, in the POS permission group field, select the POS permissions that apply 
to the job. 

6. When a worker is associated with the job, the POS permissions that are assigned 
to the job control the actions that the worker can perform in the POS system.  
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7. Complete any other fields that you require in the form. Set up Enterprise Portal 
profiles and users  

If you have set up Enterprise Portal for Microsoft Dynamics AX, you must set up user 
profiles for the employees who access Enterprise Portal. These profiles define each 
user's role and specify the store information that the user has access to.  

Use the following procedures to set up Enterprise Portal profiles and users. You can also 
view the Role Center for each profile.  

 SET UP A POSITION 

A position is an individual instance of a job. You assign each worker to a position. By 
linking a worker to a position, you associate that worker with a specific job. Therefore, 
you also assign the POS permissions that the worker requires to use the POS system in 
the retail store.  

1. Click Human resources > Common > Organization > Positions > Positions.  
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2. On the Positions list page, on the Action Pane, in the New group, click Position 
to create a new position.  

 

3. In the Create new position dialog box, in the Job list, select a retail job.  
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4. Enter the date that the position becomes active, and then click Create positions.  

5. In the Position form, complete any other fields that you require in the form. 

 

You can hire a new worker directly from the Position form. Alternatively, you can create 
a worker, and then assign the worker to the retail position.  

 SET UP A RETAIL WORKER 

Before a worker can perform job duties in a retail store, you must set up the worker in 
Microsoft Dynamics AX. You must also assign the worker appropriate privileges, so that 
the worker can log on and perform tasks by using the Microsoft Dynamics AX for Retail 
POS system.  
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Microsoft Dynamics AX for Retail uses the human resources features in Microsoft 
Dynamics AX to set up employee data, and to configure the job and position data that is 
used to create a staff member for retail processes. To set up a retail worker, you must 
complete the following tasks:  

1. Define the settings for point of sale (POS) permissions. The POS permission 
settings specify the actions that workers can perform when they use the POS 
system. Each staff member is assigned Retail POS permissions. For example, the 
permissions define whether the staff member can void transactions, perform 
tender declarations, or override prices. The permissions also define the 
maximum discount that the staff member can give. Each staff member can be 
assigned to only one store.  

2. Set up a job. A job is a collection of tasks and responsibilities that are required of 
any person who is assigned to the job. It is recommended to link POS permissions 
to each job for ease of management.  

3. Set up a position. A position is an individual instance of a job. You must assign 
each worker to a position. By assigning a worker to a position, you associate the 
worker with a specific job. Therefore the worker inherits the permissions from 
the job. 

4. Set up a worker. The information that you enter for a worker includes personnel 
details. You must assign each worker to an address book. The address book is 
used to assign the worker to a store.  

If you have set up Enterprise Portal for Microsoft Dynamics AX, you must set up user 
profiles for the employees who access Enterprise Portal. These profiles define each 
user's role and specify the store information that the user has access to. 

1. To create workers click on Retail > Common > Workers.   
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2. On the Workers list page, on the Worker tab, on the Action Pane, in the New 
group, click Hire new worker.  
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3. In the Create new worker form, enter the worker’s name. In the Worker type 
field, select whether the worker is an employee or a contractor. Enter the date 
that the worker’s employment starts. Then click Hire new worker. 
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i. Enter the First name of the new worker. 
ii. Enter the Middle name of the new worker. 

iii. Enter the Last name of the new worker. 
iv. Select the Legal entity to which the worker will belong from the drop 

down list. 
v. The Personnel number will be automatically populated if number 

sequence assigned or enter the personnel number manually. 
vi. Select the Worker type from the drop down list. The options available 

are Employee or Contractor. 
vii. Enter the Employment start date for the new worker. 

viii. Enter the Employment end date if the new worker is a contractor. 
ix. Assign a position – Select the check box to assign a position to the 

worker. 
x. Select the Position for the worker from the drop down list. 

xi. Enter the Assignment start date for the worker in the new position. 
xii. Enter the Assignment end date for the worker in the new position. 

 
 Note: 
The Personnel number field can be automatically populated based on the 
number sequence that is set up for the worker. The worker uses this number to 
log on to the POS system. 
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4. In the Worker form, on the Worker summary FastTab, in the Address books 
field, select the address book of the stores to assign the worker to. Microsoft 
Dynamics AX R2 for Retail uses the store address books that you select to link 
the worker to one or more stores.  

 Note 

Employee address book is used to associate workers (cashiers) to a retail store. 
Workers can be assigned multiple store addresses allowing them to work at multiple 
locations. The interaction of worker address book and store address book defines 
workers assigned to retail stores. 

5. Click the Retail link, and then, in the Screen layout ID field, select the POS screen 
layout if the worker uses a special screen layout on the POS system. If the worker 
uses the POS screen layout that is assigned to the store, leave this field blank.  
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6. In the Employment type field, select whether the staff member is a cashier, 
salesperson, or other type of employee.  

 

7. Under POS authentication, in the Password field, specify the password that the 
worker uses to log on to the POS system.  

8. To select a POS permission group for the worker, click the POS permissions link.  

 

9. In the POS position permissions form, do one of the following:  
o In the Position field, select a position for the worker.  
o Select the Override permissions check box, and then either select a 

permission group in the POS permission group field, or select the check 
boxes for the appropriate permissions.  

Click Here 
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You must assign the worker to a position. Otherwise, the worker does not have 
appropriate access to the POS system.  

10. Enter any other appropriate information in the Profile, Employment, Absence, 
Compensation, Payroll, and Competencies and development sections.  

 IMPORT THE RETAIL USER PROFILES 

Microsoft Dynamics AX user accounts need to be set up for each employee who 
requires access to Enterprise Portal. The below steps are required only if Enterprise 
portal access is required by the store users. 

1. Click System administration > Common > Users > User profiles.  

2. Click Import, and then click Import from AOT.  

3. Select the check boxes for the profiles to import, and then click OK.  

There are four retail user profiles:  
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 Retail Merchandising Manager  

 Retail Operations Manager  

 Retail Store Inventory Clerk  

 Retail Store Manager  

 

Assign users to the retail user profiles 

1. Click System administration > Common > Users > User profiles.  
2. Select a retail user profile.  
3. Click Add user, and then, under Select user, select a user.  

 

4. Under Select company, click All companies (Profile: %1). Alternatively, click 
Select companies, and then select the check boxes for the companies that you 
want.  
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5. Repeat steps 2 through 4 for the other retail user profiles.  

Assign stores to the users for each retail user profile 

By assigning a store to a user, you allow the user to access information for that store in 
Enterprise Portal.  

1. Click System administration > Common > Users > User profiles.  
2. Select a retail user profile, and then click the Users tab.  
3. Select a user, and then click Assign stores. 

 

4. Click New to add a store to the list. Then, in the Local store number field, select 
a store.  

5. Repeat steps 1 to 4 to add additional stores to the user profile. 
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View the Role Center for a retail user profile 

1. Click System administration > Common > Users > User profiles.  

2. Select a retail user profile.  

3. Click View role center.  

 

 ROLE BASED SECURITY FOR RETAIL 

Role-based security was introduced as part of Microsoft Dynamics AX 2012. As part of 
role based security, built in roles were added to Microsoft Dynamics AX that covered all 
functional aspects of the product. Microsoft Dynamics AX for Retail 2012 will introduce 
the uptake of role based security for functionality supported through the retail solution.  

Terms used in Security Setup for Dynamics AX 2012 

1. Roles: Where applicable, new retail roles will need to be created so that 
employees can be assigned to retail specific duties.  
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2. Processes: Functions that can be performed through headquarters and Retail 
POS will need to be organized in to processes in order to fit into the Microsoft 
Dynamics AX navigation structure for different process cycles.  

3. Duties: Duties will need to be defined and created in Retail POS that will consist 
of a set of privileges required to perform certain tasks and services related to the 
performance of an individual’s position.  

4. Privileges: Privileges will need to be defined and created. Discreet collections of 
these privileges make up individual duties within Microsoft Dynamics AX. 
Privileges can be considered menu item, form and field level securable within 
the back office.  

5. Permissions: Permissions are the access levels assigned to privileges. This could 
be considered the type of access to these privileges such as create, read, update 
or delete.  

High Level Relationship 

 

Following is the breakdown of Role Based Security framework in Microsoft Dynamics AX 
2012 for Retail: 

o 4 roles  
 Retail Store Manager  
 Retail Merchandising Manager  
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 Retail Operations Manager  
 Retail Warehouse Clerk  

o 59 duties  
o 190 privileges  
o 2300+ entry points covered  

Retail Roles  

As part of the feature, entry point level security was applied to all menus within the 
solution these entry points were then grouped into duties that were assigned to roles 
delivered out of the box. The roles and the duties/permissions assigned to them can be 
modified by the partner or end user to better suit the retailer’s needs and business 
processes. 

The following roles added for the retail solution with a brief explanation are as follows: 

 Retail Merchandising Manager: Responsible for catalog, assortment and pricing 
aspects of retail functionality.  

 Retail Operations Manager: Responsible for setting up retail reference data and 
entity management in areas such as stores, terminals, and profiles used by the 
point of sale terminals  

 Store Manager: The store manager has access to all Enterprise Portal related 
retail functionality including all supported reports as well as picking, receiving 
and stock count functionality. Access is based on stores assigned to the user 
through user profiles in system administration.  

 Store Inventory Clerk: Responsible for retail store inventory functions within EP. 
This includes order picking and receiving duties as well as the entry of stock 
counts. Access is based on stores assigned to the user through user profiles in 
system administration.  

 Retail Warehouse Manager : Responsible for retail warehouse inventory 
functions 

 

 Note:  
Some additional configuration related duties were added to the Microsoft Dynamics 
AX Information technology manager role that shipped with Microsoft Dynamics AX 
2012. These duties are mostly related to setup, configurations of store connect and 
services related configuration.  
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List of Duties Assigned by Security Role for Retail 

Retail Merchandising Manager:  
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Retail Operations Manager:  

 

 Store Manager: 
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 Store Inventory Clerk:  

 

 

 Retail Warehouse Manager:  

 

 

 TIME REGISTRATION 

For retail worker to enter time they must be set up as time registration workers.   

 Note: 
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Workers can only be activated as a time registration worker in the company that the 
worker is employed. 

 

20.8.1 ENABLE WORKERS TO REGISTER TIME AND ATTENDANCE 

1. Click Retail > Common > Workers.  

 
2. On the Workers list page, select the worker.  
3. On the Time registration tab, click Activate on registration terminals to open 

the Create time registration worker form.  

 
 Note: 

The Activate on registration terminals button is available only if you are 
working in the company that the worker is employed in.  
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4. The Active check box is selected by default. This indicates that the worker has 
been activated as a time registration worker.  

5. In the Activation date field, select a date. To activate it immediately leave it 
blank. To activate it in the future enter the future date. 

6. In the Calculation group field, select the group of workers that the worker's 
registrations are calculated with.  

a. To add a new Calculation Group right click on the field and select View 
Details 

 

b. Click New to add a new Calculation group  
c. Enter the Name and Description of the new calculation Group 
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d. To specify a password click on the General tab and put in the Password in 
the field. 

 

A supervisor or manager is responsible for calculating registrations for this group of 
workers.  

7. If the worker is responsible for calculating registrations for other workers, select 
a calculation group in the Default calculation group field. When the worker 
opens the Calculate form, this calculation group is displayed. This is the same 
selection from the Calculation Group.  

8. In the Approval group field, select the group of workers that the worker's 
registrations are approved with. A shop supervisor or manager is responsible for 
approving registrations for this group of workers.  

a. To add a new Approval group, right click on the field and select View 
Details 

b. Click New to add a new Calculation group  
c. Enter the Name and Description of the new calculation Group 
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d. To specify a password click on the General tab and put in the Password in 
the field. 

 

9. In the Standard profile field, select the work time profile that is used to calculate 
time and pay if the worker makes no registrations during a work day.  

Note 

Profiles cannot be created by location 

a. To create a new Standard profile, right click on the field and select View 
Details 

b. Click New  to create new profile 
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c. In the Profile field, type a name for the profile.  
d. In the Description field, type a description for the profile.  
e. Click the General FastTab.  

 

f. In the Profile section, press CTRL+N to create a new line.  
g. In the Profile type field, select the Profile type for this profile line.  
h. Enter starting and ending work times in the Start and End fields for the 

selected profile type.  
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i. If necessary, you can create tolerances on a profile type line. A tolerance 
is a period, in minutes, before or after the job has started or ended. The 
profile type is still valid if registrations are made within the tolerance 
period. Enter tolerances in minutes in the Tolerance before start, 
Tolerance after start, Tolerance before end, and Tolerance after end 
fields.  

j. Use the Switch code field to enable workers to make a registration on an 
alternative profile type than the one inserted in the profile. For example, 
if you have included a Flex+ profile type in your profile, you can enable 
workers who have flextime to be able to convert registered flextime into 
overtime. In that case, in the Switch code field, select the option for 
converting flex time into overtime.  

k. You can enable workers to cancel breaks in their profile. This might be 
useful in a situation where a supervisor asks workers to cancel all breaks 
for the workday so that rush orders can be completed. In that case, you 
must select an alternative profile type to the Break profile type. The 
alternative profile is as a basis for calculating time registrations if the 
worker cancels the break.  

l. In the Secondary field, on the Break profile type line, select the profile 
type that should replace a Break profile type, for example, Overtime.  

m. In the Start day and End day fields, select the appropriate workday, 
according to the selections you made in the Start and End fields in step 8.  

Note 

Typically, you select the same weekday as the day that you are creating 
the profile for. However, if you are creating a profile for a night shift, a 
profile type may start late in the evening on one weekday and end after 
midnight on the following week day. In that case, you must select one 
weekday in the Start day field, and the following weekday in the End day 
field. 

n. When you have created one weekday in a profile, the easiest way to set 
up the other weekdays is to copy that first weekday, and then adjust the 
other days, as needed.  

i. In the Profile form, on the General tab, select the weekday to 
copy in the Weekday section.  

ii. Click Copy, and select Copy day.  
iii. Select the weekdays to copy the profile to, and select the 

Overwrite check box.  
iv. If necessary, adjust the other weekdays if they have different 

profiles from the weekday that you copied.  
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o. If you have already created a work time profile covering a whole week, 
you can copy the entire profile and then make adjustments to the new 
profile, as needed. 

i. In the Profile form, select the profile to copy.  
ii. Click Copy, and select Copy profile.  

iii. Enter the name of the new profile in the Copy to field. 

Note 

To overwrite an existing profile, select that profile in the Copy to field, and then 
select the Overwrite check box. 

p. If your company works night shifts, the profile day might start before 
midnight. If so, you can make the following adjustments for the night 
shift profile on the General tab, in the Profile staggering section:  

i. In the New 24-hour period field, enter a starting time for the next 
profile day.  

ii. In the 24-hour period start field, select Previous day. 

Tip 

If you want registrations made in the current day to apply to the next 24-hour period, 
select the Push check box. 

q. Some workers may not have fixed work hours. Consequently, the 
Overtime / flex limit and Max. flex limit fields on the General tab can be 
used to determine Standard time in hours, and the maximum number of 
flexible hours allowed before converting registered time into overtime.  

For example, if you insert the number 40 in the Overtime / flex limit 
field, and the number 10 in the Max. flex limit field, it means that the 
worker has a 40-hour work week. If the worker works more than 50 hours 
during a week, 40 hours are considered standard work time, 10 hours are 
added to the flex balance, and the number of hours exceeding 50 hours is 
considered to be overtime.  

10. In the Pay agreement field, select the pay agreement that is used when the 
worker's pay is calculated.  
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 To create a new Pay Agreement click New 

 Enter the Pay Agreement and  Description 

 On the General  FastTab, enter the From date and To date 

 Enter the minutes that will trigger pay deduction 

 Enter the Rounding from and Round-off for the overtime Round off 

 In the Pay agreements form, click Pay agreement lines.  

 Create a new pay agreement line for the relevant week days for the pay 
type.  

11. In the Period code field, select the pay period that is used when the worker's pay 
is calculated.  

12. In the Profile group field, select the group that the worker belongs to. Profile 
groups contain one or more work time profiles that can be applied when a 
worker makes clock-in and clock-out registrations. The profile that you select 
depends on the date or the time of day that the worker makes a clock-in 
registration. For example, the worker may work during a day shift or a night 
shift.  

13. Select the New bundle check box to stop the worker's active jobs when he or she 
starts a new job. If you clear the check box, new jobs are bundled with the jobs 
that the worker previously started, but that have not yet been stopped or 
completed. The New bundle check box relates to job bundling. If you use job 
bundling, a worker can start multiple jobs at the same time in the Job 
registration form in Production control. If multiple jobs are started at the same 
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time, but they are not completed at the same time, the job bundling 
functionality calculates the time that is spent on each job.  

14. In the Category field, select the cost category that is used when the worker 
makes registrations for projects and project activities.  

15. Select the Use timecard check box to allow the worker to make registrations on 
the electronic timecard in Time and attendance.  

16. In the Configuration field, select the registration form that is displayed when the 
worker logs on to the Job registration form in Production control.  

17. Select the Flex allowed check box to allow the worker to register flextime.  
18. If the worker is allowed to register flextime, select a flex group in the Flex group 

ID field.  
19. Click OK to save and close the form. 

20.8.2 SETUP TIME REGISTRATION WORKER 

To facilitate management of time registration worker other tasks and setup can be 
performed. These can be done through Retail > Common > Workers. Select a worker 
and from Time registration tab click on Setup time registration worker.  

 

 

The following options are given: 
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 Absence registration: Use the Absence registrations list page to view 
absence registrations and create new absence registrations for a worker. 

 

 

 

 

 

 

 

 

o To create a new registration click New  to add a new record 
o Enter the start date/time and end date/time of the absence 
o Enable Interrupt check box to automatically stop the absence 

registration if the worker makes a clock-in registration before the 
specified end date and time 

o If the registration was Interrupted this will be enabled 
o Select the Absence group and the Absence code. New ones can 

be added by going to the Human Resources > Setup > Absence > 
Absence groups. 

o The description field shows the description of the Absence code. 

 Profile calendar: The profile calendar is used to apply a specific work time 
profile to one or more workers on specific dates. When you create a 
profile calendar entry for a worker, the worker’s time registrations are 
calculated for a profile that is different from his or her standard work time 
profile for a specific period of time. You can create a profile calendar 
entry for one day or for a longer period of time.  
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 Click New to create a line.  

 In the Compose profile calendar form, in the Profile calendar 
code field, select the worker or group of workers to add a work 
time profile to:  

o All – Apply the work time profile to all workers.  
o Group – Apply the work time profile to a group of workers.  
o Table – Apply the work time profile to a specific worker.  

 Depending on the selection in the Profile calendar code field, 
enter a worker ID or a profile group ID in the Profile calendar 
relation field.  

 In the Date field, enter the date to add the profile.  

 In the Profile field, select the profile to use.  

 In the Special day field, click a selection, if applicable. You can use 
this field to change pay or add absence registrations.  

 Flex balance: This form shows the worker’s flex balance based on the flex 
transactions.  Also has the ability to the correction of the flex. 
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Flex: Recalculates the flex balance. 

 

 

 Opening flex balance: Sets the worker’s opening flex balance and 
recalculates the balance based on the balance. 

 Worker balances: Shows the worker’s balance based on the transactions. 

 Recalculate worker balances: The functionality to recalculate the 
worker’s overall balance. 

 Switch code: This is used for switching a registration for another 
registration or for activating certain pay lines in a pay agreement. Switch 
codes can be used to override standard settings, for example, in case a 
supervisor allows a worker to take time off instead of receiving unpaid 
overtime. Switch codes can also be used to enable payment of a specific 
premium to a worker. Switch codes are valid for the entire profile day.  

 Temporary group assignment:  This form is used to second a worker to 
another calculation group or approval group for a specific period of time 

20.8.3 CALCULATE TIME AND REGISTRATION FOR WORKERS 

You can calculate time and attendance registrations for workers in the following ways:  

 Calculate registrations for all workers who are assigned to a calculation group.  
 Calculate registrations for a specific worker.  
 Calculate registrations by using a batch job.  

You can use the Day view and Week view filters as follows:  
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 Day view – View registrations for all workers for a selected weekday.  
 Week view – View registrations for a selected worker for a selected week.  

20.8.3.1 Calculate registrations for all workers in a calculation group  

1. Click Human resources > Common > Time and attendance > Calculate.  

 

 

 

 

 

 

 

 

 

 

2. In the Week or Date field, select the week or date to calculate registrations for.  
3. In the Calculation group field, select the calculation group to calculate 

registrations for, and then click OK.  
4.  
5. In the Calculate form, click Update > Calculate.  
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6. In the Calculates jobs form, verify that the calculation group is selected in the 
Calculation group field.  

7. If you use a workflow for approvals, select the Submit to workflow check box in 
the Calculates jobs form.  

8. Click Close.  

Note  

If registrations contain errors because of missing information or for other reasons, you 
must correct the registrations, and then calculate the registrations again. To view the 
worker registrations that contain errors, click Display errors. The Error tab displays 
information about the type of error.  

20.8.3.2 Calculate registrations for one worker at a time  

You can calculate registrations for a specific worker. Typically, you calculate registrations 
for a worker after you have corrected registration errors for that worker.  

1. Click Human resources > Common > Time and attendance > Calculate.  
2. In the Week or Date field, select the week or date to calculate registrations for.  
3. In the Calculation group field, select the calculation group to calculate 

registrations for, and then click OK.  
4. In the Calculate form, select the worker in the upper pane and click Select.  
5. Select the Calculated check box for the registration.  
6. Click Close.  

20.8.3.3 Reverse calculated registrations  

You can reverse the registrations that have been calculated for a worker. However, you 
cannot reverse calculated registrations after payroll information for the period has been 
exported to the payroll system. Also, if registrations have been approved, you can 
reverse the calculated registration only in the Approve form.  

1. Click Human resources > Common > Time and attendance > Calculate.  
2. In the Week or Date field, select the week or date to calculate registrations for.  
3. In the Calculation group field, select the calculation group to calculate 

registrations for, and then click OK.  
4. In the Calculate form, select the worker in the upper pane and click Select.  
5. Clear the Calculated check box for the registration.  
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6. Click Close.  

Tip  

If you have changed the registrations, and you want to restore the original values, delete 
all lines, and then click Restore lines.  

20.8.3.4 Calculate registrations by using a batch job  

1. Click Human resources > Common > Time and attendance > Calculate.  
2. In the Week or Date field, select the week or date to calculate registrations for.  
3. In the Calculation group field, select the calculation group to calculate 

registrations for, and then click OK.  
4. In the Calculate form, click Update, and then click Calculate. 

 

 

 

 

 

 

 

 

In the Calculates jobs form, click the Batch tab.  

 

5. Start the batch job.  

Note  

If you use a workflow for approvals, select the Submit to workflow check box.  
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6. Click OK.  

20.8.4 APPROVE TIME AND ATTENDANCE REGISTRATION 

After each work day, workers’ registrations must be calculated and approved. You can 
approve registrations after they have been calculated, and no errors occurred during 
calculation. You can approve registrations by using one of the following:  

 A workflow  
 A batch job  
 Manually for an approval group  
 Manually for one worker at a time  

20.8.4.1 Approve registrations using a workflow  

 

 

The approval workflow is an automatic approval process. All registrations are validated 
against the rules in the approval workflow. Only deviations that are not accepted in the 
workflow must be approved manually. The worker who is responsible for calculating 
registrations, for example, a team leader, initiates the approval process. The worker who 
is responsible for approving registrations, for example, a payroll administrator, receives a 
message regarding the need for manual approval only when some registrations could 
not be approved according to the approval workflow.  

1. Click Human resources > Common > Time and attendance > Approve.  

 

 

 

 

 

 

 

 

 

 

2. Select the approval date in the Date field.  
3. Select your group in the Approval group field.  
4. In the Approve form, select the worker in the upper pane, on the Overview tab.  

 

javascript:void(0)


Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

273 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. Click the Action button. If the worker’s registrations are ready for approval, the 
Approve and Reject options are available.  

o To approve, click Approve.  
o To reject, click Reject, and insert a note explaining why the registrations 

are rejected.  

20.8.4.2 Approve registrations using a batch job  

1. Click Human resources > Common > Time and attendance > Approve.  
2. Select the approval date in the Date field.  
3. Select your group in the Approval group field.  
4. Click Update and Approve.  
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5. Start the batch job.  

20.8.4.3 Approve registrations for all workers in an approval group  

1. Click Human resources > Common > Time and attendance > Approve.  
2. Select the approval date in the Date field.  
3. Select your group in the Approval group field.  
4. Click Update and Approve.  
5. Click OK.  

Note  

If the approval process returns errors on some registrations, for example because of 
missing information, you must edit those registrations and approve again.  

Tip  

To see a list of worker registrations that contain errors in the registration lines, click 
Display errors. The Error tab provides information about the type of error.  

20.8.4.4 Approve registrations for one worker at a time  

 

You typically must approve registrations for an individual worker after you have 
corrected errors for that worker.  

1. In the Approve form, select the worker in the upper pane.  
2. Select the Approved check box for the worker.  
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20.8.4.5 Reverse an approval  

Approved registrations for a worker can be reversed until payroll information for the 
period has been exported to the payroll system. Do the following to reverse approved 
registrations for a worker:  

1. In the Approve form, select the worker in the upper pane.  
2. Clear the Approved check box.  

Tip  

If you have made several corrections to the registrations, and, therefore, must restore 
the lines to their original value, delete all lines, and then click Restore lines.  

Once approved the data can be exported out of the system. These can be exported out 
as CSV files to be imported into a payroll system. 

20.8.5 INQUIRE JOURNAL REGISTRATION 

To inquire on time registration transactions on journal click on Retail > Common > 
Workers 

The Workers form will open. Select the worker from the list to view time registration. 

Click on Journal registration from the Inquiries group on the Time Registration tab. 

 

The Overview tab displays all the information related to the time registration. 
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It also displays other information if the time registration is related to project or 
production. 

 

The General tab displays detailed information for the time entries from the Overview 
tab 
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The Error tab shows information if there are any errors associated with the transaction. 

 

The Financial dimensions show the dimension related information associated with the 
time entry. 
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20.8.6 INQUIRE TRANSFERRED REGISTRATION 

A transferred registration is posted to an activity or job that it relates to, for example, a 
production order or a project. Also, payroll transactions are generated for each worker 
based on the registrations. 

To view the transferred registration click on Retail > Common > Workers 

The Workers form will open. Select the worker from the list to view time registration. 

Click on Transferred registration from the Inquiries group on the Time Registration tab. 

 

The information available is related to the activity and job. 

20.8.7 INQUIRE RAW REGISTRATION 

Use this form to view raw registration for all time registration workers. 

To view the raw registration click on Retail > Common > Workers 

The Workers form will open. Select the worker from the list to view time registration. 

Click on Raw registration from the Inquiries group on the Time Registration tab. 

 

The form consists of the following: 

The Overview Tab that shows the registrations made by the worker on the selected 
date. 

The General tab shows the detailed information related to production feedback for the 
registration selected on the Overview tab. 

There is functionality to clean up and load raw job. This can be done by selecting the 
Clean up registration and Load registrations buttons respectively. 
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20.8.8 INQUIRE PAYROLL STATISTICS 

You can view the calculation of workers’ pay for different types of wages, such as 
standard time and overtime. The basis for a payroll statistic is one or more pay types 
that are summarized over a specific period of time. 

To view the payroll statistics click on Retail > Common > Workers 

The Workers form will open. Select the worker from the list to view payroll. 

Click on Payroll statistics from the Inquiries group on the Time Registration tab. 

 

The form consists of the following: 

The Overview Tab that shows the payroll information including the balance, change and 
adjustments for the worker. 

The General tab shows the detailed information related to payroll information for the 
registration selected on the Overview tab. 
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The Set adjustment button can be used to adjust the amount for the adjustment. 
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30 RETAIL INQUIRIES AND REPORTS 

OVERVIEW 

This module provides information about inquiries and reports.  

1. View retail store transactions  

2. View online store transactions 

3. View retail sales  

4. View Retail POS shifts  

5. View posted statements  

6. View credit memos  

7. View or unlock gift cards  

8. View loyalty cards  

9. View Commerce Data Exchange: Synch Service Messages 

10. View retail reports  

The standard reports that are included with Microsoft Dynamics AX can be used in 
Microsoft Dynamics AX for Retail. However, Microsoft Dynamics AX for Retail also 
provides additional inquiry capabilities and reporting options.  

Both inquiries and reports provide filtering and sorting. Therefore, you can quickly view 
the information that you want. Additionally, you can perform custom filtering by date. 
You can also generate transaction-level and statistics-level reports based on the time, so 
that you can analyze the sales flow throughout the day. Additionally, you can display a 
graphical representation of sales by item and store.  

Microsoft Dynamics AX for Retail provides reports that are built on statistic tables, item 
value entries, and transactions from the registers. These reports can help you determine 
which items or variants are selling best, and which stores, registers, and staff are 
performing best.  

All the standard sales reports that are included with Microsoft Dynamics AX can be used 
to analyze sales information. However, the standard Microsoft Dynamics AX reports do 
not include products that are included in statements that have not been posted. 
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The following table lists the forms that support the Inquiries and reports business 
process component. The table entries are organized first by task, and then alphabetically 
by the name of the form that is used. 

Note: To open some of the forms in the following table, you must enter information or 
parameter settings.  

 

Business process 
component task 

Form name Usage 

View retail store 
transactions.  

Retail store 
transactions 

View transactions specific to retail 
stores.  

View online store 
transactions.  

Retail store 
transactions 

View transactions specific to online 
stores.  

View retail sales.  Retail  
View retail sales by date and 
category.  

View retail shifts.  Shifts  
View information about the shifts 
from individual stores, including Z 
reports.  

View open statements  
Open statements list 
page  

View all open statements.  

View posted statements.  Statement journal  
View statements that have been 
posted.  

View credit memos.  Credit memo table  
View the retail credit memos that 
have been issued.  
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Business process 
component task 

Form name Usage 

View gift cards.  Gift cards  
View information about all the retail 
gift cards that have been issued.  

View loyalty cards.  Loyalty cards  
View information about all the retail 
loyalty cards that have been issued.  

View Microsoft Dynamics 
AX for Commerce Data 
Exchange: Synch Service 
messages.  

Commerce Data 
Exchange: Synch 
Service messages  

View messages that have been sent 
from Commerce Data Exchange: 
Synch Service.  

View retail reports.  Retail store metrics  

View key information about retail 
stores, so that you can compare 
performance by store, employee, 
and product.  

 

Sales performance by 
products  

View and compare sales 
performance by product during 
periods that you specify.  

 

Sales performance by 
retail product category  

View and compare sales 
performance by retail product 
category during periods that you 
specify.  

 

Sales performance by 
sales category  

View and compare sales 
performance by sales category 
during periods that you specify.  

 Gross margin return 
on inventory 

View the gross margin return on 
inventory investment (GMROII) of 
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Business process 
component task 

Form name Usage 

investment (GMROII) 
by products 

product inventory by product. 

 

Gross margin return 
on inventory 
investment (GMROII) 
by category 

Measure inventory productivity by 
reviewing the gross margin return on 
inventory investments (GMROII) of 
product inventory by product 
category. 

 
Performance by 
terminal 

View the retail terminals that are 
performing the best within an 
operating unit. 

 
Top 10 OU performers 
in current year 

View the top ten performing stores, 
based on sales and gross margin. 

 
Trend by operating 
unit 

View and compare the sales trends 
for selected retail channels for a 
selected period of time. 

 
Sales comparison year 
over year by operating 
unit 

View and compare the sales trends 
for one or more retail channels in an 
operating unit. 

 

30.1.1 VIEW TRANSACTIONS 

You can view a list of transactions for all statements for retail stores or for a specific 
statement. The statement posting process is used to account for the transactions that 
occur in Microsoft Dynamics AX for Retail POS. The statement posting process uses 
Retail Scheduler to transmit a set of the point-of-sale (POS) transactions to the 
Microsoft Dynamics AX client so that you can view them in this form.  
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In Microsoft Dynamics AX 2012 R2, you can also view a list of transactions for all 
statements for online stores.  

The following types of transaction are included in the list:  

 Logon  
 Logoff  
 Sales  
 Payment  
 Remove tender  
 Float entry  
 Change tender  
 Tender declarations  
 Voided  
 Open drawer  
 Negative adjustment  
 End of day  
 End of shift  
 Sales order  
 Sales invoice  

View transactions  

1. To view the transactions for all statements for retail stores:  

  

 Click Retail > Inquiries > Retail store transactions. Transactions are listed in the 
left pane in the Retail store transactions form.  

  

 Or 

  

 To view the transactions for all statements for online stores:  

  

Click Retail > Inquiries > Online store transactions. Transactions are listed in the 
left pane in the Online store transactions form.  
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2. To view the transaction for a specific statement: Click Retail > Inquiries > Posted 
statements. In the Statement journal form, click Inquiries, and then click 
Transactions. Transactions are listed in the left pane in the Transactions form.  

  
3. Depending on your version of the product, do one of the following to add or 

remove filters for query results: 

  

  In Microsoft Dynamics AX 2012 R2: In the transactions form, click in 
the left pane, and then press CTRL+G to set the filter parameters and 
filter the transactions in the list.  

 Otherwise, in the transactions form, click the filter buttons on the 
toolbar. To view only posted transactions or un-posted transactions, 
use the filter in the Entry status column.  

4. To view a sale, payment, or reason code that is associated with a transaction  

 In the transactions form, select the transaction, click Transactions, 
and then select an option.  
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30.1.2 VIEW RETAIL SALES 

1. Click Retail > Inquiries > Retail sales.  

The Retail form displays a list of the sales transactions that have been performed 
at the stores. Microsoft Dynamics AX for Retail retrieves records based on the 
date range, time range, retail hierarchy, and item number.  

2. To view only the transactions that you want, you can specify a value for all or 
some of the parameters. You can also view only posted transactions or open 
transactions.  

3. To view the on-hand availability of an item, the inventory transactions that 
pertain to the line, and lot inquiries, select a product, click Inventory, and then 
select an option.  

30.1.3 VIEW RETAIL POS SHIFTS 

You can use the Shifts form to look up closed shifts from stores. If some shifts did not 
post during statement posting, this form can help you determine the reason. Shifts have 
unique numbers and are associated with specific registers.  

The information on the Details tab includes the information that is on X reports.  

You can also use this form to look up previous Z reports.  

1. Click Retail > Inquiries > Shifts.  

 

2. To filter the list, follow one or more of these steps:  
o In the Store number field, select the store to view shifts for.  
o In the Terminal number field, select the terminal to view shifts for.  
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o In the Shift from date field, select the starting date for the range of shifts 
to view.  

o In the Shift to date field, select the end date for the range of shifts to 
view.  

 

3. To view the details of a shift, select the shift, and then click the Details tab. 

 

4. To view the Z report for a shift, select the shift, click Functions, and then click Z-
Report.  

 

5. To view the transactions that are included in a shift, select the shift, and then 
click Inquiry. Then click the option for the type of transactions to view.  
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30.1.4 VIEW POSTED STATEMENTS 

The Statement journal form displays a list of all statements and statement lines that 
have been posted. There is one statement line per payment method per register. You 
can view a list of the transactions that are associated with any statement or statement 
line. These transactions include tender declaration transactions, payment transactions, 
and banked tender transactions. You can also view the vouchers that are included in the 
sales orders for each statement. These vouchers include sales vouchers, payment 
vouchers, discount vouchers, and the special vouchers that are created by Microsoft 
Dynamics AX for Retail.  

To sort the results of the inquiry, click the column headers. To filter the data based on 
any field in the header or any line in the form, click the filter buttons on the toolbar. For 
example, filter the upper pane by a specific store, and then filter the lower pane by a 
specific register.  

To access the Statement journal form, do the following:  

 Click Retail > Inquiries > Posted statements.  
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30.1.5 VIEW CREDIT MEMOS 

Credit memos are vouchers that can be issued and redeemed at the stores. Use the 
following procedure to view the credit memos that have been issued.  

1. Click Retail > Inquiries > Credit memo.  

The Credit memo table form displays a list of all the retail credit memos that 
have been issued. Each line includes the number of the credit memo, the date 
and time of the transaction, and the amount or value of the credit memo. If the 
credit memo has been redeemed, the Applied check box is selected, and the 
applied amount, applied date, and applied time are updated accordingly.  

 

2. You can filter the transactions for credit memos based on the transaction and 
ranges for the applied date. Use the query groups that are provided in the form. 
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3. A report that contains the data is displayed on the screen. To print this report, 
click Print in the Credit memo table form.  

 

30.1.6 VIEW OR UNLOCK GIFT CARDS 

The Gift cards form displays information about retail gift cards that have been issued 
and the transactions that are linked to them. The form displays card numbers in the 
upper pane and transactions that are related to each card in the lower pane.  

To prevent gift cards balances from being overdrawn, gift cards are locked until each 
related transaction is posted. If a network failure or other problem prevents 
transactions from posting, you can manually unlock a gift card by using the following 
procedure. To view gift cards, open the Gift cards form by following step 1.  

1. Click Retail > Inquiries > Gift cards.  
2. Select the gift card in the list, click Functions, and then click Unlock. 

 

30.1.7 VIEW LOYALTY CARDS 

The Loyalty cards form displays information about all the retail loyalty cards that have 
been issued and the transactions that are linked to those cards. The upper pane of the 
form displays card numbers, and the lower pane displays the transactions that are 
related to each card.  

1. Click Retail > Inquiries > Loyalty cards.  



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

13 

 

 

2. To view information about a specific loyalty customer, select a loyalty card in the 
list, click Inquiries, and then click Loyalty customer.  

 

30.1.8 VIEW RETAIL REPORTS 

Microsoft Dynamics AX includes numerous reports that you can use to gain valuable 
insight into your business. Additionally, the Retail module includes the following 
reports:  

 Retail store metrics – View key information about retail stores to compare 
performance by store, employee, and product.  

 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

14 

 

 Sales performance by sales category – View and compare sales performance by 
sales category during periods that you specify.  

 

 Sales performance by products – View and compare sales performance by 
product during periods that you specify.  

 

 Sales performance by retail product category – View and compare sales 
performance by retail product category during periods that you specify. 
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30.1.9  VEW COMMERCE DATA EXCHANGE: SYNC SERVICE MESSAGE 

Commerce Data Exchange: Synch Service is a service that shares data among retail 
components. These components include the head office, stores, and individual point of 
sale (POS) terminals. Retail Scheduler is used to manage the distribution of data 
between the head office and the stores.  The messages that is stored in the Commerce 
Data Exchange: Synch Service database in the tables IncomingMessages and 
OutGoingMessages can be moved to the AX HQ database by enabling the RSC upload 
options. These messages then can be viewed by the following 

3.  Click Retail > Inquiries > Commerce Data exchange: Synch service message 

 

4. To view information about a specific messages click on Message Details. This will 
show the in depth information of the message. The Cancel function is also 
available here to cancel the message. 
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5. To view the hierarchy of the message click on the View message tree. The 
following form will open showing the tree hierarchy. 
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The above will show where the error occurred. 

6. To cancel any message select the message and click Cancel. 
7. The form has the following filters: 

1. Show errors only: This will only show messages that have errors. 
2. Related Messages:  
3. Start Date/Time and End Date/Time: This will show the messages that 

were created between the date range. 
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31 WORKERS 

OVERVIEW 

This module explains how workers are cashiers and store managers created and 
managed at Microsoft Dynamics AX for Retail. The workers in retail are an uptake from 
the Human resources module in Microsoft Dynamics AX 2012. 

The workers are associated with a position. A position is always assigned to a job, which 
drives the default POS permission associated with a user. The POS permissions can be 
overridden at a worker level. 

 

A job can be associated with multiple positions, and a worker is associated with a 
position. 

The following diagram shows the conceptual model of the connections among POS 
permission groups, jobs, and workers. 
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 SET UP A JOB 

Before workers can perform their job duties in the retail store, you must set up the 
workers in Microsoft Dynamics AX. You must also assign appropriate permissions to the 
workers, so that they can log on and perform tasks by using the Microsoft Dynamics AX 
for Retail POS system. You must also set up the jobs and positions that are used in your 
retail stores, and then link workers to those jobs and positions.  

After you set up POS permissions to specify the tasks that workers can perform by using 
the POS system, you must define the jobs that the workers can perform. You must then 
link POS permissions to those jobs.  

1. Click Human resources > Common > Organization > Jobs.  

 

2. On the Jobs list page, on the Action Pane, in the New group, click Job to create a 
new job.  
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3. Enter a job title and description.  

 

4. Click the Job classification FastTab.  

5. Then, in the POS permission group field, select the POS permissions that apply 
to the job. 

When a worker is associated with the job, the POS permissions that are assigned 
to the job control the actions that the worker can perform in the POS system.  
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6. Complete any other fields that you require in the form. Set up Enterprise Portal 
profiles and users.  

If you have set up Enterprise Portal for Microsoft Dynamics AX, you must set up user 
profiles for the employees who access Enterprise Portal. These profiles define each 
user's role and specify the store information that the user has access to.  

Use the following procedures to set up Enterprise Portal profiles and users. You can also 
view the Role Center for each profile.  

 SET UP A POSITION 

A position is an individual instance of a job. You assign each worker to a position. By 
linking a worker to a position, you associate that worker with a specific job. Therefore, 
you also assign the POS permissions that the worker requires to use the POS system in 
the retail store.  

1. Click Human resources > Common > Organization > Positions > Positions.  
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2. On the Positions list page, on the Action Pane, in the New group, click Position 
to create a new position.  

 

3. In the Create new position dialog box, in the Job list, select a retail job.  
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4. Enter the date that the position becomes active, and then click Create positions.  

5. In the Position form, complete any other fields that you require in the form. 

 

You can hire a new worker directly from the Position form. Alternatively, you can create 
a worker, and then assign the worker to the retail position.  

 SET UP A RETAIL WORKER 

Before a worker can perform job duties in a retail store, you must set up the worker in 
Microsoft Dynamics AX. You must also assign the worker appropriate privileges, so that 
the worker can log on and perform tasks by using the Microsoft Dynamics AX for Retail 
POS system.  

javascript:void(0)
javascript:void(0)
javascript:void(0)


Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

24 

 

Microsoft Dynamics AX for Retail uses the human resources features in Microsoft 
Dynamics AX to set up employee data, and to configure the job and position data that is 
used to create a staff member for retail processes. To set up a retail worker, you must 
complete the following tasks:  

1. Define the settings for point of sale (POS) permissions. The POS permission 
settings specify the actions that workers can perform when they use the POS 
system. Each staff member is assigned Retail POS permissions. For example, the 
permissions define whether the staff member can void transactions, perform 
tender declarations, or override prices. The permissions also define the 
maximum discount that the staff member can give. Each staff member can be 
assigned to only one store.  

2. Set up a job. A job is a collection of tasks and responsibilities that are required of 
any person who is assigned to the job. We recommend that you link POS 
permissions to each job for ease of management.  

3. Set up a position. A position is an individual instance of a job. You must assign 
each worker to a position. By assigning a worker to a position, you associate the 
worker with a specific job. Therefore the worker inherits the permissions from 
the job. 

4. Set up a worker. The information that you enter for a worker includes personnel 
details. You must assign each worker to an address book. The address book is 
used to assign the worker to a store.  

If you have set up Enterprise Portal for Microsoft Dynamics AX, you must set up user 
profiles for the employees who access Enterprise Portal. These profiles define each 
user's role and specify the store information that the user has access to. 

1. To create workers, click Retail > Common > Workers.   
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2. On the Workers list page, on the Worker tab, on the Action Pane, in the New 
group, click Hire new worker.  
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3. In the Create new worker form, enter the worker’s name. In the Worker type 
field, select whether the worker is an employee or a contractor. Enter the date 
that the worker’s employment starts. Then click Hire new worker. 
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1. Enter the First name of the new worker. 
2. Enter the Middle name of the new worker. 
3. Enter the Last name of the new worker. 
4. Select the Legal entity to which the worker will belong from the 

drop-down list. 
5. The Personnel number is automatically populated if a number 

sequence is assigned. If not, enter the number manually. 
6. Select the Worker type from the drop-down list. The options 

available are Employee or Contractor. 
7. Enter the Employment start date for the new worker. 
8. Enter the Employment end date if the new worker is a contractor. 
9. Assign a position – Select the check box to assign a position to the 

worker. 
10. Select the Position for the worker from the drop-down list. 
11. Enter the Assignment start date for the worker in the new 

position. 
12. Enter the Assignment end date for the worker in the new 

position. 
 

 Note: 
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The Personnel number field can be automatically populated based on the 
number sequence that is set up for the worker. The worker uses this number to 
log on to the POS system. 

4. In the Worker form, on the Worker summary FastTab, in the Address books 
field, select the address book to assign the worker to. Microsoft Dynamics AX for 
Retail uses the address book that you select to link the worker to a store.  

 Note 

Employee address book is used to associate workers (cashiers) to a retail store. 
Workers can be assigned multiple store addresses allowing them to work at multiple 
locations. The interaction of worker address book and store address book defines 
workers assigned to retail stores. 

5. Click the Retail link, and then, in the Screen layout ID field, select the POS screen 
layout if the worker uses a special screen layout on the POS system. If the worker 
uses the POS screen layout that is assigned to the store, leave this field blank.  
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7. In the Employment type field, select whether the staff member is a cashier, 
salesperson, or other type of employee.  
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8. Under POS authentication, in the Password field, specify the password that the 
worker uses to log on to the POS system.  

9. To select a POS permission group for the worker, click the POS permissions link.  

 

10. In the POS position permissions form, do one of the following:  
a. In the Position field, select a position for the worker.  
b. Select the Override permissions check box, and then either select a 

permission group in the POS permission group field, or select the check 
boxes for the appropriate permissions.  
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You must assign the worker to a position. Otherwise, the worker does not have 
appropriate access to the POS system.  

11. Enter any other appropriate information in the Profile, Employment, Absence, 
Compensation, Payroll, and Competencies and development sections.  

 IMPORT THE RETAIL USER PROFILES 

Microsoft Dynamics AX user accounts need to be set up for each employee who 
requires access to Enterprise Portal. The below steps are required only if Enterprise 
Portal access is required by the store users. 

1. Click System administration > Common > Users > User profiles.  

2. Click Import, and then click Import from AOT.  

3. Select the check boxes for the profiles to import, and then click OK.  
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There are four retail user profiles:  

 Retail Merchandising Manager  

 Retail Operations Manager  

 Retail Store Inventory Clerk  

 Retail Store Manager  

 

Assign users to the retail user profiles 

To assign users to retail user profiles, follow these steps: 

1. Click System administration > Common > Users > User profiles.  
2. Select a retail user profile.  
3. Click Add user, and then, under Select user, select a user.  

 

4. Under Select company, click All companies (Profile: %1). Alternatively, click 
Select companies, and then select the check boxes for the companies that you 
want.  
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5. Repeat steps 2 through 4 for the other retail user profiles.  

Assign stores to the users for each retail user profile 

By assigning a store to a user, you allow the user to access information for that store in 
Enterprise Portal.  

1. Click System administration > Common > Users > User profiles.  
2. Select a retail user profile, and then click the Users tab.  
3. Select a user, and then click Assign stores. 

 

4. Click New to add a store to the list. Then, in the Local store number field, select 
a store.  

5. Repeat steps 1 to 4 to add additional stores to the user profile. 
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View the Role Center for a retail user profile 

1. Click System administration > Common > Users > User profiles.  

2. Select a retail user profile.  

3. Click View role center.  

 

 ROLE-BASED SECURITY FOR RETAIL 

Role-based security was introduced as part of Microsoft Dynamics AX 2012. As part of 
role-based security, built-in roles were added to Microsoft Dynamics AX that covered all 
functional aspects of the product. Microsoft Dynamics AX for Retail 2012 introduces the 
uptake of role-based security for functionality supported through the retail solution.  

Terms used in Security Setup for Dynamics AX 2012 

 Roles: Where applicable, new retail roles need to be created so that employees can 
be assigned to retail-specific duties.  
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 Processes: Functions that can be performed through headquarters and Retail POS 
need to be organized in to processes to fit into the Microsoft Dynamics AX 
navigation structure for different process cycles.  

 Duties: Duties need to be defined and created in Retail POS that consist of a set of 
privileges required to perform certain tasks and services related to the performance 
of an individual’s position.  

 Privileges: Privileges need to be defined and created. Discreet collections of these 
privileges make up individual duties within Microsoft Dynamics AX. Privileges can be 
considered menu item, form, and field level securable within the back office.  

 Permissions: Permissions are the access levels assigned to privileges. This could be 
considered the type of access to these privileges such as create, read, update, or 
delete.  

High-Level Relationship 

 

Following is the breakdown of Role-based Security framework in Microsoft Dynamics AX 
2012 for Retail: 

o 4 roles  
 Retail Store Manager  
 Retail Merchandising Manager  
 Retail Operations Manager  
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 Retail Warehouse Clerk  
o 59 duties  
o 190 privileges  
o 2300+ entry points covered  

Retail Roles  

As part of the feature, entry point-level security was applied to all menus within the 
solution. These entry points were then grouped into duties that were assigned to roles 
delivered out of the box. The partner or end user can modify the roles and the 
duties/permissions assigned to the entry points to better suit the retailer’s needs and 
business processes. 

The roles added for the retail solution with a brief explanation are as follows: 

 Retail Merchandising Manager: Responsible for catalog, assortment, and pricing 
aspects of retail functionality.  

 Retail Operations Manager: Responsible for setting up retail reference data and 
entity management in areas such as stores, terminals, and profiles used by the 
point of sale terminals  

 Store Manager: The store manager has access to all Enterprise Portal-related 
retail functionality including all supported reports as well as picking, receiving, 
and stock count functionality. Access is based on stores assigned to the user 
through user profiles in system administration.  

 Store Inventory Clerk: Responsible for retail store inventory functions within 
Enterprise Portal. This includes order picking and receiving duties as well as the 
entry of stock counts. Access is based on stores assigned to the user through 
user profiles in system administration.  

 Retail Warehouse Manager: Responsible for retail warehouse inventory 
functions. 

 

 Note:  

Some additional configuration-related duties were added to the Microsoft Dynamics 
AX Information technology manager role that shipped with Microsoft Dynamics AX 
2012. These duties are mostly related to setup, configurations of store connections, 
and services-related configuration.  
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List of Duties Assigned by Security Role for Retail 

Retail Merchandising Manager:  
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Retail Operations Manager:  

 

Store Manager: 
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Store Inventory Clerk 

 

 

Retail Warehouse Manager:  

 

 

 TIME REGISTRATION 

To enter time, retail workers must be set up as time registration workers.   

 Note: 
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A worker can only be activated as a time registration worker in the company that the 
worker is employed. 

 

31.6.1 ENABLE WORKERS TO REGISTER TIME AND ATTENDANCE 

1. Click Retail > Common > Workers.  

 
2. On the Workers list page, select the worker.  
3. On the Time registration tab, click Activate on registration terminals to open 

the Create time registration worker form.  

 
 Note: 

The Activate on registration terminals button is available only if you are 
working in the company in which the worker is employed.  
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4. The Active check box is selected by default. This indicates that the worker has 
been activated as a time registration worker.  

5. In the Activation date field, select a date. To activate it immediately, leave it 
blank. To activate it in the future, enter the future date. Note: If left blank the 
activation is immediate. 

6. In the Calculation group field, select the group of workers with whom the 
worker's registrations are calculated.  

a. To add a new Calculation Group, right-click the field and select View 
Details. 

 

b. Click New to add a new Calculation group.  
c. Enter the Name and Description of the new calculation Group. 
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d. To specify a password, click the General tab and enter in the Password in 
the field. 

 

A supervisor or manager is responsible for calculating registrations for this group of 
workers.  

7. If the worker is responsible for calculating registrations for other workers, select 
a calculation group in the Default calculation group field. When the worker 
opens the Calculate form, this calculation group is displayed. This is the same 
selection from the Calculation group.  

8. In the Approval group field, select the group of workers with whom the worker's 
registrations are approved. A shop supervisor or manager is responsible for 
approving registrations for this group of workers.  

a. To add a new Approval group, right-click the field and select View Details 
b. Click New to add a new Calculation group  
c. Enter the Name and Description of the new calculation Group 
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d. To specify a password, click the General tab and enter in the Password in 
the field. 

 

9. In the Standard profile field, select the work time profile that is used to calculate 
time and pay if the worker makes no registrations during a work day.  

Note 

Profiles cannot be created by location. 

a. To create a new Standard profile, right-click the field and select View 
Details. 

b. Click New to create new profile. 
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c. In the Profile field, type a name for the profile.  
d. In the Description field, type a description for the profile.  
e. Click the General FastTab.  

 

f. In the Profile section, press CTRL+N to create a new line.  
g. In the Profile type field, select the Profile type for this profile line.  
h. Enter starting and ending work times in the Start and End fields for the 

selected profile type.  
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i. If necessary, you can create tolerances on a profile type line. A tolerance 
is a period, in minutes, before or after the job has started or ended. The 
profile type is still valid if registrations are made within the tolerance 
period. Enter tolerances in minutes in the Tolerance before start, 
Tolerance after start, Tolerance before end, and Tolerance after end 
fields.  

j. Use the Switch code field to enable workers to make a registration on a 
profile type other than the one inserted in the profile. For example, if you 
have included a Flex+ profile type in your profile, you can enable workers 
who have flextime to be able to convert registered flextime into 
overtime. In that case, in the Switch code field, select the option for 
converting flex time into overtime.  

k. You can enable workers to cancel breaks in their profile. This might be 
useful in a situation where a supervisor asks workers to cancel all breaks 
for the workday so that rush orders can be completed. In that case, you 
must select an alternative profile type to the Break profile type. The 
alternative profile is a basis for calculating time registrations if the worker 
cancels the break.  

l. In the Secondary field, on the Break profile type line, select the profile 
type that should replace a Break profile type, for example, Overtime.  

m. In the Start day and End day fields, select the appropriate workday, 
according to the selections you made in the Start and End fields in step h.  

Note 

Typically, you select the same weekday as the day that you are creating 
the profile for. However, if you are creating a profile for a night shift, a 
profile type may start late in the evening on one weekday and end after 
midnight on the following week day. In that case, you must select one 
weekday in the Start day field and the following weekday in the End day 
field. 

n. When you have created one weekday in a profile, the easiest way to set 
up the other weekdays is to copy that first weekday, and then adjust the 
other days, as needed.  

i. In the Profile form, on the General tab, select the weekday to 
copy in the Weekday section.  

ii. Click Copy, and select Copy day.  
iii. Select the weekdays to copy the profile to, and select the 

Overwrite check box.  
iv. If necessary, adjust the other weekdays if they have different 

profiles from the weekday that you copied.  
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o. If you have already created a work time profile covering a whole week, 
you can copy the entire profile and then make adjustments to the new 
profile, as needed. 

i. In the Profile form, select the profile to copy.  
ii. Click Copy, and select Copy profile.  

iii. Enter the name of the new profile in the Copy to field. 

Note 

To overwrite an existing profile, select that profile in the Copy to field, and then 
select the Overwrite check box. 

p. If your company works night shifts, the profile day might start before 
midnight. If so, you can make the following adjustments for the night 
shift profile on the General tab, in the Profile staggering section:  

i. In the New 24-hour period field, enter a starting time for the next 
profile day.  

ii. In the 24-hour period start field, select Previous day. 

Tip 

If you want registrations made in the current day to apply to the next 24-hour period, 
select the Push check box. 

q. Some workers may not have fixed work hours. Consequently, the 
Overtime / flex limit and Max. flex limit fields on the General tab can be 
used to determine Standard time in hours, and the maximum number of 
flexible hours allowed before converting registered time into overtime.  

For example, if you insert the number 40 in the Overtime / flex limit 
field, and the number 10 in the Max. flex limit field, it means that the 
worker has a 40-hour work week. If the worker works more than 50 hours 
during a week, 40 hours are considered standard work time, 10 hours are 
added to the flex balance, and the number of hours exceeding 50 hours is 
considered to be overtime.  

10. In the Pay agreement field, select the pay agreement that is used when the 
worker's pay is calculated.  
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 To create a new Pay Agreement, click New. 

 Enter the Pay Agreement and Description. 

 On the General  FastTab, enter the From date and To date. 

 Enter the minutes that will trigger a pay deduction. 

 Enter the Rounding from and Round-off for the overtime Round off. 

 In the Pay agreements form, click Pay agreement lines.  

 Create a new pay agreement line for the relevant week days for the pay 
type.  

11. In the Period code field, select the pay period that is used when the worker's pay 
is calculated.  

12. In the Profile group field, select the group that the worker belongs to. Profile 
groups contain one or more work time profiles that can be applied when a 
worker makes clock-in and clock-out registrations. The profile that you select 
depends on the date or the time of day that the worker makes a clock-in 
registration. For example, the worker may work during a day shift or a night 
shift.  

13. Select the New bundle check box to stop the worker's active jobs when he or she 
starts a new job. If you clear the check box, new jobs are bundled with the jobs 
that the worker previously started, but that have not yet been stopped or 
completed. The New bundle check box relates to job bundling. If you use job 
bundling, a worker can start multiple jobs at the same time in the Job 
registration form in Production control. If multiple jobs are started at the same 
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time, but they are not completed at the same time, the job bundling 
functionality calculates the time that is spent on each job.  

14. In the Category field, select the cost category that is used when the worker 
makes registrations for projects and project activities.  

15. Select the Use timecard check box to allow the worker to make registrations on 
the electronic timecard in Time and attendance.  

16. In the Configuration field, select the registration form that is displayed when the 
worker logs on to the Job registration form in Production control.  

17. Select the Flex allowed check box to allow the worker to register flextime.  
18. If the worker is allowed to register flextime, select a flex group in the Flex group 

ID field.  
19. Click OK to save and close the form. 

31.6.2 SETUP TIME REGISTRATION WORKER 

To facilitate management of time registration worker, other tasks and setup can be 
performed. These can be done through Retail > Common > Setup time registration 
worker . 

 

 

The following options are given: 
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 Absence registration: Use the Absence registrations list page to view 
absence registrations and create new absence registrations for a worker. 

 

o To create a new registration, click New  to add a new record. 
o Enter the start date/time and end date/time of the absence. 
o Select the Interrupt check box to automatically stop the absence 

registration if the worker makes a clock-in registration before the 
specified end date and time. 

o If the registration was Interrupted, this is enabled. 
o Select the Absence group and the Absence code. New ones can 

be added by going to the selective form by right-clicking the field 
and selecting View details. 

o The description field describes the Absence code. 

 Profile calendar: The profile calendar is used to apply a specific work time 
profile to one or more workers on specific dates. When you create a 
profile calendar entry for a worker, the worker’s time registrations are 
calculated for a profile that is different from his or her standard work time 
profile for a specific period of time. You can create a profile calendar 
entry for one day or for a longer period of time.  

 

 Click New to create a line.  

 In the Compose profile calendar form, in the Profile calendar 
code field, select the worker or group of workers to add a work 
time profile to:  

o All – Apply the work time profile to all workers.  
o Group – Apply the work time profile to a group of workers.  
o Table – Apply the work time profile to a specific worker.  
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 Depending on the selection in the Profile calendar code field, 
enter a worker ID or a profile group ID in the Profile calendar 
relation field.  

 In the Date field, enter the date to add the profile.  

 In the Profile field, select the profile to use.  

 In the Special day field, click a selection, if applicable. You can use 
this field to change pay or add absence registrations.  

 Flex balance: Shows the worker’s flex balance based on the flex 
transactions.  It can also be used to correct the flex balance. 

 Flex: Recalculates the flex balance. 

 

 Opening flex balance: Sets the worker’s opening flex balance and 
recalculates the balance based on the balance. 

 Worker balances: Shows the worker’s balance based on the transactions. 

 Recalculate worker balances: Recalculates the worker’s overall balance. 

 Switch code: Switches a registration for another registration or activates 
certain pay lines in a pay agreement. Switch codes can be used to 
override standard settings, for example, when a supervisor allows a 
worker to take time off instead of receiving unpaid overtime. Switch 
codes can also enable payment of a specific premium to a worker. Switch 
codes are valid for the entire profile day.  

 Temporary group assignment: Adds a worker to another calculation 
group or approval group for a specific period of time. 

31.6.3 CALCULATE TIME AND REGISTRATION FOR WORKERS 

You can calculate time and attendance registrations for workers in the following ways:  

 Calculate registrations for all workers who are assigned to a calculation group.  
 Calculate registrations for a specific worker.  
 Calculate registrations by using a batch job.  

You can use the Day view and Week view filters as follows:  

 Day view – View registrations for all workers for a selected weekday.  
 Week view – View registrations for a selected worker for a selected week.  

31.6.3.1 Calculate registrations for all workers in a calculation group  

To calculate registrations for all workers in a calculation group, follow these steps: 
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1. Click Human resources > Common > Time and attendance > Calculate.  

 

2. In the Week or Date field, select the week or date to calculate registrations for.  
3. In the Calculation group field, select the calculation group to calculate 

registrations for, and then click OK.  
4. In the Calculate form, click Update > Calculate.  

 

5. In the Calculates jobs form, verify that the calculation group is selected in the 
Calculation group field.  

6. If you use a workflow for approvals, select the Submit to workflow check box in 
the Calculates jobs form.  

7. Click Close.  

Note  

If registrations contain errors because of missing information or for other reasons, you 
must correct the registrations and then calculate the registrations again. To view the 
worker registrations that contain errors, click Display errors. The Error tab displays 
information about the type of error.  

31.6.3.2 Calculate registrations for one worker at a time  

You can calculate registrations for a specific worker. Typically, you calculate registrations 
for a worker after you have corrected registration errors for that worker.  

1. Click Human resources > Common > Time and attendance > Calculate.  
2. In the Week or Date field, select the week or date to calculate registrations for.  
3. In the Calculation group field, select the calculation group to calculate 

registrations for, and then click OK.  
4. In the Calculate form, select the worker in the upper pane and click Select.  
5. Select the Calculated check box for the registration.  
6. Click Close.  

31.6.3.3 Reverse calculated registrations  

You can reverse the registrations that have been calculated for a worker. However, you 
cannot reverse calculated registrations after payroll information for the period has been 
exported to the payroll system. Also, if registrations have been approved, you can 
reverse the calculated registration only in the Approve form.  
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1. Click Human resources > Common > Time and attendance > Calculate.  
2. In the Week or Date field, select the week or date to calculate registrations for.  
3. In the Calculation group field, select the calculation group to calculate 

registrations for, and then click OK.  
4. In the Calculate form, select the worker in the upper pane and click Select.  
5. Clear the Calculated check box for the registration.  
6. Click Close.  

Tip  

If you have changed the registrations, and you want to restore the original values, delete 
all lines, and then click Restore lines.  

31.6.3.4 Calculate registrations by using a batch job  

To calculate registrations by using a batch job, follow these steps: 

1. Click Human resources > Common > Time and attendance > Calculate.  
2. In the Week or Date field, select the week or date to calculate registrations for.  
3. In the Calculation group field, select the calculation group to calculate 

registrations for, and then click OK.  
4. In the Calculate form, click Update, and then click Calculate.  
5. In the Calculates jobs form, click the Batch tab.  

 

6. Start the batch job.  

Note  

If you use a workflow for approvals, select the Submit to workflow check box.  

7. Click OK.  

31.6.4 APPROVE TIME AND ATTENDANCE REGISTRATION 

After each work day, workers’ registrations must be calculated and approved. You can 
approve registrations after they have been calculated and no errors occurred during 
calculation. You can approve registrations by using one of the following:  

 A workflow  
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 A batch job  
 Manually for an approval group  
 Manually for one worker at a time  

31.6.4.1 Approve registrations using a workflow  

The approval workflow is an automatic approval process. All registrations are validated 
against the rules in the approval workflow. Only deviations that are not accepted in the 
workflow must be approved manually. The worker who is responsible for calculating 
registrations, for example, a team leader, initiates the approval process. The worker who 
is responsible for approving registrations, for example, a payroll administrator, receives a 
message regarding the need for manual approval only when some registrations could 
not be approved according to the approval workflow.  

1. Click Human resources > Common > Time and attendance > Approve.  

 

2. Select the approval date in the Date field.  
3. Select your group in the Approval group field.  
4. In the Approve form, select the worker in the upper pane, on the Overview tab.  

 

5. Click the Action button. If the worker’s registrations are ready for approval, the 
Approve and Reject options are available.  

o To approve, click Approve.  
o To reject, click Reject, and insert a note explaining why the registrations 

are rejected.  

31.6.4.2 Approve registrations using a batch job  

To approve registrations using a batch job, follow these steps: 

1. Click Human resources > Common > Time and attendance > Approve.  
2. Select the approval date in the Date field.  
3. Select your group in the Approval group field.  
4. Click Update and Approve.  

 

5. Start the batch job.  
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31.6.4.3 Approve registrations for all workers in an approval group  

To approve registrations for all workers in an approval group, follow these steps: 

1. Click Human resources > Common > Time and attendance > Approve.  
2. Select the approval date in the Date field.  
3. Select your group in the Approval group field.  
4. Click Update and Approve.  
5. Click OK.  

Note  

If the approval process returns errors on some registrations, for example because of 
missing information, you must edit those registrations and approve again.  

Tip  

To see a list of worker registrations that contain errors in the registration lines, click 
Display errors. The Error tab provides information about the type of error.  

31.6.4.4 Approve registrations for one worker at a time  

You typically must approve registrations for an individual worker after you have 
corrected errors for that worker.  

1. In the Approve form, select the worker in the upper pane.  
2. Select the Approved check box for the worker.  

31.6.4.5 Reverse an approval  

Approved registrations for a worker can be reversed until payroll information for the 
period has been exported to the payroll system. To reverse approved registrations for a 
worker, follow these steps:  

1. In the Approve form, select the worker in the upper pane.  
2. Clear the Approved check box.  

Tip  

If you have made several corrections to the registrations, and, therefore, must restore 
the lines to their original value, delete all lines, and then click Restore lines.  
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Once approved, the data can be exported out of the system. Data can be exported out 
as CSV files to be imported into a payroll system. 

31.6.5 VIEW JOURNAL REGISTRATION 

To view on time registration transactions on a journal, click Retail > Common > Workers 

The Workers form opens. Select the worker from the list to view time registration. 

Click Journal registration from the Inquiries group on the Time Registration tab. 

 

The Overview tab displays all the information related to the time registration. 
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It also displays other information if the time registration is related to a project or 
production. 

 

The General tab displays detailed information for the time entries from the Overview 
tab 

 

The Error tab shows information if there are any errors associated with the transaction. 
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The Financial dimensions tab shows the dimension-related information associated with 
the time entry. 

 

31.6.6 VIEW TRANSFERRED REGISTRATION 

A transferred registration is posted to an activity or job that it relates to, for example, a 
production order or a project. Also, payroll transactions are generated for each worker 
based on the registrations. 

To view the transferred registration, click Retail > Common > Workers 

The Workers form opens. Select the worker from the list to view time registration. 

Click Transferred registration from the Inquiries group on the Time Registration tab. 

 

The information available is related to the activity and job. 

31.6.7 INQUIRE RAW REGISTRATION 

Use this form to view raw registration for all time registration workers. 

To view the raw registration, click Retail > Common > Workers 
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The Workers form opens. Select the worker from the list to view time registration. 

Click Raw registration from the Inquiries group on the Time Registration tab. 

 

The form consists of the following: 

The Overview tab shows the registrations made by the worker on the selected date. 

The General tab shows the detailed information related to production feedback for the 
registration selected on the Overview tab. 

There is functionality to clean up and load a raw job. Selecting the Clean up registration 
and Load registrations buttons, respectively, can do this. 

 

31.6.8 VIEW PAYROLL STATISTICS 

You can view the calculation of workers’ pay for different types of wages, such as 
standard time and overtime. The basis for a payroll statistic is one or more pay types 
that are summarized over a specific period of time. 

To view the payroll statistics, click Retail > Common > Workers 
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The Workers form opens. Select the worker from the list to view payroll. 

Click Payroll statistics from the Inquiries group on the Time Registration tab. 

 

The form consists of the following: 

The Overview tab shows the payroll information, including the balance, change, and 
adjustments for the worker. 

The General tab shows the detailed information related to payroll information for the 
registration selected on the Overview tab. 

 

The Set adjustment button can be used to adjust the amount for the adjustment. 
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32 JOURNALS 

OVERVIEW 

This module describes how to create, calculate, and post statements.  

 OPEN STATEMENTS 

In Microsoft Dynamics AX for Retail, you can create a statement of the transmitted 
transaction data from the point-of-sale (POS) database to the database for the head 
office. You can use the statement to calculate the total amount of all transactions that 
have occurred since the last store statement, and to calculate a related count of 
payment methods.  

The topics in this section provide information about how to create, calculate, and post 
statements.  

In Microsoft Dynamics AX for Retail, you can use the statement-posting process to 
account for the transactions that occur in Microsoft Dynamics AX for Retail POS. The 
statement-posting process uses Retail Scheduler to transmit a set of the POS 
transactions to the Microsoft Dynamics AX client. You define the criteria that are used to 
select transactions in the Retail Headquarters parameters form and the Store form. The 
following diagram illustrates the statement-posting process.  
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You can create a statement manually or by using batch processes that you set up to run 
periodically throughout the day. In both cases, create and post statements as follows:  

 Create the statement. This step identifies the store that the statement is 
manually created for. If you configure a batch process, you can automatically 
create statements for all stores, based on a schedule that you define.  

 Calculate the statement. This step gathers the transactions lines by using 
criteria that you define for each store and in the Retail Headquarters 
parameters and Store forms. You must define the criteria that the system uses. 
You must also specify how the transactions are calculated. The calculate 
statement process uses the global number sequence. You can use the 
Transactions form to view a list of the transactions that were included in the 
statement before the calculate statement process is run.  

A statement calculation uses tender declarations from the registers as the 
counted amount. Alternatively, you can enter the counted amount manually. 
The statement displays the difference between the sales amount for the 
transactions and the actual counted amount in all tender types. The statement is 
posted only if this difference is less than the maximum selected posting 
difference that is defined for the store.  

When you calculate a statement, the calculation performs the following tasks:  
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a. Any transactions that were not included in a previous statement 
calculation for the selected date range are marked.  

b. The total amounts that were tendered in the selected transactions are 
calculated. The results are displayed on the statement lines:  

 If the statement method is Total, a line is created for each payment 
method in the selected transactions.  

 If the statement method is Staff, a line is created for each payment 
method in transactions that were performed by the selected staff 
member.  

 If the statement method is POS terminal, a line is created for each 
payment method in transactions that were performed on the selected 
register.  

Note 

Before you can create statements, you should close the shifts in the statement 
period. 

 Post the statement. Sales orders and invoices are created for the retail sales in 
the statement. Cash and carry sales are aggregated onto one sales order and 
invoice for the default customer who is assigned to the store. Any retail sales 
that had a customer added to the transaction in Microsoft Dynamics AX for 
retail POS generate separate sales orders and invoices, one for each unique 
customer. Payment journals are automatically created for the payments in the 
statement, and the inventory is updated for the POS store. If you selected the 
Automatic settlement option on the Posting tab in the Retail Headquarters 
parameters form, payments are automatically settled against invoices. 

 

 CREATE AND POST A STATEMENT 

After all transactions from the registers have been uploaded from a retail store, a 
statement can be created, calculated, and then posted.  

The statement calculates the total amount of all transactions that have been created 
since the last store statement was created, within the statement period that you define. 
The statement also calculates the payment methods that are counted.  

The statement is calculated by using the settings for statements and posting in the 
Retail Headquarters parameters form and the Store form. After the statement is 
created, you can review the transactions. Then, if the transactions are ready to be 
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posted, you can post the statement. When you post the statement, the system creates 
accounting entries, updates customer accounts and taxes, and generates sales orders 
and invoices. Inventory is also updated, so that your point-of-sale (POS) system always 
has current inventory information.  

32.2.1 CREATE AND CALCULATE THE STATEMENT 

To create and calculate a statement, follow these steps: 

1. Click Retail > Journals > Open statements. 

 

2. On the Open statements list page, on the Action Pane, in the New group, click 
New statement.  

3. In the dialog box, in the Store number field, select the store to create a 
statement for.  

 

4. In the Statements forms, on the Action Pane, in the Function group, click 
Calculate statement. 

javascript:void(0)


Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

64 

 

 

5. Click Yes to confirm that you want to calculate the statement.  

 

When a statement is calculated for a specific period, information is updated for 
the transactions that are included in the statement calculation. These 
transactions include items that are not on file, blocked items, and blocked 
customers.  

32.2.2 POST A STATEMENT 

After you calculate a statement, the statement lines that the system has included in the 
statement are displayed on the Lines FastTab in the Statements form. Depending on the 
calculation criteria that were defined for the statement, the lines may be displayed by 
terminal number, by staff ID, or as a total. The lines are always separated by payment 
method.  

The statement lines include the transaction currency, transaction amount, and any 
difference between the transaction sales amount and the actual counted amount for all 
payment methods.  
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Note: You must assign financial accounts to items, stores, and tender types before you 
can post the calculated values in statements to the general ledger, item ledger, 
customer ledger, and other related tables. 

To post a statement, follow these steps: 

1. Click Retail > Journals > Open statements.  
2. On the Open statements list page, select a statement to post.  
3. On the Action Pane, in the Function group, click Post statement.  

 

4. Click Yes to confirm that you want to post the statement.  

The statement is posted only if the difference between the transaction sales 
amount and the actual counted amount is below the maximum posting 
difference that is defined for the store.  

32.2.3 VIEW A POSTED STATEMENT 

After a statement is posted, you can view details about the posted transactions. You can 
also print the posted statement.  

1. Click Retail > Inquiries > Posted statements.  
2. In the Statement journal form, select a statement to view.  
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3. Click Reports > Statement to print the statement.  
4. To view the details about transactions in the posted statement, click individual 

transactions in the lower pane. Alternatively, you can click Transactions, and 
then select the transaction types to view.  

32.2.4 CONFIGURE BATCH PROCESSES TO CREATE STATEMENTS 

To run the statement processes for your stores automatically, based on a schedule, 
configure the batch process for each stage of the statement process as follows:  

 Configure the calculate statement process to calculate the transaction sets for 
one store or all stores.  

 Configure the post statement process to post the calculated statements.  
 Configure the post inventory process to update the inventory for the stores 

when the statements are posted.  
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Follow these steps: 

1. Click Retail > Periodic > POS posting > Calculate statement.  
2. In the Calculate statement form, select the store or a range of stores to 

configure the calculate statement batch process for and click Add.  

 

3. Click the Batch tab to configure the batch process. Click Recurrence to set up the 
frequency of the batch.  
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To set the alerts, click Alerts. 

4. Click Retail > Periodic > POS posting > Post statement.  

5. In the form, select the store number to configure the post statement batch 
process for a single store or select multiple stores and click Add. 
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6. Click the Batch tab to configure batch process. Click on Recurrence to set up the 
frequency of the batch.  

 

7. Click Retail > Periodic > POS posting > Post inventory.  

8. Select the store number to configure the post statement batch process for a 
single store or select multiple stores and click Add.
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Note 

To keep your on-hand inventory accurate, you should run this batch job frequently. 
For example, you can set the frequency to match the frequency with which you run 
the distribution schedule for job P-0001 for each store. 

9. Click the Batch tab to configure the batch process. Click Recurrence to set up the 
frequency of the batch.  
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33 POINT OF SALE SET UP 

OVERVIEW 

This module explains that while it is typical in retail environment store employees 
perform the functions that enable store operations, there three categories on in-store 
system that can be defined: 

 Point of service systems – This category consists of checkout systems including 
self-service POS, lottery systems, ATMs, other kiosks, and even mobile systems. 
 

 Front-office systems – This category consists of sales floor systems, which are 
often consumer-facing or serve to increase direct customer service. These 
systems include digital signage, loyalty and service interface and gift registry. 
 

 Back-office systems – This category consists of all operational systems for the 
store, including inventory management, human resources and financial 
management. 

A retail store is usually set up with a back office terminal to perform end of day 
operations and to receive stock. The customer facing terminals are used for sales 
operations. 

A POS terminal usually would be a touch screen device with all the devices like scanner, 
EFTPOS machine and receipt printer attached to enable the terminal to perform sales 
operations to serve the customers. 

As part of the set up a POS terminal needs to be installed with the following: 

1. Operating System – The POS terminal needs to be installed with a supported 
version on windows operating system. The supported versions are Windows 
Embedded POSReady 2009 and Windows Embedded POSReady 7. 
 

2. SQL Server Express edition – Most of the retailers use the SQL Express edition 
because of the 10 GB database size allowance which meets most of the store 
needs. If size is a concern then higher versions of SQL can be used or the data 
can be archived depending on the business requirements. 
 

3. AX 2012 POS and Store Connect – AX 2012 POS application with store connect 
needs to be installed on the POS terminal to run the POS application. The store 
connect is configured to communicate with the Dynamics AX for Retail to receive 
master information and send back sales and inventory details. 
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4. Hardware drivers – The drivers for the connected devices like scanner, EFTPOS 
machine and receipt printer needs to be installed and configured on ever POS 
terminal. 

 
 Note 

Additional software’s may be required based on the business requirements and devices 
attached to the POS terminal. 

 INSTALL AX 2012 R2 POS 

The first step towards POS extensibility is installing the AX 2012 R2 POS from the 
Dynamics AX 2012 R2 Installation pack. The installation with provide components 
necessary to set up store and offline database along with the POS application. 

 Note 

Download a copy of Dynamics AX 2012 R2 Installation pack from partner source 
website. 

Follow the steps below to install the AX 2012 R2 POS on the POS terminal. 

1. Open the folder where you have downloaded Dynamics AX 2012 R2 Installation 
pack. 

 

2. Right click on the setup file and select Run as administrator. 
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3. The Microsoft Dynamics AX 2012 R2 installation form pops up. 

 

4. Under Install click Microsoft Dynamics AX components to select the 
components to install. 
 

5. The AX 2012 R2 Set up wizard form will open. 
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6. Click Next to continue with the installation. 
 

7. Click I accept license terms to continue with the installation. 
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8. After installing the support files, select installation type from the options: 
i. Custom installation 

ii. Single-computer installation. 
9. Select Custom installation to select the components to install. 
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10. Under Retail Components select the following components to install on the POS 
terminal: 

i. Retail POS – The Retail POS is the POS application that runs on the POS 
terminal used by cashiers and managers to do business at the stores. 
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ii. Commerce Data Exchange – The Commerce data exchange Settings is 
used to install the Sync service and the Real-time service to communicate 
from POS to AX HQ. 

 
iii. Retail Store Database Utility – The Retail store database utility is used to 

create store and offline databases at the POS terminal. 

 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

78 

 

11. The Prerequisite validation runs and checks if all the dependencies are met to 
install the selected components. If any errors are displayed follow the link to 
download and install the prerequisites. 

 

12. Click Next to install the selected component. 

Follow the section below to create store database at a POS terminal. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

79 

 

 INSTALL AND CONFIGURE STORE DATABASE  

As a prerequisite AX 2012 R2 POS needs to be installed on the POS terminal. If the 
installation is complete, then the Retail database utility component is used to create and 
configure store and offline database for a POS terminal. 

 

Below figure shows the typical architecture followed for POS deployments. 

 

Figure: High level POS architecture 
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Retail store databases are installed by using the Retail database utility. To open the 
Retail POS configuration form click on Start  All Programs  Microsoft Dynamics AX 
2012  Retail Database Utility Retail Database Utility. A store database may be 
installed either on a stand-alone database server or on a POS computer.  

 

Figure: Path for Database Utility 

Database utility can perform the following tasks: 

1. Creates Store and offline databases. 

2. Create POS configuration file. 

3. It can be installed separately from POS. 

4. It installs Synch Service.  
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Figure: Store Database configuration form 

Create a store database on a stand-alone computer or a POS computer  

1. Open the Retail POS configuration form to install store database on a stand-
alone computer or a POS terminal. 

2. Select Configure store database from the Database area. 

 

3. Populate the Store database fields under the Settings area:  

 Store database name – Enter the store database name.  

 Store server name – Type the name of the server hosting the store database 
(typically local host). 

4. If you select Configure offline database then the following additional fields are 
displayed. 
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5. Under the Offline database enter the Offline server name where the offline 
database will be created. 

6. Enter the Offline database name. 
7. Click on Test Connection to test if the server name entered exists and the Retail 

POS configuration can establish a connection to the server. 

 

 

 Note  

This step is required because of a known issue. The values that you enter can be 
arbitrary.  
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8. Optional: Test the connection.  
9. Click Continue to create and configure the store database.  

Collation of Retail POS databases 

The collation for each Retail POS database is based on the Windows locale. To avoid 
collation issues, verify that the Windows locale of each database computer in the 
store is set to one of the, supported locales for Microsoft Dynamics AX 2012 Feature 
Pack. 

Create SQL logons and assign database privileges 

On the head-office communications server, create a SQL logon with the same name 
as the Commerce Data Exchange: Synch Service domain user. The head-office 
instance of Commerce Data Exchange: Synch Service will use this logon to access the 
Commerce Data Exchange: Synch Service message database. Therefore, the logon 
must have read and write (db_datareader and db_datawriter) access privileges on 
the message database. 

On each store computer where SQL Server 2008 is installed, including the store 
communications server, create a SQL Server logon with the same name as the POS 
user group. This logon automatically provides all members of the POS user group 
(that is, all cashiers) access to the store or register database. This logon must have 
read and write (db_datareader and db_datawriter) access privileges on the store 
databases and the Commerce Data Exchange: Synch Service message database. 

In SQL Server Management Studio, expand the Security folder, right-click Logins, and 
then click New Login. 
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1. On the General page, click Search to locate and select the user account that 
you want to use for this SQL Server logon. 
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2. On the User Mapping page, select the check box for the database to which 
you want to grant access, and then, under Default Schema, click the 
Browse button. 
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3. In the Select Schema dialog box, click the Browse button. 

4. In the Browse for Objects dialog box, select the check box for the [dbo] 
object, and then click OK. 

5. In the Select Schema dialog box, click OK. 
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6. In the Database role membership for box, select the appropriate database, 
select the check boxes for the db_datareader and db_datawriter privileges, and 
then click OK. 

 CONFIGURE POS TERMINALS 

Set up user accounts and the POS user group 

To manage access to store computers and databases, you must create the following 
Windows users and user group: 

An account for Commerce Data Exchange: Synch Service – This account must be 
created only on the communications server where Commerce Data Exchange: Synch 
Service is installed and on computers where Retail POS databases are located. The 
Commerce Data Exchange: Synch Service will run as this user. 

An account for each store employee – Each employee user account must be created on 
every register that the employee will use. The employee can use this user account to 
log on to Windows and start Retail POS, and then log on to Retail POS by using the 
employee credentials set up for the employee in Retail Headquarters. 

A POS user group, to which all cashier user accounts on the computer are assigned – 
Create this group on all computers in the store, including the communications server, 
by using the same name as the SQL logon that you created for the POS user group. 
This gives all members of the group (cashiers and the Commerce Data Exchange: 
Synch Service service) automatic access to the store or register database. Without 
this access, cashiers cannot process transactions. 
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 Note: All user accounts should have strong passwords that meet the password 
policy for the organization. 

When you create the POS user group, it inherits the rights and privileges of the 
Standard user group on the computer. Typically, these rights and privileges are 
sufficient and do not need to be modified. 

Guest or temporary user accounts are not supported. 

Create user accounts 

1. Click Start, type lusrmgr.msc in the search or Run box, and then press ENTER to 
open Local Users and Groups. 

 

2. Right-click the Users folder and then click New User. 

3. Enter the following information  and then click Create. 
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4. For the Commerce Data Exchange: Synch Service user only, complete these 
additional steps: 

a. Right-click the user and then click Properties. 

b. Clear the User must change password at next logon check box, select the 
User cannot change password and Password never expires check boxes, 
and then click OK. 

5. Repeat steps 1 to 4 to add additional users. Click Close after adding users. 

Create the POS user group 

1. Click Start, type lusrmgr.msc in the search or Run box, and then press ENTER to 
open Local Users and Groups. 

2. Right-click the Groups folder, and then click New Group. 
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3. In the Group name box, type the name of the new group. Be sure to use the 
same name on all computers. 

4. Click Add. 
5. In the Enter the object names to select box, type the employee user names that 

you set up in the previous procedure. Separate the names by semicolons. Click 
Check Names to verify that you typed the names correctly, and then click OK. 

6. Click Create, and then click Close. 
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 CREATE AN OFFLINE POS DATABASE 

Offline POS Database is used by the POS terminal when the internet connectivity is 
down. The POS terminal automatically switches to offline database to continue with the 
sales transactions.   

 Note 

In offline mode cashiers can perform only limited functionality on the POS terminal. 

Figure below shows scenario when the store database is disconnected.  

 

Figure:  Offline POS 

In Dynamics AX 2012 R2, do the following steps: 

1. Open the Retail POS configuration form. 
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2. Select Configure offline database. 

 
Figure: Offline Database configuration screen 

 
3. Supply information for the Offline database fields: 

a. Offline database name – Enter the name of the offline database. 
b. Offline server name – Enter the name of the server hosting the database 

(typically localhost). 
4. Supply values for the Identification fields: 

a. Store ID – Type the store ID. This must match the value provided for the 
store in the Name field of the Retail stores form (Retail > Common > Retail 
channels > Retail stores). 

Note 

The store record does not need to be created before you complete 
this step. However, the ID must match later when the record is 
created and the profile is linked.  
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b. Register ID – Type an arbitrary designation for the POS terminal, such as 
Terminal 1 
 

Note 

The POS terminal record does not need to be created before you 
complete this step. However, the ID must match later when the record 
is created and the profile is linked.  

 
c. Data area ID – Type the company name. 

 
5. Click Continue to create and configure the offline database. 
6. In Headquarters, click Retail > Setup > Retail scheduler > Store integration > 

Database profiles to open the Database profiles form. One profile is required for 
each store. Create new profiles as needed and validate each profile by clicking 
Test connection.  

 

7. In Headquarters, click Retail > Setup > Retail scheduler > Distribution locations to 
open the Distribution locations form. The form displays a list of distribution 
locations. Assign the correct database profile for each location. 
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Note 

Do not assign AOS profiles if they are displayed on the Connection 
profile menu. This is a known issue. 

8. In Headquarters, click Retail > Setup > Retail scheduler > Store integration > 
AOS profiles to open the AOS profiles form. There must be a profile with values 
pointing to a current AOS computer. For more information, click the Help 
button in the form. 
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9. In Headquarters, click Retail > Setup > Retail scheduler > Store integration > 
Commerce Data Exchange: Synch Service profiles to open the Commerce Data 
Exchange: Synch Service profiles form. These profiles enable data to be 
synchronized between Retail Headquarters and stores. Create new profiles as 
needed to point to the correct computers and databases. For more information, 
click the Help button in the form. 

 

10. In Headquarters, click Retail > Setup > POS > Profiles > Transaction Service 
profiles to open the Transaction Service profile form. These profiles enable 
queries and data to be passed directly between Retail Headquarters and POS 
terminals. Create new profiles as needed to point to the correct computers and 
databases. 
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34 RETAIL REPORTS 

OVERVIEW 

This module explains that for retail stores, reporting begins with identifying the key 
performance indexes of their business and ensuring that timely data is collected 
accurately so that it reflects each of these indexes in a meaningful way.  Financially, 
senior managers look at all operating costs in all stores against a very granular set of 
cost centers and expense accounts. They compare stores to help spot anomalies.  Sales 
reports are vital management tools and extensive sales reports are produced on many 
pivots, such as department, category, store, and vendor.  The biggest cost to retail 
businesses is the cost of stock on hand, and considerable attention is paid to optimizing 
the level of stock held, the turn rate of stock, and the overall contribution margin areas 
of inventory provide.  The data informs constant improvement processes and 
refinement of the company’s inventory. 

 

Microsoft Dynamics AX 2012 contains a number of out-of-the-box reports built on SQL 
Server Reporting Services and SQL Server Analysis Services cubes.  The key retail-
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focused reports are found on the Retail area page as well as in Role Centers in the 
Microsoft Dynamics AX client and Enterprise Portal.  

Key features of Retail HQ Reports include the following:  

 Retail reporting  

 Category hierarchies 

 Excel Pivot Table 

It is helpful to remember the following key points: 

 Reports are built on SSRS with SQL Server Analysis Services Cubes. 

 Custom pivot tables can quickly and easily created in Excel. 

The following retail HQ reports are available on the rich client: 

 Retail Store Metrics 

 Sales Performance by Sales Categories 

 Sales Performance by Products 

 Sales Performance by Retail Product Category 

 RETAIL STORE METRICS 

Use this report to view the performance of the retail stores by organization unit. The 
organization unit is based on the default reporting hierarchy. This report includes the 
sales quantity and amount by store, and the profit margin for each store. 

Click Retail > Reports > Retail store metrics. 
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When you generate this report, the following default parameters appear. You can use 
these parameters to filter the data that appears on the report.  

 

Field Description 

Sort by  Select how to sort the store metric data on the report. Select 
one of the following options:  

 Sales amount  

 Gross profit margin  

 Sales quantity  

From date  Enter the earliest date for the store metrics you want to include 
on this report.  

To date  Enter the latest date for the store metrics you want to include on 
this report.  

Printer  Make sure the selected printer is the one you want to use. To 
select a different printer, click Destinations. This field is blank if 
Screen is selected in the Print destination field.  

Print 
destination  

Make sure the destination where the report is produced is 
correct. Click Destinations to change the destination for the 
report.  
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 SALES PERFORMANCE BY SALES CATEGORIES 

Use this report to view and compare sales performance by sales category during periods 
that you specify. The sales category is based on the default sales category hierarchy. 
This report includes the sales quantity, sales amount, profit margin, and profit 
percentage. This report is available only to users who are assigned to the Merchandising 
manager role. 

This report can also be accessed in Enterprise Portal for Microsoft Dynamics AX. 

Click Retail > Reports > Sales performance by sales category.  

To access the report from Enterprise Portal, click the Retail tab. Under Reports, click the 
Performance by sales category report. Specify a date range by using the From date and 
To date fields, and then click View report. 

Note: Steps for viewing the data in the report remain the  same as those explained in 
previous section 

 

 

To access the report from Enterprise Portal, click the Retail tab. Under Reports, click the 
Performance by sales category report. Specify a date range by using the From date and 
To date fields, and then click View report. 

When you generate this report, the following default parameters appear. You can use 
these parameters to filter the data that is displayed on the report.  

Field  Description  
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Sort by  Select the sort order for the sales performance data on the 
report. Select one of the following options:  

 Sales amount  

 Gross profit margin  

 Sales quantity  

From date  Enter the earliest date for the sales performance data to include 
on this report.  

To date  Enter the latest date for the sales performance data to include on 
this report.  

Printer  Make sure the selected printer is the one you want to use. To 
select a different printer, click Destinations. This field is blank if 
Screen is selected in the Print destination field.  

Print 
destination  

Make sure the destination where the report is produced is 
correct. Click Destinations to change the destination for the 
report.  

 

 SALES PERFORMANCE BY PRODUCTS 

Use this report to view and compare sales performance by product during periods that 
you specify. This report includes the sales quantity, sales amount, profit margin, and 
profit percentage. 

This report can also be accessed in Enterprise Portal for Microsoft Dynamics AX, and the 
report data is filtered by store. 

Click Retail > Reports > Sales performance by products.  

Note: Steps for viewing the data in the report remain the same as explained in previous 
section 
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To access the report from Enterprise Portal, click the Retail tab. Under Reports, click the 
Performance by product report. Specify a date range by using the From date and To 
date fields, and then click View report. 

When you generate this report, the following default parameters appear. You can use 
these parameters to filter the data that is displayed on the report.  

Field  Description  

Sort by  Select the sort order for the sales performance data on the report. 
Select one of the following options:  

 Sales amount  

 Gross profit margin  

 Sales quantity  

From date  Enter the earliest date for the sales performance data to include 
on this report.  

Number of rows  By default, the report prints 100 rows of information. Enter 
another number to change the number of rows on the report.  

To date  Enter the latest date for the sales performance data to include on 
this report.  

Printer  Make sure the selected printer is the one you want to use. To 
select a different printer, click Destinations. This field is blank if 
Screen is selected in the Print destination field.  
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Print destination  Make sure the destination where the report is produced is correct. 
Click Destinations  to change the destination for the report.  

 

 SALES PERFORMANCE BY RETAIL PRODUCT CATEGORY 

Use this report to view and compare sales performance by retail product category 
during periods that you specify. The retail product categories are based on the retail 
product hierarchy that is defined for your organization. This report includes the sales 
quantity, sales amount, profit margin, and profit percentage. This report is only available 
to users who are assigned to the Merchandising manager role. 

Click Retail > Reports > Sales performance by retail product category.  

To access the report from Enterprise Portal, click the Retail tab. Under Reports, click the 
Performance by retail category report. Specify a date range by using the From date and 
To date fields, and then click View report. 

Field  Description  

Sort by  Select the sort order for the sales performance data on the 
report. You can sort the data by Sales amount, Gross profit 
margin, or Sales quantity.  

From date  Enter the earliest date for the sales performance data to include 
on this report.  

To date  Enter the latest date for the sales performance data to include 
on this report.  

Printer  Make sure the selected printer is the one you want to use. To 
select a different printer, click Destinations. This field is blank if 
Screen is selected in the Print destination field.  

Print 
destination  

Make sure the destination where the report is produced is 
correct. Click Destinations  to change the destination for the 
report.  
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This report provides summary and detailed product sales information by retail category. 
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Expand each node to view sales information by subcategories. 

 

Drill down on any node to view the detailed product sales data. 
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 GMROII BY PRODUCTS 

To view the GMROII by products, click Retail > Reports > Gross margin return on 
inventory investment (GMROII) by products. 

The Parameters form opens. 

1. Select the Fiscal period from drop-down list.  
2. Make sure the Printer field displays the printer that you want to use. To select a 

different printer, click Destinations. This field is blank if Screen is selected in the 
Print destination field. 

3. Click Destination to select where the report is displayed. 
4. Click OK to run the report based on the selected parameters. 
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 GMROII BY CATEGORY 

To view the GMROII by category, click Retail > Reports > Gross margin return on 
inventory investment (GMROII) by category. 

The Parameters form opens. 
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1. Select the Fiscal period from drop-down list.  
2. Make sure the Printer field displays the printer that you want to use. To select a 

different printer, click Destinations. This field is blank if Screen is selected in the 
Print destination field. 

3. Click Destination to select where the report is displayed. 
4. Click OK to run the report based on the selected parameters. 
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 SALE PERFORMANCE BY CATEGORY BY STORE 

To view the report, click Retail > Reports > Sale performance by category by store. 

The Parameters form opens. 

1. Select the From date from which the sales performance needs to be calculated 
and displayed. 

2. Make sure the Show fields displays the fields the user can select to be displayed 
on the report. The fields that can be displayed are: 

a. Amount 
b. Quantity 
c. Margin 
d. Percentage 

3. Select the Store from the drop-down list. 
4. Select the To date to which the sales performance needs to be calculated and 

displayed. 
5. Make sure the Printer field displays the printer that you want to use. To select a 

different printer, click Destinations. This field is blank if Screen is selected in the 
Print destination field. 

6. Click Destination to select where the report is displayed. 
7. Click OK to run the report based on the selected parameters. 
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 PERFORMANCE BY TERMINAL 

To view the report, click Retail > Reports > Performance by terminal. 

The Parameters form opens. 
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1. Select the From date from which the terminal performance needs to be 
calculated and displayed. 

2. Select the To date to which the sales performance needs to be calculated and 
displayed. 

3. Select the POS registers from the drop-down list. 
4. Make sure the Printer field displays the printer that you want to use. To select a 

different printer, click Destinations. This field is blank if Screen is selected in the 
Print destination field. 

5. Click Destination to select where the report is displayed. 
6. Click OK to run the report based on the selected parameters. 
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 TOP 10 UI PERFORMERS IN CURRENT YEAR 

To view the report, click Retail > Reports > Top 10 UI performers in current year. 

The Parameters form opens. 
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1. Make sure the Printer field displays the printer that you want to use. To select a 
different printer, click Destinations. This field is blank if Screen is selected in the 
Print destination field. 

2. Click Destination to select where the report is displayed. 
3. Click OK to run the report based on the selected parameters. 
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 SALES COMPARISON YEAR OVER YEAR BY 
OPERATING UNIT 

To view the report, click Retail > Reports > Sales comparison year over year by 
operating unit. 

The Parameters form opens. 

1. Select the From year from which the year-on-year performance needs to be 
calculated and displayed for the selected retail stores. 

2. Select the Retail store from the drop-down list. 
3. Select the To year to which the year on year performance needs to be calculated 

and displayed for the selected retail stores. 
4. Make sure the Printer field displays the printer that you want to use. To select a 

different printer, click Destinations. This field is blank if Screen is selected in the 
Print destination field. 

5. Click Destination to select where the report is displayed. 
6. Click OK to run the report based on the selected parameters. 
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 RETAIL ANALYTICS WITH BUILT IN CUBES AND 
EXCEL 

Microsoft Dynamics AX for Retail includes a sales cube that can be used to gain powerful 
insights into sales performance: 

Merchandizing analytics 

 Sales performance by retail category – Identify key performing categories and 
eliminate nonperforming categories by leveraging the Sales performance by 
retail category and Sales performance by retail category period-over-period 
comparison reports. 

 Sales performance by product -- Eliminate nonperforming products and optimize 
assortments with the right product mix by leveraging the Sales performance by 
product report. This report provides insight into overall sales, quantity, gross 
margin, and gross margin percentage by product. 

Retail channel analytics 

 Sales performance by retail channel – Compare sales performance across 
channel, and identify ROI across individual channels. This report provides insights 
into overall sales, quantity, gross margin and gross margin percentage by 
channel. 
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Store analytics 

 Store sales by worker – View sales performance by staff and identify staffing 
improvements based on the Store sales by worker report. 

 Store sales by hour– Identify peak traffic hours and staffing requirement by 
leveraging the Store sales by hour report. 

 Store sales performance report – View store sales performance and track store 
performance across periods. 

Operating unit analytics 

 Operating unit sales performance – View a summary on how the overall business 
is performing by opening the operating unit sales performance report. 

Prerequisites:  

 Configure Excel to point to the cube. 

 Open Excel. 

 Click the Data tab. 

 Click From External Data Sources, and select From Analysis Services. 
 

 
 

 Connect to the Microsoft Dynamics AX machine.  
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 Select Sales cube.  

 

 Click Finish. 
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 Import data into the Excel Spreadsheet. 
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Users can easily choose the source for rows, columns, and metrics. 

Select Customer invoice line amount. 
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Select Customer invoice quantity. 

 

Click the Values grid in PivotTable Field List panel on the right. 

Select the  Customer Invoice Line Amount field. 

Select Value Field Settings. 

Set custom properties such as display name and formatting for each field if needed. 
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Click here, and then type "Sales Amount". 

Click Number Format. 
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Select Currency. 

 

 

Click OK. 
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Click OK again. 
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Click the Customer Invoice Quantity field in the Values grid. 
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Select Value Field Settings. 

Set custom properties such as display name and formatting for each field if needed. 

 

 

 

 

 

 

 

 

Click here and type "Sales Quantity". 
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Select Number. 

 

Click Format Cells, and then type "0" decimal places.  
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Click OK. 

 

Click OK again. 
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From the PivotTable Field List, scroll down to Retail channel – Name. 

 

Click here, and drag to Column Labels. 
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Similarly, select Parent Category. 

 

Users can filter by row or column to view only relevant data. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

132 

 

 

Expand the All Node on Left column to view all categories. 
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Viewing other reports from cube in Excel 

For all the reports, you must to follow the same steps as outlined above to modify the 
value field settings in Excel 

Retail category sales performance report  
o From the PivotTable Field List, select the Retail Category > Parent Category 

field (by default, it is added to the row labels). 
o From the PivotTable Field List  add the following values:  

 customer invoice Line amount  
 Customer invoice line amount 
 Gross margin  
 Gross margin percentage 

o Drill down, and view the performance by category. 

Product sales Performance report 
o From the ,PivotTable Field List, select Retail Category > Parent 

Category (by default, it is added to the row labels). 
o From the PivotTable Field List, add the following values:  

 customer invoice Line amount  
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 Customer invoice line amount,  
 Gross margin 
 Gross margin percentage 

o View the product sales performance report 

Channel sales performance report 
o From the PivotTable Field List, select Retail Channel > Retail Channel 

Name (by default, it is added to the row labels). 
o From the PivotTable Field List, add the following values:  

 customer invoice Line amount  
 Customer invoice line amount,  
 Gross margin  
 Gross margin percentage 

o View the channel sales performance report 

Sales by store by worker 
o From the PivotTable Field List, select Retail Channel > Retail Channel 

Name (by default, it is added to the row labels). 
o Select Add Worker > Worker name  (it is added to the row labels). 
o From the PivotTable Field List, add the following values:  

 customer invoice Line amount  
 Customer invoice line amount,  
 Gross margin  
 Gross margin percentage 

o Drill down, and view the sales by store by worker. 

Sales by Store by Terminal 
o From the PivotTable Field List, select Retail Channel > Retail Channel 

Name (by default, it is added to the row labels). 
 Select POS Terminal > Terminal name  (it is added to the row 

labels). 
o From the PivotTable Field List, add the following values:  

 customer invoice Line amount 
 Customer invoice line amount  
 Gross margin  
 Gross margin percentage 

o Drill down and view the sales by store by terminal. 

 

Operating Unit Sales Performance Report 
o From the PivotTable Field List, select Organization Unit > Parent 

Organization Unit (by default, it is added to the row labels). 
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o From the PivotTable Field List, add the following values:  
 customer invoice Line amount  
 Customer invoice line amount  
 Gross margin  
 Gross margin percentage 

o Drill down, and view the operating unit sales performance report. 

Sales by Store by Hour (applicable only when detailed posting is done) 

 From the PivotTable Field List, select Retail Channel > Retail Channel 
Name (by default, it is added to the row labels) 

 Select Hour of Day > Hour Day- name  (it is added to the row labels). 

 From the PivotTable Field List, add the following values:  
 customer invoice Line  
 Customer invoice line amount  
 Gross margin  
 Gross margin percentage 

 View the sales by store by hour report 
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 POWERVIEW REPORTS 

Leveraging the Powerview tool available from SQL Server 2012 SP1 and Excel, users can 
generate dynamic and interactive analytical data that is derived from the retail cube. 

Few Powerview reports are provided out-of-the-box for users to leverage the power of 
Powerview and SQL Server 2012. 

34.13.1  SALES BY REGION 

This report displays the sales by region across the merchandising categories. 

 

You can zoom-in or zoom-out to drill into a region to see the details of its sales. Click the 
(+) or the (-) sign on the top right-hand corner of the report. 
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Click the funnel  icon to filter the report. The filter section appears on the right side 
of the report. 

 

Rest the pointer over each region to view details of the sales. 

 

34.13.2  RETAIL CHANNEL PERFORMANCE BY HOR OF DAY 

This report provides the sales performance of every retail channel associated with a 
business. 
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Rest your pointer over the bubble to view the high-level summary of the performance. 

 

If you wish to view all the transactions in that hour for the channel, click the bubble. 
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34.13.3  RETAIL CHANNEL REPORT 

This report provides a high-level summary of the customer invoice line amount, COGS, 
gross profit margin, and inventory turn around by channel. 
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34.13.4  SALES BY RETAIL CATEGORIES 

This report provides the gross profit margin % by year across category levels and the 
COGS total by year across category levels. 
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 OTHER AVAILABLE RETAIL REPORTS 

The following reports are also available on Retail in Microsoft Dynamics AX 2012. These 
reports cannot be accessed directly under the rich client retail Area page but are 
available through either Enterprise Portal or the Role Center 

34.14.1  BOTTOM 10 PRODUCT PERFORMERS ROLE CENTER 
REPORT 

Use this report to view a list of the products that are the lowest performers. You can use 
this information to optimize your assortments. This report lists the product name, the 
quantities sold, and the profit margin for the product. 

This report is designed for use on Role Centers. This report is available on the 
Merchandising Manager Role Center. 
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34.14.2  TOP 10 PRODUCT PERFORMERS ROLE CENTER REPORT 

Use this report to view a list of the 10 products that are selling the best. This report lists 
the product name, the quantities sold, and the profit margin for the product. 

This report is designed for use on Role Centers. This report is available on the 
Merchandising Manager Role Center. 

34.14.3  RETAIL SALES BY STORE REPORT 

Use this report to view the sales performance for stores within a given date range. The 
report displays the sales performance of all stores that the user is assigned to, and it 
also includes the store name, amount, and cost of goods sold, quantity, profit margin, 
and profit margin percentage. 

This report is not available in the Microsoft Dynamics AX client. However, this report is 
available in Enterprise Portal.  

Access the report on Enterprise Portal as follows: 

Click the Retail tab, and select the Sales by store report. Specify a date range by using 
the From date and To date fields, and then click View report. 

34.14.4  SALES BY WORKER REPORT 

Use this report to view sales performance by worker for a given store. 

This report is designed to use in Enterprise Portal for Microsoft Dynamics AX.  

Access the report on Enterprise Portal as follows: 

Click the Retail tab, and select the Sales by worker report. Specify a date range by using 
the From date and To date fields, and then click View report.  

This report is also available on the Store Manager Role Center. 

34.14.5  STORE SALES BY HOUR REPORT 

Use this report to and monitor hourly sales volume for a given date. The store manager 
can use data on this report to staff the store based on peak sales times. 

This report is designed to use in Enterprise Portal for Microsoft Dynamics AX.  

This report is not available in the Microsoft Dynamics AX client.  
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Access the report on Enterprise Portal as follows: 

Click the Retail tab, and select the Sales by hour report. In the Date field, select a date, 
and then click View report.  

This report can also be accessed from the Store Manager Role Center. 

34.14.6  STORE SALES COMPARISON BY YEAR REPORT 

Use this report to view the year-over-year sales comparison for a given store. You select 
the year against which to compare the sales, and the report compares sales for the 
specified year with the previous year for a given store. 

This report is designed to use in Enterprise Portal for Microsoft Dynamics AX.  

This report is not available in the Microsoft Dynamics AX client.  

Access the report on Enterprise Portal as follows: 

Click the Retail tab, and select the Sales comparison by year report. In the Fiscal year 
field, select the fiscal year that you want to compare with the current year’s sales, and 
then click View report. 

This report can also be accessed from the Store Manager Role Center. 
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35 POINT OF SALE SET UP 

OVERVIEW 

This module explains that typically in a retail environment, store employees perform the 
functions that enable store operations. Three categories of in-store systems can be 
defined: 

 Point of service systems – This category consists of checkout systems including 
self-service POS, lottery systems, ATMs, other kiosks, and even mobile systems. 
 

 Front-office systems – This category consists of sales floor systems, which are 
often consumer facing or serve to increase direct customer service. These 
systems include digital signage, loyalty and service interface, and gift registry. 
 

 Back-office systems – This category consists of all operational systems for the 
store, including inventory management, human resources, and financial 
management. 

A retail store is usually set up with a back office terminal to perform end-of-day 
operations and to receive stock. The customer-facing terminals are used for sales 
operations. 

A POS terminal usually would be a touch screen device with all the devices like scanner, 
EFTPOS machine, and receipt printer attached to enable the terminal to perform sales 
operations to serve the customers. 

As part of the setup, a POS terminal needs to be installed with the following: 

5. Operating System – The POS terminal needs to be installed with a supported 
version of Windows operating system. The supported versions are Windows 
Embedded POSReady 2009 and Windows Embedded POSReady 7. 
 

6. SQL Server Express edition – Most of the retailers use the SQL Express edition 
because of the 10 GB database size allowance, which meets most of the store 
needs. If size is a concern, then higher versions of SQL can be used or the data 
can be archived depending on the business requirements. 
 

7. Microsoft Dynamics AX 2012 POS and Store Connect – Microsoft Dynamics AX 
2012 POS application with store connect needs to be installed on the POS 
terminal to run the POS application. The store connect is configured to 
communicate with Microsoft Dynamics AX for Retail to receive master 
information and send back sales and inventory details. 
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8. Hardware drivers – The drivers for the connected devices like scanner, EFTPOS 

machine and receipt printer need to be installed and configured on every POS 
terminal. 

 
 Note 

Additional software may be required based on the business requirements and devices 
attached to the POS terminal. 

 INSTALL MICROSOFT DYNAMICS AX 2012 POS 

The first step toward POS extensibility is installing the Microsoft Dynamics AX 2012 POS 
from the Microsoft Dynamics AX 2012 Retail feature pack. The installation includes 
components necessary to set up the store and offline database along with the POS 
application. 

 Note 

Download a copy of Microsoft Dynamics AX 2012 Retail feature pack from the partner 
source website. 

To install the Microsoft Dynamics AX 2012 POS on the POS terminal, follow these steps: 

13. Open the folder where you have downloaded the Microsoft Dynamics AX 2012 
Retail feature pack. 
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14. Right-click the setup file, and select Run as administrator. 
 

15. The Microsoft Dynamics AX 2012 installation form appears. 

 

16. Under Install, click Microsoft Dynamics AX components to select the 
components to install. 
 

17. The Microsoft Dynamics AX 2012 Setup Wizard opens. 
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18. Click Next to continue with the installation. 
 

19. Select I accept license terms to continue with the installation. 
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20. After installing the support files, select the installation type from the options: 
i. Custom installation. 

ii. Single-computer installation. 

Select Custom installation if you want to select the components to install. 
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21. Under Retail Components, select the following components to install on the POS 
terminal: 

i. Retail POS – The Retail POS is the POS application that runs on the POS 
terminal used by cashiers and managers to do business at the stores. 
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ii. Commerce Data Exchange – The Commerce data exchange settings are 
used to install the Sync service and the Real-time service to communicate 
from POS to Microsoft Dynamics AX HQ. 

 
iii. Retail Store Database Utility – The Retail store database utility is used to 

create store and offline databases at the POS terminal. 
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22. The Prerequisite validation runs and checks if all the dependencies are met to 
install the selected components. If any errors are displayed, follow the link to 
download and install the prerequisites. 

 

23. Click Next to install the selected component. 

The following section describes how to create a store database at a POS terminal. 
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 INSTALL AND CONFIGURE STORE DATABASE  

As a prerequisite, Microsoft Dynamics AX 2012 POS must be installed on the POS 
terminal. If the installation is complete, then the Retail database utility component is 
used to create and configure store and offline database for a POS terminal. 

 

The following figure shows the typical architecture for POS deployments. 

 

Figure: High-level POS architecture 
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Retail store databases are installed by using the Retail database utility. To open the 
Retail POS configuration form, click Start > All Programs > AX 2012 > Retail Database 
Utility > Retail Database Utility. A store database may be installed either on a stand-
alone database server or on a POS computer.  

 

Figure: Path for Database Utility 

Database utility can perform the following tasks: 

5. Creates store and offline databases. 

6. Create POS configuration file. 

7. Installs Synch Service  

It can be installed separately from POS. 
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Figure: Store Database configuration form 

To create a store database on a stand-alone computer or a POS computer, follow these 
steps:  

10. Open the Retail POS configuration form to install store database on a stand-
alone computer or a POS terminal. 

11. Select Configure store database from the Database area. 

 

12. Populate the Store database fields under the Settings area as follows:  

 Store database name – Enter the store database name.  

 Store server name – Type the name of the server hosting the store database 
(typically localhost). 

If you selected Configure offline database, you can complete additional fields as follows: 
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13. Under the Offline database, enter the Offline server name where the offline 
database will be created. 

14. Enter the Offline database name. 
15. Click Test Connection to test if the server name entered exists and the Retail 

POS configuration can establish a connection to the server. 

 

 

 Note  

This step is required because of a known issue. The values that you enter can be 
arbitrary.  
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16. Optional: Test the connection.  
17. Click Continue to create and configure the store database.  

Collation of Retail POS databases 

The collation for each Retail POS database is based on the Windows locale. To avoid 
collation issues, verify that the Windows locale of each database computer in the 
store is set to one of the supported locales for the Microsoft Dynamics AX 2012 
feature pack. 

Create SQL logons and assign database privileges 

On the head-office communications server, create a SQL logon with the same name 
as the Commerce Data Exchange: Synch Service domain user. The head-office 
instance of Commerce Data Exchange: Synch Service will use this logon to access the 
Commerce Data Exchange: Synch Service message database. Therefore, the logon 
must have read and write (db_datareader and db_datawriter) access privileges on 
the message database. 

On each store computer where SQL Server 2008 is installed, including the store 
communications server, create a SQL Server logon with the same name as the POS 
user group. This logon automatically provides all members of the POS user group 
(that is, all cashiers) access to the store or register database. This logon must have 
read and write (db_datareader and db_datawriter) access privileges on the store 
databases and the Commerce Data Exchange: Synch Service message database. 

In SQL Server Management Studio, expand the Security folder, right-click Logins, and 
then click New Login. 
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7. On the General page, click Search to locate and select the user account that 
you want to use for this SQL Server logon. 
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8. On the User Mapping page, select the check box for the database to which 
you want to grant access, and then, under Default Schema, click Browse. 
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9. In the Select Schema dialog box, click Browse. 

10. In the Browse for Objects dialog box, select the check box for the [dbo] 
object, and then click OK. 

11. In the Select Schema dialog box, click OK. 
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12. In the Database role membership for box, select the appropriate database, 
select the check boxes for the db_datareader and db_datawriter privileges, and 
then click OK. 

 CONFIGURE POS TERMINALS 

Set up user accounts and the POS user group 

To manage access to store computers and databases, you must create the following 
Windows users and user group: 

An account for Commerce Data Exchange: Synch Service – This account must be 
created only on the communications server where Commerce Data Exchange: Synch 
Service is installed and on computers where Retail POS databases are located. The 
Commerce Data Exchange: Synch Service runs as this user. 

An account for each store employee – Each employee user account must be created on 
every register that the employee will use. The employee can use this user account to 
log on to Windows and start Retail POS, and then log on to Retail POS by using the 
employee credentials set up for the employee in Retail Headquarters. 

A POS user group, to which all cashier user accounts on the computer are assigned – 
Create this group on all computers in the store, including the communications server, 
by using the same name as the SQL logon that you created for the POS user group. 
This gives all members of the group (cashiers and the Commerce Data Exchange: 
Synch Service) automatic access to the store or register database. Without this 
access, cashiers cannot process transactions. 
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 Note 

All user accounts should have strong passwords that meet the password policy for the 
organization. 

When you create the POS user group, it inherits the rights and privileges of the 
Standard user group on the computer. Typically, these rights and privileges are 
sufficient and do not need to be modified. 

Guest or temporary user accounts are not supported. 

To create user accounts, follow these steps: 

6. Click Start, type “lusrmgr.msc” in the search or Run box, and then press ENTER to 
open Local Users and Groups. 

 

7. Right-click the Users folder and then click New User. 
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8. Enter the following information, and then click Create. 

 

9. For the Commerce Data Exchange: Synch Service user only, complete these 
additional steps: 

a. Right-click the user and then click Properties. 

b. Clear the User must change password at next logon check box, select the 
User cannot change password and Password never expires check boxes, 
and then click OK. 

10. Repeat steps 1 to 4 to add additional users. Click Close after adding users. 

To create the POS user group, follow these steps: 

7. Click Start, type “lusrmgr.msc” in the search or Run box, and then press ENTER to 
open Local Users and Groups. 

8. Right-click the Groups folder and then click New Group. 
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9. In the Group name box, type the name of the new group. Be sure to use the 
same name on all computers. 

10. Click Add. 
11. In the Enter the object names to select box, type the employee user names that 

you set up in the previous procedure. Separate the names by semicolons. Click 
Check Names to verify that you typed the names correctly, and then click OK. 

12. Click Create, and then click Close. 

  



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

164 

 

 CREATE AN OFFLINE POS DATABASE 

Offline POS Database is used by the POS terminal when the Internet connectivity is 
down. The POS terminal automatically switches to the offline database to continue the 
sales transactions.   

 Note 

In offline mode, cashiers can perform only limited functionality on the POS terminal. 

The following figure shows a scenario where the store database is disconnected.  

 

Figure:  Offline POS 

In Microsoft Dynamics AX 2012, follow these steps: 

11. Open the Retail POS configuration form. 
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12. Select Configure offline database. 

 
Figure: Offline database configuration screen 

 
13. Enter information for the Offline database fields: 

a. Offline database name – Enter the name of the offline database. 
b. Offline server name – Enter the name of the server hosting the database 

(typically localhost). 
14. Enter values for the Identification fields: 

a. Store ID – Type the store ID. This must match the value provided for the 
store in the Name field of the Retail stores form (Retail > Common > Retail 
channels > Retail stores). 

Note 

The store record does not need to be created before you complete 
this step. However, the ID must match later when the record is 
created and the profile is linked.  
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b. Register ID – Type an arbitrary designation for the POS terminal, such as 
“Terminal 1”. 

Note 

The POS terminal record does not need to be created before you 
complete this step. However, the ID must match later when the record 
is created and the profile is linked.  

 
c. Data area ID – Type the company name. 

 
15. Click Continue to create and configure the offline database. 
16. In Headquarters, click Retail > Setup > Retail scheduler > Store integration > 

Database profiles to open the Database profiles form. One profile is required for 
each store. Create new profiles as needed and validate each profile by clicking 
Test connection.  

 

17. In Headquarters, click Retail > Setup > Retail scheduler > Distribution locations to 
open the Distribution locations form. The form displays a list of distribution 
locations. Assign the correct database profile for each location. 
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Note 

Do not assign AOS profiles if they are displayed on the Connection 
profile menu. This is a known issue. 

18. In Headquarters, click Retail > Setup > Retail scheduler > Store integration > 
AOS profiles to open the AOS profiles form. There must be a profile with values 
pointing to a current AOS computer. For more information, click the Help 
button in the form. 
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19. In Headquarters, click Retail > Setup > Retail scheduler > Store integration > 
Commerce Data Exchange: Synch Service profiles to open the Commerce Data 
Exchange: Synch Service profiles form. These profiles enable data to be 
synchronized between Retail Headquarters and stores. Create new profiles as 
needed to point to the correct computers and databases. For more information, 
click the Help button in the form. 

 

20. In Headquarters, click Retail > Setup > POS > Profiles > Transaction Service 
profiles to open the Transaction Service profile form. These profiles enable 
queries and data to be passed directly between Retail Headquarters and POS 
terminals. Create new profiles as needed to point to the correct computers and 
databases. 
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Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

170 

 

36 POINT OF SALE 

OVERVIEW 

The day-to-day operations of Microsoft Dynamics AX for Retail Point of Sales (POS), for 
the point of sales terminals, and the installation and configuration of the store database 
are described in this module.   

For installation or technical information, refer to the Deployment and Installation Guide 
or the Retail POS Technical Reference.   

In Microsoft Dynamics AX for Retail POS, the point of sales terminal layout can be 
configured by store, user, or by the user profile.  The layouts can be modified at the 
register level. However, the layouts are overridden by the layout that is configured at 
the Microsoft Dynamics AX Retail headquarters office level.   

If you have the appropriate permissions to modify the point of sale layout so that you 
can assign different properties at the POS level, you must right-click the button that you 
want to change, click Button Properties, and then in the Action box, select the new 
action.  

 

 

 Important 

Because Microsoft Dynamics AX for Retail POS can be customized, the buttons on some 
windows might differ from the buttons that are described in this training guide. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

171 

 

 Note 

Depending on the employee role settings, you might not be able to perform some 
operations. 

 POS START AND EXIT 

To use Microsoft Dynamics AX for Retail POS, the employee’s name, employee ID and 
password must be set up in Microsoft Dynamics AX Retail.  

Start 

To start, click Start, and then point to All Programs. Point to Microsoft Dynamics AX 
2012, point to Retail POS, and then click Retail POS. 

 
 Note 

The user ID and password are set from the Retail headquarters for the workers 
that are assigned to a store.  

The first time users start Microsoft Dynamics AX for Retail POS, the program displays the 
Initial confirmation form. Here, the required settings for the first configuration must be 
completed. For information about these settings, refer to the Deployment and 
Installation Guide. 

The logon and logoff procedures in Microsoft Dynamics AX for Retail POS can be 
manually performed by logging on or logging off, by scanning a bar code, by swiping a 
card, or by a combination of these methods. Microsoft Dynamics AX for Retail POS 
always starts with the logon dialog box.   

Manual Logon 
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In the Logon form, type the operator ID and password, and then press ENTER. 

 
 

 Note 

 If you use the demonstration data that is included with Microsoft Dynamics AX for 
Retail, refer to the employee information in Microsoft Dynamics AX for Retail for 
the logon credentials that you should use for the sample employees. 

 In the bottom-right corner of the POS log on screen there are four actions to use. 
These actions include the following:  

o Restart: - Restarts the computer. 

o Shutdown: Shuts down the computer system. 

o Training Mode: If the store configuration is set up so that the user can set 
the POS terminal in the training mode, this action appears on this submenu 
list.  

o Exit: To exit the POS terminal screen requires having to completely exit the 
POS system.  

Bar code Logon 

Microsoft Dynamics AX for Retail POS can be set up so that users can scan a bar code 
logon that is configured and issued to users by the headquarters office or the retail 
operations. An ID and password are not used with this method. A logon transaction is 
saved when this is performed.  
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During a transaction that is in progress, you can scan the bar code to switch users. A 
new user ID is then registered with the transaction. 

 Note 

This operation is not yet tested and implemented, so it will require using the 
customization.   

Card Swipe - Logon 

A card with a magnetic stripe can be used to log on. Logging on with a card resembles 
logging on with a bar code, as is described in the preceding section. 

 Note 

This operation is not yet implemented. This operation is not yet tested, so this operation 
will require that the customization can be used.   

Automatic logoff -After each transaction 

Microsoft Dynamics AX for Retail POS can be set up to automatically log off after each 
transaction.  In the table RETAILTERMINALTABLE, change the field 
EXITAFTEREACHTRANSACTION from zero to one. 

After a certain period of time 

Microsoft Dynamics AX for Retail POS can be setup to automatically log off after a certain 
period of time. In the table RETAILTERMINALTABLE, change the field 
AUTOLOGOFFTIMEOUT from zero to the number of minutes Microsoft Dynamics AX for 
Retail POS is idle before automatically logging you off.  

If Microsoft Dynamics AX for Retail POS is in a long process or in design mode, or if a 
dialog box is displayed, the logoff countdown is delayed until the process ends or the 
dialog closes and then it restarts the countdown.    

 

The POS logon and permission verification logic is as follows: 
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i. Verify the user ID and password. 

ii. Verify the store assignment through the address book. 

iii. Verify a current position (date effective). 

iv. Check for the POS permissions override on the position. 

v. Check for POS permissions on the job. 

Exit Retail POS 

i. Click Log off, and then click the red Close (X) button. 

ii. Type your employee ID, and then press ENTER. 

iii. Type your password, and then press ENTER. 

 Note 

Depending on the employee role settings, users might not be able to exit Microsoft 
Dynamics AX for Retail POS.  

Lock and unlock the register 

The user can lock the register if, for example, he or she must step away from the 
register. When the user locks the register, the screen can longer be used and the POS 
transactions cannot be processed. Only a user that has the appropriate authority level 
can unlock the screens and continue operating the POS terminals. 

To lock the register, follow these steps.  
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1. Click Lock Register. A message is displayed to accept or reject the action. 
After you accept the lock action, the following screen is displayed on the POS 
terminal.   

 
2. When you return to the register, you can either unlock the register or log off 

the register. 

To unlock the register, follow these steps. 

 

1. Enter your operator ID and password. 
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2. To log off, click the log off button. This action will return you to the POS log on 
screen. 
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 POS NAVIGATION 

 

 

 

1. Customer pane – Use the buttons in the customer pane to add a new customer, 
search for an existing customer to add to the transaction, or create a customer 
order. When a customer is added to the transaction, the customer pane displays 
information about the customer. 

2. Function buttons – Use these buttons to add products to the transaction, or to 
perform tasks such as applying a discount, suspending a transaction, or opening 
the cash drawer. 

3. Receipt pane – View the products that are added to the transaction. The 
information that is displayed includes prices and quantities. 

4. Title/Image/Logo – Company information that displayed 
5. Bar code and quantity number pad – Use the number pad to enter numbers, such 

as product numbers and quantities. 

2 

1 3 

6 

7 

5 

8 

4 
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6. Totals pane – View information about the transaction's subtotal, sales tax, 
shipping charge, and total. 

7. Payment buttons – Use these buttons to accept different forms of payment, such 
as cash, check, or credit card. 

8. Fast Search /Quantity – Use this to quickly perform a search on the customer/item 
or to manually enter the quantity before adding the item. When you perform a 
fast search, enter the number and press Enter. This opens the Search form that 
can be filtered on the customer or item. 

 

 

 POS TRAINING MODE 

In Microsoft Dynamics AX for Retail POS, the training mode can be used without 
affecting transactions or other information in the database. The sales that are processed 
in the training mode are not recorded, the cash drawer does not open and credit card, 
debit card and check transactions are not processed. 

 Note 

A user can or cannot have access to the training mode. This will depend on the user’s 
employee role settings.  
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To access the training mode, follow these steps. 

1. Start Microsoft Dynamics AX for Retail POS. 
2. On the Logon screen, click the arrow next to the red Close (X) button, and then 

click Activate training. 
3. Log on by using your employee ID and password. 
4. Practice using Microsoft Dynamics AX for Retail POS. 
5. When you finish practicing, click Log Off, and then click Deactivate training. 

 CUSTOMIZE POS BUTTONS 

A button grid is a group of similar buttons. When a new button grid is created, buttons 
are created based on the number of columns and rows that are specified. For example, 
if a grid is created that has four columns and five rows, 20 buttons are created. These 
buttons can be configured for specific POS operations. 
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36.4.1 CREATE A BUTTON GRID 

To create a new button grid, follow these steps. 

1. Right-click an existing button and then click New Button Grid. 

 

2. In the Button grid ID box, type a unique ID. 

3. In the Name box, type a name. 

4. In the Keyboard field – select one of the activity items from the drop down list 
box. 
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5. In the Number of columns and Number of rows boxes, type the number of 
columns and rows that the button grid will contain. These values can be changed 
later. 

6. In the Space between buttons box, type the number of pixels that re required 
between the buttons. 

7. In the Font box, click the button and then select the font that is required for the 
text on the buttons. 

8. In the Default font style box, select the default font style of the text that is 
required on the buttons. 

9. In the Default button color box, select the default color of the buttons. 

10. In the Default font size box, type the default font size of the text on the buttons. 

11.  After you complete the settings for the button grid, click OK. 

How to display the new button grid is described in the following section. 

 

36.4.2 OPEN A BUTTON GRID 

To open a button grid, follow these steps. 

1. Right-click the Function pane area, and click Open Button Grid. 
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2. From the Open Grid form, select the custom button grid that is created. 

 
3. Select the required button grid, and then click Open. 

 
 

36.4.3 CHANGE THE PROPERTIES OF A BUTTON GRID 

The properties on the button grid resemble the properties that are used to create a new 
button grid, except the number of rows and columns cannot be changed. 

To create a new button grid, follow these steps. 

1. Right-click a button grid, and then click Button grid properties. 
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2. Change the properties that require changes and then click OK. 

36.4.4 ADD A ROW 

To add a row, right-click a button grid, and then click Add a row. Microsoft Dynamics AX 
for Retail POS adds a row of buttons underneath the last row of the button grid. 

36.4.5 ADD A COLUMN 

To add column, right-click a button grid and then click Add a column. Retail Microsoft 
Dynamics AX for Retail POS adds a column of buttons at the right edge of the button 
grid. 

36.4.6 DELETE A ROW 

To delete a row, right-click a row in a button grid, and then click Delete row. Microsoft 
Dynamics AX for Retail POS displays a message confirming whether you want to delete 
the row. 

36.4.7 DELETE A COLUMN 

To delete a column, right-click a column in a button grid and then click Delete column. 
Microsoft Dynamics AX for Retail POS displays a message confirming whether you want 
to delete the column. 

36.4.8 CUSTOMIZE BUTTONS 

 Note 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

184 

 

Frequently, the layout of the Microsoft Dynamics AX for Retail POS screen is 
specified at the headquarters office by using Microsoft Dynamics AX for Retail. 
Then, the layout is sent to the stores. Any local customizations that are performed 
in the stores are overridden. 

 Microsoft Dynamics AX for Retail POS does not support currency triangulation. In 
currency triangulation, two currencies are not converted directly. Instead, the 
two currencies are converted through a third currency, such as the euro. 

In Microsoft Dynamics AX for Retail POS, users can customize many of the properties 
on buttons, such as the text, color, and operation. 

36.4.9 CHANGE THE TEXT, FONT, OR COLOR OF A BUTTON 

To change the text, font, or color of a button, follow these steps. 

1. Right-click the button that you want to change and then click Button 
properties. 

 
2. In the Appearance area, in the Text on button box, type the text that is to 

appear on the button. 
3. In the Font size and Font style boxes, type the font size and then select the 

required font style. 
4. In the Color box, select the required color. 
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5. Click OK.  

36.4.10 ASSIGN A PICTURE TO A BUTTON 

Images can be assigned to buttons. To assign images to buttons, follow these steps.  

1. Right-click the button which requires an image to be attached and then click 
Button properties. 

2. In the Button preview area, click Select image. 

 

 

3. To use one of the available pictures, select the picture in the list. Or, to add a 
new picture to the list, click New picture, and then select the required picture 
from a different location on the computer or the network. To remove a picture 
from the list, right-click the picture, and then click Delete picture. 
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4. Click Select image, and then click OK. 

36.4.11 REMOVE A PICTURE FROM A BUTTON 

To remove a picture from a button, right-click the button that you want to change, and 
then click Button properties. Then, in the Button preview area, click Clear image. 

36.4.12 CHANGE THE SIZE OF A BUTTON 

To change the size of a button, in the Size in columns field and in the Size in rows field, 
type the number of columns and rows that are required for the button to extend 
across. 

36.4.13 DELETE A BUTTON 

To delete a button, right-click the button that you want to delete, and then click the 
Delete button. 

36.4.14 CHANGE THE OPERATION THAT A BUTTON PERFORMS 

To change the operation a button performs, follow these steps. 

1. Right-click the buttons that must be changed and then click the Button 
properties. 

2. In the Action area, in the Item box, select the operation that you want the 
button to perform. 
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3. Click OK. 

 POS OPERATIONS 

 Note 

 Typically the layout of the Microsoft Dynamics AX for Retail POS screen is 
specified at the headquarters office by using Microsoft Dynamics AX for Retail 
and then is sent to the stores. In these cases, any local customizations that are 
done at the stores are overridden. 

 Microsoft Dynamics AX for Retail POS does not support currency triangulation. In 
currency triangulation, two currencies are not converted directly. Instead, the 
two currencies are converted through a third currency, such as the euro.  

Many actions can be assigned to a button on Microsoft Dynamics AX for Retail POS. To 
assign an action, browse to the Properties window and then set the Item Property. 

 

The operations that you can assign to buttons are described in the following table. The 
table is sorted alphabetically, based on the name that is used for each operation in the 
Button Properties form.  

Name Description 

Add 

shipping 

address 

Add a shipping address for the customer of the transaction. 
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Name Description 

Add to gift card Add money to the specified gift card. 

Bank drop Record the amount of money that is sent to the bank and other 
information, such as the number of the bank bag. 

Blank operation Represents a button that can be customized and, or programmatically 
changed by a software developer for any specialized operation that the 
business requires. 

Blind close shift Set the current shift to blind close, and log off the cashier. 

Change unit of measure Change the scanned item's unit of measure. 

Clear qty (quantity) Reset the quantity of an item to 1. 

Clear salesperson Clear any salesperson from the transaction. 

Close shift Close the current shift. 

Customer Open a form where the cashier can type a customer ID to search for the 
customer. If a customer is found, the customer is added to the 
transaction. 

Customer account 
deposit 

Make a payment to a customer’s account. 

Customer add Open the Add customer form. Here, the cashier can enter information 
about a new customer. When the information is saved, the new 
customer is added to the customer list. 

Customer clear Clear a customer from the transaction. If any price agreements apply to 
the customer, prices and discounts in the transaction might change. 

Customer search Open a form where the cashier can search for a customer. The cashier 
can then add the customer to the transaction. 

Customer transactions Display the transactions for the selected customer. 

Customer transactions 
report 

Print a report that shows the transactions for the selected customer. 
Currently this is not implemented. 

Declare start amount Declare the amount that is in the cash drawer when the day or shift 
starts. 

Design mode disable Prevent changes to the screen layout of the terminal. The functionality 
profile of the terminal specifies whether the cashier has access to this 
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Name Description 

operation. 

Design mode enable Allow changes to the screen layout of the terminal. The functionality 
profile of the terminal specifies whether the cashier has access to this 
operation. 

Display total Display the balance of the transaction on the customer display. 

End of day This operation is not used and might be removed from future releases. 

End of shift This operation is not used and might be removed from future releases. 

Expense accounts Record money that is removed from the cash drawer for occasional 
expenses. 

Float entry Register a float entry to the cash drawer, such as an addition or a 
change. 

Gift card balance Display the balance of a gift card. (Uses transaction services.) 

Income accounts Record money that is put into the cash drawer for a reason other than a 
sale. 

Inventory lookup Look up on-hand inventory for the current store and other available 
locations. 

Invoice comment Enter a comment about the transaction. The comment is saved together 
with the transaction, and appears on the receipt or invoice. 

Issue credit memo Issue a central credit memo through Commerce Data Exchange: Real-
time Service, and print a copy. 

Issue gift card Issue a gift card through Commerce Data Exchange: Real-time Service, 
and print a copy. 

Item comment Add a comment to the selected line item in the transaction. The 
comment is saved together with the transaction and appears on the 
receipt. 

Item sale Add an item to the transaction. The button must be configured 
specifically for the item. 

Item search Search for an item. You can search for an item by item ID, item 
description, or item category. Search results can be sorted. 

Line discount amount Enter a discount amount for a line item in the transaction. This operation 
is used only for discountable items and only in specified discount limits. 
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Name Description 

Line discount percent Enter a discount percentage for a line item in the transaction. This 
operation is used only for discountable items and only in specified 
discount limits. 

Lock terminal Lock the register when the cashier must leave the register. The cashier 
unlocks the register by logging on. 

Log off Log off the register, and suspend any sales until the next logon. 

Loyalty request Enter the customer’s loyalty card number. The cashier can also initiate 
this operation by swiping a loyalty card. 

The loyalty request can be performed at any time during the transaction. 
Microsoft Dynamics AX for Retail POS calculates loyalty points at the 
end of the transaction. 

The number of loyalty points that is awarded for the items in the 
transaction depends on how the loyalty program is set up in Microsoft 
Dynamics AX for Retail. 

Minimize POS window Minimize the Microsoft Dynamics AX for Retail POS window. 

Open drawer Open the cash drawer when a sale is not made. This operation is 
recorded in the database. 

Override line item tax Override the tax on the selected line item, and use a different tax. The 
new tax must previously be specified in Microsoft Dynamics AX for 
Retail POS. 

Override line item tax 
from list 

Override the tax on the selected line item, and use a tax that the cashier 
selects in a list. The list of taxes must previously be specified in 
Microsoft Dynamics AX for Retail POS. 

Override transaction tax Override the tax on a transaction, and use a different tax. The new tax 
must previously be specified in Microsoft Dynamics AX for Retail POS. 

Override transaction tax 
from list 

Override the tax on a transaction, and use a tax that the cashier selects 
in a list. The list of taxes must previously be specified in Microsoft 
Dynamics AX for Retail POS. 

Pay card Accept a credit card or debit card as payment. The cashier types the 
card’s number and expiration date. The cashier can also specify 
overpayment or underpayment, if the store allows overpayment or 
underpayment. 

The cashier can also initiate this operation by swiping a credit card or 
debit card. In this case, Microsoft Dynamics AX for Retail POS 
automatically completes the transaction. 
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Name Description 

Pay cash Accept cash as payment. The cashier can select to pay the transaction’s 
total, overpayment, or underpayment, if the store allows overpayment or 
underpayment. 

If overpayment is allowed, Microsoft Dynamics AX for Retail POS 
displays the amount that exceeds the transaction’s total.  

Pay cash quick Complete the transaction in "one touch," provided that the customer 
paid the exact amount of the transaction’s total in cash.   

Pay check Accept a check as payment for the transaction. 

Pay corporate card Accept a corporate card as payment. The cashier types the card’s 
number and expiration date. The cashier can also initiate this operation 
by swiping a credit card or debit card. In this case, Microsoft Dynamics 
AX for Retail POS automatically completes the transaction. 

The authorization for corporate cards can differ from the authorization 
for credit cards and debit cards. Restrictions can be specified for 
corporate cards, so that the purchase of certain items is allowed or 
prohibited. Currently this is not implemented.  

Pay credit memo Accept a credit memo that is issued by the store. 

Pay currency Accept payment in several currencies. The cashier selects the payment 
currency, and Microsoft Dynamics AX for Retail POS calculates the 
transaction’s total in that currency. 

The cashier can also specify overpayment or underpayment, if the store 
allows overpayment or underpayment. 

Pay customer account Charge a transaction to a customer’s account. The cashier can also 
specify overpayment or underpayment, if the store allows overpayment 
or underpayment. Microsoft Dynamics AX for Retail POS also checks 
whether the customer is blocked. 

If necessary, you can add the customer to the transaction at this time.  

You can also check a customer’s credit before you allow the payment, if 
credit checking has been set up in Microsoft Dynamics AX for Retail 
POS.   

Pay gift card Accept a gift certificate or gift card issued by the store. 

Picking and receiving Open the Picking and receiving form, where you can select a 
purchase order or transfer order that you want to receive or pick 
merchandise for. 

Popup menu Select a button grid that is associated with the button.  
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Name Description 

When the button is clicked, Microsoft Dynamics AX for Retail POS 
displays the selected button grid in a separate window. 

Price check Check the price of the product. Microsoft Dynamics AX for Retail POS 
asks for the item number. You can scan the item or search for the item. 

When the product is found, Microsoft Dynamics AX for Retail POS 
displays the price of the item, and you can add the product to the 
transaction.    

Price override Override the price of the product, if the product is set up to allow price 
overrides. Microsoft Dynamics AX for Retail POS displays a number pad 
that you can use to enter the new price.  

Print X (X report) Print an X report. 

Print ZZ (ZZ report) Print a ZZ report. 

Recall order Open the Sales order form. Here, you can search for a customer and 
the customer's sales orders and quotations. 

Recall transaction Recall a suspended transaction. 

Reprint Z (Z report) Reprint a Z report. 

Return item Perform a return of individual products. The next scanned product is 
noted as a returned item that has a negative quantity and price. 

Return transaction Perform a return of an entire transaction. 

Safe drop Perform a safe drop to move money from the register to a safe. 

Sales invoice Display information about a sales invoice for a specific customer. 

Sales order Display information about sales orders for a specific customer. 

Search shipping address Open a form where you can search for a shipping address. 

Set qty (quantity) Change the quantity of a line item in the transaction. 

Show blind closed shifts Display a list of blind closed shifts. 

Show journal View the register’s journal. You can then view transactions, reprint 
receipts, or print invoices. 
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Name Description 

Stock count Open the Stock counting form, where you can scan or enter bar codes. 

Sub menu Select a button grid that is associated with the button.  

When the button is clicked, Microsoft Dynamics AX for Retail POS 
displays the selected button grid instead of the existing button grid. 

Suspend shift Suspend the current shift, and log off the current cashier.  

Suspend transaction Suspend a transaction, which you can recall later. 

Tender declaration Open the Tender declaration form. 

Tender removal Record the removal of money from the cash drawer. 

Total discount amount Enter a total discount amount. This amount is divided among all items in 
the transaction. 

Total discount percent Enter a total discount percentage. This percentage is divided among all 
items in the transaction. 

Transaction comment Add a comment to the transaction. The comment is saved together with 
the transaction and appears on the receipt. 

Void item Void a line item in the transaction. The line item is removed from the 
transaction’s total and appears marked as voided. 

Void payment Void all payment methods that are applied to the transaction. 

Void transaction Void the transaction. Voided transactions are saved in the database and 
have a void status. 

 

 DATABASE CONNECTION STATUS 

When the system is temporarily down or the store database is unavailable and the 
register is offline, users can perform only basic transactions, such as sales and returns.  

Microsoft Dynamics AX for Retail POS displays the connection status in the status bar. 
Refer to the follow illustration. (Connect to Store Database is highlighted in yellow in 
the bottom right side of the POS screen.) 
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 Note 

To work offline, an offline database must be set up on the register.  As a best practice, 
every register should be configured with an offline database. 

When the connection with the store database is lost, Microsoft Dynamics AX for Retail 
POS automatically switches to the offline database so that users can process basic sales 
transactions with limited functionality. 

 
 Note 

If a transaction is in progress when the connection is lost, users must void the 
transaction and then start a new transaction by using the offline database. 

While connected to the offline database, users can perform only basic transactions, such 
as sales and returns. Users cannot close shifts, open new shifts, create new customers, 
add products to the system, or process returns for transactions that are performed on 
other registers. 

When the connection with the store database is reestablished, Microsoft Dynamics AX 
for Retail POS automatically connects with the store database. 

  TENDER PROCESS 

Customers can provide payment for their purchases by tendering different types of 
transactions to the cashier. To finalize the sale, a cashier will select the payment 
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methods from the payments pane area on the screen that is offered by the customer to 
settle the transaction. 

Microsoft Dynamics AX for Retail POS supports the following payments scenarios: 

 Single Tender  
o Full receipt amount paid by cash in the local currency 
o Full receipt amount in a foreign currency 
o Full receipt amount paid by card 

 Multi Tender – In this scenario the cashier can accept multiple forms of 
payment from the customer for a single sales transaction. These forms of 
payment can include the following: 

o Cash and card 
o Multiple Currency 

Click the button for the appropriate payment method. In the Enter the amount field, 
enter the amount the customer offers to pay or settle the sale. If the amount is equal to 
or greater than the Total Amount Due then, Microsoft Dynamics AX for Retail POS 
completes the transaction and displays the change that is due the customer, if the 
customer has tendered an amount greater than the amount due.  

If the payment is not a full payment, Microsoft Dynamics AX Retail for POS adds a 
payment line to the transaction and the customer pays the balance with another 
payment method. For example, in the following illustration there are two item lines. The 
total amount due that must be paid is 115.00 United States dollars (USD). The customer 
decides to pay 15.00 by cash and the rest by card.  
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 Note: If the customer pays with exact change, click the “Exact” button, instead of 
the Cash button. 
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 POS FUNCTIONALITY 

36.8.1 DRAWER OPERATIONS 

Typically, the drawer operations at the Microsoft Dynamics AX for Retail POS register 
include the following functions: 

 Declare Start amount 

 Bank Drop 

 Float Entry 

 Safe Drop 

 Print X 

 Print Z 

 Tender Removal 

 Open Drawer 

 Show Blind Close Shifts 

 Tender Declaration 

 Close Shift 
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Open the cash drawer  

The cash drawer opens automatically at the end of a sales transaction. However, a user 
can open the cash drawer when it is required based on authorized levels.  Additionally, 
a user might need to provide a reason code if the cash drawer is opened to perform a 
non-sales or no procedural function. This operation is recorded in the database.  
 

 Note: 
Depending on the employee’s role settings, the employee might not be able to open the 
cash drawer without processing a sale.  
 

To open a cash drawer, click Open drawer from the POS screen. Typically this function is 
underneath the Drawer operations button.  

36.8.1.1 DECLARE OPENING OR CLOSING AMOUNTS 

Specify opening or closing amounts 

Typically, at the beginning of the day, the cashier enters a starting amount, performs 
sales transactions during the day, and at the end of the day, enters an ending amount. 
The cashier performs a tender declaration, closes the shift and runs a Z report to verify 
whether there is an overage or shortage. 

Microsoft Dynamics AX for Retail POS keeps track of these daily totals with shifts. A shift 
is the record of one register’s activity from the close of the previous shift through the 
close of the current shift. Typically, a shift includes the opening amount, sales 
transactions, and the closing amount. 

Often, one cashier works at one register, opening a shift at the start of work and closing 
the shift at the end of the day or work shift. However, cashiers can also log on and off 
multiple registers during the day. In this case, remember these points about shifts. 

Floating shift 

 If a cashier logs on to two different registers, the cashier logs on to two different 
shifts. 

 Multiple cashiers sharing the same register share the same shift. 

 When a cashier logs off and another one logs on, a new shift is not created. 
Performing a close shift operation is the only way to close a shift and open a 
new one. 
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36.8.1.2 ENTER AN OPENING AMOUNT 

To enter an opening amount, follow these steps. 

1. Log on to Microsoft Dynamics AX for Retail POS. 

 

 

2. Click Tasks, and then click Declare Start Amount. 

3. In the Amount box, type the opening amount. 

4. If necessary, enter a description in the Description box. 

36.8.1.3 CLOSE THE REGISTER 

Typically, a cashier closes the register at the end of the day or work shift. This closes the 
current shift and opens a new one. 

 Note: 

If the store manager counts the drawer in addition to the cashier, he or she performs 
separate counts in the step 2 that follows. Then the store manager enters any notes in 
the Tender Declaration form. 

If the store manager counts the cash drawer instead of the cashier, the store manager 
logs on to the register first, and performs the following steps. 
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1) Click Tasks, and then click Tender Declaration. 

2) Count the contents of the cash drawer and enter the amounts in the Tender 
declaration form. The following Tender declaration form shows the set-up for 
the retail organizations accepting multiple currencies. 

 

3) If necessary, enter any notes in the Notes box.  The count button from the 
previous screen lets the user count the currency by denominations to record and 
add the total count for that specific currency. 
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4) As soon as the tender declaration is complete and the OK button is clicked, the 
store manager receives the following message: Are you sure that you want to 
write these amounts to the database?  

 

5) Click Yes to close the shift. 

6) Click Tasks, and then click Close shift. 

7) Click Tasks, and then click Print Z to print a Z report. 

8) Verify that the counted amount agrees with the expected amount from the Z 
report. 

36.8.1.4 TENDER REMOVAL 

When cash has to be withdrawn from the cash drawer, this operation can be used, with 
an optional description that could be allocated to an expense or income account and 
also with a reason code.  Tender could be removed by a safe drop function that is 
discussed later. 
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36.8.1.5 FLOAT ENTRY 

Sometimes the cashier might require additional change in the register during the shift. 
Any addition or change in the register cash tenders(s) other than the tenders that are 
received from a sales process must be registered as a float entry to the cash drawer. 

36.8.1.6 SAFE DROP 

For security reasons, some retailers might set business policies to make sure that 
cashiers remove excess cash from the register and store it in the safe.  To perform a safe 
drop to move money from the register to a safe, the cashier can click the Safe drop 
button underneath the drawer operations.  The Safe drop screen opens.  

 
 
Users can perform multiple safe drops during the shift. By doing this, the amounts from 
the safe drop transaction are totaled when you post to the General Ledger.  
 

36.8.1.7 BANK DROP 

Make a cash drop or payout 

Make a cash drop, which is also called a bank drop, to reduce the amount of money that 
is in the cash drawer. Users can also make a cash payout to remove a small amount of 
money from the cash drawer for a specific purpose, such as to pay for a minor expense. 

 Note 
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Depending on the employee’s role settings, the employee might not be able to 
make cash drops or cash payouts. 
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36.8.1.8 MAKE A BANK DROP 

 

To perform a bank drop, the user is required to have a specific security access. If the 
user has the specific security access, he or she can click Bank drop in the Cashiers Task. 
Then, the user receives the following message: Are you sure you want to perform a bank 
drop? If the user clicks Yes, then the Bank Count form opens. Now, the user can count 
the cash for the bank drop by tender type (by Currency). Then, the Count window is 
displayed. In the Count window, the user can calculate several currency denominations 
that will be removed from the cash register for the bank drop. As soon as the user is 
finished, he or she can click the OK button. Now, the user receives the following 
question: Are you sure you want to write these amounts to the database? If the user 
clicks YES, form is displayed. Here, the Bank Bag Number is entered as a reference or a 
comment. As soon as this action is completed, Microsoft Dynamics AX for Retail POS 
records the operation in the database.    
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36.8.1.9 MAKE A CASH PAYOUT 

Retail Stores can use the cash to pay for in-store expenses and the stores are required to 
enter the account name that is created in the system to identify the expense for which 
the cash is withdrawn. To process an expense account, the user must follow these steps. 

1. Click Expense account. 

 

 

 

 

 

 

 

 

2. An Expense form opens. Here the user selects the appropriate category 
of expense. 

3. After the user selects the expense account the Expense amount form 
opens. Here the user enters the expense amount. 
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 The entry is recorded in the POS transaction window and then the user can 
tender the transaction as “Cash” by clicking the payment pane. 

 Microsoft Dynamics AX for Retail POS opens the cash drawer so that the user can 
remove the cash amount and then Microsoft Dynamics AX for Retail POS records 
the operation in the database. 

36.8.1.10 RECEIVE CASH FOR NON INVENTORY ITEMS 

Retail Stores can receive cash for non-inventory transactions and classify the cash into 
required income accounts.  To   receive cash and classify the cash as income, follow 
these steps.  

1. Click Income account underneath the cashier tasks. 

 

 

 

 

 

 

 

 

 

2. The Income opens. Here user selects the appropriate category of Income. 
3. After the user selects the income account, the Income amount form 

opens. Here, the user enters the income amount. 
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 The entry is recorded in the POS transaction window, and then the user can 
tender the transaction as “Cash” by clicking the payment pane. 

 Microsoft Dynamics AX for Retail POS opens the cash drawer so that the user can 
add the cash received amount and then Microsoft Dynamics AX for Retail POS 
records the operation in the database. 

36.8.1.11 BLIND CLOSE / BLIND CLOSE SHIFTS / CLOSE SHIFTS 

The user can perform a blind close to end the POS shift or to end the floating shift and 
then exit the register. However, the user should enter a closing amount and post the 
current shift later. For example, if the user does not want to count the cash drawer in 
the store front, the user can remove the cash drawer and finalize the closing amount in 
the back office. 

 Note 

Depending on the employee role settings, employees/users might not be able to 
perform a blind close. 

To perform the blind close, follow these steps. 

1. Click Blind close underneath the drawer operations functions. 
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Microsoft Dynamics AX for Retail POS marks the shift as blind closed and 
prints the blind close report, which is a receipt. 

 
2. Typically, the cashier places the blind close receipt in the till, places the 

cover on the till, then locks the till, removes the cash drawer and returns 
to the back office to complete the closing and counting routine. 

36.8.2 CLOSING THE BLIND CLOSED SHIFT 

To close the blind closed shift, follow these steps. 

1. The cashier logs on to a POS terminal in the back office to start the closing 
routine, and then clicks Close blind closed shift or Show Blind Close Shifts. 
By selecting the Show Blind Close Shifts the user can identify the register 
number and the shift number to be processed for the closing routine. 
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2. Select the shift, enter the declare start amount if an opening balance exists. 
3. Click Tender declaration, count the contents of the till by currency where this is 

required and then enter the amounts. 

 
 

 
4. After the count is completed, click the OK button and then the user receives the 

following message: Are you sure that you want to write these amounts to the 
database?  If the user clicks Yes the counted amounts are recorded. 
 Note 

If the user re-clicks the Declare Start Amount button or the Tender Declaration 
button and repeats steps 3 through 5, in the former procedure, then the 
previous counts are overridden. 

5. If the user has the correct permissions, he or she can print an X report to verify 
the entered amounts. Or, the user can click Close shift to close the shift, and 
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finalize the declaration amounts and then Microsoft Dynamics AX for POS 
automatically prints a Z report. 

 

36.8.2.1 PRINT THE X REPORT 

The X report shows the register’s activity since the register opened. The X report shows 
information such as the sales, the sum of all discounts given, and the customer count for 
the customers who have visited the store during the current shift. 

To print the X report, the user can log on to the Microsoft Dynamics AX for Retail POS 
register and then click the Print X button underneath the drawer operations functions. 

When the X report is printed, it does not close the current shift. The report is printed on 
the register's receipt printer. 

 Note: 

The store manager can perform a spot audit by counting the register’s contents and 
then comparing it to the X report. 

 Click Cashier Tasks or Drawer Operations, and then click Print X. 

36.8.2.2 PRINT Z REPORT 

Refer to the following section.  

36.8.2.3 PRINT A ZZ REPORT 

A ZZ report shows the statistics from all the register's Z reports that are created since 
the last ZZ report. The report is printed on the register's receipt printer. 

 Note 

 You must enter opening and closing amounts before you can print a Z report. 

 Printing a ZZ report closes the current shift and opens a new shift. 

Click Tasks, and then click Print ZZ. 

36.8.2.4 PRINT Z REPORT 

The Z report shows information about the last closed shift, such as shift number, sales, 
amount of cash dropped, sales tax and the expected closing total. Microsoft Dynamics 
AX for Retail POS automatically prints a Z report when a user closes a shift. The Z report 
can be used to verify that the expected closing total agrees with the actual counted 
contents of the cash drawer. 
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Reprinting the Z report does not close the current shift or display information about the 
current shift. The Z report can be for multiple days, and it printed on the register's 
receipt printer. 

Typically, in the standard POS Layout, users can print Z Reports by logging on to 
Microsoft Dynamics AX for Retail POS and accessing the Drawer operations function. 

To print the Z report, click Reprint Z. 
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36.8.3 INVENTORY OPERATIONS 

Inventory operations can be accessed from Tasks > Inventory. Several inventory 
operations are available in Microsoft Dynamics AX for Retail POS. These operations 
include the following tasks: 

 Picking (outgoing transfers) and Receiving – (purchase orders or inbound 
transfers) 

 Stock Count 

 Price Check 

 Inventory Look Up 

 

36.8.3.1 PICKING AND RECEIVING 

 Receive inventory 

Inventory can be received in the store from purchase orders and incoming transfer 
orders. Employees who have been granted access can receive the merchandise. When 
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the orders are completed, the orders are uploaded to Microsoft Dynamics AX for Retail 
POS to track the movement and posting of the inventory. 

Product variants and units of measure can be included when you receive inventory. 

 Note: 

You can also receive inventory by using Enterprise Portal for Microsoft Dynamics AX. 
Enterprise Portal requires only a browser and an Internet connection. For more 
information, refer to Enterprise Portal Help. 

To receive inventory, follow these steps. 

1. Start Microsoft Dynamics AX for Retail POS and log on by using an account that 
has store inventory access. 

2. Typically, these operations are classified underneath the Inventory Operations 
functional menu. Click the Inventory operations menu to review the functional 
activities. 

3. Click Picking and receiving. The Picking and receiving menu opens. This menu 
displays the list of orders to be received or picked. 

 

 Note 
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 The location of the Picking and receiving button might differ, depending on 
the screen layout. In the default layout, this button is located underneath 
Tasks. 

 Microsoft Dynamics AX for Retail POS displays a list of purchase orders, 
incoming transfer orders, and outgoing transfer orders for the store. 

4. Click Refresh to refresh the list of purchase orders or transfer orders. 

5. Select the purchase order or incoming transfer order that you want to receive 
and then click Select. 
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6. After you click the Select button, Microsoft Dynamics AX for Retail POS displays 
the Receiving form. 

7. Scan the product that you want to receive or type the item number in the Scan 
or enter barcode box, and then press ENTER. You can also click Search to search 
for the product. 

 Microsoft Dynamics AX for Retail POS displays the Quantity form. 

8. In the Enter quantity box, type the quantity, and then press ENTER. 

9. Repeat steps 5 and 6 for each product that must be received. 

10. When you finish receiving the inventory, click Commit to send the changes to 
Microsoft Dynamics AX for Retail POS. 

 Picking inventory 

Pick a transfer or sales order 

In Microsoft Dynamics AX for Retail POS, the user can pick outgoing transfer orders and 
pick sales order items for delivery to the other locations or customers. Employees who 
have been granted access can pick the merchandise. When the orders are completed, 
the orders are uploaded to Microsoft Dynamics AX for Retail so that they can be posted. 

 Note: Users can also receive inventory by using Enterprise Portal for Microsoft 
Dynamics AX. Enterprise Portal requires only a browser and an Internet 
connection. For more information, refer to Enterprise Portal Help. 

To pick inventory, follow these steps. 

1. Start Microsoft Dynamics AX for Retail POS and log on by using an account that has 
store inventory access. 

2. Typically, these operations are classified underneath the Inventory Operations 
functional menu. Click the Inventory operations menu to review the functional 
activities. 

3. Click Picking and receiving. The Picking and receiving menu opens. This menu 
displays the list of transfer out orders to be picked. 
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 Note 

 The location of the Picking and receiving button might differ, depending on 
the screen layout. In the default layout, this button is located underneath 
Tasks. 

 Microsoft Dynamics AX for Retail POS displays a list of outgoing transfer 
orders and pick lists for the store. 

4. Click Refresh. 

5. Highlight the order that you want, and then click Select. Microsoft Dynamics AX for 
Retail POS displays the Picking dialog box. 

6. Scan a product that you want to pick, or type the item number in the Scan or enter 
barcode box, and then press ENTER. 

 Microsoft Dynamics AX for Retail POS displays the Quantity form. 

7. In the Enter quantity box, type the quantity, and then press ENTER. 

8. Repeat steps 5 and 6 for each product that you want to pick. 

9. When you finish picking the order, click Commit to send the changes to Microsoft 
Dynamics AX for Retail POS. 
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36.8.3.2 STOCK COUNT 

 Perform a stock count 

You can perform a basic stock count either by using a scanner or by manually entering 
the item information. The register can be either online or offline when you perform 
stock counts in Microsoft Dynamics AX for Retail POS. You can suspend the stock count 
and resume the count later, if necessary.  

Variants can be counted in stock counts. However, serial numbers and units of measure 
cannot be counted. 

 Note: 

You can perform scheduled stock counts, and also basic stock counts, by using 
Enterprise Portal for Microsoft Dynamics AX. Enterprise Portal requires only a browser 
and an Internet connection. For more information, refer to Enterprise Portal Help. 

To perform the stock count, follow these steps.   

1. Start Microsoft Dynamics AX for Retail POS and log on by using an account 
that has store inventory access. 

2. Click Stock count. 

 Microsoft Dynamics AX for Retail POS displays the Stock counting form. 

3. Scan an item, or type the item number in the Scan or enter barcode box, 
and then press ENTER. 

4. In the Enter quantity box, type the quantity, and then press ENTER. 

 If the item has variants, Microsoft Dynamics AX for Retail POS displays the 
Select form. 

5. If necessary, select the appropriate variant dimensions. 

6. Repeat steps 3 through 5 for each item that you want to count. 

7. When you finish the stock count, click Commit to send the stock count to 
Microsoft Dynamics AX for Retail POS. 

36.8.3.3 PRICE CHECK 

To perform a price check, follow these steps. 
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1. Start Microsoft Dynamics AX for Retail POS and log on by using an account that 
has store inventory access. 

2. Typically, these operations are classified underneath the Inventory Operations 
functional menu. Click the Inventory operations menu to review the functional 
activities. 

3. Click Price Check. 

Microsoft Dynamics AX for Retail POS displays the Price check form. 

4. To check the price, scan the product’s bar code or enter the Item Number.  

Microsoft Dynamics AX for Retail POS displays the product’s price and 
description.  

Or, you can check the price of a product by using the Search function.  
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5. To check the price of a product by using the Search function, follow these steps. 
i. On the Price Check form, click Search. 

 Microsoft Dynamics AX for Retail POS displays the product list. 

 In the product list, the Item Search window can be used to search 
for the product. 

ii. Select the product that is required, and then  click Show price. 

 Microsoft Dynamics AX for Retail POS displays the Price column. 

iii. In the list, select the required product and click OK to return to the Price 
check window. 

6. Click Sell Item to record the  product in the POS window for transaction 
processing or close the screen. 

36.8.3.4 INVENTORY LOOK UP 

From the Microsoft Dynamics AX for Retail POS terminal, to search for products and the 
stock levels at several locations, follow these steps. 

1. Start Microsoft Dynamics AX for Retail POS and log on by using an account that 
has store inventory access. 

2. Typically, these operations are classified underneath the Inventory Operations 
functional menu. Click the Inventory operations menu to review the functional 
activities. 

3. Click Inventory look up to search for an item and then click Search. 
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4. The item search list is displayed on the screen. To expand the search, type the 
full and, or part of the name of the product.  

5. To check the quantity of a product, highlight the product and then click the 
Search button. 

Use the Inventory lookup display grid to view the locations and the stock 
levels at each of these locations. 
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6. Add the selected product to the transaction. Or, scan or type the product’s 
bar code and then click Search.  

 Microsoft Dynamics AX for Retail POS displays the product together 
with the quantity that is in inventory. 

 If the item is found, the product’s status will be displayed at the top of 
the dialog.  The inventory status of the stores in the retail operations 
will be displayed in the list together with the stock levels. 

7. After the search and the quantities check is completed, click Close.  
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36.8.4 LOYALTY PROCESS 

The loyalty schemes are set-up at the Microsoft Dynamics AX Retail level. Typically, the 
loyalty customer and transactional details are obtained at the store level at the point of 
sale register. 

36.8.4.1 USING THE OPERATION IN MICROSOFT DYNAMICS AX FOR 
RETAIL POS 

The two loyalty activities on Microsoft Dynamics AX for Retail POS are accruing points 
based on sales transactions according to the loyalty scheme and the redemption of the 
points that are accrued. 

To process loyalty at the point of sale, the customer’s loyalty card number must be 
entered by selecting the loyal request task. Or, the cashier can also start this operation 
by swiping the customer’s loyalty card. The loyalty request can be performed at any 
time during the transaction. Microsoft Dynamics AX for Retail POS calculates loyalty 
points at the end of the transaction. 

The number of loyalty points that is awarded for the items in the transaction is based on 
the loyalty schemes that are set up in Microsoft Dynamics AX for Retail POS.  
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To redeem loyalty points, the card payment dialog must be opened and a card that is 
identified as a loyalty card must be used. 

How to Accrue Points 

To accrue loyalty points, a loyalty card must be added to the transaction manually by 
using the loyalty request button or by swiping the loyalty card at any time during the 
transaction.  If the card is identified as the loyalty card, a message is displayed on the 
message panel.  Then, the user must follow these steps.  

1. Start the Microsoft Dynamics AX for Retail POS application.  

 

 If the application is already running then log off and 
then log back on. 

 If the new setup is replicated from Microsoft Dynamics 
AX for Retail to the POS local database, then the new 
loyalty request button should be visible. 

2. Click the Loyalty Request button.  

3. Type the Loyalty card number in the number dialog box. 

Only one Loyalty card can be registered for each 
transaction. If the user tries to add a second Loyalty card a 
message appears asking whether to override the existing 
loyalty record.   
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How to Redeem Points 

When you use the Loyalty card to redeem points, the card payment dialog must be 
opened. To use the Loyalty card to redeem points, follow these steps. 

1. Enter the items to be purchased. 

2. Press the Card payment button. The Card payment dialog 
box appears. 

3. Swipe or enter the Loyalty card number and then enter 
the amount to be paid. 

 Note:  

Typically, the redemption is a type of tender that is used to pay for a sales 
transaction based on the number of points accrued. The Loyalty card must be set 
up as a Card Type to make sure that the redemption process is available at the 
Point of Sale level. 

36.8.5 GIFT CARD – ISSUE AND REDEMPTION 

Functional Overview 

A gift card is a non-inventory item that is purchased by the customer and is issued by 
the retailer. The gift card has a value attached to it that the customer can use as tender 
to pay for products that are purchased in the retail store(s).  In Microsoft Dynamics AX 
for Retail POS, the following four gift card operations exist:  

 Issue a gift card to the customer 

 Add a balance to the gift card 

 Check the gift card balance 

 Pay for a transaction partially or fully with a gift card. 

36.8.5.1 ABOUT GIFT CARDS 

By default, the gift cards feature is turned off both in Microsoft Dynamics AX for Retail 
POS and Microsoft Dynamics AX for Retail. For information about how to make this 
feature available, refer to the Deployment and Installation Guide. 

Before gift cards can be used by retail stores, the gift cards must be set up in Microsoft 
Dynamics Retail. After the gift cards are set-up, four key functions can be used at the 
Point of Sale (POS) terminal(s) across the retail stores that are in the business 
operations. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

225 

 

A gift card that is issued in one store can be redeemed in another store, if the store is in 
the same retail operation and the store uses Microsoft Dynamics AX for Retail POS. 
However, gift cards cannot be returned for a refund at the point of sale.  

In stores that use different currencies, balances are displayed in the local currency, 
based on the currencies and exchange rates that are set up in Microsoft Dynamics AX 
Retail. 

An amount that is due to a customer as part of a return transaction can be added to a 
gift card. 

36.8.5.2 ISSUE A GIFT CARD 

To Issue a gift card, follow these steps. 

1. Click Gift Card. Typically, this is located underneath the sales operations tasks. 
Three options exist— Issue Gift Card, Add To Gift Card or Gift Card Balance. 
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2. Select Issue Gift Card. 
3. Scan the gift card, or enter the gift card number in the Gift card number box. 

4. In the Gift card amount box, enter the amount of the gift card, and then click 
OK. 

Microsoft Dynamics AX for Retail POS adds the gift card to the transaction. 

 

5. Complete the transaction. 

Together with the sales receipt, Microsoft Dynamics AX for Retail POS prints a 
separate gift card receipt that includes the gift card number and the balance. 

36.8.5.3 ADD MONEY TO A GIFT CARD 

To add money to an existing gift card, following these steps. 

1. Click gift card. Typically, this is located underneath the sales operations tasks. 
Three options exist—Issue Gift Card, Add to Gift Card or to Check Gift Card 
Balance. 

2. Select Add to gift card. 
3. Scan the existing gift card provided by the customer or enter the gift card 

number in the Gift card number box. 
4. In the Gift card amount box, enter the amount that the customer wants to add 

to the gift card, and then click OK. Microsoft Dynamics AX for Retail POS adds the 
gift card to the transaction. 
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5. Complete the transaction. The receipt for the transaction includes the gift card 
number and the balance. 

 Note: 
For the tax effects for issuing a gift card or adding more money to an existing gift 
card, refer to the retailer’s financial controller or a key stakeholder. 
 

36.8.5.4 CHECK THE GIFT CARDS BALANCE 

To check the balance on an existing gift card, follow these steps. 

1. Click gift card. Typically, this is located underneath the sales operations tasks. 
Three options exist—Issue Gift Card, Add To Gift Card or Gift Card Balance. 

2. Select Check Gift Card Balance. 
3. Scan the gift card or, enter the gift card number in the Gift card number box. 

Microsoft Dynamics AX for Retail POS displays the gift card's balance. 

 

4. To print a receipt that includes the balance, click Print receipt. 

36.8.5.5 REDEEM A GIFT CARD 

Gift cards can be used as the payment method to pay for the sales transactions at the 
Point of Sale register. Typically, gift cards are set up as a tender type so that cashiers can 
accept the card as payment.   
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To accept a gift card as a payment, follow these steps. 

1. Select or create a customer and then process the sales transaction.  After the 
sales transaction is completed, the customer can use the gift card or a 
combination of the gift card and the other tender types to pay for the sales 
transaction. 

2. Click the Gift Card button or the Card button on the Payment Pane of the Point 
of Sale terminal to redeem the gift card. 

3. Scan the gift card, or enter the gift card number in the Gift card number box. 
4. In the Gift card amount box, enter the amount that the customer wants to pay 

by using the gift card, and then click OK. 
5. Complete the transaction. Microsoft Dynamics AX for Retail POS includes the gift 

card’s balance on the sales receipt. 
 

 

 Note: 

Offline database 

Microsoft Dynamics AX for Retail 2012 introduces support for local offline databases on 
the Retail POS register. This means that if for any reason the connection to the store 
database fails or if the store database must go through maintenance that will take it off 
line, the Retail POS registers can continue to process transactions. Although the offline 
database is not required, it creates a contingency for unexpected network issues. For 
example, if the store database cannot be accessed, the Retail POS register that is 
connected to the offline database can process gift cards based on the condition that the 
transaction service is functional and will check the balance for the gift card that is 
tendered at the point of sale. If the transaction service is not functional or the Microsoft 
Dynamics AX Retail database cannot be accessed, gift cards cannot be redeemed.   



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

229 

 

36.8.6 TIME CLOCK 

Retail workers can enter their time through Microsoft Dynamics AX for Retail POS, and  
managers can review the times that are entered by each store. 

36.8.6.1 TIME MANAGEMENT AT POS 

As soon as the worker can access Microsoft Dynamics AX for Retail POS and the worker 
is setup for time registration, he or she can enter time from the POS. 

To enter time, follow these steps. 

1. Log on to Microsoft Dynamics AX for Retail POS by entering the Operator ID and 
password. 

 
2. Depending on the layout and design of the POS setup, select the Timeclock 

button.  
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POS > Tasks > Time clock 

 
The Register time form opens and shows the current status of the worker, for 
example, if the worker is clocked in, and so on. 

 
Time Registration for cashier 

3. Now, the cashier can perform the following functionality: 
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 Clock-in and clock-out: A worker clocks in when the worker arrives at 
work and when the worker leaves work.  

 Register breaks: During the work day, a worker takes breaks. Break types 
available include Break from work and Break for lunch. When the worker 
returns and logs on again, Microsoft Dynamics AX for Retail POS registers 
that the worker is back, and the break registration stops.  

 Logbook: This shows all the time registration transactions of the worker. 

Note 

Logging off does not clock out a worker. Workers need to clock out to end their shift. 

36.8.6.2 MANAGER CAN REVIEW TIME REGISTRATION 

For a manager to view the time registration for workers in stores, follow these steps.  

1. Select the View Time clock button. 

 

Manager POS 

The View time clock entries form opens. This View time clock entries form shows the 
time registration transactions.  
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2. The transactions can be filtered by the following options: 

 Clock in: The clock in entry for all workers. 

 Clock out: The clock out entries for all workers. 

 Break for lunch: The worker’s transaction that is created for a lunch break. 

 Break for work: The worker’s transaction that is created for a work break. 

 Select Store: Shows the transactions by specific store. 

 Select all Store: Shows the transactions for all stores. 

 

 SALES OPERATIONS 

General sales and customer sales orders are the most common scenarios in Microsoft 
Dynamics AX for Retail POS. Sometimes a customer order might require ordering 
products that are not available in stock at the store. In Microsoft Dynamics AX for Retail 
POS, four types of transactions at the point of sale include the following: 

 Sales Quotation:  Used to give the customer the price estimate for a specific 
product/service. 

 Sales Orders: Used for products not normally stocked or temporarily not 
available in the store.  (This includes customized orders, and pre-order 
scenarios.) 

 Sales Transactions: Used for a normal sales transaction activity. 
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 Return Transactions: Used to recall an existing transaction for return or for 
customers returning goods accepted by the store based on the store’s policy. 

Customer orders can be used by retailers to create an order in the store. This order can 
be picked up in the store or shipped to the customer.  Additionally, the orders can be 
picked up in another store in the group, and the picking and packing activities can be 
started and completed from Microsoft Dynamics AX for Retail POS or when the 
customer picks up the order at the store.  Microsoft Dynamics AX for Retail POS also 
supports order return and order cancellation from the retail point of sale.  The 
configuration for the customer orders, deposit requirements, and so on, are set up in 
the “Retail Parameters” section in the “Retail Parameters – Customers’ Orders and 
Quotes” chapter.  
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36.9.1 PERFORM A BASIC SALES TRANSACTION 

Order Creation and Order Modification 

To create and maintain a sales transaction, follow these steps. 

1. In the transaction pane, search and select the products that the customer wants 
to order that are temporarily out of stock.  You can do this before or after you 
perform step 2.  

2. In Microsoft Dynamics AX for Retail POS, click Create order to launch the Order 
details form. By doing this, you can enter the order type, customer information, 
shipping and delivery information, and you can also view the order summary 
before you commit the order. Products can be added to an order by using the 
regular Microsoft Dynamics AX for Retail POS transaction pane. 
 

 
 

3. Click the Change button, select Quote, and enter the Expiration date for the 
quote. 
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4. Click Customer information to enter customer data. 
 

 
 

5. Click Shipping and delivery to select the shipping and delivery options. 
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The Mixed Delivery option can be used to pick the products from the ordering 
store or from a different store.  Additionally, this option can be used to view a 
combination of actions, for example, pick up goods from a store and have the 
balance shipped to a selected address. 

6. Click Order summary to review order information before committing the order. 
After verifying that all information is accurate, submit the quote or order. 
 

 

Basic Sales transactions 

To add a customer to a basic sales transaction, follow these steps.  

1. Click Add customer or Customer search to add a customer to the transaction. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

237 

 

2. Scan the products, or click the buttons on the screen for the products, or search for 
the products. 

Microsoft Dynamics AX for Retail POS adds the products to the transaction. 

 Note 

If your store has a loyalty program and the customer participates in the program, 
swipe the customer's loyalty card or click Tasks, and then click Loyalty request. 
This credits the transaction to the customer's loyalty account. 

 

3. Click the button for the appropriate payment method, in this case, the Cash button. 

Microsoft Dynamics AX for Retail POS displays the Cash form. 

 Note: 

If the customer pays with exact change, click the Exact button, instead of the 
Cash button. 

4. In the Enter the amount box, type the amount that the customer pays. 
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5. Press ENTER. 

Microsoft Dynamics AX for Retail POS completes the transaction and displays the 
change that is due the customer. Or, if the payment is a partial payment, Microsoft 
Dynamics AX for Retail POS adds a payment line to the transaction and the customer 
pays the balance with another payment method. 

36.9.2  ADD PRODUCT / PRODUCT VARIANTS 

To add a product to a transaction, follow these steps. 

1. Scan the product's bar code. Or, click the button for the product on the screen 
that is set up for the product. Or, click the Product Search, select a product in 
the list, and then click Select. 
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Note: If users know the full or partial product name they can type it to quickly find 
the product.  Microsoft Dynamics AX for Retail POS adds the product to the 
transaction and displays a number one in the Quantity column.  
 

2. If there are two or more units of a product, click Set Qty, type the quantity, and then 
click OK. 
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3. If you want to change the product's unit of measure, click Tasks, and then click 
Change unit of measure. 

36.9.3 EDIT LINE ITEM 

To edit the line item, follow these steps. 

1. In the receipt pane, select the line item whose quantity you want to change.  
2. Click Set Qty.  

Microsoft Dynamics AX for Retail POS displays the Price Check dialog box.  

3. Type the quantity you want, and then press ENTER or OK.  

Microsoft Dynamics AX for Retail POS changes the quantity and notes the 
unit price on the line item. 

4. Other functions to edit a line item are Clear Quantity (sets the quality to 
one), Item comment (the user can add a comment to the line), Void Item (if 
the user has the permissions necessary, the user can void the item with a 
reason code), or Return Item (the user can process the product as a return 
item – any transaction can have a return and a sale in the same receipt, 
typically an exchange). 

36.9.4 ADD A WEIGHED PRODUCT 

To add a product that must be weighed and priced based on weight, follow these steps. 

1. Place the merchandise on the scale. 
2. Add the product to the transaction, either by clicking Product Search and 

selecting the product from the list, or clicking the button on the screen that is set 
up for the product.  Microsoft Dynamics AX for Retail POS adds the product to 
the transaction and displays the weight on the line item. 

36.9.5 ADD A PRODUCT WITH VARIANTS 

To add a product with variants, follow these steps. 

1. Scan the product's bar code. Or, click the button for the product on the screen 
that is set up for the product. Or, click Product Search, select a product in the 
list, and then click Select.   

2. In the Select color, size, style, configuration form, select a dimension for each of 
the product's variants. Typically the products are bar coded to use the scan 
process. 
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36.9.6 ADD A PRODUCT WITH A SERIAL NUMBER 

To add a product with a serial number, follow these steps. 

1. Add a product as described in the previous step procedure. 
2. Click Product comment, and then type the serial number.  

36.9.7 PRICE OVERRIDE 

To override a price, follow these steps. 

1. In the receipt pane, select the line item for which you want to change the price. 
2. Click Price override. 
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3. In the Enter a price form, type the price that you want to use, and then press ENTER. 

Microsoft Dynamics AX for Retail POS changes the price of the line item and notes 
the original price.  If the a reason code is set up to capture the reason for the price 
override the cashier is required to select the reason code for the price override 
action. 

36.9.8 APPLY A DISCOUNT TO A LINE ITEM 

 Note 

Based on the employee role settings, you can or cannot apply discounts to line 
items.  

Discounts and price adjustments are set up and applied automatically in Microsoft 
Dynamics AX for Retail if a product is added to a transaction. 

Discounts can be a specific amount or a discount percentage. Discounts include two 
specialized discounts—quantity discounts and mix-and-match discounts. 

To apply an additional discount to a line item at the register, follow these steps. 

1. Select the line item that you want to apply a discount to. 
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2. To apply a specific discount amount, click Line discount amount, and then specify 
the amount. Or, to apply a specific discount percentage, click Line discount percent, 
and then specify the percentage. 

Microsoft Dynamics AX for Retail POS applies the discount to the line item. 

 Note: 

Based on the configuration of the security in Microsoft Dynamics AX Retail, you can or 
cannot apply a line item discount. Additionally, you might be required to capture a 
reason code for the discount if the reason code is configured in Microsoft Dynamics AX 
Retail. 

36.9.9 TRANSACTIONS 

36.9.10 ADD A COMMENT TO A LINE ITEM 

To add a comment to a line item, follow these steps. 

1. In the receipt pane, select the line item to which you want to add a comment. 
2. In the edit line item tasks, click Item comment. 
3. On the Enter a comment form, type the comment, and then press ENTER. 

 

Microsoft Dynamics AX for Retail POS adds the comment to the line item. 
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 Note 
Depending on the receipt formats that are used at the store, comments that you 
add to line items might appear on receipts. 
 

36.9.11 APPLY OR REMOVE TAX FROM A LINE ITEM 

Typically, Microsoft Dynamics AX for Retail POS automatically applies local taxes that are 
configured in Microsoft Dynamics AX Retail. However, if different sales taxes options are 
set-up in Microsoft Dynamics AX Retail, you can override the sales tax that Microsoft 
Dynamics AX for Retail POS applies to the line items and the transactions. 

 Note 

 Depending on the employee role settings, you can or cannot apply or clear taxes 
at the register. 

 Many states require retailers to record a proof of tax-exempt status with each 
tax-exempt transaction. For example, a tax-exempt ID number or an out-of-state 
ID. A customer's tax ID number can be added to the transaction as a detail or 
comment, or it can be entered in the customer's record. 

 Tax configuration settings and options to override taxes must be set up for a 
retail organization together with the financial controller of the retail operations. 

To override a line item tax, follow these steps. 

1. In the receipt pane, select a line item. 
2. Click Override line Product tax to override the line item tax with a preselected 

alternative. Or, click Override line item tax from list to select a new tax from a 
list. 
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3. Click Yes and then a list of taxes will be displayed. 
4. Select the appropriate tax level. 

Microsoft Dynamics AX for Retail POS replaces the existing line item tax with the 
new line item tax. 

36.9.12 CHANGE THE CURRENCY OF A TRANSACTION 

To change the transaction currency at the POS level, the currencies and the exchange 
rates must be configured in Microsoft Dynamics AX. If you have the authorized 
permissions, you can change the currency of a transaction.  

To change a currency of a transaction, follow these steps. 

1. Log on to the POS terminal. 
2. Scan or add at least one product to the transaction. 
3. Click Pay currency. 

 Note: 

The Pay currency change currency function is underneath the Edit transactions tasks. 
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4. Select a currency from the list. 

 

Microsoft Dynamics Retail for POS displays the transaction amounts in the selected 
currency.  

36.9.13 VOID A TRANSACTION 

You can void a transaction that is in progress. However, you can only do this after the 
product is scanned or entered and before the transaction is tendered. 

 Note 

Depending on your employee role settings, you can or cannot void a transaction. 

To void a transaction, follow these steps. 
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1. Add at least one product to the transaction. 
2. Click Void transaction. You will receive a message asking whether you 

want to void the transaction.  Click Yes to void the transaction.

 

Microsoft Dynamics AX for Retail POS voids the transaction. Voided transactions are 
saved in the database with a Void status. 

36.9.14 HOLD AND RECALL A TRANSACTION  

If a sales transaction is interrupted at the register, you can put the customer’s 
transaction on hold, and if necessary, serve the next customer. Then, when the 
customer is ready to complete the transaction, you can recall and complete the 
transaction that is on hold.   

 Note  

You can hold a transaction only after you have added at least one product to it.  

To place a customer transaction on hold, follow these steps.  

1. Add at least one product to the transaction.  
2. Click Suspend transaction. 
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 Note  

You cannot recall a transaction while another transaction is in progress.  

To recall a transaction that is placed on hold, follow these steps. 

1. Complete any transaction that is in progress.  
2. Click Recall transaction.  

 

A list of transactions on hold in the store will be displayed. 
3. Select the transaction that is on hold and then click Retrieve to continue to process 

the transaction that is on hold. 
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4. Add or void products (based on permissions) to, and from the transaction that is on 
hold, if this is necessary. 

5. Complete the transaction by tendering the transaction and collecting the payment. 

36.9.15 VOID PAYMENT 

Payments can be voided only after the transaction is completed. Typically, a payment is 
voided when a customer does not want to continue with the sales, or the customer 
provided the incorrect amount or the incorrect card.  

To continue to void a payment, follow these steps.  

1. Click Void Payment in the functions pane of the POS terminal. Only the last payment 
of the transaction can be voided. If you attempt to void another payment you will 
receive the message: You cannot undo voiding a tender line. 

 

2. If you have processed many payments, then the only option is to continue with the 
transaction because it cannot be voided.  Click OK, and then you can process a 
refund to reverse the transaction. 

 CUSTOMER QUOTE TO ORDER 

In Microsoft Dynamics AX for Retail POS, you can create a sales quote from a customer’s 
request and then change it directly to a sales order. 

 

36.10.1 CREATE A SALES QUOTE 

To create a sales quote, follow these steps. 

1. Log on to the POS terminal by entering the Operator ID and password. 
 

2. Search and add the customer in the customer pane or create a new customer if 
the customer does not exist. 
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3. Add the product(s) to the transaction by entering the items in the Search 
Quantity field and then selecting the item. Items can also be added from Sales > 
Tasks > Inventory > Inventory Lookup. 
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4. Click Sales > Tasks > Custom Order > Create Custom Order. 
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5. On the Order information page, enter the following information: 

 Order Type - Click the Change button and select Quote. 

 Salesperson – This should automatically be set to the salesperson that is 
logged on, if the salesperson must be changed. Click the Change button 
that is next to the field and then select the salesperson for the quote. 

 Expiration date – Enter the date that the quote expires. 

 Comments – Enter the appropriate comments, if this is required. 

 Loyalty card – Enter the loyalty card of the customer, if this is required. 

6. Click Save, and then in the left navigation pane, click Customer information. 
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7.  On the Customer information page, enter the following information: 

 Contact information – Make sure that the customer's information is 
correct. If not, click Search, select the customer, and then correct the 
information. 

8. Click Save, and then in the navigation pane, click Shipping and delivery. 
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9. In Shipping and Delivery information, for each item, Ship or Pickup can be 

selected. 

 Click Ship. The Shipping information window opens. 
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 Shipping address – Make sure that the customer's shipping 
address is correct. If not, click Search, and then select a shipping 
address.  

 Shipping method - Click Change, and select a shipping method. 

 Shipping charge - Click Add charge or Remove charge to add or 
remove a shipping charge. 

 Requested delivery date - Click the calendar icon, and select a 
date. This is the date the item will be shipped. 

 Click Pick. The Pickup information form opens. 

 
 Requested delivery date - Click the calendar icon, and then select a 

date. This is the date the sales quote will be picked up by the 
customer. 

 In the list of stores, select the store where the customer will pick up 
the sales quote. To select a different store other than the stores 
listed, click Search, and select a store. 

10. If the customer wants all the products on the sales quote shipped, click Ship all. 

11. If the customer wants to pick up all the products on the sales quote, click Pick up 
all. 

12. Click Save, and then in the navigation pane, click Order summary.  
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13. Make sure that the information is correct, and then click Save. If the information 
is not correct, click a page name in the navigation pane to return to a page, 
correct the information, return to the Order summary page, and then click Save. 
 

14. Complete the transaction. Microsoft Dynamics AX for Retail POS prints the sales 
quote receipt on a full-page printer, not the receipt printer. 

 

36.10.2 MODIFY A SALES QUOTE 

You can modify a sales quote. For example, if you want to update delivery information, 
and, or add or remove products. Product prices and the deposit can also be recalculated 
for changes that are made to the sales quote. 

1. Search and Add a customer to the transaction from the point of sale, or you can 
enter the customer information in the step 2. 
 

2. Click Tasks and then click Recall Order.  
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3. Enter the information that is related to the sales quote and then click the search 

function. 
 

  
 

4. Select the sales quote in the list, and then click View details. 
 

5. Make the required changes to the sales quote, and then click Save. 
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6. Microsoft Dynamics AX for Retail POS prints the sales quote receipt on a full-
page printer and not from the receipt printer. 

 

36.10.3 CANCEL THE SALES QUOTE 

36.10.4 CHANGE THE SALES QUOTE TO THE SALES ORDER 

In Microsoft Dynamics AX for Retail POS, as soon as the sales quote is accepted, you can 
change the sales quote to the sales order. 

To change the sales quote to the sales order, follow these steps  

1. Search and Add a customer to the transaction from the point of sale or you can 
enter the customer information in step 2. 
 

2. Click Tasks and then click Recall Order.  

 
3. Enter the information that is related to the sales quote and then click the Search 

function. 
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4. Select the sales quote in the list, and then click View details. 
 

5. On the Order information page, click Change for the order type and select Sales 
Order. 
 

6. Make any other required changes to the sales order, and then click Save. 
 

7. Click Order summary.  
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8. Make sure that the information is correct, and then click Save. If the information 
is not correct, click a page name in the navigation pane to return to a page, 
correct the information, return to the Order summary page, and then click Save. 
 

9. If necessary, collect a deposit for the order, and then complete the transaction. 
Microsoft Dynamics AX for Retail POS prints the sales order receipt on a full-page 
printer, not the receipt printer. 

 

 CUSTOMER SALES 

36.11.1 CREATE THE SALES ORDER 

You can create a sales order if a customer wants to buy products that are currently out 
of stock or are a non-stock item, and might have to be ordered from a supplier. 

To create the sales order, follow these steps. 

1. Log on to the POS terminal by entering the Operator ID and password. 
 

2. Search and add the customer in the customer pane or create a new 
customer if the customer does not exist. 
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3. Add the product that is out of stock to the transaction or the quantity of 
stock that is not available. The item can be added from Sales > Tasks > 
Inventory > Inventory Lookup. 
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4. Click Sales > Tasks > Custom Orders > Create Custom Order. 
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5. On the Order information page, enter the following information:  

 Order Type – This should be set to Sales Order, if it is not, click 
Change and select Sales Order. 

 Salesperson – This should automatically be set to the salesperson 
that is logged on, if the salesperson must be changed. Click 
Change next to the field and then select the salesperson for the 
order. 

 Comments – Enter the appropriate comments, if this is required. 

 Loyalty card – Enter the loyalty card of the customer, if this is 
required. 

6. Click Save, and then in the left navigation pane, click Customer 
information. 

 
7. On the Customer information page, enter the following information: 

Contact information - Ensure that the customer's information is correct. 
If not, click Search, select the customer, and then correct the 
information. 

8. Click Save, and then in the navigation pane, click Shipping and delivery. 
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In Shipping and Delivery information for each item, Ship or Pickup can be 
selected. 

9. Click Ship.  The Shipping information window opens. 
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 Shipping address – Make sure that the customer's shipping 
address is correct. If it is not, click Search, and then select a 
shipping address. You can also add a new shipping address from 
the main point of sale section. 

 

10. Click Add Shipping Address. Enter the shipping address information and 
then click Save. 

  
 Shipping method - Click Change, and select a shipping method. 
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 Shipping charge - Click Add charge or Remove charge to add or 
remove a shipping charge. 

 Requested delivery date - Click the calendar icon, and select a 
date. This is the date the order will be shipped. 

11. Click Pick. The Pickup information form opens. 

 
 Requested delivery date - Click the calendar icon, and then select a 

date. This is the date the sales order will be picked up by the 
customer. 
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 In the list of stores, select the store where the customer will pick up 
the sales order. To select a different store other than the stores listed, 
click Search, and select a store. 

 If the customer wants all the products on the sales order shipped, click Ship all. 

 If the customer wants to pick up all the products on the sales order, click Pick up 
all. 

11. Click Save, and then in the navigation pane, click Order summary.  

 
 

12. Make sure that the information is correct, and then click Save. If the information 
is not correct, click a page name in the navigation pane to return to a page, 
correct the information, return to the Order summary page, and then click Save. 
 

13. If necessary, collect a deposit for the order, and then complete the transaction. 
Microsoft Dynamics AX for Retail POS prints the sales order receipt on a full-page 
printer, not the receipt printer. 

 

36.11.2 MODIFY THE SALES ORDER 

You can modify a sales order. For example, to update delivery information, and add or 
remove products. Product prices and the deposit can also be recalculated for changes 
that are made to the sales order. 

To modify the sales order, follow these steps. 
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1. Search and Add a customer to the transaction from the point of sale or 
you can enter the customer information in step 2. 

2. Click Tasks, click Recall order, and enter the information that is related to 
the sales order and then click the order search function. 

 
 

3. Select the sales order in the list, and then click View details. 
 

4. Make the required changes to the sales order, and then click Save. 
 

5. If the deposit amount changed, collect an additional amount or refund an 
amount to the customer and then complete the transaction. 

Microsoft Dynamics AX for Retail POS prints the sales order receipt on a full-page 
printer and not from the receipt printer. 

 

36.11.3 CANCEL A SALES ORDER 

In Microsoft Dynamics Retail POS, a sales order can be can canceled until the time the 
order is picked (a pick list is created in Microsoft Dynamics AX). If a pick list is created, 
then the orders must be canceled in Microsoft Dynamics AX. 
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If the cancellation charge is set up, the charge is deducted from the refund amount. 
Depending on the employee role settings, you can change this charge when you cancel 
the order. 

To cancel a sales order, follow these steps. 

1. Search and Add a customer to the transaction from the point of sale or you can 
enter the customer information in the step 2. 
 

2. Click Tasks, click Recall order, and enter the information that is related to the 
order and then click the order search function. 
 

 
 

3. Select the sales order and then click Cancel order. Microsoft Dynamics AX for 
Retail POS displays the order's Cancellation charge page. 
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4. To change or remove the cancellation charge, enter the following action. 

 To add or change the charge, click Add charge. 

 To remove the charge, click Remove charge. 

5. Click Save. 
 

6. If a cancellation charge applies, collect the charge, and then complete the 
transaction. 

Microsoft Dynamics AX for Retail POS prints the canceled sales order receipt on a full-
page printer, not the receipt printer. 

 

36.11.4 PICK UP ALL OR PART OF A SALES ORDER 

In Microsoft Dynamics AX Retail for POS, to pick up all or part of a sales order, follow 
these steps. 

1. Search and Add a customer to the transaction from the point of 
sale or you can enter the customer information in the next step. 
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2. Click Tasks, click Recall order, and enter the information that is 
related to the order and then click the order search function. 

 
 

3. Select the sales order and then click Pick up order.  
4. Click Item details. 
5. In Pick up qty, enter the quantity of each item that is being picked 

up and click Save. 
6. If the deposit amount changed, collect an additional amount or 

refund an amount to the customer, and then complete the 
transaction. 

 
 

36.11.5 CREATE THE PICKING LIST 

To create a picking list for existing sales orders, follow these steps.  

1. Search and Add a customer to the transaction from the point of sale or you can 
enter the customer information in the step 2. 
 

2. Click Tasks, click Recall order, and enter the information that is related to the 
order and then click the order search function. 
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3. Select the sales order and then click Create picking List. 
 
You will receive a confirmation that the picking list is created. 

36.11.6 CREATE AND PRINT THE PACKING SLIP 

When a sales order is shipped from a store, you can create and print packing slips.  
However, you must first create the sales order before you create and print a packing 
slip. 

To create and print the packing slip, follow these steps. 

1. Search and Add a customer to the transaction from the point of sale or you can 
enter the customer information in step 2. 
 

2. Click Tasks, click Recall order, and enter the information that is related to the 
order and then click the order search function. 
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3. Select the sales order and then click Create packing slip. 
 

 Note 

If the packing slip is already created, the Create packing slip button is 
unavailable. 

4. To print the packing slip, click Print packing slip. 

Microsoft Dynamics AX for Retail POS prints the packing slip. 

 

36.11.7 RETURN THE SALES ORDER 

If a customer returns a purchase, you can use the point of sale to return all or part of 
the order.  You can process the return with or without a receipt, depending on the 
store’s return policy. After the sales order is located, the way the sales order is returned 
resembles the way a regular sales transaction is returned.  

To return the sales order, follow these steps.  
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1. Search and Add a customer to the transaction from the point of sale or you can 
enter the customer information in step 2. 
 

2. Click Tasks, click Recall order, and enter the information that is related to the 
sales order and then click the order search function. 

  
 

3. Select the sales order and then click Return order. 
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4. Select line or Select all for the items that you want to return. 
 

5. Click Return items. 
 

6. Enter the Return reason and click Select. 
 

7. Complete the transaction and refund any balance due to the customer. 

 CREDIT MEMOS 

FUNCTIONAL OVERVIEW 

A credit memo acknowledges a liability and provides authorization to pay the debt. A 
credit memo is issued when a customer returns bought goods and it can be used as 
payment for other goods.  A credit memo is never sold.  

Microsoft Dynamics AX for Retail POS uses the term credit memo.  However, Microsoft 
Dynamics AX for Retail uses the term credit voucher. 

When you create credit memos in Microsoft Dynamics AX for Retail POS a request is 
sent to Microsoft Dynamics AX for Retail through the Retail POS Transaction Service. The 
credit memo is created in Microsoft Dynamics AX for Retail and the information is 
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returned to Microsoft Dynamics AX for Retail POS and then it continues with the sale 
whether it is a payment, printing a certificate and so on. 

36.12.1 ISSUE A CREDIT MEMO 

To issue a credit memo, follow these steps. 

1. Add a customer to the transaction. 

2. Add products to the transaction. 

3. Click Issue credit memo. 

4. In the Credit memo amount box, enter the amount of the credit 
memo, and then click OK. 

 

 

 

 

 

Microsoft Dynamics AX for Retail POS adds the credit memo to the transaction. 

 

5. Complete the transaction. 

Together with the sales receipt, Microsoft Dynamics AX for Retail POS prints a 
separate credit memo receipt that includes the credit memo number and the 
balance. 

36.12.2 TOTAL A SALE PAID BY GIFT CARD OR CREDIT MEMO 

To total a sale paid by gift card or credit memo, follow these steps. 
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1. Scan the products, click the buttons on the screen for the products, or search 
for the products. 

Microsoft Dynamics AX for Retail POS adds the products to the transaction. 

If necessary, add the customer to the transaction. 

2. Click Pay gift card or Pay credit memo. 

3. Scan or swipe the gift card. Or, in the Gift card number box, enter the gift 
card number. Or, in the Credit memo number box, enter the credit memo 
number. 

4. Press ENTER. 

Microsoft Dynamics AX for Retail POS completes the transaction. Or, if the 
payment is a partial payment, Microsoft Dynamics AX for Retail POS adds a 
payment line to the transaction and the customer pays the balance by using 
another payment method.  

 

36.12.3 ISSUE A CREDIT MEMO INSTEAD OF A REFUND 

If you want to issue a store credit instead of a refund, you can issue a credit memo.  

To issue a credit memo instead of a refund, follow these steps. 

1. Click Show journal. 

2. Select the transaction that you want to return, and then click Return 
transaction. 

3. Select the line items that the customer wants to return: 

 To return one line item, select the line item, and then click Select line. 

 To return all line items, click Select all. 
4. Click Return products. 

5. Click Issue credit memo. 

6. Complete the transaction. 

Microsoft Dynamics AX for Retail POS prints a credit memo receipt that includes 
the credit memo number and the balance. 
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Note :  

Offline database  

Microsoft Dynamics AX for Retail 2012 introduces support for local offline databases on 
the Microsoft Dynamics AX for Retail POS register. This means that if for any reason the 
connection to the store database fails or if the store database requires maintenance that 
will take it off line, the Microsoft Dynamics AX for Retail POS registers can continue to 
process transactions. The offline database is not required. However it creates a 
contingency for expected network issues. In the event that the store database cannot be 
accessed, the Microsoft Dynamics AX for Retail POS register that is connected to its 
offline database can perform credit memo, and other transaction service related 
functions.  

 

 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

279 

 

37 ENTERPRISE PORTAL – RETAIL COMPONENTS 

OVERVIEW 

This module discusses how the Microsoft Dynamics® AX Enterprise Portal is used to 
perform  back-office retail operations.  

With Enterprise Portal, store managers and other employees can use a web browser to 
access store-inventory information at the headquarters office and perform inventory 
tasks that would otherwise require Microsoft Dynamics® AX for Retail. 

Note 

 Before an employee can use the Enterprise Portal, the employee must be 
assigned to one of three retail user profiles and to one or more stores in 
Microsoft Dynamics AX. For more information, refer to the Microsoft Dynamics 
AX Retail User’s Guide. 

 Enterprise Portal and Role Centers are features of Microsoft Dynamics AX. For 
more information about how to use Enterprise Portal and Role Centers, refer to 
the documentation for Microsoft Dynamics AX. 

 For installation or technical information about the Enterprise Portal, refer to the 
documentation for Microsoft Dynamics AX. 
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40 ENTERPRISE PORTAL HOME PAGE 

OVERVIEW 

In this module we will discuss the Enterprise Portal display of the Home page.  

 Note: Enterprise Portal displays the Home page with the Role Center that is assigned to 
you. For more information, refer to Role Centers, later in this module. 

 LOG ON 

To log on, follow these steps. 

1. Start a browser and go to the retailer’s Enterprise Portal webpage. 

2. Log on with Windows credentials. 

40.1.1 SELECT A STORE 

An employee can access information about only those stores that have been assigned to the 
employee. If an employee has been assigned to more than one store, the primary store is 
displayed by default and other stores can be selected. 

3. On the Enterprise Portal toolbar, on the Store drop-down menu, select a store. 

40.1.2 VIEW INFORMATION ABOUT THE STORE 

4. Click the Retail FastTab. 

a. Enterprise Portal displays the store’s contact information and hours, lists of stock 

counts, purchase orders and incoming transfer orders, and outgoing transfer orders. For 

more information, refer to "Stock counts," "Receiving," and "Picking," later in this 

module. 

40.1.3 VIEW A LIST OF ALL ITEMS 

To view a list of all items, follow these steps. 

5. Click the Retail FastTab. 

6. Under Main lists, click Retail item list. 

 Enterprise Portal displays the list of all the items that are carried by all stores, with 
information such as prices and quantities. You can search and browse the list. The list is 
read-only. 
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7. To view the details about the item, double-click the item. 

8. To view related information about the item, on the Item details form, click Related information, 

and then do one of the following: 

 To view on-hand quantities of the item at all stores, click On-hand. 

 To view information about variants of the item, click Item variants. 

 To view documents related to the item, click Documents. 

40.1.4 VIEW THE STORE’S PROMOTIONS AND DISCOUNTS 

To view the store’s promotions and discounts, follow these steps. 

9. Click the Retail FastTab. 

10. In Main lists, click Promotions and discounts. 

 Enterprise Portal displays the list of the promotions and discounts that are assigned to 
the store with information such as type and status. You can search and browse the list. 
The list is read-only.  

11. To view details about the item, double-click the item. 

40.1.5 VIEW REPORTS 

You can use reports to monitor sales trends, inventory, pricing, and employee performance to 
gain valuable insights about the retail business. 

To view reports, follow these steps. 

12. Click the Retail FastTab. 
13. In Retail Reports, click the report that you want. Enterprise Portal includes these reports: 

 Sales Performance 

 Select Week to date, Month to date, or Year to date. 
 Sales Comparison by Year  

 Select 7 days, 12 weeks, 6 months, or 1 year. 
 Sales by Hour 

 Click the calendar icon, and then select a date. 
 Sales by Staff 

 Select Today, Current week, Current month, or previous month. 
 Sales by Item Hierarchy 

 Select Today, Week to date, Month to date, or Year to date. 
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 ROLE CENTERS 

40.2.1.1 Overview 

In this module we will discuss Role Centers and that they are pages in the Enterprise Portal that 
display business information, links, and key tasks that are geared for specific retail roles. The 
retail roles (and their Role Centers) include: 

 Retail  

 Store Manager 

 Store Associate 
 

40.2.1.2 Retail  

This Role Center is designed for employees whose primary work is item maintenance, 
promotions and discounts, inventory replenishment, and statement posting. The Role Center 
includes these parts: 

My Links 

 Retail item list – Displays the list of all the items that are carried by all the stores. 

 Promotions and discounts – Displays the list of the promotions and discounts that are assigned to 

the store. 

 On-hand item stock inquiry – Displays on-hand inventory information for all stores. 

Sales performance – Displays the sales information for the top 10 and bottom 10 stores for a 
specified period. By default, the report displays data for Month to date. You can also choose 
Week to date or Year to date periods. 

Sales by item hierarchy – Displays a pie chart that shows the store’s sales amounts by a selected 
item hierarchy group (business group, division group, retail department, and retail group) for a 
specified period, either Week to date, Month to date, or Year to date. 

For example, if you select Retail department, the pie chart displays sales percentages for the top 
five departments, and Other (all other departments). 

Sales comparison – Displays the line chart that compares the store’s sales for a specified period 
in the current year to the store’s sales in the same period in the previous year. You can choose 
periods of 7 Days, 12 Weeks, or 6 Months. By default, the period is 12 Weeks. 

Work List – Displays messages and alerts from Microsoft Dynamics AX Retail. 
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40.2.1.3 Store Manager 

This Role Center is designed for employees with management responsibilities and privileges. 
Typically, these are store managers. The Role Center includes the following parts: 

My Links 

 Retail item list – Displays the list of all the items carried by all the stores. 

 Promotions and discounts – Displays the list of the promotions and discounts that are assigned to 

the store. 

Sales by staff member – Displays the bar chart that shows sales figures for the store’s staff for a 
specified period. By default, the report displays data for This week. You can also select This 

month or Previous month periods. 

Sales by hour – Displays the bar chart that shows the store’s sales amounts for the current day, 
by hour. 

Sales comparison – Displays the line chart that compares the store’s sales for the specified 
period in the current year to the store’s sales for the same period in the previous year. You can 
select periods of 7 Days, 12 Weeks, or 6 Months. By default, the period is 12 Weeks. 

Work List – Displays the messages and alerts from Microsoft Dynamics AX Retail. 

40.2.1.4 Store Associate 

This Role Center is designed for employees whose primary work is non-management-related. 
Typically, cashiers, stock clerks, floor sales staff, and so on. The Role Center includes the 
following parts: 

My Links 

 Retail item list – Displays the list of all the items carried by all the stores. 

 Promotions and discounts – Displays the list of the promotions and discounts that are assigned to 

the store. 

Sales by hour – Displays the bar chart that shows store’s sales amounts for the current day, by 
hour. 

Work List – Displays messages and alerts from Microsoft Dynamics AX Retail. 
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40.2.2 STOCK COUNTS 

You can use the Enterprise Portal to perform stock counts from any computer with Internet 
access. You do not need to use a point of sale register. And, you can use the Enterprise Portal to 
perform two kinds of stock counts:  

 Unscheduled stock count – This is a stock count initiated by a store when the items to be 
counted are not predetermined by the headquarters office. This type of count is 
frequently used for informal counts or spot checks as part of loss-prevention measures. 

 Scheduled stock count – This stock count is initiated at the headquarters office, and it 
specifies what items to count. The headquarters office creates a counting document and 
sends it to the store, where actual stock-on-hand quantities are entered into the 
Enterprise Portal. 

When either kind of stock count is finished, the store sends the completed counting document 
back to the headquarters office, where it is posted to inventory. 

You can perform a stock count by using a scanner or by manually entering the item information. 
You can suspend the stock count and resume the count at a later time, if necessary. 

Tip 

You can also perform unscheduled stock counts in Microsoft Dynamics AX Retail POS. For 
more information, refer to the Microsoft Dynamics AX Retail POS User’s Guide. 

Note: Before you can perform a stock count, make sure that a store inventory terminal, a worksheet 

mask, and a staff member with store inventory access are set up. For more information, refer to the 

Microsoft Dynamics AX Retail User’s Guide. 

40.2.2.1 Perform a stock count 

To perform a stock count, follow these steps. 

1. Log on to the company’s Enterprise Portal with an account that has store inventory access. 

2. Enterprise Portal displays the Home page with the Role Center that is assigned to you. 

3. Click the Retail FastTab, and then in Main lists, click Stock counts. 

4. Enterprise Portal displays the list of open and scheduled stock counts. 

5. Click New to create a new stock count, or double-click and open or schedule a stock count. 

6. Enterprise Portal displays the Stock count form. 

7. In the Reference number box, type a reference number for the stock count. 

8. In the Store inventory ID box, type the store’s ID number. 
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9. In the Type box, select Stock count. 

10. In the Worksheet mask box, select the worksheet mask for the stock count. 

11. In the Staff box, select your name. 

12. Do one of the following: 

i. Scan an item. 

ii. Click Look up, and then select the item. 

iii. In the Item number or bar code box, type the item number. 

13. In the Quantity box, type the item’s quantity. 

14. If the item is a variant, select dimensions in the Size, Color, Style, and Configuration boxes, as 

necessary. 

15. Click Add. 

16. Repeat steps 9 through 12 for the items that you want to count. 

17. When you finish adding the items to the stock count, click Submit to send the stock count to 

Microsoft Dynamics AX Retail. 

40.2.3 RECEIVING 

You can receive inventory from purchase orders and incoming transfer orders. The receiving 
documents can be downloaded from Microsoft Dynamics AX Retail, on demand, and employees 
who have access can receive the merchandise. Completed receiving documents are then 
uploaded to Microsoft Dynamics AX Retail so that the documents can be posted to the original 
purchase orders or transfer orders. 

Item variants and units of measure can be included when receiving inventory. 

Tip 

You can also receive inventory in Microsoft Dynamics AX for Retail POS. For more 
information, refer to the Microsoft Dynamics AX Retail POS User’s Guide. 

 Note: Before you can receive inventory, make sure that a store inventory terminal, a worksheet 

mask, and a staff member with store inventory access are set up. For more information, refer to 

the Microsoft Dynamics AX Retail User’s Guide. 

 

40.2.3.1 Receive a purchase order or transfer order 

To receive a purchase order or transfer order, follow these steps. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

7 

 

1. Log on to the company’s Enterprise Portal with an account that has store inventory access. 

2. Enterprise Portal displays the Home page with the Role Center that is assigned to you. 

3. Click the Retail FastTab, and then in Main lists, click Receiving. 

4. Enterprise Portal displays the list of receiving documents. 

5. Double-click the receiving document that you want. 

a. The Order number box displays the number of the order. 

b. The Store inventory ID box displays the store number. 

6. In the Staff box, select a staff member. 

7. Select an item that is listed on the order. 

8. In the Quantity column, type the item’s quantity. 

9. Click Add. 

10. Repeat steps 5 through 7 for the items that you want to receive. 

11. When you finish receiving the items, click Submit to send the completed receiving document to 

Microsoft Dynamics AX Retail. 

 

40.2.4 PICKING 

You can use the Enterprise Portal to complete outgoing transfer orders and pick merchandise 
for the outgoing orders. Picking documents can be downloaded from Microsoft Dynamics AX 
Retail on demand, and employees can pick the merchandise. Completed picking documents are 
then uploaded to Microsoft Dynamics AX Retail so that the picked documents can be posted to 
the original transfer orders. 

Tip 

You can also pick merchandise and complete outgoing transfer orders in Microsoft 
Dynamics AX for Retail POS. For more information, refer to the Microsoft Dynamics AX Retail 

POS User’s Guide. 

 Note: Before you can complete outgoing transfer orders, make that a store inventory terminal, a 

worksheet mask, and a staff member with store inventory access are set up. For more 

information, refer to the Microsoft Dynamics AX Retail User’s Guide. 

 

40.2.4.1 Complete an outgoing transfer order 

To complete an outgoing transfer order, follow these steps. 
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1. Log on to the company’s Enterprise Portal with an account that has store inventory access. 

2. Enterprise Portal displays the Home page with the Role Center that is assigned to you. 
3. Click the Retail FastTab, and then in Main lists, click Picking. 

4. Enterprise Portal displays the list of picking documents. 
5. Double-click a picking document. 

6. Enterprise Portal displays the Picking form. 
a. The Order number box displays the number of the transfer order. 

7. In the Store inventory ID box, type the store’s ID number. 
a. The Type box displays the type of order. 

8. In the Staff box, select a staff member. 
9. Select an item that is listed on the order. 
10. In the Quantity box, type the item’s quantity. 
11. Click Add. 
12. Repeat steps 6 through 8 for the items that you want to pick. 
13. When you finish picking the items for the transfer order, click Submit to send the picking 

document to Microsoft Dynamics AX Retail. 
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41 COMMERCE DATA EXCHANGE: REAL-TIME SERVICE 

OVERVIEW 

In this module we will discuss the Functional overview and the Commerce Data Exchange: Real-
time Service is an integrated service that provides real-time communication between Microsoft 
Dynamics AX and individual point of sale (POS) terminals.  

When you install this component, the Retail Salt Utility and the .NET Business Connector are 
also installed. The Retail Salt Utility provides extra encryption for the passwords and credentials 
that are associated with the Microsoft Dynamics AX Retail system. The .NET Business Connector 
enables applications to interact with instances of Application Object Server (AOS).  

Note  

Retail components are available only with Microsoft Dynamics AX 2012 Feature Pack and 
Microsoft Dynamics AX 2012 R2. In Microsoft Dynamics AX 2012 Feature Pack, Real-time 
Service is called Commerce Data Exchange: Real-time Service.  

At the headquarters office, install Real-time Service on the communications server.  

On the computer where you plan to install this component, run the prerequisite validation 
utility to verify that the system requirements are being met.  
 

41 COMMERCE DATA EXCHANGE: REAL-TIME SERVICES: 
CONNECTION CONFIGURATION 

Use the following procedure to install Real-time Service. If you install other Microsoft Dynamics 
AX components at the same time, the installation pages differ, depending on the components 
that you are installing.  

1. Start Microsoft Dynamics AX Setup. On Install, select Microsoft Dynamics AX components.  
2. Advance through the first wizard pages.  
3. If the Setup Support files are not yet installed on this computer, the Select a file location 

page is displayed. The Setup Support files are required for installation. Provide a file 
location or accept the default location, and then click Next.  

4. On the Ready to install page, click Install.  
5. On the Select installation type page, click Custom installation, and then click Next.  
6. On the Select components page, select Real-time Service, and then click Next.  
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7. On the Prerequisite validation results page, resolve any errors. When no errors remain, 
click Next.  

8. If you are installing on a 64-bit operating system, the Select a file location page is displayed. 
Select the location where you want to install the 32-bit versions of Microsoft Dynamics AX 
files, and then click Next.  

9. On the Select a display language page, select the language in which you want to run 
Microsoft Dynamics AX for the first time.  

Note  

.NET Business Connector is a kind of Microsoft Dynamics AX client. Therefore, if .NET 
Business Connector is the first client that you install on a computer, Setup requires that 
you set the display language.  

10. On the Specify a location for configuration settings page, specify whether you want .NET 
Business Connector to access configuration information from the registry on the local 
computer or from a shared configuration file. If you want to use a shared configuration file, 
you must enter the network location of the file. Click Next.  

11. On the Connect to an AOS instance page, enter the name of the computer that runs the 
instance of Application Object Server (AOS) that you want to connect to. You can optionally 
specify the name of the AOS instance, the TCP/IP port number, and the WSDL port for 
services. Click Next.  

Note  

If you entered information about the AOS connection for other Microsoft Dynamics AX 
components that are installed on this computer, this page is not displayed. Later 
installations on the same computer reuse the existing AOS connection.  

12. On the Specify Business Connector proxy account information page, enter the password 
for the proxy account that is used by the .NET Business Connector. Click Next.  

13. On the Prerequisite validation results page, resolve any errors. When no errors remain, 
click Next.  

14. On the Ready to install page, click Install.  
15. After the installation is completed, click Finish to close the wizard.  

41.1.1 COMMERCE DATA EXCHANGE: REAL-TIME SERVICES: REAL TIME SERVICE 
PROFILE 

When you set up a profile for Commerce Data Exchange: Real-time Service, you enable the 
point of sale (POS) register or the online store to access the Application Object Server (AOS). 
The register or the online store can then retrieve or update information in real time.  
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Real-time Service acts as an agent for the register or the online store. The POS system and the 
online store do not access the remote AOS instance.  

Real-time Service is also used by Commerce Data Exchange: Synch Service to upload status 
messages. 

To create a Real-time Service profile, follow these steps.  

1. Click Retail > Setup > Retail scheduler > Channel integration > Real-time Service profiles.  

 

 

2. Select an existing profile, or press CTRL+N to create a new profile.  
3. Enter a name and a description for the profile.  
4. On the Connection FastTab, enter the following information:  

o Server – Enter the server name or IP address where Real-time Service is running.  
o Port – Enter the port number that the web service for Real-time Service uses.  
o Protocol – Select the communication protocol that Real-time Service uses.  
o Web application name – Enter the name of the web application that hosts Real-time 

Service.  
o Common name – Enter the common name for the certificate that is used to establish 

an encrypted channel with Real-time Service.  
o Passphrase – Enter the passphrase that is used to authenticate the POS connection.  
o Language – Select the language that is used by the AOS instance.  
o Real-time Service version – If the service has a different release version than 

Microsoft Dynamics AX, select the version of this instance of the service.  
5. On the Settings FastTab, select the Commerce Data Exchange: Real-time Service staff check 

box to enable Microsoft Dynamics AX for Retail POS to validate the operator logon through 
the service.  
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41.1.1.1 Assign a Real-time Service profile to a register  

 

Before POS registers can access AOS to retrieve or update information in real time, you must 
assign each POS register a Real-time Service profile. 

To assign a register a Real-time Service profile, follow these steps.  

1. Click Retail > Setup > POS > POS registers.  
2. Double-click the register to modify, and then click the Maintain button.  
3. In the POS registers form, click the General FastTab.  
4. In Profiles, in the Real-time Service profile field, select the appropriate Real-time Service 

profile.  

 

 

41.1.1.2 Assign a Real-time Service profile to an online store  

Before online stores can access AOS to retrieve or update information in real time, you must 
assign each online store a Real-time Service profile.  

To assign the online store a Real-time Service profile, follow these steps. 

 

1. Click Retail > Common > Retail channels > Online stores.  
2. Double-click the online store to modify, and then click the Maintain button.  
3. In the Online store form, click the General FastTab.  
4. On Profiles, in the Real-time Service profile field, select the appropriate Real-time Service 

profile. 

javascript:void(0)
javascript:void(0)
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 COMMERCE DATA EXCHANGE: SYNCH SERVICE UPLOAD 
OPTIONS 

Microsoft Dynamics AX Retail provides resources to monitor Commerce Data Exchange: Synch 
Service. To set up communications between Microsoft Dynamics AX and stores, you must set up 
Synch Service profiles for Microsoft Dynamics AX at the headquarters office and for store 
locations. The details that you select for a profile determine how Microsoft Dynamics AX 
communicates with stores and store registers. In the profile, you select whether and how often 
status messages are uploaded from stores to Microsoft Dynamics AX. Use this form to set up 
upload details for messages. 

Commerce Data Exchange: Real-time Service is used by Commerce Data Exchange: Synch 
Service to upload status messages to Microsoft Dynamics AX. You control whether this upload 
occurs, and how often it occurs, by selecting a set of upload options for each Synch Service 
profile. 

41.2.1 SET UP UPLOAD OPTIONS FOR SYNCH SERVICE MESSAGES 

To create a set of upload options for Synch Service, follow these steps.  

1. Click Retail > Setup > Retail scheduler > Channel integration > Commerce Data Exchange: 
Synch Service upload options.  

2. In the Commerce Data Exchange: Synch Service upload options form; click New to create a 
new set of upload options.  
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3. In the Name field, enter a name for the set of upload options.  
4. Select the Upload enabled check box if messages are uploaded to Microsoft Dynamics AX 

for instances of Synch Service that use these upload options. Clear the check box if 
messages are stored only in the message database for Synch Service at the store.  

5. Select the Error message only check box to upload only error messages. Clear the check box 
to upload status messages of all types. These status messages include error messages.  

6. In the Interval (minutes) field, enter the number of minutes between uploads.  
7. Repeat steps 2 through 6 for any other set of upload options that you require.  

41.2.2 SYNCH SERVICE PROFILES 

To use the Synch Service Profiles form to set up the profile for Synch Service, follow these 
steps.  

1. Click Retail > Setup > Retail scheduler > Channel integration > Commerce Data Exchange: 
Synch Service profiles.  
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2. Click New to enter a new service profile. 
3. Enter the Service name of the Synch Service.  
4. Enter the Server name on which you installed the Synch Service instance. 
5. Enter the Port that is used by the selected instance of Synch Service. By default, Synch 

Service uses port 16750. 
6. Select the Disable IPsec to disable Internet Protocol security (IPsec) for the port that you are 

using for the selected profile.  

Important  

You should disable IPsec only if you have another way to provide secure communication 
channels for Synch Service. For more information, refer to Configure or bypass IPsec for 
Commerce Data Exchange: Synch Service.  

7. Select the Prefer IPv6 to use IPv6 for communication if both IPv6 and IPv4 protocols are 
available on the network  

8. In the Timeout field, enter the maximum number of seconds before a communication job 
ends. If you enter 0 (zero), jobs do not time out.  

9. Select a Real-time Service profile. Synch Service uses this profile to connect to Real-time 
Service to monitor the status of jobs. If you do not want this instance of Synch Service to 
monitor status, leave this field blank.  

10. Select the upload configuration for the selected Synch Service profile.  
11. Click Database to select the database profiles that use the selected Synch Service profile.  
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12. Click Test connection to confirm that the connection string for the selected Commerce Data 

Exchange: Synch Service profile is correct. 
13. Select each profile that upload options are assigned to, and then click Send configuration.  

 COMMERCE DATA EXCHANGE: REAL-TIME SERVICE: 
SALES ORDERS 

41.3.1  FUNCTIONAL OVERVIEW 

The sales order is the order that is received by the business from the customer. The sales order 
can be for products and, or services, for example, a furniture store where the customer orders 
the items at a consulting counter and not at the POS. 

The Sales Order function is used to prepay or pay the total balance of a sales order that is 
created in Microsoft Dynamics AX for Retail. Microsoft Dynamics AX for POS receives 
information about the sales orders through the Transaction Service because POS does not keep 
any information about the sales.  

The Sales Invoice function is used to pay for the sales order that is created and invoiced in 
Microsoft Dynamics AX for Retail. 

41.3.2  CONFIGURING MICROSOFT DYNAMICS AX FOR RETAIL 

Microsoft Dynamics AX User Settings 

The Microsoft Dynamics AX for Retail user that runs the Transaction Service must be part of the 
Microsoft Dynamics AX user group that has permission to do the following: 

 Use and post the payment journal that is selected in the Microsoft Dynamics AX for 
Retail  parameters for POS payments 

 Post sales orders 

Transaction Services Settings 

The Microsoft Dynamics AX Retail POS Transaction Service must be configured. No other 
Transaction Service configuration is required. 

Payment Journal Settings 

Payment journal settings must be set up for Sales order payments to be processed accurately 
through the Microsoft Dynamics AX Retail POS Transaction Service. 

To configure the Sales orders to be posted directly after the Sales order is completely paid at 
the Microsoft Dynamics Retail POS, you must set up the following settings. 
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 Click RETAIL > SETUP > PARAMETERS. 

 Select the Prepayment FastTab.  

 Enter a check mark in Post sales order. 

If you set up these setting, you must fill in all the required attributes when you create a Sale 
order that has the Warehouse ID, and so on.   

Create Buttons on the Till Layout 

To have access to the Sales order function, a button must be added to the Till layout. 

Sales Order 

To create a button on the Till layout, follow these steps.  

 CLICK RETAIL > SETUP> POS > RETAIL POS > BUTTON GRID. 

 Select an existing button grid or create a new one. 

 Add a new button with Action Sales Order. 

 

Send the Updated Values to Retail POS 

To send the updated values, follow these steps. 

1. Click RETAIL SCHEDULER > SCHEDULER JOBS. 

2. Send the relevant scheduler jobs to update the data on the Microsoft Dynamics AX Retail 
POS terminal –  (N-Terminal). 
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41.3.3 USING THE FUNCTION IN RETAIL POS 

To use the new setup, follow these steps. 

1. Start the Microsoft Dynamics AX for Retail POS application. 

2. If the application is already running, log off and then log back on. 

3. If the new setup is replicated from Microsoft Dynamics AX for Retail to the POS local 
database the new button should be visible. 

4. Click Sales Order. 

The Sales Order dialog box will be displayed. 

 

5. If the sales order ID is available, follow these steps.  

a. Type the Sales Order Id. 

b. Click Get.  

Information about the sales order will be displayed in the Sales Orders dialog box.  

6. If the sales order ID is not available: 

 Enter the Customer ID. 

 Click Get.  

 Search for a sales order by clicking Search. A list of all available sales orders for the 
customer is displayed. 
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 Select a sales order. 

Information about the sales order will be displayed in the Sales Orders dialog box. 

 

Pre-Payment 

When sales orders are created, a prepayment amount can be decided. This is the minimum 
amount that must be paid before the sales order is processed. 

Information about the prepayment amount is available in the Sales Order dialog box after the 
sales order is selected. 

 

 

To pay the prepayment amount, click Prepay sales order and the prepayment amount is added 
to the transaction. When the transaction is being paid, Microsoft Dynamics AX for Retail is 
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notified through the Commerce Data Exchange: Real-time Service and the sales order balance 
amount is reduced or increased by the amount that is prepaid. 

Pay Sales Order Total Balance 

After the sales order is selected, information about the remaining balance on the sales order is 
available in the Sales order dialog box. 

To pay the total balance, click Get sales order and the whole balance of the sales order is added 
to the transaction. 

When the transaction is being paid, Microsoft Dynamics AX for Retail is notified through the 
Transaction Service and the sales order balance amount is updated. 

 

Create Picking List and Create Packing Slip 

Create Picking List and Create Packing Slip on the Sales order dialog box start a printout in 
Microsoft Dynamics AX for Retail by using the Transaction Service. 

The picking list contains the details of the ordered items. 

A packing slip is a shipping document that accompanies delivery packages. It includes the 
itemized details of the package contents. Sometimes it can also include the customer pricing.   

41.3.4 TROUBLESHOOTING 

If the error that is displayed occurs when a sales order is paid, the Payment journal settings 
might not be set or the Microsoft Dynamics AX for Retail user that is running the Transaction 
Service does not have the necessary user permissions. 
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To temporarily resolve this issue on Retail POS, use Void Transaction to void the whole 
transaction. 

 

 COMMERCE DATA EXCHANGE: REAL-TIME SERVICE: 
SALES INVOICES 

41.4.1 FUNCTIONAL OVERVIEW 

The sales invoice is a commercial document that is issued by the seller and is sent to the buyer. 
The sales invoice shows the products, quantities and agreed prices for products or services that 
the seller already provided to the buyer. 

You can use Sales Invoice to pay the sales invoice that is created in Microsoft Dynamics AX for 
Retail. Retail POS receives the information about sales invoices through the Transaction Service 
from the POS. However, Retail POS does not store any information about the sales invoices. 

41.4.2 CONFIGURING MICROSOFT DYNAMICS AX FOR RETAIL 

Microsoft Dynamics AX User Settings 

The Microsoft Dynamics AX for Retail user that is running the Transaction Service must be part 
of the Microsoft Dynamics AX user group that has permission to do the following: 

 Use and post the payment journal that is selected in the Retail  parameters for POS 
payments 

 Settle transactions 

Transaction Service Settings 

The POS Transaction Service must be configured. No other Transaction Service configuration is 
required. 

Payment Journal Settings 

To process payments correctly, the payment journal setting for sales invoices must be set 
through the Retail POS Transaction Service. To do this, follow these steps. 

1. Click RETAIL > SETUP > PARAMETERS. 
2. Select the Prepayment FastTab. 
3. Select Name. 
4. Select Ledger Account. 
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Create Buttons on the Till Layout 

To access the Sales Invoice button, you must add a button to the Till layout. 

 

Sales Invoice 

To create the Sales Invoice button on the Till layout, follow these steps. 

1. CLICK RETAIL > SETUP > POS > RETAIL POS > BUTTON GRID. 

2. Select the existing button grid or create the new button grid. 

3. In the Action area, select Sales Invoice to add the new button.  

 

Send the Updated Values to Retail POS 

To send updated values, follow these steps. 

1. Click RETAIL SCHEDULER > SCHEDULER JOBS. 

2. Send the relevant scheduler jobs to update the data on the Retail POS terminal. 
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41.4.3 USING THE FUNCTION IN RETAIL POS 

To add a balance to an invoice, follow these steps. 

1. Start the Retail POS application. 

2. If the application is already running, log off and then log back on. 

3. If the new setup is replicated from Microsoft Dynamics AX for Retail to the 
POS local database the new button should be visible. 

4. Select Customer. 

5. Click Sales Invoice. 

The Sales Invoice selection dialog box is displayed. 

 

6. Select a Sales invoice from the list. 

7. Click Select. 

The Sales Invoice balance amount is added to the transaction. 

When the transaction is being paid, Microsoft Dynamics AX for Retail is notified through the 
Transaction Service and the sales invoice balance amount is updated. 

 COMMERCE DATA EXCHANGE: REAL-TIME SERVICE: 
CUSTOMER VALIDATION 

41.5.1 FUNCTIONAL OVERVIEW 

When an amount is being charged to a customer, the Retail POS Transaction Service can be 
used to retrieve information from Microsoft Dynamics AX for Retail about the customer's credit 
limit and if the payment is within the limit. Microsoft Dynamics AX for Retail maintains a 
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customer balance based on the total of the transaction that is being charged and the amount 
the customer has paid.  The limit on this balance is decided on each customer by setting the 
Credit limit. 

 

41.5.2 CONFIGURING MICROSOFT DYNAMICS AX FOR RETAIL 

The Retail POS Transaction Service must be configured. No other Transaction Service 
configuration is required. 

Send the Updated Values to Retail POS 

To send the updated values, follow these steps. 

 

1. Click RETAIL SCHEDULER>SCHEDULER JOBS. 

2. Send the relevant scheduler jobs to update the data on the Retail POS 
terminal. 

Changing the Customer’s Credit Limit 

To change the customer’s credit limit, follow these steps. 

1. Click ACCOUNTS RECEIVABLE>CUSTOMER DETAILS. 

2. Select any of the existing customers. 

3. Select the General FastTab. 

4. Set the Credit limit to any value. 

5. Check the Mandatory credit limit: 
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6. Click ACCOUNT RECEIVABLE > CUSTOMERS to view the current balance on each 
customer. 

 

 

 

The information that is shown here indicates that customer 3000 only can charge 1500.00 
United Stated dollars (USD).  If more is charged an error will be created in Retail POS.  

41.5.3 USING THE FUNCTION IN RETAIL POS 

On the Microsoft Dynamics AX for Retail POS window create a transaction of more than 
1500.00 USD and charge it to customer 3000. 

Because the 1750.00 USD amount exceeds the 1500.00 USD credit limit by 250.00 USD, a 
message is displayed stating that the credit limit is exceeded.  

By increasing the credit limit to 1750.00 USD, the transaction can be completed. 
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41.5.4 TROUBLE SHOOTING 

If an error occurs when you pay a customer account, the Retail POS Transaction Service is not 
configured correctly. 

Check the Transaction Service Profile settings again, make sure that they are correct, and then 
test the Transaction Service connection. 

 

 COMMERCE DATA EXCHANGE: REAL-TIME SERVICE: 
INVENTORY LOOKUP 

41.6.1 FUNCTIONAL OVERVIEW 

Inventory Lookup is used to request the stock level of the selected item. The Transaction 
Service will return the stock level for the item in each location.  This is convenient when an item 
does not exist and the customer wants to know in which store the item can be found. 

41.6.2 CONFIGURING MICROSOFT DYNAMICS AX FOR RETAIL 

On the Microsoft Dynamics AX for Retail window, the Transaction Service settings must be set. 
Additionally, a button must be added to the Microsoft Dynamics AX for Retail POS Till layout to 
access Inventory Lookup.   

Create Buttons on the Till Layout 

For more information about how to create button grids and Till layouts refer to Part I. 

Inventory Lookup 

To create a button on the Till layout, follow these steps. 

1. CLICK RETAIL > SETUP > POS > RETAIL POS > BUTTON GRID. 

2. Select the existing button grid or create the new button grid. 

3. In the Action area, to add a new button select Inventory Lookup. 
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Send the Updated Values to Retail POS 

To send updated values, follow these steps. 

1. Click RETAIL SCHEDULER > SCHEDULER JOBS. 

2. Send the relevant scheduler jobs to update the data on the Retail POS terminal. 

41.6.3 USE THE FUNCTION IN RETAIL POS 

To use Inventory Lookup, follow these steps. 

1. Start the Retail POS application. 

If the application is already running, log off and then log back on. 

If the new setup is replicated from Microsoft Dynamics AX for Retail to the 
POS local database, the new button should be visible. 

2. Click Inventory Lookup. 

The Inventory Lookup dialog box will be displayed. 
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4. Use one of the following two methods: 

a. Type an item number, and press Enter 

b. Click Search button, and select an item from the list 

 

If the item is found, the items status will be displayed at the top of the dialog box.  The 
inventory status of other stores in the chain will be displayed in the list. 
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 RETAIL TRANSACTION SERVICE: STOCK COUNTING 

41.7.1 FUNCTIONAL OVERVIEW 

The basic stock count can be performed in Microsoft Dynamics AX for Retail POS by using a 
scanner or by manually entering the item information. This can be performed at the POS 
register online or offline. You can suspend the stock count and resume the stock count at a 
later time, if necessary.  Variants can be counted in stock counts. However, serial numbers or 
units of measure cannot be counted in stock counts.  

 Note: The scheduled or basic stock count can be performed by using the Enterprise 
Portal with a browser and an Internet connection. 

41.7.2 CONFIGURING MICROSOFT DYNAMICS AX FOR RETAIL 

Transaction Service Settings 

The Retail POS Transaction Service must be configured. 

No other Transaction Service configuration is required. 

Create Buttons on the Till Layout 

You do not have to create a new button for Stock Count because it is already configured on the 
current till layout under Tasks. 

41.7.3 USE THE FUNCTION IN RETAIL POS 

To use Stock Count, follow these steps. 

1. Start Retail POS and log on with an account that has store inventory access. 

2. Click Tasks, and then click Stock Count. 

3. Retail POS displays the Stock Counting form. 
4. Scan an item, or in the Scan or enter barcode box, type the item number, and then 

press ENTER. 
5. In the Enter quantity box, type the quantity, and then press ENTER. 
6. If the item has variants, Retail POS displays the Select form. 
7. Select the appropriate variant dimensions. 
8. Repeat the stock count steps for each item that you want to count. 
9. When finish the stock count, click Commit to send the stock count to Microsoft 

Dynamics AX Retail. 
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41.7.4 COMMERCE DATA EXCHANGE: REAL-TIME SERVICE: PURCHASE ORDER AND TRANSFER 
ORDERS 

41.7.4.1 Functional Overview 

You can receive inventory from purchase orders and incoming transfer orders. The receiving 
documents can be downloaded from Microsoft Dynamics AX Retail on demand, and employees 
who are granted access can receive the merchandise. Completed receiving documents are then 
uploaded to Microsoft Dynamics AX Retail for posting to the original purchase orders or 
transfer orders. 

Item variants and units of measure can be included when receiving inventory. 

You can use Microsoft Dynamics AX Retail for POS to complete outgoing transfer orders and 
pick merchandise for them. The picking documents for transfer orders can be downloaded from 
Microsoft Dynamics AX Retail on demand, and employees who are granted access can pick the 
merchandise. Completed picking documents are then uploaded to Microsoft Dynamics AX 
Retail so these documents can be posted to the original transfer orders.   

Note: You can also pick merchandise by using the Enterprise Portal with a browser and an 
Internet connection. For more information, refer to the Enterprise Portal Retail User’s Guide. 

 

41.7.5 COMMERCE DATA EXCHANGE: REAL-TIME SERVICE: CENTRALIZED 
RETURNS 

41.7.5.1 Functional Overview 

Microsoft Dynamics AX for Retail POS can retrieve previously posted transactions. Therefore, a 
customer can return one or more items from the original transaction by using the original price.  
You could not do this in earlier versions.  

The system must be configured so that each receipt number is unique. By passing the unique 
receipt number, Microsoft Dynamics AX for Retail can locate the transaction and send it to the 
Retail POS. 

However, the transaction might not yet be posted in Microsoft Dynamics AX for Retail. 
Therefore, if the transaction is not found in Microsoft Dynamics AX for Retail, a check is 
performed to determine whether the transaction can be found in the local database. If it still 
cannot be found, then an error message is displayed indicating that the transaction is not 
found. 

Note: The transaction must be returned to the same register if P-Term is not run.  
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41.7.5.2 Configuring Microsoft Dynamics AX for Retail 

Transaction Service Settings 

The Retail POS Transaction Service must be configured. 

No other Transaction Service configuration is required. 

Create Buttons on the Till Layout 

To have access to the Centralized returns, you must add a button to the Till layout. 

Centralized returns 

To create the Return Transaction button on the Till layout, follow these steps. 

1. CLICK RETAIL > SETUP > POS > RETAIL POS > BUTTON GRID. 

2. Select the existing button grid or create the new button grid. 

3. In the Action area, to add a new button select Return Transaction.  

Send the Updated Values to Retail POS 

To send updated values, follow these steps. 

 Click RETAIL SCHEDULER > SCHEDULER JOBS. 

 Send the relevant scheduler jobs to update the data on the Retail POS 
terminal. 

41.7.5.3  Use the function in Retail POS 

To process returns, follow these steps. 

1. Start the Retail POS application. 
2. If the application is already running, log off and then log back on. 
3. If the new setup is replicated from Microsoft Dynamics AX for Retail to the 

Retail POS local database, the new button should be visible. 
4. Click Return Transaction. 

A message asking for the receipt number is displayed. 
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5. Type the receipt number. 

If the receipt number is found in Microsoft Dynamics AX for Retail, a message 
is displayed with every item from that transaction. 

 

 

 

6. Select the items that must returned by using any of the following buttons: 

 Select line (Selects one line.  Selecting a line has the same affect.) 

 Select all (Selects all the lines.) 

 Clear selection (Deselects all the lines.) 

7. Press Return items to return the selected items or press Cancel to stop the 
function. 

The items selected will be added to the current transaction. 
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When the transaction is paid, Microsoft Dynamics AX for Retail is notified through the 
Transaction Service.  Each returned item is checked again to make sure that the item can be 
returned. This prevents the same items to be returned in two stores at the same time. 

 

41.7.6 COMMERCE DATA EXCHANGE: REAL-TIME SERVICE: STAFF VALIDATION 

41.7.6.1 Functional Overview 

This functionality is used so that query features in the centralized Microsoft Dynamics AX for 
Retail database can validate operator log on at the Retail POS. The query features also monitor 
when an operator is not logged on to many terminals at the same time.  Therefore, the 
centralized log off communication is used to make sure that Microsoft Dynamics AX for Retail is 
aware when an operator is not logged on. 

 

41.7.6.2 Configuring Microsoft Dynamics AX for Retail 

Transaction Service Settings 

The Retail POS Transaction Service must be configured. 

To set Transaction Service settings, follow these steps. 

1. Click RETAIL > SETUP > POS > TRANSACTION SERVICE PROFILE. 
2. Select the Transaction Profile the current terminal is using. 
3. Select the Settings FastTab. 
4. Select Staff. 
5. Save the settings. 

 

Create Buttons on the Till Layout 

If the Log off button does not already exists, you must add a Log off button to the Till layout. 

Logoff button 

To create the Log off button on the Till layout, follow these steps. 
1. CLICK RETAIL > SETUP > POS > RETAIL POS>BUTTON GRID. 
2. Select the existing payment button grid or create the new button grid. 
3. In the Action area, to add a new button select Logoff.   

Creating an Operator in Microsoft Dynamics AX for Retail POS 
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1. To create a staff member in Microsoft Dynamics AX for Retail POS, you must first 
create an Employee. 

2. Click BASIC > EMPLOYEE DETAILS and the Employee form is displayed. 
3. Press CTRL+N to create a new Employee. 
4. Select the General FastTab. 
5. Place a check mark next to the Retail field to change the new employee that is 

created to a Staff member. 

 

 

6. Click RETAIL > SETUP > STORE > STAFF and the Staff form is displayed. 

The new Staff member will be visible in the list. 

7. Type the information that relates to Retail POS as it is described in the following 
table. 

 

 

 

 

Tab Field Description 

General Name The name of the cashier. 
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General Name on receipt The name as it appears on 
the receipt. 

General Blocked Checked if the cashier should 
temporarily not be able to 
log on (online check). 

Personal Password The password to be entered. 

Privileges Allow multiple logins Whether the cashier should 
be allowed to log on to 
multiple terminals at any 
given time (online check). 

8. Set the necessary Privileges, as they are defined on the Privileges FastTab.

 

9. Click RETAIL SCHEDULER > SCHEDULER JOBS. 

10. Send the relevant scheduler jobs to update the data on the Retail POS terminal. 
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41.7.6.3 Use the function in Retail POS 

To log off, follow these steps. 

11. When the POS starts, the user is prompted with the following window: Log on with 
the user ID and the password that is provided in the previous steps. 

12. To log off, make sure that the Log off button is available. 

You can press the Log off function only if the transaction is blank. However, if the 
transaction is not blank, the POS returns to the log on state.  

41.7.7 COMMERCE DATA EXCHANGE: REAL-TIME SERVICE: CREDIT MEMO 
(CREDIT VOUCHER) 

41.7.7.1 Functional overview 

Credit memo is the term that will be referred to in this document.  However, Credit voucher is 
the term that is referred to in Microsoft Dynamics AX for Retail.  

Characteristics of the credit memo include the following: 

 The credit memo acknowledges a liability and provides authorization to pay a debt.  

 The credit memo is issued when the customer returns purchased goods, and only if the 
customer can claim that he or she has a valid reason for receiving the credit memo.  

 The credit memo cannot be sold.  

When you create the credit memo in Retail POS, a request is sent to Microsoft Dynamics AX for 
Retail through the Retail POS Transaction Service. The credit memo is created in Microsoft 
Dynamics AX for Retail and the information is returned to the Retail POS. Then, the Retail POS 
can continue with the payment of the sale, print a certificate and so on.  

41.7.7.2 Configuring Microsoft Dynamics AX for Retail 

To create the credit memo correctly, you must create the number sequence and set some 
tender type configurations.  

Commerce Data Exchange: Real-time Service Settings 

The Retail POS Transaction Service must be configured. 

No other Transaction Service configuration is required. 
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Credit Memo Number Sequence 

To set the number sequence, follow these steps. 

 Click RETAIL > SETUP > PARAMETERS. 

 Select the Number sequences FastTab. 

 Set the number sequence for Credit voucher Number. 

Tender type properties 

Decide the minimum value that will be allowed on the Credit Memo tenders and the tender to 
use if the balance is less than the minimum. 

To set the tender type properties, follow these steps. 

 CLICK RETAIL > SETUP > STORE > STORES. 

 Select the Store that you want to use. 

 Click Setup and select Tender Types. 

 Select the Tender type Credit Memo. 

 Select the Change FastTab. 

Above Minimum change tender is the tender that should be used if the remainder of 
the balance is more than the Minimum Change. 

Minimum change is the minimum balance that can be on the credit memo before you 
give the customer change and invalidate the credit memo. 

 Set Change tender to Cash (or any other tender type that you want). 

 Select the General FastTab and set the Operation ID to 213 (Pay Credit memo). 

 Repeat steps 2 through 7 for every store that is being used. 

 

 

Create Buttons on the Till Layout 
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To issue and use credit memos, buttons must be added to the Till layout. 

Pay Credit Memo 

To create the pay credit memo, follow these steps. 

 Create a button on the Till layout to pay with a gift card, by clicking Retail > Setup > 
POS > Retail POS > Button Grid. 

 Select the existing button grid or create the new button grid. 

 In the Action area, add the new Pay with Credit Memo button and select the Payment 
type as Credit Memo. 

The Pay with Credit Memo works as follows: 

 If the transaction is a negative or return action, a credit memo will be issued. 

 If the transaction is a positive number, then the cashier will be asked for a credit 
memo ID to use as payment. 

Issue credit memo 

1. Create a button on the Till layout to issue a gift card, by clicking RETAIL > SETUP > POS > RETAIL POS > 

BUTTON GRID. 

2. Select the existing button grid or create the new button grid. 
3. In the Action area, add the new Issue Credit Memo button. 
The Issue Credit Memo button issues a credit memo for the amount that the store owes the 
customer for the transaction. 
Send the updated values to Retail POS 
To send the updated values, follow these steps. 
1. Click RETAIL SCHEDULER > SCHEDULER JOBS. 
2. Send the relevant scheduler jobs to update the data on the Retail POS terminal. 

41.7.7.3  Use the function in Retail POS 

To issue the credit memo, follow these steps. 

1. Start the Retail POS application. 
2. If the application is already running, log off and then log back on. 

a. If the new setup is replicated from Microsoft Dynamics AX for Retail to the POS 
local database, new buttons should be visible. 

3. Return an item. 
4. Click Issue Credit Memo and if the balance of the transaction is a negative number, the 

credit memo will be created through the Transaction Service. 



Retail Application Functionality in Microsoft Dynamics® AX 2012 R2 

39 

 

5. Click RETAIL AX > RETAIL > INQUIRES > CREDIT VOUCHERS. 
a. The credit memo that is just created will be visible in the list with Applied as 

false. 
6. Sell a few items. 
7. Click Pay with Credit Memo that is previously created. 

a. A message asking for the credit memo number is displayed. 
8. Enter the credit memo number that is previously created. 
9. Click Get. 

a. The Credit memo amount is displayed in the dialog box. 

 

 Click OK. 

 Click RETAIL AX > RETAIL > INQUIRES > CREDIT VOUCHERS. 

The credit memo that is previously created will now have Applied as 
true, and if the credit memo balance is not completely used, a new 
credit voucher is issued.  

41.7.8 COMMERCE DATA EXCHANGE: REAL-TIME SERVICE: GIFT CARD 

41.7.8.1 Functional Overview 

A gift card is a non-monetary item that is purchased by the customer and is issued by the 
retailer. At the POS terminal there are four options:  

 Issue a Gift Card to the customer  

 Add balance to Gift Card  

 Check Gift Card balance  

 Allow the customer to pay with a Gift Card 

41.7.8.2  Configuring Microsoft Dynamics AX for Retail 

Transaction Service Settings 

The Retail POS Transaction Service must be configured. 
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No other Transaction Service configuration is required. 

Create Buttons on the Till Layout 

To have access to the Centralized returns function, a button must be added to the Till layout. 

Gift Card 

To create the Issue Gift Card, Add To Gift Card, and Gift Card Balance buttons on the Till 
layout, follow these steps. 

 CLICK RETAIL > SETUP > POS > RETAIL POS > BUTTON GRID. 
 Select the existing button grid or create the new button grid. 

 In the Action area, add the new Issue Gift Card button. 

 In the Action area, add the new Add to Gift Card button. 

 In the Action area, add the new Gift Card Balance button. 

Send the Updated Values to Retail POS 

To send the updated values, follow these steps. 

1. Click RETAIL SCHEDULER > SCHEDULER JOBS. 

2. Send the relevant scheduler jobs to update the data on the Retail POS terminal. 

41.7.8.3  Use the function in Retail POS 

Four main functions are included on the Retail POS: 

1. Issue Gift Card 
2. Add Balance to Gift Card 
3. Check Balance on Gift Card 
4. Redeem a Gift Card 

Issue a Gift Card 

To issue a gift card, follow these steps. 

 At the POS, click Task/Issue Gift Card. 

 Scan the gift card or type the number in the Gift card number box. 

 Enter the gift card amount and click OK to complete the transaction. 
POS prints a sales receipt and a gift receipt. 
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Add Balance to Gift Card 
To add a balance to a gift card, follow these steps. 

o At the POS, configure the button with the action Add to Gift Card. 
o Click Add to Gift Card. 
o Scan the gift card or type the number in the Gift card number box. 
o Enter the gift card amount and click OK to complete the transaction. 

 

Check Gift Card Balance 

To view the gift card balance, follow these steps. 

 At the POS, configure the button with the action Gift Card Balance. 

 Click Gift Card Balance. 

 Scan the gift card or type the number in the Gift card number box. 

 Click Get to view the gift card balance. 

 Click Print Receipt to print a receipt with the balance of the gift card. 
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Redeem a Gift Card 

To redeem a gift card, follow these steps. 

1. Add items to the transaction. 
2. Click Pay Gift Card. 
3. Scan the gift card or type the number in the Gift card number box. 
4. Click OK to complete the transaction. 

 

41.7.9 COMMERCE DATA EXCHANGE: REAL-TIME SERVICE: LOYALTY 

41.7.9.1  Functional Overview 

The loyalty system is based mainly on two functions—accruing points and spending points.  To 
accrue points, a loyalty customer must be set up. Each loyalty customer can have a reference 
(optional) to a real customer in the system.  More than one loyalty customer can have a 
reference to the same real customer.  After the loyalty customer is created, one or more 
Loyalty cards can be issued that belong to this loyalty customer.  Each Loyalty card has a 
reference to a loyalty scheme. The loyalty scheme specifies the accruement points rule. The 
accruement points rule shows how many points can be accrued and how the points are earned.  
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Additionally, each Loyalty card is identified how it can be used is shown, such as only accruing, 
accruing and spending and so on. 

41.7.9.2  Configuring Microsoft Dynamics AX for Retail 

The details of the loyalty configuration are discussed in the Microsoft Dynamics AX for Retail HQ 
User Guide. 

41.7.9.3  Use the function in Retail POS 

There are two main functions on the Retail POS—accruing points and spending points.  Points 
can be accrued any time during the transaction, either by swiping the Loyalty card or pressing a 
special button to manually enter the Loyalty card number. Actions that can start to accrue 
points include the following:  

 Direct purchase of an item  

 Purchase of an item that belongs to one of the following: Retail group, Retail department, 
Special group, Business group, Division group  

 Purchase of any item 

 Purchase of a particular variant of an item  

 Use of a special vendor type to make  payment 

To spend loyalty points, the Card payment dialog box must be opened and a card that is 
identified as the Loyalty card must be used. 

How to Accrue Points 

To accrue loyalty points, the Loyalty card must be added to the transaction.  One way is to 
swipe the Loyalty card at any time during the transaction.  If the card is identified as a Loyalty 
card a message is displayed on the message panel. 

Another way is to manually enter the Loyalty card number. To enter the card number, following 
these steps. 

 Start the Retail POS application. 

 If the application is already running, log off and then log back on. 

 If the new setup is replicated from Microsoft Dynamics AX for Retail to the POS local 
database, new button should be visible. 

 Click Loyalty Request. 

 Type the Loyalty card number in the Card number dialog box. 

Only one Loyalty card can be registered for each transaction. If the user tries to add a 
second Loyalty card, a message is displayed asking the user if he or she wants to 
override the existing loyalty record. 
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How to Spend Points 

When the Loyalty card is used to spend points, the Card payment dialog box must be opened. 

To open the Card payment dialog box, follow these steps. 

 Enter the items to be purchased. 

 Press the Card payment button. 
The Card payment dialog box appears. 

 Swipe or enter the loyalty card number and enter the amount to be paid. 
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42 POS EXTENSIBILITY & PLUGINS 

Introduction 

Microsoft Dynamics AX for Retail provides a range of services and triggers to extend the POS 
functionality. The POS extensibility is focused towards: 
 

 Improving existing ISV scenarios and support new scenarios based on partner and customer 
feedback. 

 Supporting multiple ISV customizations in a single instance of POS. 
 
POS Extensibility and plug in should not be perceived to be used: 

 To completely rewrite POS UI or architecture. 

 To be used as an Add-in manager. 
 
The below diagram provides an architectural overview on how triggers and services reside 
within POS. 
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The triggers and services area under POS are completely replaceable by the ISV and partner 
customizations.  

Contract DLL defines all the interface definitions for services and triggers. These definitions are 
inherited by triggers and services to implement specific business functionalities. 

The POS extensibility is broadly divided into 2 areas: 
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 Services define the business logic for retail operations. Services are divided into various 
modules (Ex. Customer, currency, Infocodes, Item) which provide user forms and business 
logic to be extended by ISVs. Partners can modify the user forms and add additional 
functionalities in the services area based on customer requirements. 
 

 Triggers define the call points for an event to occur. Once an event is triggered services 
methods can be called to perform specific business operations. 

 Skins: Custom themes can be developed using the DevExpress Skin editor to create various 
look and feel for Point of Sale (POS) users. A DevExpress developer can create a new skin 
from existing skin and modify the look as feel as required. After the skin has been created 
and tested, the skin DLL needs to be copied to the Skins folder in the POS installation 
directory on every register to make it available for Point of Sale (POS) users. 
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42.1 INSTALL POS PLUG IN 

The first step towards POS extensibility is installing the POS plug from the Dynamics AX 2012 
Retail feature pack. The installation will provide source codes of the services and triggers for ISV 
development team to implement vertical solutions or extend existing functionalities. 

Note 

Please down a copy of Dynamics AX 2012 Retail feature pack from partner source to install the 
POS plug in. 

Follow the steps below to install the POS plug in on your local computer. 

1. Open the folder where you have downloaded AX 2012 Retail feature pack. 
 

 

2. Right click on the setup file and select Run as administrator. 
 

3. The Microsoft Dynamics AX 2012 installation form pops up. 
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4. Under Install click Microsoft Dynamics AX components to select the components to install. 
 

5. The AX 2012 Set up wizard form will open. 
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6. Click Next to continue with the installation. 
 

7. Click I accept license terms to continue with the installation. 
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8. The following screen provides options to add/modify components and remove components. 
Select add or modify components and click next. 
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9. Under Retail Components select the Retail POS Plug-Ins to install the plug in on the local 
computer. 
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10. The Prerequisite validation runs and checks if all the dependencies are met to install the 
selected components. 
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11. Click Next to install the selected component. 

Note 

The POS Plug-Ins will be installed at the default user directory (C:\Users\username\Documents) 
under the folder Retail POS Plug-ins. Open the folder to view the following directories. 
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42.2 SERVICES AND TRIGGERS 

Customer operations are handled by the customer service interface, which enables partners to 
extend features for the needs of specific retailers.  

Services POS plug-ins 

1. Open the folder where the Retail POS Plug-ins is installed. Open the Services folder. Double 
click on the Services.sln to open the services solution in Visual Studio 2010. 

 

2. The Sevices solution will open with a list of projects (Ex. Sales Order, Stock Count, Tax, 
Customer etc.) which provides forms and interface definitions for ISVs and partners to 
extend the POS functionalities. 
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Let us pick Customer service as an example to explore the forms and interfaces. 

Open the WinFormTouch folder under the Customer project to view the forms exposed for ISVs 
and partners to customize the forms. 

The customer service interface extends all the customer operations. A typical workflow is as 
follows. 
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CORE Operation

Customer Search

ICustomer 

CustomerSearch

frmCustomerSearch
DataAccess

GetCustomers
Get Data

 

Figure Customer service interface workflow. 

 

 Caution 

Follow the development guidelines to keep the look and feel of POS similar across all the areas. 

The Devexpress version for POS customization is specific for Microsoft without APTCA. (Allow 
Partially Trusted Callers). 

Triggers POS Plug-in 

1. Open the folder where the Retail POS Plug-ins is installed. Open the Services folder. Double 
click on the Services.sln to open the services solution in Visual Studio 2010. 
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2. The Sevices solution will open with a list of projects (Ex. Item triggers, Discount triggers, 
Transaction triggers, Customer triggers etc.) which provides interface definitions for ISVs 
and partners to extend the POS functionalities. 

 

3. Lets dwell into the customer tiggers project and open the CustomerTriggers.cs file to review 
the interfaces definitions. 
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The interface has the following methods: 

 PreCustomerClear – This interface method can be used as a trigger call point to perform 
specific operations before the customer is cleared from a transaction. 
 

 PostCustomerClear – This interface method can be used as a trigger call point to perform 
specific operations after the customer is cleared from a transaction. 
 

 Caution 

Review the customization code implemented in the interface to limit the performance of POS 
operations. 
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